Skype4COM: Main Page

Skype4COM 1.0.38.0
  • Main Page
  • Related Pages
  • Modules
  • Classes
  • Files
  • Examples

Skype4COM Documentation

Introduction:
Skype4COM represents the Skype API as objects, with:
  • methods
  • properties
  • events
  • collections
  • caching
Skype4COM provides an ActiveX interface to the Skype API. Develop for Skype in a familiar programming environment, such as Visual Studio or Delphi, using preferred scripting languages such as VBScript, PHP, or Javascript.
Requirements:
  • Skype 3.0 must be installed
  • Windows 2000, XP, Vista, 7
How to use:
This document is a reference guide to the Skype4COM interface to the Skype API . Follow the links to navigate through the guide and familiarise yourself with the contents. Follow the examples to get started on a variety of tasks.
See also:
Important: This document is a companion to the Skype API reference which you must read and consult regularly when using Skype4COM.
Example:
The following sample code, written in VBScript, provides a simple introduction:
 '// Create a Skype4COM object:
 Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

 '// Place a call to echo123:
 Set oCall = oSkype.PlaceCall("echo123")

 '// Call status events:
 Public Sub Skype_CallStatus(ByRef aCall, ByVal aStatus)
   WScript.Echo ">Call " & aCall.Id & " status " & oSkype.Convert.CallStatusToText(aStatus)
 End Sub
Copyright © 2006 Skype Limited. All rights reserved.


Skype4COM: Related Pages

  • Modules
  • Classes
  • Files
  • Examples

Related Pages

Here is a list of all related documentation pages:
  • Error Codes
  • Version History
  • Using Skype4COM with Internet Explorer
  • Deprecated List


Skype4COM: Error Codes

  • Examples

Error Codes

  • 0x80040200 E_SKYPE_NOT_CONNECTED
  • 0x80040201 E_SKYPE_WAIT_TIMEOUT
  • 0x80040202 E_SKYPE_WAIT_FAILED
  • 0x80040203 E_SKYPE_PROTOCOL_ERROR
  • 0x80040204 E_SKYPE_CONNECTION_REFUSED
  • 0x80040205 E_SKYPE_PROTOCOL_VERSION
  • 0x80040206 E_SKYPE_RUN_FAILED
  • 0x80040207 E_SKYPE_NOT_INSTALLED


Skype4COM: Version History

Version History

1.0.38
  • fixed: crash running multiple instances of Skype.
1.0.37
  • changed: Disable using Skype4COM from Internet Explorer.
  • fixed: DLL registration on Vista and Windows 7
  • added: IChatMessage::Guid property.
1.0.36
  • fixed: IClient::IsRunning property (supports Skype 5.1 and later builds).
1.0.35
  • added UIPI message filter (Windows 7, Vista).
1.0.34
  • fixed bug in collection enumerators.
1.0.33
  • fixed memory leak in Skype class constructor.
1.0.32
  • fixed: IClient::Focus and open dialog commands did not focus Skype 4.0 window
1.0.30
  • fixed: IClient::IsRunning property.
1.0.29
  • added: _ISkypeEvents::SilentModeStatusChanged event.
  • added: _ISkypeEvents::UserAuthorizationRequestReceived event.
  • added: ISkype::PredictiveDialerCountry property.
  • bugfix: IChatMember::CanSetRoleTo always returned VARIANT_FALSE:
1.0.28
  • added: ICall::TargetIdentity property.
  • added: IChat::AcceptAdd method.
  • added: IChat::ActivityTimestamp property.
  • added: IChat::AlertString property.
  • added: IChat::Applicants property.
  • added: IChat::Blob property.
  • added: IChat::ClearRecentMessages method.
  • added: IChat::Description property.
  • added: IChat::DialogPartner property.
  • added: IChat::Disband method.
  • added: IChat::EnterPassword method.
  • added: IChat::GuideLines property.
  • added: IChat::Join method.
  • added: IChat::Kick method.
  • added: IChat::KickBan method.
  • added: IChat::MemberObjects property.
  • added: IChat::MyRole property.
  • added: IChat::MyStatus property.
  • added: IChat::Options property.
  • added: IChat::PasswordHint property.
  • added: IChat::SetPassword method.
  • added: IChat::TopicXML property.
  • added: IChat::TopicXML property.
  • added: IChat::Type property.
  • added: IClient::OpenLiveTab method.
  • added: ISettings::LoadAvatarFromFile method.
  • added: ISettings::ResetIdleTimer method.
  • added: ISettings::SaveAvatarToFile method.
  • added: ISkype::CreateChatUsingBlob method.
  • added: ISkype::FindChatUsingBlob method.
  • added: ISkype::FocusedContacts property.
  • added: IUser::IsVoicemailCapable property.
  • added: TChatMemberRole type.
  • added: TChatMyStatus type.
  • added: TChatOptions type.
  • added: TChatType type.
  • added: _ISkypeEvents::CallTransferStatusChanged event.
  • added: _ISkypeEvents::ChatMembersChanged event.
  • added: _ISkypeEvents::ChatMemberRoleChanged event.
  • added: interfaces IChatMember and IChatMemberCollection.
  • change: ISettings::RingToneStatus property settable.
  • change: calls to event handler are now serialised.
  • added: _ISkypeEvents::CallVideoStatusChanged event.
  • added: _ISkypeEvents::CallVideoSendStatusChanged event.
  • added: _ISkypeEvents::CallVideoReceiveStatusChanged event.
  • bugfix: #59913 Microphone stream redirection to port and file
1.0.27
  • added: ICall::CanTransfer property.
  • added: ICall::TransferStatus property.
  • added: ICall::TransferActive property.
  • added: ICall::TransferredBy property.
  • added: ICall::TransferredTo property.
  • added: ICall::Transfer method.
  • added: ISkype::ActiveFileTransfers property.
  • added: ISkype::FileTransfers property.
  • added: _ISkypeEvents::FileTransferStatusChanged event.
  • added: IUser::RichMoodText property.
  • added: IProfile::RichMoodText property.
  • fixed: _ISkypeEvents::GroupUsers event did not fire.
1.0.26
  • fixed: bugs in translation file.
  • fixed: IDL incompatibility with version 1.0.0.22
1.0.25
  • fixed: self-registration for LUA user.
  • fixed: ICall::InputDevice and ICall::OutputDevice caching problem.
  • fixed: ISkype::Protocol wrong value.
  • added: ISkype::ApiWrapperVersion property.
  • added: ISkype::SilentMode property.
  • added: IClient::Wallpaper property.
  • added: _ISkypeEvents::WallpaperChanged event.
1.0.24.0
  • added PluginEvent class.
  • added PluginMenuItem class.
  • added _ISkypeEvents::PluginEventClicked event.
  • added _ISkypeEvents::PluginMenuItemClicked event.
1.0.23.0
  • changed file versioning format.
  • added TChatMessageType::cmeEmoted.
  • added _ISkypeEvents::CallSeenStatusChanged event.
  • changed ICall::Seen property readable.
  • added ICall::ForwardedBy property.
  • changed IUser::DisplayName property is now writable.
  • fixed: bug in IProfile::CallSendToVM implementation.
1.0.0.22
  • added ISkype::AsyncSearchUsers method.
  • added ICall::InputDevice property.
  • added ICall::InputStatus property.
  • added ICall::OutputDevice property.
  • added ICall::CaptureMicDevice property.
  • added IUser::NumberOfAuthBuddies property.
  • added _ISkypeEvents::CallInputStatusChanged event.
  • added _ISkypeEvents::AsyncSearchUsersFinished event.
1.0.0.21
  • added IClient::OpenSmsDialog method.
  • added IProfile::ValidatedSmsNumbers property.
  • added ISkype::CreateSms property.
  • added ISkype::MissedSmss property.
  • added ISkype::SendSms method.
  • added ISkype::Smss property.
  • added SmsChunk class.
  • added SmsChunkCollection class.
  • added SmsMessage class.
  • added SmsMessageCollection class.
  • added SmsTarget class.
  • added SmsTargetCollection class.
  • fixed: bug in IChatMessage::Seen implementation.
1.0.0.14
  • added IProfile::IPCountry property.
  • fixed: bug in command cache implementation that caused strings to be truncated.
1.0.0.12
  • added ISkype::ApiSecurityContextEnabled property.
  • added ISkype::EnableApiSecurityContext method.
  • added ISkype::MissedVoicemails property.
  • added ICall::Rate property.
  • added ICall::RateCurrency property.
  • added ICall::RatePrecision property.
  • added IChat::Bookmarked property.
  • added IChat::Bookmark method.
  • added IChat::Unbookmark method.
  • added IChatMessage::Sender property.
  • added IGroup::Accept method.
  • added IGroup::Decline method.
  • added IGroup::Share method.
  • changed: ISettings::Language writable.
  • added IVoicemail::SetUnplayed property.
1.0.0.11
  • added CallChannel class.
  • added CallChannelCollection class.
  • added CallChannelManager class.
  • added CallChannelMessage class.
1.0.0.10
  • added _ISkypeEvents::UserMood event.
1.0.0.9
  • added HTML documentation


Skype4COM: Using Skype4COM with Internet Explorer

Using Skype4COM with Internet Explorer

Adding Skype4COM to a web page
Deprecated:
For security reasons default installation settings disable using Skype4COM in Internet Explorer. The following instructions are obsolete and apply to earlier versions only.
To add Skype4COM controls to a web page, use the OBJECT tag in the HTML code.
 <html>
 <body>
 <object id=Skype
         name=Skype
         height=0
         width=0
         classid=clsid:830690FC-BF2F-47A6-AC2D-330BCB402664
         codebase="http://www.yoursite.com/Skype4COM.dll" >
   <span style="color: red">Failed to load control.</span>
 </object>
 </body>
 </html>
Installing Skype4COM with Internet Explorer
Before you begin, ensure that Internet Explorer security policies are set to download signed ActiveX controls. Select Tools menu > Internet Options > Security tab and click the Custom Level button to display the ActiveX settings.
If downloading ActiveX controls is set to Prompt, when a user first visits a web page containing a Skype4COM object, Internet Explorer displays a warning.
The user must click the Install button to start the download. After the installation, the Internet Explorer page reloads, and Skype4COM is ready for use.
Skype4COM security policies for Internet Explorer
Internet Explorer defines five security zones for web content:
  • Local Machine (this zone is not visible in the Internet Explorer security tab)
  • Local Intranet
  • Trusted
  • Internet
  • Restricted
Skype4COM defines four API security contexts:
  • Voice services
  • Messaging services
  • Account services
  • Contact services
During installation, Skype4COM creates custom policies for each API context in each Internet Explorer security zone.

Security Zone

Voice API

Messaging API

Account API

Contact API

Local Machine

Allow

Allow

Allow

Allow

Local Intranet

Allow

Allow

Prompt

Allow

Trusted

Allow

Allow

Prompt

Allow

Internet

Prompt

Prompt

Prompt

Prompt

Restricted

Disallow

Disallow

Disallow

Disallow

If the zone setting for a security context is set to "Prompt", Skype4COM displays a window where the user must select whether to allow this context or not. For example, if a web page contains a Call Me button, and voice services for the Internet security zone are set to prompt, the following window appears:
The user receives multiple prompts if a web page contains more than one Skype API security context, for example a page with a Call Me button and a Chat to Me button, where the security policies for voice and messaging services are both set to Prompt.
If the user selects the Allow (first) or Disallow (last) option, the preference is saved as a host setting. When the user next visits this web page, Internet Explorer compares the security policies for the zone and the host, and applies the most secure policy. For example, if security for the zone is set to Prompt, and security for the host is set to Disable (user selected Disable on a previous visit to the web page), Internet Explorer applies the most secure policy, does not display a prompt window to the user, and does not enable the service.
Managing security policies
Custom security policies for web content zones are stored in the Windows registry for the current user. Skype4COM provides a window where you can view and change these settings. Type skype4com:openzonesettings into the Internet Explorer address bar to access the zone security settings.
Custom security policies entered by the user in prompt windows are stored in Windows registry for the current user. Skype4COM provides a window where you can view and change these settings. Type skype4com:openhostsettings into the Internet Explorer address bar to access the host security settings.


Skype4COM: Deprecated List

Deprecated List

Class Conversion
The SKYPE4COMLib::Conversion class is deprecated, support for multilanguage status codes support will be dropped in the future.

Member ICall::Status
Set ICall::Status is deprecated, use the ICall::Hold, ICall::Resume, ICall::Finish or ICall::Answer instead.

Member IChat::Status
ICall::Status is deprecated, use the IChat::Type and IChat::MyStatus instead.

Member ISettings::Avatar ([in, defaultvalue("1")] BSTR Id)
Use the ISettings::LoadAvatarFromFile instead.

Page Using Skype4COM with Internet Explorer
For security reasons default installation settings disable using Skype4COM in Internet Explorer. The following instructions are obsolete and apply to earlier versions only.


Skype4COM: Modules

Modules

Here is a list of all modules:
  • Skype4COM


Skype4COM: Skype4COM

Typedefs | Enumerations

Skype4COM

Typedefs

typedef enum TAttachmentStatus | TAttachmentStatus
typedef enum TConnectionStatus | TConnectionStatus
typedef enum TUserStatus | TUserStatus
typedef enum TCallFailureReason | TCallFailureReason
typedef enum TCallStatus | TCallStatus
typedef enum TCallType | TCallType
typedef enum TCallHistory | TCallHistory
typedef enum TCallVideoStatus | TCallVideoStatus
typedef enum TCallVideoSendStatus | TCallVideoSendStatus
typedef enum TCallIoDeviceType | TCallIoDeviceType
typedef enum TChatMessageType | TChatMessageType
typedef enum TChatMessageStatus | TChatMessageStatus
typedef enum TChatMemberRole | TChatMemberRole
typedef enum TUserSex | TUserSex
typedef enum TBuddyStatus | TBuddyStatus
typedef enum TOnlineStatus | TOnlineStatus
typedef enum TChatLeaveReason | TChatLeaveReason
typedef enum TChatStatus | TChatStatus
typedef enum TChatType | TChatType
typedef enum TChatMyStatus | TChatMyStatus
typedef enum TChatOptions | TChatOptions
typedef enum TVoicemailType | TVoicemailType
typedef enum TVoicemailStatus | TVoicemailStatus
typedef enum
TVoicemailFailureReason 		TVoicemailFailureReason
typedef enum TGroupType | TGroupType
typedef enum TCallChannelType | TCallChannelType
typedef enum TApiSecurityContext | TApiSecurityContext
typedef enum TSmsMessageType | TSmsMessageType
typedef enum TSmsMessageStatus | TSmsMessageStatus
typedef enum TSmsFailureReason | TSmsFailureReason
typedef enum TSmsTargetStatus | TSmsTargetStatus
typedef enum TPluginContext | TPluginContext
typedef enum TPluginContactType | TPluginContactType
typedef enum TFileTransferType | TFileTransferType
typedef enum TFileTransferStatus | TFileTransferStatus
typedef enum
TFileTransferFailureReason 		TFileTransferFailureReason

Enumerations

enum TAttachmentStatus {
apiAttachUnknown = -1, apiAttachSuccess = 0, apiAttachPendingAuthorization = 1, apiAttachRefused = 2,
apiAttachNotAvailable = 3, apiAttachAvailable = 4
}
enum TConnectionStatus {
conUnknown = -1, conOffline = 0, conConnecting = 1, conPausing = 2,
conOnline = 3
}
enum TUserStatus {
cusUnknown = -1, cusOffline = 0, cusOnline = 1, cusAway = 2,
cusNotAvailable = 3, cusDoNotDisturb = 4, cusInvisible = 5, cusLoggedOut = 6,
cusSkypeMe = 7
}
enum TCallFailureReason {
cfrUnknown = -1, cfrMiscError = 0, cfrUserDoesNotExist = 1, cfrUserIsOffline = 2,
cfrNoProxyFound = 3, cfrSessionTerminated = 4, cfrNoCommonCodec = 5, cfrSoundIOError = 6,
cfrRemoteDeviceError = 7, cfrBlockedByRecipient = 8, cfrRecipientNotFriend = 9, cfrNotAuthorizedByRecipient = 10,
cfrSoundRecordingError = 11
}
enum TCallStatus {
clsUnknown = -1, clsUnplaced = 0, clsRouting = 1, clsEarlyMedia = 2,
clsFailed = 3, clsRinging = 4, clsInProgress = 5, clsOnHold = 6,
clsFinished = 7, clsMissed = 8, clsRefused = 9, clsBusy = 10,
clsCancelled = 11, clsLocalHold = 12, clsRemoteHold = 13, clsVoicemailBufferingGreeting = 14,
clsVoicemailPlayingGreeting = 15, clsVoicemailRecording = 16, clsVoicemailUploading = 17, clsVoicemailSent = 18,
clsVoicemailCancelled = 19, clsVoicemailFailed = 20, clsTransferring = 21, clsTransferred = 22
}
enum TCallType {
cltUnknown = -1, cltIncomingPSTN = 0, cltOutgoingPSTN = 1, cltIncomingP2P = 2,
cltOutgoingP2P = 3
}
enum | TCallHistory { chsAllCalls = 0, chsMissedCalls = 1, chsIncomingCalls = 2, chsOutgoingCalls = 3 }
enum TCallVideoStatus {
cvsUnknown = -1, cvsNone = 0, cvsSendEnabled = 1, cvsReceiveEnabled = 2,
cvsBothEnabled = 3
}
enum TCallVideoSendStatus {
vssUnknown = -1, vssNotAvailable = 0, vssAvailable = 1, vssStarting = 2,
vssRejected = 3, vssRunning = 4, vssStopping = 5, vssPaused = 6
}
enum | TCallIoDeviceType { callIoDeviceTypeUnknown = -1, callIoDeviceTypeSoundcard = 0, callIoDeviceTypePort = 1, callIoDeviceTypeFile = 2 }
enum TChatMessageType {
cmeUnknown = -1, cmeCreatedChatWith = 0, cmeSawMembers = 1, cmeAddedMembers = 2,
cmeSetTopic = 3, cmeSaid = 4, cmeLeft = 5, cmeEmoted = 6,
cmePostedContacts = 7, cmeGapInChat = 8, cmeSetRole = 9, cmeKicked = 10,
cmeSetOptions = 11, cmeKickBanned = 12, cmeJoinedAsApplicant = 13, cmeSetPicture = 14,
cmeSetGuidelines = 15
}
enum TChatMessageStatus {
cmsUnknown = -1, cmsSending = 0, cmsSent = 1, cmsReceived = 2,
cmsRead = 3
}
enum TChatMemberRole {
chatMemberRoleUnknown = -1, chatMemberRoleCreator = 0, chatMemberRoleMaster = 1, chatMemberRoleHelper = 2,
chatMemberRoleUser = 3, chatMemberRoleListener = 4, chatMemberRoleApplicant = 5
}
enum | TUserSex { usexUnknown = -1, usexMale = 0, usexFemale = 1 }
enum TBuddyStatus {
budUnknown = -1, budNeverBeenFriend = 0, budDeletedFriend = 1, budPendingAuthorization = 2,
budFriend = 3
}
enum TOnlineStatus {
olsUnknown = -1, olsOffline = 0, olsOnline = 1, olsAway = 2,
olsNotAvailable = 3, olsDoNotDisturb = 4, olsSkypeOut = 5, olsSkypeMe = 6
}
enum TChatLeaveReason {
leaUnknown = -1, leaUserNotFound = 0, leaUserIncapable = 1, leaAdderNotFriend = 2,
leaAddedNotAuthorized = 3, leaAddDeclined = 4, leaUnsubscribe = 5
}
enum TChatStatus {
chsUnknown = -1, chsLegacyDialog = 0, chsDialog = 1, chsMultiNeedAccept = 2,
chsMultiSubscribed = 3, chsUnsubscribed = 4
}
enum TChatType {
chatTypeUnknown = -1, chatTypeDialog = 0, chatTypeLegacyDialog = 1, chatTypeLegacyUnsubscribed = 2,
chatTypeMultiChat = 3, chatTypeSharedGroup = 4
}
enum TChatMyStatus {
chatStatusUnknown = -1, chatStatusConnecting = 0, chatStatusWaitingRemoteAccept = 1, chatStatusAcceptRequired = 2,
chatStatusPasswordRequired = 3, chatStatusSubscribed = 4, chatStatusUnsubscribed = 5, chatStatusDisbanded = 6,
chatStatusQueuedBecauseChatIsFull = 7, chatStatusApplicationDenied = 8, chatStatusKicked = 9, chatStatusBanned = 10,
chatStatusRetryConnecting = 11
}
enum TChatOptions {
chatOptionJoiningEnabled = 1, chatOptionJoinersBecomeApplicants = 2, chatOptionJoinersBecomeListeners = 4, chatOptionHistoryDisclosed = 8,
chatOptionUsersAreListeners = 16, chatOptionTopicAndPictureLockedForUsers = 32
}
enum TVoicemailType {
vmtUnknown = -1, vmtIncoming = 0, vmtDefaultGreeting = 1, vmtCustomGreeting = 2,
vmtOutgoing = 3
}
enum TVoicemailStatus {
vmsUnknown = -1, vmsNotDownloaded = 0, vmsDownloading = 1, vmsUnplayed = 2,
vmsBuffering = 3, vmsPlaying = 4, vmsPlayed = 5, vmsBlank = 6,
vmsRecording = 7, vmsRecorded = 8, vmsUploading = 9, vmsUploaded = 10,
vmsDeleting = 11, vmsFailed = 12
}
enum TVoicemailFailureReason {
vmrUnknown = -1, vmrNoError = 0, vmrMiscError = 1, vmrConnectError = 2,
vmrNoPrivilege = 3, vmrNoVoicemail = 4, vmrFileReadError = 5, vmrFileWriteError = 6,
vmrRecordingError = 7, vmrPlaybackError = 8
}
enum TGroupType {
grpUnknown = -1, grpCustomGroup = 0, grpAllUsers = 1, grpAllFriends = 2,
grpSkypeFriends = 3, grpSkypeOutFriends = 4, grpOnlineFriends = 5, grpPendingAuthorizationFriends = 6,
grpRecentlyContactedUsers = 7, grpUsersWaitingMyAuthorization = 8, grpUsersAuthorizedByMe = 9, grpUsersBlockedByMe = 10,
grpUngroupedFriends = 11, grpSharedGroup = 12, grpProposedSharedGroup = 13
}
enum | TCallChannelType { cctUnknown = -1, cctDatagram = 0, cctReliable = 1 }
enum TApiSecurityContext {
apiContextUnknown = 0x0000, apiContextVoice = 0x0001, apiContextMessaging = 0x0002, apiContextAccount = 0x0004,
apiContextContacts = 0x0008
}
enum TSmsMessageType {
smsMessageTypeUnknown = -1, smsMessageTypeIncoming = 0, smsMessageTypeOutgoing = 1, smsMessageTypeCCRequest = 2,
smsMessageTypeCCSubmit = 3
}
enum TSmsMessageStatus {
smsMessageStatusUnknown = -1, smsMessageStatusReceived = 0, smsMessageStatusRead = 1, smsMessageStatusComposing = 2,
smsMessageStatusSendingToServer = 3, smsMessageStatusSentToServer = 4, smsMessageStatusDelivered = 5, smsMessageStatusSomeTargetsFailed = 6,
smsMessageStatusFailed = 7
}
enum TSmsFailureReason {
smsFailureReasonUnknown = -1, smsFailureReasonMiscError = 0, smsFailureReasonServerConnectFailed = 1, smsFailureReasonNoSmsCapability = 2,
smsFailureReasonInsufficientFunds = 3, smsFailureReasonInvalidConfirmationCode = 4, smsFailureReasonUserBlocked = 5, smsFailureReasonIPBlocked = 6,
smsFailureReasonNodeBlocked = 7
}
enum TSmsTargetStatus {
smsTargetStatusUnknown = -1, smsTargetStatusUndefined = 0, smsTargetStatusAnalyzing = 1, smsTargetStatusAcceptable = 2,
smsTargetStatusNotRoutable = 3, smsTargetStatusDeliveryPending = 4, smsTargetStatusDeliverySuccessful = 5, smsTargetStatusDeliveryFailed = 6
}
enum TPluginContext {
pluginContextUnknown = -1, pluginContextChat = 0, pluginContextCall = 1, pluginContextContact = 2,
pluginContextMyself = 3, pluginContextTools = 4
}
enum | TPluginContactType { pluginContactTypeUnknown = -1, pluginContactTypeAll = 0, pluginContactTypeSkype = 1, pluginContactTypeSkypeOut = 2 }
enum | TFileTransferType { fileTransferTypeIncoming = 0, fileTransferTypeOutgoing = 1 }
enum TFileTransferStatus {
fileTransferStatusNew = 0, fileTransferStatusConnecting = 1, fileTransferStatusWaitingForAccept = 2, fileTransferStatusTransferring = 3,
fileTransferStatusTransferringOverRelay = 4, fileTransferStatusPaused = 5, fileTransferStatusRemotelyPaused = 6, fileTransferStatusCancelled = 7,
fileTransferStatusCompleted = 8, fileTransferStatusFailed = 9
}
enum TFileTransferFailureReason {
fileTransferFailureReasonSenderNotAuthorized = 1, fileTransferFailureReasonRemotelyCancelled = 2, fileTransferFailureReasonFailedRead = 3, fileTransferFailureReasonFailedRemoteRead = 4,
fileTransferFailureReasonFailedWrite = 5, fileTransferFailureReasonFailedRemoteWrite = 6, fileTransferFailureReasonRemoteDoesNotSupportFT = 7, fileTransferFailureReasonRemoteOfflineTooLong = 8
}

Detailed Description

Skype4COM is a COM library that enables you to develop applications using the Skype API in a range of ActiveX programming environments and scripting languages.

Enumeration Type Documentation

enum TApiSecurityContext

contains API security contexts for Internet Explorer.

Enumerator:
apiContextUnknown

indicates that the API security context is unknown.

apiContextVoice

relates to call and voicemail commands and events

apiContextMessaging

relates to text and app2app messaging commands and events

apiContextAccount

relates to user profile and global settings commands and events

apiContextContacts

relates to contacts commands and events

enum TAttachmentStatus

contains the status of an attachment with the Skype API.

Enumerator:
apiAttachUnknown

indicates that the attachment status is unknown.

apiAttachSuccess

indicates that the client is successfully attached.

apiAttachPendingAuthorization

indicates that Skype has acknowledged a connection request and is waiting for user authorisation.

apiAttachRefused

indicates that a user has explicitly denied access to the client.

apiAttachNotAvailable

indicates that the Skype API is not available.

apiAttachAvailable

indicates that the Skype API is available.

enum TBuddyStatus

contains the status of a user.

Enumerator:
budUnknown

indicates the status of a contact is unknown.

budNeverBeenFriend

indicates the contact has never been in the user's contactlist.

budDeletedFriend

indicates the contact was deleted from the contact list.

budPendingAuthorization

indicates the contact is pending authorization.

budFriend

indicates the contact is in a contact list.

enum TCallChannelType

contains the call channel type.

Enumerator:
cctUnknown

indicates that the call channel type is unknown.

cctDatagram

indicates that the call channel is a datagram type channel.

cctReliable

indicates that the call channel is a reliable type channel.

enum TCallFailureReason

contains the reason a call fails.

Enumerator:
cfrUnknown

indicates the reason for call failure is unknown.

cfrMiscError

indicates the call failed because of a miscellaneous error.

cfrUserDoesNotExist

indicates the call failed because the user or phone number does not exist.

cfrUserIsOffline

indicates the call failed because the user is offline.

cfrNoProxyFound

indicates the call failed because no proxy was found.

cfrSessionTerminated

indicates the call failed because the session terminated.

cfrNoCommonCodec

indicates the call failed because no common codec was found.

cfrSoundIOError

indicates the call failed because of an audio I/O error.

cfrRemoteDeviceError

indicates the call failed because of a problem with the remote sound device.

cfrBlockedByRecipient

indicates the recipient blocked the call.

cfrRecipientNotFriend

indicates the call failed because the recipient is not a friend.

cfrNotAuthorizedByRecipient

indicates the call failed because the user is not authorized by the recipient.

cfrSoundRecordingError

indicates the call failed because of a sound recording error.

enum TCallHistory

defines call types in call history.

Enumerator:
chsAllCalls

indicates all calls in call history.

chsMissedCalls

indicates all missed calls in call history.

chsIncomingCalls

indicates all incoming calls in call history.

chsOutgoingCalls

indicates all outgoing calls in call history.

enum TCallIoDeviceType

contains the call io device types.

Enumerator:
callIoDeviceTypeUnknown

indicates that device is unknown.

callIoDeviceTypeSoundcard

indicates soundcard.

callIoDeviceTypePort

indicates local port.

callIoDeviceTypeFile

indicates local file.

enum TCallStatus

contains the status of a call.

Enumerator:
clsUnknown

indicates the call status is unknown.

clsUnplaced

indicates the call was not placed.

clsRouting

indicates the call is in the process of being routed.

clsEarlyMedia

indicates that early media is currently being played, such as recorded speech.

clsFailed

indicates the call failed.

clsRinging

indicates the call is in the process of ringing.

clsInProgress

indicates the call is in progress.

clsOnHold

indicates the call is placed on hold.

clsFinished

indicates the call is finished.

clsMissed

indicates the call was missed.

clsRefused

indicates the call was refused.

clsBusy

indicates the call destination was busy.

clsCancelled

indicates the call was cancelled.

clsLocalHold

indicates the call is placed on hold by the local user.

clsRemoteHold

indicates the call is placed on hold by the remote user.

clsVoicemailBufferingGreeting

indicates that voicemail is preparing a greeting.

clsVoicemailPlayingGreeting

indicates that voicemail is playing a greeting.

clsVoicemailRecording

indicates that voicemail is recording a message.

clsVoicemailUploading

indicates that voicemail is being loaded to the server.

clsVoicemailSent

indicates that voicemail has been sent.

clsVoicemailCancelled

indicates that voicemail has been cancelled.

clsVoicemailFailed

indicates that voicemail failed.

clsTransferring

indicates that call is beeing transferred.

clsTransferred

indicates that call has been transferred.

enum TCallType

contains information about call types.

Enumerator:
cltUnknown

indicates the call type is unknown.

cltIncomingPSTN

indicates the call is an incoming call from the PSTN.

cltOutgoingPSTN

indicates the call is an outgoing call to the PSTN.

cltIncomingP2P

indicates the call is an incoming Skype call.

cltOutgoingP2P

indicates the call is an outgoing Skype call.

enum TCallVideoSendStatus

contains the status for video send streams.

Enumerator:
vssUnknown

indicates that video send status is unknown.

vssNotAvailable

indicates that video send is not available because video is disabled or a webcam is unplugged.

vssAvailable

indicates that video send is available but the video is not running.

vssStarting

indicates that video is sending but not yet running at full speed.

vssRejected

indicates that video send was rejected by the receiver.

vssRunning

indicates that video send is actively running.

vssStopping

indicates that video send is in the process of stopping but not halted yet.

vssPaused

indicates that video send is placed on hold.

enum TCallVideoStatus

contains the video status of a call.

Enumerator:
cvsUnknown

indicates that call video status is unknown.

cvsNone

indicates that call video status is that video is not enabled.

cvsSendEnabled

indicates that call video status is that video send is enabled.

cvsReceiveEnabled

indicates that call video status is that video receive is enabled.

cvsBothEnabled

indicates that call video status is that video send and receive are enabled.

enum TChatLeaveReason

contains the reason a user leaves a chat.

Enumerator:
leaUnknown

indicates the reason for leaving a chat is unknown.

leaUserNotFound

indicates the reason for leaving a chat is that a user was not found.

leaUserIncapable

indicates the reason for leaving a chat is that a user has an old version of Skype which does not support multichat.

leaAdderNotFriend

indicates the reason for leaving a chat is that the recipient accepts messages from contacts only and the sender is not in this contact list.

leaAddedNotAuthorized

indicates the reason for leaving a chat is the recipient accepts authorised contacts only and has not authorised the sender.

leaAddDeclined

indicates that the invited user declined the chat invitation.

Note:
This message type existed in earlier versions of Skype, and is not used any more.
leaUnsubscribe

indicates the reason for leaving is the user unsubscribed from the chat.

enum TChatMemberRole

Chat member roles.

Enumerator:
chatMemberRoleUnknown

Unknown role.

chatMemberRoleCreator

Chat creator.

chatMemberRoleMaster

Chat master.

chatMemberRoleHelper

Chat helper.

chatMemberRoleUser

Chat user.

chatMemberRoleListener

Chat listener.

chatMemberRoleApplicant

Chat applicant.

enum TChatMessageStatus

contains the status of a chat message.

Enumerator:
cmsUnknown

indicates the status of the chat message is unknown.

cmsSending

indicates the message is in the process of being sent.

cmsSent

indicates the message has been sent.

cmsReceived

indicates the message has been received.

cmsRead

indicates the message has been read.

enum TChatMessageType

Chat message types.

Enumerator:
cmeUnknown

Unknown message type.

cmeCreatedChatWith

Chat created.

cmeSawMembers

Saw chat members.

cmeAddedMembers

Added chat members.

cmeSetTopic

Chat topic changed.

cmeSaid

Sent message.

cmeLeft

Left the chat.

cmeEmoted

Sent emoted message.

cmePostedContacts

Posted contacts.

cmeGapInChat

Indicates gap in chat.

cmeSetRole

Member role changed.

cmeKicked

Member kicked from chat.

cmeSetOptions

Chat options changed.

cmeKickBanned

Member kicked and banned from chat.

cmeJoinedAsApplicant

Member joined as applicant.

cmeSetPicture

Chat picture changed.

cmeSetGuidelines

Chat guidelines changed.

enum TChatMyStatus

Chat status.

Enumerator:
chatStatusUnknown

Unknown status.

chatStatusConnecting

Connecting to chat.

chatStatusWaitingRemoteAccept

Waiting for accept.

chatStatusAcceptRequired

Accept is required.

chatStatusPasswordRequired

Password is required.

chatStatusSubscribed

Subscribed to chat.

chatStatusUnsubscribed

Unsubscribed from chat.

chatStatusDisbanded

Chat was disbanded.

chatStatusQueuedBecauseChatIsFull

Queued because the chat is full.

chatStatusApplicationDenied

Application was denied.

chatStatusKicked

Kicked from chat.

chatStatusBanned

Banned from chat.

chatStatusRetryConnecting

Trying to reconnect.

enum TChatOptions

Chat options.

Enumerator:
chatOptionJoiningEnabled

Joining enabled.

chatOptionJoinersBecomeApplicants

Joiners become applicants.

chatOptionJoinersBecomeListeners

Joiners become listeners.

chatOptionHistoryDisclosed

History disclosed.

chatOptionUsersAreListeners

Users are listeners.

chatOptionTopicAndPictureLockedForUsers

Topic and picture are locked for users.

enum TChatStatus

contains the status of a chat.

Enumerator:
chsUnknown

indicates the status of a chat is unknown.

chsLegacyDialog

indicates the chat is in a legacy window mode which does not support multichats.

chsDialog

indicates the chat is in a chat window.

chsMultiNeedAccept

indicates the chat is waiting for acceptance by multiple users.

chsMultiSubscribed

indicates the chat is subscribed to by multiple users.

chsUnsubscribed

indicates the chat is unsubscribed.

enum TChatType

Chat types.

Enumerator:
chatTypeUnknown

Unknown type.

chatTypeDialog

Chat with two participants.

chatTypeLegacyDialog

Legacy dialog.

chatTypeLegacyUnsubscribed

Legacy dialog (unsubscribed).

chatTypeMultiChat

Chat with multiple members.

chatTypeSharedGroup

Chat used to syncronize shared groups.

enum TConnectionStatus

indicates the status of a network connection.

Enumerator:
conUnknown

indicates that the status of a connection is unknown.

conOffline

indicates that a connection does not exist.

conConnecting

indicates that a connection is in the process of being established.

conPausing

indicates that a connection is pausing.

conOnline

indicates that a connection exists.

enum TFileTransferFailureReason

File transfer failure reason codes.

Enumerator:
fileTransferFailureReasonSenderNotAuthorized

Sender is not authorized by remote user.

fileTransferFailureReasonRemotelyCancelled

Remote user cancelled the file transfer.

fileTransferFailureReasonFailedRead

File read error.

fileTransferFailureReasonFailedRemoteRead

Remote file read error.

fileTransferFailureReasonFailedWrite

File write error.

fileTransferFailureReasonFailedRemoteWrite

Remote file write error.

fileTransferFailureReasonRemoteDoesNotSupportFT

Remote party does not support file transfer.

fileTransferFailureReasonRemoteOfflineTooLong

Remote party has been offline too long.

enum TFileTransferStatus

File transfer status.

Enumerator:
fileTransferStatusNew

A new file transfer.

fileTransferStatusConnecting

Connecting to user.

fileTransferStatusWaitingForAccept

Waiting user to accept the file transfer.

fileTransferStatusTransferring

The file is beeing transferred.

fileTransferStatusTransferringOverRelay

The file is beeing transferred over relay.

fileTransferStatusPaused

The file transfer is paused.

fileTransferStatusRemotelyPaused

The file transfer is paused by remote user.

fileTransferStatusCancelled

The file transfer has been cancelled.

fileTransferStatusCompleted

The file transfer completed.

fileTransferStatusFailed

The file transfer failed.

enum TFileTransferType

File transfer types.

Enumerator:
fileTransferTypeIncoming

Incoming file transfer.

fileTransferTypeOutgoing

Outgoing file transfer.

enum TGroupType

contains the group type.

Enumerator:
grpUnknown

indicates the group type is unknown.

grpCustomGroup

indicates the group type is user-defined.

grpAllUsers

indicates the group type is all other users a user knows about, including users in the contactlist, users recently contacted, and blocked users.

grpAllFriends

indicates the group type is all contacts in the user's contactlists.

grpSkypeFriends

indicates the group type is Skype contacts in the contactlist.

grpSkypeOutFriends

indicates the group type is SkypeOut contacts in the contactlist.

grpOnlineFriends

indicates the group type is Skype contacts in the contactlist who are online.

grpPendingAuthorizationFriends

indicates the group type is contacts in the contactlist who have not yet authorized the user.

grpRecentlyContactedUsers

indicates the group type is contacts the user has conversed with recently, including non-friends.

grpUsersWaitingMyAuthorization

indicates the group type is contacts who are awaiting response to an authorisation request, including non-friends.

grpUsersAuthorizedByMe

indicates the group type is all authorised contacts, including non-friends.

grpUsersBlockedByMe

indicates the group type is all blocked contacts, including non-friends.

grpUngroupedFriends

indicates the group type is all contacts in the contactlist that do not belong to any custom group.

grpSharedGroup

indicates the group type is shared group.

grpProposedSharedGroup

indicates the group type is proposed shared group.

enum TOnlineStatus

contains the online status of a user.

Enumerator:
olsUnknown

indicates the online status of the user is unknown.

olsOffline

indicates the user is offline (not connected).

olsOnline

indicates the user is online.

olsAway

indicates the user is away (has been inactive for certain period).

olsNotAvailable

indicates the user is not available.

olsDoNotDisturb

indicates the user is in do not disturb mode.

olsSkypeOut

indicates the user is in the SkypeOut contact list.

olsSkypeMe

indicates the user is in SkypeMe mode.

enum TPluginContactType

This property contains the contact type for the TPluginContext::pluginContextContact

Enumerator:
pluginContactTypeUnknown

This value indicates that the plug-in contact type is undefined.

pluginContactTypeAll

This value indicates that the plug-in is available for all contacts.

pluginContactTypeSkype

This value indicates that the plug-in is available for Skype contacts.

pluginContactTypeSkypeOut

This value indicates that the plug-in is available for SkypeOut contacts.

enum TPluginContext

contains the plug-in context.

Enumerator:
pluginContextUnknown

This value indicates that the plug-in context is undefined.

pluginContextChat

This value indicates that the plug-in works with chats.

pluginContextCall

This value indicates that the plug-in works with calls.

pluginContextContact

This value indicates that the plug-in works with contact list items.

pluginContextMyself

This value indicates that the plug-in is a personal plug-in that works for a user who is logged into Skype.

pluginContextTools

This value indicates that the plug-in is available as a generic tool.

enum TSmsFailureReason

contains the reason an SMS message failed.

Enumerator:
smsFailureReasonUnknown

indicates the SMS message failed for an unknown reason.

smsFailureReasonMiscError

indicates the SMS message failed due to a miscellaneous error.

smsFailureReasonServerConnectFailed

indicates a failure to connect to the server.

smsFailureReasonNoSmsCapability

indicates the user has no SMS capability.

smsFailureReasonInsufficientFunds

indicates the user does not have sufficent funds to send an SMS message.

smsFailureReasonInvalidConfirmationCode

indicates the SMS message has an invalid confirmation code.

smsFailureReasonUserBlocked

indicates the SMS message failed because the user is blocked by the SMS service.

smsFailureReasonIPBlocked

indicates the SMS message failed because the IP address is blocked by the SMS service.

smsFailureReasonNodeBlocked

indicates the SMS message failed because the node is blocked by the SMS service.

enum TSmsMessageStatus

contains the status of an SMS message.

Enumerator:
smsMessageStatusUnknown

indicates the SMS message status is unknown.

smsMessageStatusReceived

indicates the SMS message was received.

smsMessageStatusRead

indicates the SMS message was read.

smsMessageStatusComposing

indicates the user is composing a SMS message.

smsMessageStatusSendingToServer

indicates that Skype is sending an SMS message to the server.

smsMessageStatusSentToServer

indicates an SMS message was sent to the server.

smsMessageStatusDelivered

indicates an SMS message was delivered.

smsMessageStatusSomeTargetsFailed

indicates an SMS message failed to reach some targets.

smsMessageStatusFailed

indicates an SMS message failed.

enum TSmsMessageType

contains the type of the SMS message.

Enumerator:
smsMessageTypeUnknown

indicates the SMS message is of an unknown type.

smsMessageTypeIncoming

indicates an incoming SMS message.

smsMessageTypeOutgoing

indicates an outgoing SMS message.

smsMessageTypeCCRequest

indicates the SMS message is a confirmation code request.

smsMessageTypeCCSubmit

indicates the SMS message is a confirmation code reply.

enum TSmsTargetStatus

contains the status of the target of an SMS message.

Enumerator:
smsTargetStatusUnknown

indicates the status of the target is unknown.

smsTargetStatusUndefined

indicates the status of the target is undefined.

smsTargetStatusAnalyzing

indicates that Skype is analyzing the target number.

smsTargetStatusAcceptable

Indicates the target number is acceptable.

smsTargetStatusNotRoutable

indicates that there is no route to the target.

smsTargetStatusDeliveryPending

indicates that delivery to the target is pending.

smsTargetStatusDeliverySuccessful

indicates the message was delivered to the target.

smsTargetStatusDeliveryFailed

indicates the SMS message failed to be delivered to the target.

enum TUserSex

contains information about the sex of a user.

Enumerator:
usexUnknown

indicates the sex of the user is unknown.

usexMale

indicates the user is male.

usexFemale

indicates the user is female.

enum TUserStatus

contains the Skype user status.

Enumerator:
cusUnknown

indicates the user status is unknown.

cusOffline

indicates the user is offline.

cusOnline

indicates the user is online.

cusAway

indicates the user is away.

cusNotAvailable

indicates the user is not available.

cusDoNotDisturb

indicates the user is in do not disturb mode.

cusInvisible

indicates the user is invisible to others.

cusLoggedOut

indicates the user is logged out.

cusSkypeMe

indicates the user is in SkypeMe mode.

enum TVoicemailFailureReason

contains the reason for voicemail failure.

Voicemail failure reasons.

Enumerator:
vmrUnknown

indicates the reason for failure is unknown.

vmrNoError

indicates the reason for failure is none.

vmrMiscError

indicates the reason for failure is due to a miscellaneous error.

vmrConnectError

indicates the reason for failure is due to a connection error.

vmrNoPrivilege

indicates the reason for failure is the user has no voicemail service.

vmrNoVoicemail

indicates the reason for failure is there is no such voicemail.

vmrFileReadError

indicates the reason for failure is due to an error reading the file.

vmrFileWriteError

indicates the reason for failure is due to an error writing the file.

vmrRecordingError

indicates the reason for failure is due to a recording error.

vmrPlaybackError

indicates the reason for failure is due to a playback error.

enum TVoicemailStatus

contains the status of a voicemail.

Voicemail status.

Enumerator:
vmsUnknown

indicates that voicemail status is unknown.

vmsNotDownloaded

indicates that voicemail status is downloaded.

vmsDownloading

indicates that voicemail status is in the process of downloading.

vmsUnplayed

indicates that voicemail status is not played.

vmsBuffering

indicates that voicemail status is buffering.

vmsPlaying

indicates that voicemail status is playing.

vmsPlayed

indicates that voicemail status has been played.

vmsBlank

indicates that voicemail status is blank.

vmsRecording

indicates that voicemail status is recording.

vmsRecorded

indicates that voicemail status has been recorded.

vmsUploading

indicates that voicemail status is uploading.

vmsUploaded

indicates that voicemail status has been uploaded.

vmsDeleting

indicates that voicemail status is in the process of being deleted.

vmsFailed

indicates that voicemail status is failed.

enum TVoicemailType

defines voicemail types.

Enumerator:
vmtUnknown

indicates the voicemail type is unknown.

vmtIncoming

indicates the voicemail type is incoming.

vmtDefaultGreeting

indicates the voicemail type is the default voicemail greeting.

vmtCustomGreeting

indicates the voicemail type is a custom voicemail greeting.

vmtOutgoing

indicates the voicemail type is an outgoing voicemail.


Skype4COM: Class List

  • Class List
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
_ICallChannelManagerEvents | CallChannelManager event source interface
_ISkypeEvents | Skype event source interface
Application | This class enables two applications sharing the same name to communicate over the Skype network
ApplicationStream | This class manages application streams
ApplicationStreamCollection | This class manages application stream collections
Call | This class manages calls and call properties
CallChannel | This class forms a logical connection between the ApplicationStream and Call objects
CallChannelCollection | Container class for CallChannel objects
CallChannelManager | This class manages Call data channels
CallChannelMessage | This class manages CallChannel messages
CallCollection | This class manages Call collections
Chat | This class manages chats
ChatCollection | This class manages Chat collections
ChatMember | This class manages chat member
ChatMemberCollection | This class manages chat member collections
ChatMessage | This class manages chat messages
ChatMessageCollection | This class manages chat message collections
Client | This class controls features related to the Skype user interface
Command | This class manages Skype API command objects
Conference | This class manages conference calls
ConferenceCollection | This class manages conference collections
Conversion | This class converts text to constant values and converts constant values to text
Group | This class manages contact groups
GroupCollection | This class manages collections of Group objects
IApplication | Application class default interface
IApplicationStream | ApplicationStream class default interface
IApplicationStreamCollection | ApplicationStreamCollection class default interface
ICall | Call class default interface
ICallChannel | CallChannel class default interface
ICallChannelCollection | CallChannelCollection class default interface
ICallChannelManager | CallChannelManager class default interface
ICallChannelMessage | CallChannelMessage class default interface
ICallCollection | CallCollection class default interface
IChat | Chat class default interface
IChatCollection | ChatCollection class default interface
IChatMember | ChatMember class default interface
IChatMemberCollection | ChatMemberCollection class default interface
IChatMessage | ChatMessage class default interface
IChatMessageCollection | ChatMessageCollection class default interface
IClient | Client class default interface
ICommand | Command class default interface
IConference | Conference class default interface
IConferenceCollection | ConferenceCollection class default interface
IConversion | Conversion class default interface
IFileTransfer | File transfer object default interface
IFileTransferCollection | File transfer collection class default interface
IGroup | Group class default interface
IGroupCollection | GroupCollection class default interface
IParticipant | Participant class default interface
IParticipantCollection | ParticipantCollection class default interface
IPluginEvent | This is the default interface for the PluginEvent class
IPluginMenuItem | Class PluginMenuItem default interface
IProfile | Profile class default interface
ISettings | Settings class default interface
ISkype | Skype is the default interface for the class
ISmsChunk | SmsChunk is the default interface forthis class
ISmsChunkCollection | SmsChunkCollection is the default interface for this class
ISmsMessage | SmsMessage is the default interface for this class
ISmsMessageCollection | SmsMessageCollection is the default interface for this class
ISmsTarget | SmsTarget is the default interface for this class
ISmsTargetCollection | SmsTargetCollection is the default interface for this class
IUser | User class default interface. This interface enables you to read user properties
IUserCollection | UserCollection class default interface
IVoicemail | Voicemail class default interface
IVoicemailCollection | VoicemailCollection class default interface
Participant | This class manages participants in a conference call
ParticipantCollection | This class manages collections of participants in a conference call
PluginEvent | This class manages plug-in event
PluginMenuItem | Plugin menu item
Profile | This class manages the user profile
Settings | This class manages the Skype API general parameters
Skype | Skype API COM wrapper
SmsChunk | SMS message chunk
SmsChunkCollection | Collection class for SmsChunk objects
SmsMessage | SMS message
SmsMessageCollection | Collection class for SMS messages
SmsTarget | SMS message target
SmsTargetCollection | Collection class for SMS targets
User | This class manages user properties
UserCollection | User collection
Voicemail | This class manages Skype voicemail
VoicemailCollection | Voicemail collection


Skype4COM: _ICallChannelManagerEvents Interface Reference

Public Member Functions

_ICallChannelManagerEvents Interface Reference

CallChannelManager event source interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Channels ([in] ICallChannelManager *pManager,[in] ICallChannelCollection *pChannels)
This event indicates a change in the call channels.
HRESULT | Message ([in] ICallChannelManager *pManager,[in] ICallChannel *pChannel,[in] ICallChannelMessage *pMessage)
This event indicates that a call channel message has been received.
HRESULT | Created ()
This event indicates that the Application context was successfuly created.

Detailed Description

CallChannelManager event source interface.

Member Function Documentation

HRESULT Channels | ( | [in] ICallChannelManager * | pManager,
 |  | [in] ICallChannelCollection * | pChannels
 | ) |  |

This event indicates a change in the call channels.

Parameters:
[in] | pManager | contains the interface pointer for the CallChannelManager object.
[in] | pChannels | contains the interface pointer for the CallChannelCollection object.
HRESULT Message | ( | [in] ICallChannelManager * | pManager,
 |  | [in] ICallChannel * | pChannel,
 |  | [in] ICallChannelMessage * | pMessage
 | ) |  |

This event indicates that a call channel message has been received.

Parameters:
[in] | pManager | contains the interface pointer for the CallChannelManager object.
[in] | pChannel | contains the interface pointer for the CallChannel object.
[in] | pMessage | contains the interface pointer for the CallChannelMessage object.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

_ICallChannelManagerEvents Member List

This is the complete list of members for _ICallChannelManagerEvents, including all inherited members.
Channels([in] ICallChannelManager *pManager,[in] ICallChannelCollection *pChannels) | _ICallChannelManagerEvents
Created() | _ICallChannelManagerEvents
Message([in] ICallChannelManager *pManager,[in] ICallChannel *pChannel,[in] ICallChannelMessage *pMessage) | _ICallChannelManagerEvents


Skype4COM: _ISkypeEvents Interface Reference

Public Member Functions

_ISkypeEvents Interface Reference

Skype event source interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Command ([in] ICommand *pCommand)
This event indicates the command object to use with the Skype API.
HRESULT | Reply ([in] ICommand *pCommand)
This event indicates the API response to the command object.
HRESULT | Error ([in] ICommand *pCommand,[in] LONG Number,[in] BSTR Description)
This event indicates the error number and description associated with a bad command object.
HRESULT | AttachmentStatus ([in] TAttachmentStatus Status)
This event is caused by a change in the status of an attachment to the Skype API.
HRESULT | ConnectionStatus ([in] TConnectionStatus Status)
This event is caused by a connection status change.
HRESULT | UserStatus ([in] TUserStatus Status)
This event is caused by a user status change.
HRESULT | OnlineStatus ([in] IUser *pUser,[in] TOnlineStatus Status)
This event is caused by a change in the online status of a user.
HRESULT | CallStatus ([in] ICall *pCall,[in] TCallStatus Status)
This event is caused by a change in call status.
HRESULT | CallHistory ()
This event is caused by a change in call history.
HRESULT | Mute ([in] VARIANT_BOOL Mute)
This event is caused by a change in mute status.
HRESULT | MessageStatus ([in] IChatMessage *pMessage,[in] TChatMessageStatus Status)
This event is caused by a change in chat message status.
HRESULT | MessageHistory ([in] BSTR Username)
This event is caused by a change in message history.
HRESULT | AutoAway ([in] VARIANT_BOOL Automatic)
This event is caused by a change of auto away status.
HRESULT | CallDtmfReceived ([in] ICall *pCall,[in] BSTR Code)
This event is caused by a call DTMF event.
HRESULT | VoicemailStatus ([in] IVoicemail *pMail,[in] TVoicemailStatus Status)
This event is caused by a change in voicemail status.
HRESULT | ApplicationConnecting ([in] IApplication *pApp,[in] IUserCollection *pUsers)
This event is caused by users connecting to an application.
HRESULT | ApplicationStreams ([in] IApplication *pApp,[in] IApplicationStreamCollection *pStreams)
This event is caused by a change in application streams.
HRESULT | ApplicationDatagram ([in] IApplication *pApp,[in] IApplicationStream *pStream,[in] BSTR Text)
This event is caused by the arrival of an application datagram.
HRESULT | ApplicationSending ([in] IApplication *pApp,[in] IApplicationStreamCollection *pStreams)
This event is caused by a change of application sending streams.
HRESULT | ApplicationReceiving ([in] IApplication *pApp,[in] IApplicationStreamCollection *pStreams)
This event is caused by a change of application receiving streams.
HRESULT | ContactsFocused ([in] BSTR Username)
This event is caused by the contacts tab gaining or losing focus.
HRESULT | GroupVisible ([in] IGroup *pGroup,[in] VARIANT_BOOL Visible)
This event is caused by a user hiding/showing a group in the contacts tab.
HRESULT | GroupExpanded ([in] IGroup *pGroup,[in] VARIANT_BOOL Expanded)
This event is caused by a user expanding or collapsing a group in the contacts tab.
HRESULT | GroupUsers ([in] IGroup *pGroup,[in] IUserCollection *pUsers)
This event is caused by a change in a contact group.
HRESULT | GroupDeleted ([in] LONG GroupId)
This event is caused by a user deleting a custom contact group.
HRESULT | UserMood ([in] IUser *pUser,[in] BSTR MoodText)
This event is caused by a change in the mood text of the user.
HRESULT | SmsMessageStatusChanged ([in] ISmsMessage *pMessage,[in] TSmsMessageStatus Status)
This event is caused by a change in the SMS message status.
HRESULT | SmsTargetStatusChanged ([in] ISmsTarget *pTarget,[in] TSmsTargetStatus Status)
This event is caused by a change in the SMS target status.
HRESULT | CallInputStatusChanged ([in] ICall *pCall,[in] VARIANT_BOOL Status)
This event is caused by a change in the Call voice input status change.
HRESULT | AsyncSearchUsersFinished ([in] LONG Cookie,[in] IUserCollection *pUsers)
This event occurs when a search is completed.
HRESULT | CallSeenStatusChanged ([in] ICall *pCall, VARIANT_BOOL Status)
This event occurs when the seen status of a call changes.
HRESULT | PluginEventClicked ([in] IPluginEvent *pEvent)
This event occurs when a user clicks on a plug-in event.
HRESULT | PluginMenuItemClicked ([in] IPluginMenuItem *pMenuItem,[in] IUserCollection *pUsers,[in] TPluginContext PluginContext,[in] BSTR ContextId)
This event occurs when a user clicks on a menu item.
HRESULT | WallpaperChanged ([in] BSTR Path)
This event occurs when a wallpaper changes.
HRESULT | FileTransferStatusChanged ([in] IFileTransfer *pTransfer,[in] TFileTransferStatus Status)
This event occurs when a file transfer status changes.
HRESULT | CallTransferStatusChanged ([in] ICall *pCall,[in] TCallStatus Status)
This event occurs when a call transfer status changes.
HRESULT | ChatMembersChanged ([in] IChat *pChat,[in] IUserCollection *pMembers)
This event occurs when a chat members change.
HRESULT | ChatMemberRoleChanged ([in] IChatMember *pMember,[in] TChatMemberRole Role)
This event occurs when a chat member role changes.
HRESULT | CallVideoStatusChanged ([in] ICall *pCall,[in] TCallVideoStatus Status)
This event occurs when a call video status changes.
HRESULT | CallVideoSendStatusChanged ([in] ICall *pCall,[in] TCallVideoSendStatus Status)
This event occurs when a call video send status changes.
HRESULT | CallVideoReceiveStatusChanged ([in] ICall *pCall,[in] TCallVideoSendStatus Status)
This event occurs when a call video receive status changes.
HRESULT | SilentModeStatusChanged ([in] VARIANT_BOOL Silent)
This event occurs when a silent mode is switched off.
HRESULT | UILanguageChanged ([in] BSTR Code)
This event occurs when user changes Skype client language.
HRESULT | UserAuthorizationRequestReceived ([in] IUser *pUser)
This event occurs when user sends you authorization request.

Detailed Description

Skype event source interface.

Examples:

Call.php.

Member Function Documentation

HRESULT ApplicationConnecting | ( | [in] IApplication * | pApp,
 |  | [in] IUserCollection * | pUsers
 | ) |  |

This event is caused by users connecting to an application.

Parameters:
[in] | pApp | contains the interface pointer for the Application object.
[in] | pUsers | contains the interface pointer for the UserCollection object.
HRESULT ApplicationDatagram | ( | [in] IApplication * | pApp,
 |  | [in] IApplicationStream * | pStream,
 |  | [in] BSTR | Text
 | ) |  |

This event is caused by the arrival of an application datagram.

Parameters:
[in] | pApp | contains the interface pointer for the Application object.
[in] | pStream | contains the interface pointer for the ApplicationStream object.
[in] | Text | contains the datagram text.
HRESULT ApplicationReceiving | ( | [in] IApplication * | pApp,
 |  | [in] IApplicationStreamCollection * | pStreams
 | ) |  |

This event is caused by a change of application receiving streams.

Parameters:
[in] | pApp | contains the interface pointer for the Application object.
[in] | pStreams | contains the interface pointer for the ApplicationStreamCollection object.
HRESULT ApplicationSending | ( | [in] IApplication * | pApp,
 |  | [in] IApplicationStreamCollection * | pStreams
 | ) |  |

This event is caused by a change of application sending streams.

Parameters:
[in] | pApp | contains the interface pointer for the Application object.
[in] | pStreams | contains the interface pointer for the ApplicationStreamCollection object.
HRESULT ApplicationStreams | ( | [in] IApplication * | pApp,
 |  | [in] IApplicationStreamCollection * | pStreams
 | ) |  |

This event is caused by a change in application streams.

Parameters:
[in] | pApp | contains the interface pointer for the Application object.
[in] | pStreams | contains the interface pointer for the ApplicationStreamCollection object.
HRESULT AsyncSearchUsersFinished | ( | [in] LONG | Cookie,
 |  | [in] IUserCollection * | pUsers
 | ) |  |

This event occurs when a search is completed.

Parameters:
[in] | Cookie | contains the search identifier.
[in] | pUsers | contains the interface pointer for the UserCollection object.
See also:
ISkype::AsyncSearchUsers
HRESULT AttachmentStatus ( [in] TAttachmentStatus Status )

This event is caused by a change in the status of an attachment to the Skype API.

Parameters:
[in] Status contains the new attachment status.
Examples:
Call.php.
HRESULT AutoAway ( [in] VARIANT_BOOL Automatic )

This event is caused by a change of auto away status.

Parameters:
[in] Automatic contains the new auto away status.
HRESULT CallDtmfReceived | ( | [in] ICall * | pCall,
 |  | [in] BSTR | Code
 | ) |  |

This event is caused by a call DTMF event.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Code | contains the received DTMF code.
Note:
This event can be received with P2P calls.
HRESULT CallInputStatusChanged | ( | [in] ICall * | pCall,
 |  | [in] VARIANT_BOOL | Status
 | ) |  |

This event is caused by a change in the Call voice input status change.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Status | contains the voice input status (VARIANT_TRUE: Active, VARIANT_FALSE: Inactive).
See also:
ICall::InputDevice
HRESULT CallSeenStatusChanged | ( | [in] ICall * | pCall,
 |  | VARIANT_BOOL | Status
 | ) |  |

This event occurs when the seen status of a call changes.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Status | contains the call seen status (VARIANT_TRUE: Seen, VARIANT_FALSE: Unseen).
See also:
ICall::Seen
HRESULT CallStatus | ( | [in] ICall * | pCall,
 |  | [in] TCallStatus | Status
 | ) |  |

This event is caused by a change in call status.

Parameters:
[in] | pCall | receives the interface pointer for the Call object.
[in] | Status | contains the new call status.
Examples:
Call.php.
HRESULT CallTransferStatusChanged | ( | [in] ICall * | pCall,
 |  | [in] TCallStatus | Status
 | ) |  |

This event occurs when a call transfer status changes.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Status | contains the new call transfer status.
HRESULT CallVideoReceiveStatusChanged | ( | [in] ICall * | pCall,
 |  | [in] TCallVideoSendStatus | Status
 | ) |  |

This event occurs when a call video receive status changes.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Status | contains new video receive status.
HRESULT CallVideoSendStatusChanged | ( | [in] ICall * | pCall,
 |  | [in] TCallVideoSendStatus | Status
 | ) |  |

This event occurs when a call video send status changes.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Status | contains new video send status.
HRESULT CallVideoStatusChanged | ( | [in] ICall * | pCall,
 |  | [in] TCallVideoStatus | Status
 | ) |  |

This event occurs when a call video status changes.

Parameters:
[in] | pCall | contains the interface pointer for the Call object.
[in] | Status | contains new video status.
HRESULT ChatMemberRoleChanged | ( | [in] IChatMember * | pMember,
 |  | [in] TChatMemberRole | Role
 | ) |  |

This event occurs when a chat member role changes.

Parameters:
[in] | pMember | contains the interface pointer for the ChatMember object.
[in] | Role | contains the new role code.
HRESULT ChatMembersChanged | ( | [in] IChat * | pChat,
 |  | [in] IUserCollection * | pMembers
 | ) |  |

This event occurs when a chat members change.

Parameters:
[in] | pChat | contains the interface pointer for the Chat object.
[in] | pMembers | contains the interface pointer for the UserCollection object.
HRESULT Command ( [in] ICommand * pCommand )

This event indicates the command object to use with the Skype API.

Parameters:
[in] pCommand contains the Command object.
HRESULT ConnectionStatus ( [in] TConnectionStatus Status )

This event is caused by a connection status change.

Parameters:
[in] Status contains the new connection status.
HRESULT ContactsFocused ( [in] BSTR Username )

This event is caused by the contacts tab gaining or losing focus.

Parameters:
[in] Username is an optional field to enter the Skypename of the user.
HRESULT Error | ( | [in] ICommand * | pCommand,
 |  | [in] LONG | Number,
 |  | [in] BSTR | Description
 | ) |  |

This event indicates the error number and description associated with a bad command object.

Parameters:
[in] | pCommand | contains the Command object.
[in] | Number | contains the error number to be returned by the Skype API.
[in] | Description | contains a description of the error.
HRESULT FileTransferStatusChanged | ( | [in] IFileTransfer * | pTransfer,
 |  | [in] TFileTransferStatus | Status
 | ) |  |

This event occurs when a file transfer status changes.

Parameters:
[in] | pTransfer | contains the interface pointer for the File Transfer object.
[in] | Status | contains the new file transfer status.
See also:
ISkype::FileTransfers, ISkype::ActiveFileTransfers
HRESULT GroupDeleted ( [in] LONG GroupId )

This event is caused by a user deleting a custom contact group.

Parameters:
[in] GroupId contains the ID of the deleted group.
HRESULT GroupExpanded | ( | [in] IGroup * | pGroup,
 |  | [in] VARIANT_BOOL | Expanded
 | ) |  |

This event is caused by a user expanding or collapsing a group in the contacts tab.

Parameters:
[in] | pGroup | contains the interface pointer for the Group object.
[in] | Expanded | is a Boolean indicator. When the value is set to True, the group is expanded.
HRESULT GroupUsers | ( | [in] IGroup * | pGroup,
 |  | [in] IUserCollection * | pUsers
 | ) |  |

This event is caused by a change in a contact group.

Parameters:
[in] | pGroup | contains the interface pointer for the Group object.
[in] | pUsers | contains the interface pointer for the UserCollection object.
HRESULT GroupVisible | ( | [in] IGroup * | pGroup,
 |  | [in] VARIANT_BOOL | Visible
 | ) |  |

This event is caused by a user hiding/showing a group in the contacts tab.

Parameters:
[in] | pGroup | contains the interface pointer for the Group object.
[in] | Visible | is a Boolean indicator. It is set to True when the group is visible in the contacts tab.
HRESULT MessageHistory ( [in] BSTR Username )

This event is caused by a change in message history.

Parameters:
[in] Username contains the name of the user whose message history changed.
HRESULT MessageStatus | ( | [in] IChatMessage * | pMessage,
 |  | [in] TChatMessageStatus | Status
 | ) |  |

This event is caused by a change in chat message status.

Parameters:
[in] | pMessage | receives the interface pointer for the ChatMessage object.
[in] | Status | contains the new message status.
HRESULT Mute ( [in] VARIANT_BOOL Mute )

This event is caused by a change in mute status.

Parameters:
[in] Mute contains the new mute status value.
HRESULT OnlineStatus | ( | [in] IUser * | pUser,
 |  | [in] TOnlineStatus | Status
 | ) |  |

This event is caused by a change in the online status of a user.

Parameters:
[in] | pUser | receives the interface pointer for the User object.
[in] | Status | contains the new online status of the user.
HRESULT PluginEventClicked ( [in] IPluginEvent * pEvent )

This event occurs when a user clicks on a plug-in event.

Parameters:
[in] pEvent contains the interface pointer for the PluginEvent object.
See also:
IPluginEvent
HRESULT PluginMenuItemClicked | ( | [in] IPluginMenuItem * | pMenuItem,
 |  | [in] IUserCollection * | pUsers,
 |  | [in] TPluginContext | PluginContext,
 |  | [in] BSTR | ContextId
 | ) |  |

This event occurs when a user clicks on a menu item.

Parameters:
[in] | pMenuItem | contains the interface pointer for the PluginMenuItem object.
[in] | pUsers | contains the interface pointer for the UserCollection object.
[in] | PluginContext | contains the plug-in context.
[in] | ContextId | contains the context id.
See also:
IPluginMenuItem
HRESULT Reply ( [in] ICommand * pCommand )

This event indicates the API response to the command object.

Parameters:
[in] pCommand contains the response to the Command object.
HRESULT SilentModeStatusChanged ( [in] VARIANT_BOOL Silent )

This event occurs when a silent mode is switched off.

Parameters:
[in] Silent contains the Skype client silent status.
HRESULT SmsMessageStatusChanged | ( | [in] ISmsMessage * | pMessage,
 |  | [in] TSmsMessageStatus | Status
 | ) |  |

This event is caused by a change in the SMS message status.

Parameters:
[in] | pMessage | contains the interface pointer for the SmsMessage object.
[in] | Status | contains the new message status.
HRESULT SmsTargetStatusChanged | ( | [in] ISmsTarget * | pTarget,
 |  | [in] TSmsTargetStatus | Status
 | ) |  |

This event is caused by a change in the SMS target status.

Parameters:
[in] | pTarget | contains the interface pointer for the SmsTarget object.
[in] | Status | contains the new target status.
HRESULT UILanguageChanged ( [in] BSTR Code )

This event occurs when user changes Skype client language.

Parameters:
[in] Code contains the new language code.
HRESULT UserAuthorizationRequestReceived ( [in] IUser * pUser )

This event occurs when user sends you authorization request.

Parameters:
[in] pUser contains the the interface pointer for the User object.
HRESULT UserMood | ( | [in] IUser * | pUser,
 |  | [in] BSTR | MoodText
 | ) |  |

This event is caused by a change in the mood text of the user.

Parameters:
[in] | pUser | contains the interface pointer for the User object.
[in] | MoodText | contains the new mood text.
HRESULT UserStatus ( [in] TUserStatus Status )

This event is caused by a user status change.

Parameters:
[in] Status contains the new user status.
HRESULT VoicemailStatus | ( | [in] IVoicemail * | pMail,
 |  | [in] TVoicemailStatus | Status
 | ) |  |

This event is caused by a change in voicemail status.

Parameters:
[in] | pMail | contains the interface pointer for the Voicemail object.
[in] | Status | contains the new voicemail status.
HRESULT WallpaperChanged ( [in] BSTR Path )

This event occurs when a wallpaper changes.

Parameters:
[in] Path to new wallpaper bitmap.
See also:
IClient::Wallpaper
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

_ISkypeEvents Member List

This is the complete list of members for _ISkypeEvents, including all inherited members.
ApplicationConnecting([in] IApplication *pApp,[in] IUserCollection *pUsers) | _ISkypeEvents
ApplicationDatagram([in] IApplication *pApp,[in] IApplicationStream *pStream,[in] BSTR Text) | _ISkypeEvents
ApplicationReceiving([in] IApplication *pApp,[in] IApplicationStreamCollection *pStreams) | _ISkypeEvents
ApplicationSending([in] IApplication *pApp,[in] IApplicationStreamCollection *pStreams) | _ISkypeEvents
ApplicationStreams([in] IApplication *pApp,[in] IApplicationStreamCollection *pStreams) | _ISkypeEvents
AsyncSearchUsersFinished([in] LONG Cookie,[in] IUserCollection *pUsers) | _ISkypeEvents
AttachmentStatus([in] TAttachmentStatus Status) | _ISkypeEvents
AutoAway([in] VARIANT_BOOL Automatic) | _ISkypeEvents
CallDtmfReceived([in] ICall *pCall,[in] BSTR Code) | _ISkypeEvents
CallHistory() | _ISkypeEvents
CallInputStatusChanged([in] ICall *pCall,[in] VARIANT_BOOL Status) | _ISkypeEvents
CallSeenStatusChanged([in] ICall *pCall, VARIANT_BOOL Status) | _ISkypeEvents
CallStatus([in] ICall *pCall,[in] TCallStatus Status) | _ISkypeEvents
CallTransferStatusChanged([in] ICall *pCall,[in] TCallStatus Status) | _ISkypeEvents
CallVideoReceiveStatusChanged([in] ICall *pCall,[in] TCallVideoSendStatus Status) | _ISkypeEvents
CallVideoSendStatusChanged([in] ICall *pCall,[in] TCallVideoSendStatus Status) | _ISkypeEvents
CallVideoStatusChanged([in] ICall *pCall,[in] TCallVideoStatus Status) | _ISkypeEvents
ChatMemberRoleChanged([in] IChatMember *pMember,[in] TChatMemberRole Role) | _ISkypeEvents
ChatMembersChanged([in] IChat *pChat,[in] IUserCollection *pMembers) | _ISkypeEvents
Command([in] ICommand *pCommand) | _ISkypeEvents
ConnectionStatus([in] TConnectionStatus Status) | _ISkypeEvents
ContactsFocused([in] BSTR Username) | _ISkypeEvents
Error([in] ICommand *pCommand,[in] LONG Number,[in] BSTR Description) | _ISkypeEvents
FileTransferStatusChanged([in] IFileTransfer *pTransfer,[in] TFileTransferStatus Status) | _ISkypeEvents
GroupDeleted([in] LONG GroupId) | _ISkypeEvents
GroupExpanded([in] IGroup *pGroup,[in] VARIANT_BOOL Expanded) | _ISkypeEvents
GroupUsers([in] IGroup *pGroup,[in] IUserCollection *pUsers) | _ISkypeEvents
GroupVisible([in] IGroup *pGroup,[in] VARIANT_BOOL Visible) | _ISkypeEvents
MessageHistory([in] BSTR Username) | _ISkypeEvents
MessageStatus([in] IChatMessage *pMessage,[in] TChatMessageStatus Status) | _ISkypeEvents
Mute([in] VARIANT_BOOL Mute) | _ISkypeEvents
OnlineStatus([in] IUser *pUser,[in] TOnlineStatus Status) | _ISkypeEvents
PluginEventClicked([in] IPluginEvent *pEvent) | _ISkypeEvents
PluginMenuItemClicked([in] IPluginMenuItem *pMenuItem,[in] IUserCollection *pUsers,[in] TPluginContext PluginContext,[in] BSTR ContextId) | _ISkypeEvents
Reply([in] ICommand *pCommand) | _ISkypeEvents
SilentModeStatusChanged([in] VARIANT_BOOL Silent) | _ISkypeEvents
SmsMessageStatusChanged([in] ISmsMessage *pMessage,[in] TSmsMessageStatus Status) | _ISkypeEvents
SmsTargetStatusChanged([in] ISmsTarget *pTarget,[in] TSmsTargetStatus Status) | _ISkypeEvents
UILanguageChanged([in] BSTR Code) | _ISkypeEvents
UserAuthorizationRequestReceived([in] IUser *pUser) | _ISkypeEvents
UserMood([in] IUser *pUser,[in] BSTR MoodText) | _ISkypeEvents
UserStatus([in] TUserStatus Status) | _ISkypeEvents
VoicemailStatus([in] IVoicemail *pMail,[in] TVoicemailStatus Status) | _ISkypeEvents
WallpaperChanged([in] BSTR Path) | _ISkypeEvents


Skype4COM: Application Class Reference

  • SKYPE4COMLib
  • Application

Application Class Reference

This class enables two applications sharing the same name to communicate over the Skype network. More...

import "Skype4COM.idl";

Detailed Description

This class enables two applications sharing the same name to communicate over the Skype network.

See also:
IApplication, IApplicationStream
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ApplicationStream Class Reference

  • SKYPE4COMLib
  • ApplicationStream

ApplicationStream Class Reference

This class manages application streams. More...

import "Skype4COM.idl";

Detailed Description

This class manages application streams.

The ApplicationStream class provides a reliable connection between two application endpoints.

See also:
IApplicationStream
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ApplicationStreamCollection Class Reference

  • SKYPE4COMLib
  • ApplicationStreamCollection

ApplicationStreamCollection Class Reference

This class manages application stream collections. More...

import "Skype4COM.idl";

Detailed Description

This class manages application stream collections.

See also:
IApplicationStreamCollection, IApplicationStream
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Call Class Reference

  • SKYPE4COMLib
  • Call

Call Class Reference

This class manages calls and call properties. More...

import "Skype4COM.idl";

Detailed Description

This class manages calls and call properties.

Use the Call class to manage call properties, answer incoming calls, change call status, and send DTMF tones.

Example 1: Placing a call
  '// Create a Skype object:
  Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

  '// Place a call using this Skype object:
  Set oCall = oSkype.PlaceCall("echo123")

  '// To place a call on hold:
  oCall.Hold

  '// To resume a call that was on hold:
  oCall.Resume

  '// To end a call:
  oCall.Finish

  '// Call status events:
  Public Sub Skype_CallStatus(ByRef oCall, ByVal Status)
  End Sub
Example 2: Accessing call properties
  '// To query a call object with a specified ID:
  Set oCall = oSkype.Call(oId)

  '// To query the Skypename of a remote caller:
  Set oHandle = oCall.PartnerHandle

  '// To query the display name of a remote caller:
  Set oName = oCall.PartnerDisplayName
See also:
ICall, ICallCollection, _ISkypeEvents
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: CallChannel Class Reference

  • SKYPE4COMLib
  • CallChannel

CallChannel Class Reference

This class forms a logical connection between the ApplicationStream and Call objects. More...

import "Skype4COM.idl";

Detailed Description

This class forms a logical connection between the ApplicationStream and Call objects.

The CallChannel is an abstract layer above the Call and ApplicationStream objects. The lifetime of the CallChannel (and the corresponding ApplicationStream) is determined by the lifetime of the active Call.

See also:
ICallChannel, ICallChannelCollection, ICallChannelManager
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: CallChannelCollection Class Reference

  • SKYPE4COMLib
  • CallChannelCollection

CallChannelCollection Class Reference

Container class for CallChannel objects. More...

import "Skype4COM.idl";

Detailed Description

Container class for CallChannel objects.

See also:
ICallChannel, ICallChannelCollection, ICallChannelManager
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: CallChannelManager Class Reference

  • SKYPE4COMLib
  • CallChannelManager

CallChannelManager Class Reference

This class manages Call data channels. More...

import "Skype4COM.idl";

Detailed Description

This class manages Call data channels.

The CallChannelManager class listens for incoming Skype Call and attempts to create a data channel between the callers. The ApplicationStream is created when the ICall::Status is TCallStatus::clsRinging. The ApplicationStream is deleted when the call status changes to TCallStatus::clsCancelled, TCallStatus::clsFailed, TCallStatus::clsFinished or TCallStatus::clsRefused.

Note:
To create a data channel it is necessary to have an instance of the CallChannelManager with the same name running on both endpoints of a call. It is possible to have multiple data channels running at the same time.
See also:
ICallChannelManager, _ICallChannelManagerEvents, ICallChannel
Example:
 '// To create a channel manager object:
 Set oMgr = WScript.CreateObject("Skype4COM.CallChannelManager", "ChannelManager_")

 '// Create the application context:
 oMgr.Create("TestApplicationName")

 '// Wait for the application context to be created:
 Do While Not oMgr.Created
   WScript.Sleep(1000)
 Loop

 '// This event occurs when a new channel is created or an existing channel is deleted:
 Public Sub ChannelManager_Channels(ByRef aManager, ByRef aChannels)
 End Sub

 '// This event occurs when a message arrives from a remote user
 Public Sub ChannelManager_Message(ByRef aManager, ByRef aChannel, ByRef aMessage)
 End Sub

 '// This event occurs when an application context is created
 Public Sub ChannelManager_Created()
 End Sub
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: CallChannelMessage Class Reference

  • SKYPE4COMLib
  • CallChannelMessage

CallChannelMessage Class Reference

This class manages CallChannel messages. More...

import "Skype4COM.idl";

Detailed Description

This class manages CallChannel messages.

See also:
ICallChannelMessage, ICallChannelManager
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: CallCollection Class Reference

  • SKYPE4COMLib
  • CallCollection

CallCollection Class Reference

This class manages Call collections. More...

import "Skype4COM.idl";

Detailed Description

This class manages Call collections.

The CallCollection class is used to manage call collections. To query items in a collection, use For Each .. Next statements.

Example:
  '// To query call history:
  For Each oCall In oSkype.Calls
  Next

  '// To query the call history for a user:
  For Each oCall In oSkype.Calls("echo123")
  Next

  '// To query active calls:
  For Each oCall In oSkype.ActiveCalls
  Next

  '// To query missed calls:
  For Each oCall In oSkype.MissedCalls
  Next
See also:
ICall, ICallCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Chat Class Reference

  • SKYPE4COMLib
  • Chat

Chat Class Reference

This class manages chats. More...

import "Skype4COM.idl";

Detailed Description

This class manages chats.

The Chat class groups messages with the same chat name.

Example:
  '// To query a chat object with a specified name:
  Set oChat = oSkype.Chat(oName)

  '// To query a chat topic:
  Set oTopic = oChat.Topic

  '// To query a chat timestamp:
  Set oTime = oChat.Timestamp

  '// To iterate through messages in a chat:
  For Each oMsg In oChat.Messages
  Next
See also:
IChat, IChatCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ChatCollection Class Reference

  • SKYPE4COMLib
  • ChatCollection

ChatCollection Class Reference

This class manages Chat collections. More...

import "Skype4COM.idl";

Detailed Description

This class manages Chat collections.

This class manages collections of Chat objects. To query a chat collection, use For Each .. Next statements.

Example:
  '// To query chat history:
  For Each oChat In oSkype.Chats
  Next
See also:
IChat, IChatCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ChatMember Class Reference

  • SKYPE4COMLib
  • ChatMember

ChatMember Class Reference

This class manages chat member. More...

import "Skype4COM.idl";

Detailed Description

This class manages chat member.

See also:
IChatMember
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ChatMemberCollection Class Reference

  • SKYPE4COMLib
  • ChatMemberCollection

ChatMemberCollection Class Reference

This class manages chat member collections. More...

import "Skype4COM.idl";

Detailed Description

This class manages chat member collections.

See also:
IChatMemberCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ChatMessage Class Reference

  • SKYPE4COMLib
  • ChatMessage

ChatMessage Class Reference

This class manages chat messages. More...

import "Skype4COM.idl";

Detailed Description

This class manages chat messages.

See also:
IChatMessage
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ChatMessageCollection Class Reference

  • SKYPE4COMLib
  • ChatMessageCollection

ChatMessageCollection Class Reference

This class manages chat message collections. More...

import "Skype4COM.idl";

Detailed Description

This class manages chat message collections.

See also:
IChatMessageCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Client Class Reference

  • SKYPE4COMLib
  • Client

Client Class Reference

This class controls features related to the Skype user interface. More...

import "Skype4COM.idl";

Detailed Description

This class controls features related to the Skype user interface.

See also:
IClient
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Command Class Reference

  • SKYPE4COMLib
  • Command

Command Class Reference

This class manages Skype API command objects. More...

import "Skype4COM.idl";

Detailed Description

This class manages Skype API command objects.

See also:
ICommand
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Conference Class Reference

  • SKYPE4COMLib
  • Conference

Conference Class Reference

This class manages conference calls. More...

import "Skype4COM.idl";

Detailed Description

This class manages conference calls.

The Conference class manages a call connected to multiple participants.

See also:
IConference, IConferenceCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ConferenceCollection Class Reference

  • SKYPE4COMLib
  • ConferenceCollection

ConferenceCollection Class Reference

This class manages conference collections. More...

import "Skype4COM.idl";

Detailed Description

This class manages conference collections.

Use the ConferenceCollection class to query conference collections in call history. To query a collection class, use For Each .. Next statements.

See also:
IConference, IConferenceCollection, ISkype::Conferences
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Conversion Class Reference

  • SKYPE4COMLib
  • Conversion

Conversion Class Reference

This class converts text to constant values and converts constant values to text. More...

import "Skype4COM.idl";

Detailed Description

This class converts text to constant values and converts constant values to text.

Example:
  '// To create an object:
  Set oSkype = CreateObject("Skype4COM.Skype")

  '// To convert an attachment status to text:
  oAttachStatus = oSkype.Convert.AttachmentStatusToText(oSkype.AttachmentStatus)

  '// To change the online status of a user:
  oSkype.CurrentUserStatus = oSkype.Convert.TextToUserStatus("ONLINE")
See also:
IConversion, ISkype::Convert
Deprecated:
The SKYPE4COMLib::Conversion class is deprecated, support for multilanguage status codes support will be dropped in the future.
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Group Class Reference

  • SKYPE4COMLib
  • Group

Group Class Reference

This class manages contact groups. More...

import "Skype4COM.idl";

Detailed Description

This class manages contact groups.

See also:
IGroup
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: GroupCollection Class Reference

  • SKYPE4COMLib
  • GroupCollection

GroupCollection Class Reference

This class manages collections of Group objects. More...

import "Skype4COM.idl";

Detailed Description

This class manages collections of Group objects.

See also:
IGroupCollection, IGroup
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: IApplication Interface Reference

Public Member Functions | Properties

IApplication Interface Reference

Application class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Create ()
This command creates the application context.
HRESULT | Delete ()
This command deletes the application context.
HRESULT | Connect ([in] BSTR Username,[in, defaultvalue(0)] VARIANT_BOOL WaitConnected)
This command connects a user to the application context.
HRESULT | SendDatagram ([in] BSTR Text,[in, defaultvalue(0)] IApplicationStreamCollection *pStreams)
This command broadcasts a datagram to connected streams.

Properties

BSTR | Name [get]
This command queries an application name.
IApplicationStreamCollection | Streams [get]
This command queries application streams.
IUserCollection | ConnectableUsers [get]
This command queries users that can connect to the application.
IUserCollection | ConnectingUsers [get]
This command queries the users who are currently connecting to the application.
IApplicationStreamCollection | SendingStreams [get]
This command queries application sending streams.
IApplicationStreamCollection | ReceivedStreams [get]
This command queries application receiving streams.

Detailed Description

Application class default interface.

See also:
IApplicationStream

Member Function Documentation

HRESULT Connect | ( | [in] BSTR | Username,
 |  | [in, defaultvalue(0)] VARIANT_BOOL | WaitConnected
 | ) |  |

This command connects a user to the application context.

Parameters:
[in] | Username | contains the Skypename of the user to connect.
[in] | WaitConnected | is an optional Boolean value to indicate whether to wait for the user to connect or not.
HRESULT SendDatagram | ( | [in] BSTR | Text,
 |  | [in, defaultvalue(0)] IApplicationStreamCollection * | pStreams
 | ) |  |

This command broadcasts a datagram to connected streams.

Parameters:
[in] | Text | contains the text of the datagram.
[in] | pStreams | is an optional parameter you can use to specify the collection of streams that will receive the datagram.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IApplication Member List

This is the complete list of members for IApplication, including all inherited members.
Connect([in] BSTR Username,[in, defaultvalue(0)] VARIANT_BOOL WaitConnected) | IApplication
ConnectableUsers IApplication
ConnectingUsers IApplication
Create() IApplication
Delete() IApplication
Name IApplication
ReceivedStreams IApplication
SendDatagram([in] BSTR Text,[in, defaultvalue(0)] IApplicationStreamCollection *pStreams) | IApplication


Skype4COM: IApplicationStream Interface Reference

Public Member Functions | Properties

IApplicationStream Interface Reference

ApplicationStream class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Read ([out, retval] BSTR *pText)
This command reads a text string from an application stream.
HRESULT | Write ([in] BSTR Text)
This command writes a text string to an application stream.
HRESULT | SendDatagram ([in] BSTR Text)
This command sends a datagram message. Delivery of the message is not quaranteed.
HRESULT | Disconnect ()
This command disconnects an application stream from an application context.

Properties

BSTR | ApplicationName [get]
This command queries an application name.
BSTR | Handle [get]
This command queries the name of an application stream.
LONG | DataLength [get]
This command queries the data length of an application stream.
BSTR | PartnerHandle [get]
This command queries the Skypename of the sender of an application stream.

Detailed Description

ApplicationStream class default interface.

See also:
IApplication

Member Function Documentation

HRESULT Read ( [out, retval] BSTR * pText )

This command reads a text string from an application stream.

Parameters:
[out] pText receives the text string from the application stream.
HRESULT SendDatagram ( [in] BSTR Text )

This command sends a datagram message. Delivery of the message is not quaranteed.

Parameters:
[in] Text contains the message to send.
Note:
To transmit binary data use the base64 encoding to convert your data to strings before passing those strings to IApplication.SendDatagram or IApplicationStream.Write methods.
Example:
 //Declare the variables
 var Skype, App;

 //Create the Skype application object.
 Skype = new ActiveXObject("Skype4COM.Skype");

 // Connect events:
 WScript.ConnectObject(Skype, "Skype_");

 //Create the application object
 var App = Skype.Application("TestBase64DataTransfer");

 //Create the application context
 App.Create();
 WScript.Echo ("App created.");

 //Connect remote user
 if (WScript.Arguments.Count() > 0)
 {
   App.Connect(WScript.Arguments.Item(0), true);
   WScript.Echo (WScript.Arguments.Item(0) + " connected.");
 }
 //Byte array
 var byteArray = new Array(17,34,51,68,85,102,119,136,153,170);

 // Send datagram
 if (App.Streams.Count)
 {
   //Encoded byte array
   var encoded = encode64(byteArray);

   //Send encoded array to streams
   for (var i=0; i < App.Streams.Count; i++)
   {
     var stm = App.Streams.Item(i+1);
     for (var i=0; i < App.Streams.Count; i++){
       stm.SendDatagram(encoded);
     }
   }
   WScript.Echo(">Datagram [" + byteArray + "] sent");
 }
 //Sleep 10 minutes
 WScript.Sleep(600000);

 //Application datagram events
 function Skype_ApplicationDatagram(aApp, aStream, aText)
 {
   WScript.Echo(">Datagram [" + decode64(aText) + "] received");
 }

 //Heres the encode function
 function encode64(inp)
 {
   // Read more about base64 at http://en.wikipedia.org/wiki/Base64
   ...
 }

 //Heres the decode function
 function decode64(inp)
 {
   ...
 }
HRESULT Write ( [in] BSTR Text )

This command writes a text string to an application stream.

Parameters:
[in] Text contains the text string to write.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IApplicationStream Member List

This is the complete list of members for IApplicationStream, including all inherited members.
ApplicationName | IApplicationStream
DataLength | IApplicationStream
Disconnect() | IApplicationStream
Handle | IApplicationStream
PartnerHandle | IApplicationStream
Read([out, retval] BSTR *pText) | IApplicationStream
SendDatagram([in] BSTR Text) | IApplicationStream
Write([in] BSTR Text) | IApplicationStream


Skype4COM: IApplicationStreamCollection Interface Reference

Public Member Functions | Properties

IApplicationStreamCollection Interface Reference

ApplicationStreamCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IApplicationStream *pItem)
This command adds a new item to an ApplicationStreamCollection.
HRESULT | Remove ([in] long Index)
This command removes a stream from an ApplicationStreamCollection.
HRESULT | RemoveAll (void)
This command removes all streams from an ApplicationStreamCollection.

Properties

LONG | Count [get]
This command queries the number of streams in an ApplicationStreamCollection.
IApplicationStream | Item ([in] LONG Index) [get]
This command queries a stream with a specified index in an ApplicationStreamCollection.
IUnknown | _NewEnum [get]
This command queries an ApplicationStreamCollection enumerator object.

Detailed Description

ApplicationStreamCollection class default interface.

See also:
IApplicationStream

Member Function Documentation

HRESULT Add ( [in] IApplicationStream * pStream )

This command adds a new item to an ApplicationStreamCollection.

Parameters:
[in] pStream contains the ApplicationStream to add.
HRESULT Remove ( [in] long Index )

This command removes a stream from an ApplicationStreamCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries a stream with a specified index in an ApplicationStreamCollection.

Parameters:
[in] Index contains the stream to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IApplicationStreamCollection Member List

This is the complete list of members for IApplicationStreamCollection, including all inherited members.
_NewEnum | IApplicationStreamCollection
Add([in] IApplicationStream *pItem) | IApplicationStreamCollection
Count | IApplicationStreamCollection
Item | IApplicationStreamCollection
Remove([in] long Index) | IApplicationStreamCollection
RemoveAll(void) | IApplicationStreamCollection


Skype4COM: ICall Interface Reference

Public Member Functions | Properties

ICall Interface Reference

Call class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Hold ()
This command places a call on hold.
HRESULT | Resume ()
This command resumes a call that was on hold.
HRESULT | Finish ()
This command ends a call.
HRESULT | Answer ()
This command answers a call.
HRESULT | Join ([in] LONG Id)
This command joins a call with another call to form a call conference.
HRESULT | StartVideoSend ()
This command starts video send.
HRESULT | StopVideoSend ()
This command stops video send.
HRESULT | StartVideoReceive ()
This command starts video receive.
HRESULT | StopVideoReceive ()
This command stops video receive.
HRESULT | RedirectToVoicemail ()
This command redirects an incoming call to voicemail.
HRESULT | Forward ()
This command forwards an incoming call.
HRESULT | Transfer ([in] BSTR Target)
Transfers call to contact or phone number.

Properties

LONG | Id [get]
This command queries the call ID.
DATE | Timestamp [get]
This command queries the call timestamp.
BSTR | PartnerHandle [get]
This command queries the Skypename of a remote caller.
BSTR | PartnerDisplayName [get]
This command queries the name of the remote caller.
LONG | ConferenceId [get]
This command queries a call conference ID.
TCallType | Type [get]
This command queries a call type.
TCallStatus | Status [get, set]
This command queries/sets a call status.
TCallFailureReason | FailureReason [get]
This command queries a call failure reason.
BSTR | Subject [get]
This command queries the subject of a call.
BSTR | PstnNumber [get]
This command queries the PSTN number of a call.
LONG | Duration [get]
This command queries the duration of a call.
BSTR | PstnStatus [get]
This command queries the call PSTN status.
VARIANT_BOOL | Seen [get, set]
This command queries or sets the call to a status of seen.
BSTR | DTMF [set]
This command sends a DTMF tone.
IParticipantCollection | Participants [get]
This command queries the number of participants in a conference call not hosted by the user.
LONG | VmDuration [get]
This command returns the duration of a voicemail.
LONG | VmAllowedDuration [get]
This command returns the permitted duration of a voicemail.
TCallVideoStatus | VideoStatus [get]
This command queries call video status.
TCallVideoSendStatus | VideoSendStatus [get]
This command queries call video send status.
TCallVideoSendStatus | VideoReceiveStatus [get]
This command queries call video receive status.
LONG | Rate [get]
This command queries the call rate, expressed in cents.
BSTR | RateCurrency [get]
This command queries currency code for the call rate.
LONG | RatePrecision [get]
This command queries the call rate precision.
BSTR | InputDevice ([in] TCallIoDeviceType DeviceType) [get, set]
This command queries or sets the input sound device.
BSTR | OutputDevice ([in] TCallIoDeviceType DeviceType) [get, set]
This command queries or sets the output sound device.
BSTR | CaptureMicDevice ([in] TCallIoDeviceType DeviceType) [get, set]
This command queries or sets the mic capture device.
VARIANT_BOOL | InputStatus [get]
This command queries the call voice input status.
BSTR | ForwardedBy [get]
This command queries the the identity of a user who forwards a call.
VARIANT_BOOL | CanTransfer ([in] BSTR Target) [get]
This command queries if a call can be transferred to contact or number.
TCallStatus | TransferStatus [get]
Returns call transferring status.
VARIANT_BOOL | TransferActive [get]
Returns true if the call has been transferred.
BSTR | TransferredBy [get]
Returns the Skypename of the user who transferred the call.
BSTR | TransferredTo [get]
Returns the Skypename of the user or phone number the call has been transferred to.
BSTR | TargetIdentity [get]
Returns the target number for incoming SkypeIN calls.

Detailed Description

Call class default interface.

Member Function Documentation

HRESULT Join ( [in] LONG Id )

This command joins a call with another call to form a call conference.

Parameters:
[in] Id contains the ID of the other call to join to the conference.
HRESULT Transfer ( [in] BSTR Target )

Transfers call to contact or phone number.

Parameters:
[in] Target phone number(s) or Skypename(s) the call is beeing transferred to.
Note:
You can transfer an incoming call to a group by specifying a comma separated list of targets, first one of the group to answer will get the call.
See also:
ICall::CanTransfer

Property Documentation

HRESULT CanTransfer [get]

This command queries if a call can be transferred to contact or number.

Parameters:
[in] Target Skypename or phone number the call to be transferre to.
See also:
ICall::Transfer
HRESULT CaptureMicDevice [get, set]

This command queries or sets the mic capture device.

Parameters:
[in] DeviceType contains the device type, TCallIoDeviceType::callIoDeviceTypeSoundcard cannot be used with this property.
Note:
This command functions for active calls only.
HRESULT DTMF [set]

This command sends a DTMF tone.

Parameters:
[in] newVal contains the DTMF value to send. Permitted symbols are: {0..9,#,*}.
Note:
This command functions for active calls only.
HRESULT InputDevice [get, set]

This command queries or sets the input sound device.

Parameters:
[in] DeviceType contains the device type.
Note:
This command functions for active calls only.
HRESULT OutputDevice [get, set]

This command queries or sets the output sound device.

Parameters:
[in] DeviceType contains the device type.
Note:
This command functions for active calls only.
HRESULT Seen [get, set]

This command queries or sets the call to a status of seen.

Parameters:
[in] newVal contains a Boolean value to indicate if a call is seen or not.
Note:
You cannot alter the call seen status from seen to unseen.
HRESULT Status [get, set]

This command queries/sets a call status.

Deprecated:
Set ICall::Status is deprecated, use the ICall::Hold, ICall::Resume, ICall::Finish or ICall::Answer instead.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICall Member List

This is the complete list of members for ICall, including all inherited members.
Answer() | ICall
CanTransfer | ICall
CaptureMicDevice | ICall
ConferenceId | ICall
DTMF | ICall
Duration | ICall
FailureReason | ICall
Finish() | ICall
Forward() | ICall
ForwardedBy | ICall
Hold() | ICall
Id | ICall
InputDevice | ICall
InputStatus | ICall
Join([in] LONG Id) | ICall
OutputDevice | ICall
Participants | ICall
PartnerDisplayName | ICall
PartnerHandle | ICall
PstnNumber | ICall
PstnStatus | ICall
Rate | ICall
RateCurrency | ICall
RatePrecision | ICall
RedirectToVoicemail() | ICall
Resume() | ICall
Seen | ICall
StartVideoReceive() | ICall
StartVideoSend() | ICall
Status | ICall
StopVideoReceive() | ICall
StopVideoSend() | ICall
Subject | ICall
TargetIdentity | ICall
Timestamp | ICall
Transfer([in] BSTR Target) | ICall
TransferActive | ICall
TransferredBy | ICall
TransferredTo | ICall
TransferStatus | ICall
Type | ICall
VideoReceiveStatus | ICall
VideoSendStatus | ICall
VideoStatus | ICall
VmAllowedDuration | ICall
VmDuration | ICall


Skype4COM: ICallChannel Interface Reference

Public Member Functions | Properties

ICallChannel Interface Reference

CallChannel class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | SendTextMessage (BSTR Text)
This command sends a CallChannel message.

Properties

TCallChannelType | Type [get, set]
This command queries/sets the CallChannel type.
IApplicationStream | Stream [get]
This command returns the channel ApplicationStream object.
ICallChannelManager | Manager [get]
This command returns the related CallChannelManager object.
ICall | Call [get]
This command returns the related Call object.

Detailed Description

CallChannel class default interface.

Member Function Documentation

HRESULT SendTextMessage ( BSTR Text )

This command sends a CallChannel message.

Parameters:
[in] Text contains the text of the message to send.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICallChannel Member List

This is the complete list of members for ICallChannel, including all inherited members.
Call ICallChannel
Manager ICallChannel
SendTextMessage(BSTR Text) ICallChannel


Skype4COM: ICallChannelCollection Interface Reference

Public Member Functions | Properties

ICallChannelCollection Interface Reference

CallChannelCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] ICallChannel *pChannel)
This command adds a new call channel to a CallChannelCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a CallChannelCollection.
HRESULT | RemoveAll (void)
This command removes all items from a CallChannelCollection.

Properties

LONG | Count [get]
This command queries the number of call channels in a CallChannelCollection.
ICallChannel | Item ([in] LONG Index) [get]
This command queries a CallChannelCollection item with a specified index.
IUnknown | _NewEnum [get]
This command queries a CallChannelCollection enumerator object.

Detailed Description

CallChannelCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] ICallChannel * pItem )

This command adds a new call channel to a CallChannelCollection.

Parameters:
[in] pItem contains the interface pointer for the CallChannel object.
HRESULT Remove ( [in] long Index )

This command removes an item from a CallChannelCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries a CallChannelCollection item with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICallChannelCollection Member List

This is the complete list of members for ICallChannelCollection, including all inherited members.
_NewEnum | ICallChannelCollection
Add([in] ICallChannel *pChannel) | ICallChannelCollection
Count | ICallChannelCollection
Item | ICallChannelCollection
Remove([in] long Index) | ICallChannelCollection
RemoveAll(void) | ICallChannelCollection


Skype4COM: ICallChannelManager Interface Reference

Public Member Functions | Properties

ICallChannelManager Interface Reference

CallChannelManager class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Connect ([in] ISkype *pSkype)
This command binds the CallChannelManager object to the Skype object.
HRESULT | Disconnect ()
This command disconnects an existing binding between the CallChannelManager and the Skype object.
HRESULT | CreateApplication ([in, defaultvalue("")] BSTR ApplicationName)
This command creates the Application context.

Properties

ICallChannelCollection | Channels [get]
This command queries call data channels.
TCallChannelType | ChannelType [get, set]
This command queries/sets the default call channel type.
BSTR | Name [get, set]
This command queries/sets the Application context name.
VARIANT_BOOL | Created [get]
This command returns the application context creation status.

Detailed Description

CallChannelManager class default interface.

Member Function Documentation

HRESULT Connect ( [in] ISkype * pSkype )

This command binds the CallChannelManager object to the Skype object.

Parameters:
[in] pSkype contains the interface pointer for the Skype object.
HRESULT CreateApplication ( [in, defaultvalue("")] BSTR ApplicationName )

This command creates the Application context.

Parameters:
[in] ApplicationName contains an optional application context name.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICallChannelManager Member List

This is the complete list of members for ICallChannelManager, including all inherited members.
Channels ICallChannelManager
ChannelType ICallChannelManager
Connect([in] ISkype *pSkype) | ICallChannelManager
CreateApplication([in, defaultvalue("")] BSTR ApplicationName) | ICallChannelManager


Skype4COM: ICallChannelMessage Interface Reference

Properties

ICallChannelMessage Interface Reference

CallChannelMessage class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

BSTR Text [get, set]
This command queries/sets message text.

Detailed Description

CallChannelMessage class default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICallChannelMessage Member List

This is the complete list of members for ICallChannelMessage, including all inherited members.
Text ICallChannelMessage


Skype4COM: ICallCollection Interface Reference

Public Member Functions | Properties

ICallCollection Interface Reference

CallCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] ICall *pCall)
This command adds a new call to a CallCollection.
HRESULT | Remove ([in] long Index)
This command removes a call from a CallCollection.
HRESULT | RemoveAll (void)
This command removes all calls from a CallCollection.

Properties

LONG | Count [get]
This command queries the number of calls in a CallCollection.
ICall | Item ([in] LONG Index) [get]
This command queries a call with a specified index in a CallCollection.
IUnknown | _NewEnum [get]
This command queries the enumerator object of a CallCollection.

Detailed Description

CallCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] ICall * pCall )

This command adds a new call to a CallCollection.

Parameters:
[in] pCall receives the interface pointer for the Call object.
HRESULT Remove ( [in] long Index )

This command removes a call from a CallCollection.

Parameters:
[in] Index contains the call to be removed.

Property Documentation

HRESULT Item [get]

This command queries a call with a specified index in a CallCollection.

Parameters:
[in] Index contains the call to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICallCollection Member List

This is the complete list of members for ICallCollection, including all inherited members.
_NewEnum | ICallCollection
Add([in] ICall *pCall) | ICallCollection
Count | ICallCollection
Item | ICallCollection
Remove([in] long Index) | ICallCollection
RemoveAll(void) | ICallCollection


Skype4COM: IChat Interface Reference

Public Member Functions | Properties

IChat Interface Reference

Chat class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | OpenWindow ()
This command opens a chat window.
HRESULT | SendMessage ([in] BSTR MessageText,[out, retval] IChatMessage **pVal)
This command sends a chat message.
HRESULT | Leave ()
This command leaves a chat.
HRESULT | AddMembers ([in] IUserCollection *pMembers)
This command adds new members to a chat.
HRESULT | Bookmark ()
This command bookmarks a chat.
HRESULT | Unbookmark ()
This command removes the bookmark for a chat.
HRESULT | SetPassword ([in] BSTR Password,[in, defaultvalue("")] BSTR Hint)
Sets chat password.
HRESULT | Join (void)
Joins the chat.
HRESULT | Kick ([in] BSTR Handle)
Kicks member from chat.
HRESULT | KickBan ([in] BSTR Handle)
Kicks and ban member from chat.
HRESULT | Disband (void)
Ends chat.
HRESULT | EnterPassword ([in] BSTR Password)
Enters chat password.
HRESULT | ClearRecentMessages (void)
Clears recent chat messages.
HRESULT | AcceptAdd (void)
Accepts shared group add.

Properties

BSTR | Name [get]
This commmand queries the chat name.
IChatMessageCollection | Messages [get]
This commmand queries chat messages.
DATE | Timestamp [get]
This command queries the chat timestamp.
IUser | Adder [get]
This command queries who added a user to a chat.
TChatStatus | Status [get]
This command queries a chat status.
IUserCollection | Posters [get]
This command queries users who have posted messages to a chat.
IUserCollection | Members [get]
This command queries the members of a chat.
BSTR | Topic [get, set]
This command queries/sets a chat topic.
IUserCollection | ActiveMembers [get]
This command queries the active members of a chat.
BSTR | FriendlyName [get]
This command queries the "friendly" name of a chat.
IChatMessageCollection | RecentMessages [get]
This command queries the most recent chat messages.
VARIANT_BOOL | Bookmarked [get]
This command queries if a chat is bookmarked.
BSTR | TopicXML [get, set]
Returns/sets chat topic in XML format.
IChatMemberCollection | MemberObjects [get]
Returns chat member objects collection.
BSTR | Blob [get]
Returns chat blob.
LONG | Options [get, set]
Returns/sets chat options.
BSTR | PasswordHint [get]
Returns chat password hint.
BSTR | GuideLines [get, set]
Returns/sets chat guidelines.
BSTR | Description [get, set]
Returns/sets chat description.
BSTR | DialogPartner [get]
Returns chat dialog partner.
DATE | ActivityTimestamp [get]
Returns chat activity timestamp.
TChatMemberRole | MyRole [get]
Returns my chat role.
IUserCollection | Applicants [get]
Returns chat applicants collection.
BSTR | AlertString [set]
Sets chat alert string.
TChatType | Type [get]
Returns chat type.
TChatMyStatus | MyStatus [get]
Returns my chat status.

Detailed Description

Chat class default interface.

Member Function Documentation

HRESULT AddMembers ( [in] IUserCollection * pMembers )

This command adds new members to a chat.

Parameters:
[in] pMembers receives the interface pointer for the UserCollection object.
HRESULT EnterPassword ( [in] BSTR Password )

Enters chat password.

Parameters:
[in] Password contains password string.
HRESULT SendMessage | ( | [in] BSTR | MessageText,
 |  | [out, retval] IChatMessage ** | pVal
 | ) |  |

This command sends a chat message.

Parameters:
[in] | MessageText | contains the message text.
[out] | pVal | receives the interface pointer for the ChatMessage object.
HRESULT SetPassword | ( | [in] BSTR | Password,
 |  | [in, defaultvalue("")] BSTR | Hint
 | ) |  |

Sets chat password.

Parameters:
[in] | Password | contains password.
[in] | Hint | contains password hint.
See also:
IChat::PasswordHint

Property Documentation

HRESULT Options [get, set]

Returns/sets chat options.

See also:
TChatOptions
HRESULT Status [get]

This command queries a chat status.

Deprecated:
ICall::Status is deprecated, use the IChat::Type and IChat::MyStatus instead.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IChat Member List

This is the complete list of members for IChat, including all inherited members.
AcceptAdd(void) | IChat
ActiveMembers | IChat
ActivityTimestamp | IChat
Adder | IChat
AddMembers([in] IUserCollection *pMembers) | IChat
AlertString | IChat
Applicants | IChat
Blob | IChat
Bookmark() | IChat
Bookmarked | IChat
ClearRecentMessages(void) | IChat
Description | IChat
DialogPartner | IChat
Disband(void) | IChat
EnterPassword([in] BSTR Password) | IChat
FriendlyName | IChat
GuideLines | IChat
Join(void) | IChat
Kick([in] BSTR Handle) | IChat
KickBan([in] BSTR Handle) | IChat
Leave() | IChat
MemberObjects | IChat
Members | IChat
Messages | IChat
MyRole | IChat
MyStatus | IChat
Name | IChat
OpenWindow() | IChat
Options | IChat
PasswordHint | IChat
Posters | IChat
RecentMessages | IChat
SendMessage([in] BSTR MessageText,[out, retval] IChatMessage **pVal) | IChat
SetPassword([in] BSTR Password,[in, defaultvalue("")] BSTR Hint) | IChat
Status | IChat
Timestamp | IChat
Topic | IChat
TopicXML | IChat
Type | IChat
Unbookmark() | IChat


Skype4COM: IChatCollection Interface Reference

Public Member Functions | Properties

IChatCollection Interface Reference

ChatCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IChat *pItem)
This command adds a new chat to a ChatCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a ChatCollection.
HRESULT | RemoveAll (void)
This command removes all items from a ChatCollection.

Properties

LONG | Count [get]
This command queries the number of chats in a ChatCollection.
IChat | Item ([in] LONG Index) [get]
This command queries a chat collection item with a specified index.
IUnknown | _NewEnum [get]
This command queries a ChatCollection enumerator object.

Detailed Description

ChatCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] IChat * pItem )

This command adds a new chat to a ChatCollection.

Parameters:
[in] pItem contains the interface pointer for the Chat object.
HRESULT Remove ( [in] long Index )

This command removes an item from a ChatCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries a chat collection item with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IChatCollection Member List

This is the complete list of members for IChatCollection, including all inherited members.
_NewEnum | IChatCollection
Add([in] IChat *pItem) | IChatCollection
Count | IChatCollection
Item | IChatCollection
Remove([in] long Index) | IChatCollection
RemoveAll(void) | IChatCollection


Skype4COM: IChatMember Interface Reference

Properties

IChatMember Interface Reference

ChatMember class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

BSTR | Id [get]
Returns member id.
BSTR | Handle [get]
Returns member Skypename.
TChatMemberRole | Role [get, set]
Sets/returns member role.
VARIANT_BOOL | CanSetRoleTo ([in] TChatMemberRole Role) [get]
Checks if the new role can be applied to member.
VARIANT_BOOL | IsActive [get]
Returns member activity status.
IChat | Chat [get]
Returns related chat object.

Detailed Description

ChatMember class default interface.

Property Documentation

HRESULT CanSetRoleTo [get]

Checks if the new role can be applied to member.

Parameters:
[in] Role contains the new role.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IChatMember Member List

This is the complete list of members for IChatMember, including all inherited members.
CanSetRoleTo | IChatMember
Chat | IChatMember
Handle | IChatMember
Id | IChatMember
IsActive | IChatMember
Role | IChatMember


Skype4COM: IChatMemberCollection Interface Reference

Properties

IChatMemberCollection Interface Reference

ChatMemberCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

LONG | Count [get]
This command queries the number of chat members in a ChatMemberCollection.
IChatMember | Item ([in] LONG Index) [get]
This command queries an item in a ChatMemberCollection with a specified index.
IUnknown | _NewEnum [get]
This command queries an enumerator object for a ChatMemberCollection.

Detailed Description

ChatMemberCollection class default interface.

Property Documentation

HRESULT Item [get]

This command queries an item in a ChatMemberCollection with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IChatMemberCollection Member List

This is the complete list of members for IChatMemberCollection, including all inherited members.
_NewEnum | IChatMemberCollection
Count | IChatMemberCollection
Item | IChatMemberCollection


Skype4COM: IChatMessage Interface Reference

Properties

IChatMessage Interface Reference

ChatMessage class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

LONG | Id [get]
This command queries a message ID.
DATE | Timestamp [get]
This command queries a message timestamp.
BSTR | FromHandle [get]
This command queries the Skypename of a message sender.
BSTR | FromDisplayName [get]
This command queries the display name of a sender.
TChatMessageType | Type [get]
This command queries a message type.
TChatMessageStatus | Status [get]
This command queries a message status.
TChatLeaveReason | LeaveReason [get]
This command queries the reason for leaving a chat.
BSTR | Body [get, set]
Returns/sets chat message body.
BSTR | ChatName [get]
This command queries the name of a chat that includes the message.
IUserCollection | Users [get]
This command queries which users are added to chat.
VARIANT_BOOL | Seen [set]
This command marks missed a chat message as seen.
IChat | Chat [get]
This command queries a message chat.
IUser | Sender [get]
This command queries the sender of a chat message.
BSTR | EditedBy [get]
Returns chat message editor Skypename.
DATE | EditedTimestamp [get]
Returns chat message editing timestamp.
TChatMemberRole | Role [get]
Returns chat member role changed by this message.
LONG | Options [get]
Returns chat options changed by this message.
VARIANT_BOOL | IsEditable [get]
Returns chat message editable status.
BSTR | Guid [get]
Returns chat message unique identifier.

Detailed Description

ChatMessage class default interface.

Property Documentation

HRESULT LeaveReason [get]

This command queries the reason for leaving a chat.

Note:
Applies to messages with TChatMessageType::cmeLeft type.
HRESULT Options [get]

Returns chat options changed by this message.

Note:
Applies to messages with TChatMessageType::cmeSetOptions type.
HRESULT Role [get]

Returns chat member role changed by this message.

Note:
Applies to messages with TChatMessageType::cmeSetRole type.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IChatMessage Member List

This is the complete list of members for IChatMessage, including all inherited members.
Body | IChatMessage
Chat | IChatMessage
ChatName | IChatMessage
EditedBy | IChatMessage
EditedTimestamp | IChatMessage
FromDisplayName | IChatMessage
FromHandle | IChatMessage
Guid | IChatMessage
Id | IChatMessage
IsEditable | IChatMessage
LeaveReason | IChatMessage
Options | IChatMessage
Role | IChatMessage
Seen | IChatMessage
Sender | IChatMessage
Status | IChatMessage
Timestamp | IChatMessage
Type | IChatMessage
Users | IChatMessage


Skype4COM: IChatMessageCollection Interface Reference

Public Member Functions | Properties

IChatMessageCollection Interface Reference

ChatMessageCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IChatMessage *pItem)
This command adds a new item to a ChatMessageCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a ChatMessageCollection.
HRESULT | RemoveAll (void)
This command removes all items from a ChatMessageCollection.

Properties

LONG | Count [get]
This command queries the number of chat messages in a ChatMessageCollection.
IChatMessage | Item ([in] LONG Index) [get]
This command queries an item in a ChatMessageCollection with a specified index.
IUnknown | _NewEnum [get]
This command queries an enumerator object for a ChatMessageCollection.

Detailed Description

ChatMessageCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] IChatMessage * pItem )

This command adds a new item to a ChatMessageCollection.

Parameters:
[in] pItem contains the interface pointer for teh ChatMessage object.
HRESULT Remove ( [in] long Index )

This command removes an item from a ChatMessageCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries an item in a ChatMessageCollection with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IChatMessageCollection Member List

This is the complete list of members for IChatMessageCollection, including all inherited members.
_NewEnum | IChatMessageCollection
Add([in] IChatMessage *pItem) | IChatMessageCollection
Count | IChatMessageCollection
Item | IChatMessageCollection
Remove([in] long Index) | IChatMessageCollection
RemoveAll(void) | IChatMessageCollection


Skype4COM: IClient Interface Reference

Public Member Functions | Properties

IClient Interface Reference

Client class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Start ([in, defaultvalue(0)] VARIANT_BOOL Minimized,[in, defaultvalue(0)] VARIANT_BOOL Nosplash)
This command starts the Skype client.
HRESULT | Minimize ()
This command minimizes (hides) the Skype client.
HRESULT | Shutdown ()
This command closes the Skype client.
HRESULT | OpenProfileDialog ()
This command opens the profile window for the current user.
HRESULT | OpenUserInfoDialog ([in] BSTR Username)
This command opens the information window for the current user.
HRESULT | OpenConferenceDialog ()
This command opens the create conference window.
HRESULT | OpenSearchDialog ()
This command opens the search contacts window.
HRESULT | OpenOptionsDialog ([in] BSTR Page)
This command opens the options window.
HRESULT | OpenCallHistoryTab ()
This command brings the call history tab into focus.
HRESULT | OpenContactsTab ()
This command brings the contacts tab into focus.
HRESULT | OpenDialpadTab ()
This command brings the dialpad tab into focus.
HRESULT | OpenSendContactsDialog ([in, defaultvalue("")] BSTR Username)
This command opens the send contacts window.
HRESULT | OpenBlockedUsersDialog ()
This command opens the blocked users window.
HRESULT | OpenImportContactsWizard ()
This command opens the import contacts window.
HRESULT | OpenGettingStartedWizard ()
This command opens the getting started wizard.
HRESULT | OpenAuthorizationDialog ([in] BSTR Username)
This command opens the user authorization window.
HRESULT | OpenDialog ([in] BSTR Name,[in, defaultvalue("")] BSTR Param1,[in, defaultvalue("")] BSTR Param2)
This command opens the user interface window.
HRESULT | OpenVideoTestDialog ()
This command opens the video test window.
HRESULT | OpenAddContactDialog ([in, defaultvalue("")] BSTR Username)
This command opens the "Add a Contact" window.
HRESULT | OpenMessageDialog ([in] BSTR Username,[in, defaultvalue("")] BSTR Text)
This command opens the "Send an IM Message" window.
HRESULT | OpenFileTransferDialog ([in] BSTR User,[in] BSTR Folder)
This command opens the file transfer window.
HRESULT | Focus ()
This command brings the client window into focus.
HRESULT | ButtonPressed ([in] BSTR Key)
This command sends a button pressed notification event.
HRESULT | ButtonReleased ([in] BSTR Key)
This command sends a button released notification event.
HRESULT | OpenSmsDialog ([in] BSTR SmsId)
This command opens SMS window.
HRESULT | CreateEvent ([in] BSTR EventId,[in] BSTR Caption,[in] BSTR Hint,[out, retval] IPluginEvent **pEvent)
This command creates a plug-in event.
HRESULT | CreateMenuItem ([in] BSTR MenuItemId,[in] TPluginContext PluginContext,[in] BSTR CaptionText,[in, defaultvalue("")] BSTR HintText,[in, defaultvalue("")] BSTR IconPath,[in, defaultvalue(-1)] VARIANT_BOOL Enabled,[in, defaultvalue(pluginContactTypeAll)] TPluginContactType ContactType,[in, defaultvalue(0)] VARIANT_BOOL MultipleContacts,[out, retval] IPluginMenuItem **pMenuItem)
This command creates a menu item for a plug-in.
HRESULT | OpenLiveTab ()
This command brings the Live tab into focus.

Properties

VARIANT_BOOL | IsRunning [get]
This command queries the running status of the Skype client.
BSTR | Wallpaper [get, set]
This command queries/sets path to wallpaper bitmap.

Detailed Description

Client class default interface.

Member Function Documentation

HRESULT ButtonPressed ( [in] BSTR Key )

This command sends a button pressed notification event.

Parameters:
[in] Key is a button key (0-9, A-Z, #, *, UP, DOWN, YES, NO, SKYPE, PAGEUP, PAGEDOWN).
HRESULT ButtonReleased ( [in] BSTR Key )

This command sends a button released notification event.

Parameters:
[in] Key is button key (0-9, A-Z, #, *, UP, DOWN, YES, NO, SKYPE, PAGEUP, PAGEDOWN).
HRESULT CreateEvent | ( | [in] BSTR | EventId,
 |  | [in] BSTR | Caption,
 |  | [in] BSTR | Hint,
 |  | [out,retval] IPluginEvent ** | pEvent
 | ) |  |

This command creates a plug-in event.

Parameters:
[in] | EventId | is a unique identifier for the plug-in event.
[in] | Caption | event contains caption text.
[in] | Hint | event contains hint text.
[out] | pEvent | receives the interface pointer for the PluginEvent object.
HRESULT CreateMenuItem | ( | [in] BSTR | MenuItemId,
 |  | [in] TPluginContext | PluginContext,
 |  | [in] BSTR | CaptionText,
 |  | [in,defaultvalue("")] BSTR | HintText,
 |  | [in, defaultvalue("")] BSTR | IconPath,
 |  | [in, defaultvalue(-1)] VARIANT_BOOL | Enabled,
 |  | [in, defaultvalue(pluginContactTypeAll)] TPluginContactType | ContactType,
 |  | [in, defaultvalue(0)] VARIANT_BOOL | MultipleContacts,
 |  | [out,retval] IPluginMenuItem ** | pMenuItem
 | ) |  |

This command creates a menu item for a plug-in.

Parameters:
[in] | MenuItemId | is a unique identifier for the menu item.
[in] | PluginContext | contains the plug-in context.
[in] | CaptionText | contains the caption text for the menu item.
[in] | HintText | contains the hint text for the menu item (optional).
[in] | IconPath | is the path to an icon file (optional).
[in] | Enabled | defines the initial state of the menu item (optional - default enabled).
[in] | ContactType | is the contact type and is relevant only in theTPluginContext::pluginContextContact context (optional - default all contacts).
[in] | MultipleContacts | defines whether multiple contacts are allowed for this menu item (optional - default does not allow multiple contacts).
[out] | pMenuItem | receives the interface pointer for the PluginMenuItem object.
See also:
TPluginContext
HRESULT OpenAddContactDialog ( [in, defaultvalue("")] BSTR Username )

This command opens the "Add a Contact" window.

Parameters:
[in] Username is an optional field for the Skypename of the contact.
HRESULT OpenAuthorizationDialog ( [in] BSTR Username )

This command opens the user authorization window.

Parameters:
[in] Username contains the Skypename of the user.
HRESULT OpenDialog | ( | [in] BSTR | Name,
 |  | [in, defaultvalue("")] BSTR | Param1,
 |  | [in, defaultvalue("")] BSTR | Param2
 | ) |  |

This command opens the user interface window.

Parameters:
[in] | Name | The Name field contains the name of the window.
[in] | Param1 | is an optional parameter.
[in] | Param2 | is an optional parameter.
HRESULT OpenFileTransferDialog | ( | [in] BSTR | Username,
 |  | [in] BSTR | Folder
 | ) |  |

This command opens the file transfer window.

Parameters:
[in] | Username | contains the Skypename of the user
[in] | Folder | contains the folder name to transfer.
HRESULT OpenMessageDialog | ( | [in] BSTR | Username,
 |  | [in, defaultvalue("")] BSTR | Text
 | ) |  |

This command opens the "Send an IM Message" window.

Parameters:
[in] | Username | contains the message target.
[in] | Text | is an optional field which can contain message text.
HRESULT OpenOptionsDialog ( [in] BSTR Page )

This command opens the options window.

Parameters:
[in] Page contains the page to open.
HRESULT OpenSendContactsDialog ( [in, defaultvalue("")] BSTR Username )

This command opens the send contacts window.

Parameters:
[in] Username is an optional field for the Skypename of the user.
HRESULT OpenSmsDialog ( [in] BSTR SmsId )

This command opens SMS window.

Parameters:
[in] SmsId is SMS message id.
HRESULT OpenUserInfoDialog ( [in] BSTR Username )

This command opens the information window for the current user.

Parameters:
[in] Username contains the Skypename of the user
HRESULT Start | ( | [in, defaultvalue(0)] VARIANT_BOOL | Minimized,
 |  | [in, defaultvalue(0)] VARIANT_BOOL | Nosplash
 | ) |  |

This command starts the Skype client.

Parameters:
[in] | Minimized | if True, Skype is minimized in the system tray.
[in] | Nosplash | if True, Skype does not display a splash screen on start up.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IClient Member List

This is the complete list of members for IClient, including all inherited members.
ButtonPressed([in] BSTR Key) | IClient
ButtonReleased([in] BSTR Key) | IClient
CreateEvent([in] BSTR EventId,[in] BSTR Caption,[in] BSTR Hint,[out, retval] IPluginEvent **pEvent) | IClient
CreateMenuItem([in] BSTR MenuItemId,[in] TPluginContext PluginContext,[in] BSTR CaptionText,[in, defaultvalue("")] BSTR HintText,[in, defaultvalue("")] BSTR IconPath,[in, defaultvalue(-1)] VARIANT_BOOL Enabled,[in, defaultvalue(pluginContactTypeAll)] TPluginContactType ContactType,[in, defaultvalue(0)] VARIANT_BOOL MultipleContacts,[out, retval] IPluginMenuItem **pMenuItem) | IClient
Focus() IClient
IsRunning IClient
Minimize() IClient
OpenAddContactDialog([in, defaultvalue("")] BSTR Username) | IClient
OpenAuthorizationDialog([in] BSTR Username) | IClient
OpenBlockedUsersDialog() IClient
OpenCallHistoryTab() IClient
OpenConferenceDialog() IClient
OpenContactsTab() IClient
OpenDialog([in] BSTR Name,[in, defaultvalue("")] BSTR Param1,[in, defaultvalue("")] BSTR Param2) | IClient
OpenDialpadTab() IClient
OpenFileTransferDialog([in] BSTR User,[in] BSTR Folder) | IClient
OpenGettingStartedWizard() IClient
OpenImportContactsWizard() IClient
OpenLiveTab() IClient
OpenMessageDialog([in] BSTR Username,[in, defaultvalue("")] BSTR Text) | IClient
OpenOptionsDialog([in] BSTR Page) | IClient
OpenProfileDialog() IClient
OpenSearchDialog() IClient
OpenSendContactsDialog([in, defaultvalue("")] BSTR Username) | IClient
OpenSmsDialog([in] BSTR SmsId) | IClient
OpenUserInfoDialog([in] BSTR Username) | IClient
OpenVideoTestDialog() IClient
Shutdown() IClient
Start([in, defaultvalue(0)] VARIANT_BOOL Minimized,[in, defaultvalue(0)] VARIANT_BOOL Nosplash) | IClient


Skype4COM: ICommand Interface Reference

Properties

ICommand Interface Reference

Command class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

LONG | Id [get, set]
This command queries/sets a command ID.
LONG | Timeout [get, set]
This command queries/sets the wait timeout in milliseconds.
VARIANT_BOOL | Blocking [get, set]
This command queries/sets if blocking is set.
BSTR | Command [get, set]
This command queries/sets the command text.
BSTR | Reply [get, set]
This command queries/sets the reply text.
BSTR | Expected [get, set]
This command queries/sets the expected reply text.

Detailed Description

Command class default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ICommand Member List

This is the complete list of members for ICommand, including all inherited members.
Blocking | ICommand
Command | ICommand
Expected | ICommand
Id | ICommand
Reply | ICommand
Timeout | ICommand


Skype4COM: IConference Interface Reference

Public Member Functions | Properties

IConference Interface Reference

Conference class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Hold ()
This command places all calls in a conference on hold and all active calls have the status TCallStatus::clsLocalHold.
HRESULT | Resume ()
This command resumes a conference that was placed on hold and all active calls have the status TCallStatus::clsInProgress.
HRESULT | Finish ()
This command finishes a conference and all active calls have the status TCallStatus::clsFinished.

Properties

LONG | Id [get]
This command queries the ID of a conference.
ICallCollection | Calls [get]
This command queries calls with the same conference ID.
ICallCollection | ActiveCalls [get]
This command queries active calls with the same conference ID.

Detailed Description

Conference class default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IConference Member List

This is the complete list of members for IConference, including all inherited members.
ActiveCalls | IConference
Calls | IConference
Finish() | IConference
Hold() | IConference
Id | IConference
Resume() | IConference


Skype4COM: IConferenceCollection Interface Reference

Public Member Functions | Properties

IConferenceCollection Interface Reference

ConferenceCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IConference *pItem)
This command adds a new conference to a ConferenceCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a ConferenceCollection.
HRESULT | RemoveAll (void)
This command removes all items from a ConferenceCollection.

Properties

LONG | Count [get]
This command queries the number of conferences in a ConferenceCollection.
IConference | Item ([in] LONG Index) [get]
This command queries a ConferenceCollection item with a specified index.
IUnknown | _NewEnum [get]
This command queries the enumerator object of a ConferenceCollection.

Detailed Description

ConferenceCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] IConference * pConference )

This command adds a new conference to a ConferenceCollection.

Parameters:
[in] pConference receives the interface pointer for the Conference object.
HRESULT Remove ( [in] long Index )

This command removes an item from a ConferenceCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries a ConferenceCollection item with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IConferenceCollection Member List

This is the complete list of members for IConferenceCollection, including all inherited members.
_NewEnum | IConferenceCollection
Add([in] IConference *pItem) | IConferenceCollection
Count | IConferenceCollection
Item | IConferenceCollection
Remove([in] long Index) | IConferenceCollection
RemoveAll(void) | IConferenceCollection


Skype4COM: IConversion Interface Reference

Public Member Functions | Properties

IConversion Interface Reference

Conversion class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | OnlineStatusToText ([in] TOnlineStatus status,[out, retval] BSTR *pVal)
This command converts a user's online status from status code to text.
HRESULT | TextToOnlineStatus ([in] BSTR Text,[out, retval] TOnlineStatus *pVal)
This command converts text to online status code.
HRESULT | BuddyStatusToText ([in] TBuddyStatus status,[out, retval] BSTR *pVal)
This command converts contact status to text.
HRESULT | TextToBuddyStatus ([in] BSTR Text,[out, retval] TBuddyStatus *pVal)
This command converts contact status text to contact status code.
HRESULT | CallStatusToText ([in] TCallStatus Status,[out, retval] BSTR *pVal)
This command converts call status to text.
HRESULT | TextToCallStatus ([in] BSTR Text,[out, retval] TCallStatus *pVal)
This command converts call status text to call status code.
HRESULT | CallTypeToText ([in] TCallType CallType,[out, retval] BSTR *pVal)
This command converts the call type to text.
HRESULT | TextToCallType ([in] BSTR Text,[out, retval] TCallType *pVal)
This command converts call type text to call type code.
HRESULT | UserSexToText ([in] TUserSex Sex,[out, retval] BSTR *pVal)
This command converts user sex value to text.
HRESULT | TextToUserSex ([in] BSTR Text,[out, retval] TUserSex *pVal)
This command converts the user sex text string to code.
HRESULT | ConnectionStatusToText ([in] TConnectionStatus Status,[out, retval] BSTR *pVal)
This command converts the connection status to a text string.
HRESULT | TextToConnectionStatus ([in] BSTR Text,[out, retval] TConnectionStatus *pVal)
This command converts a text string of connection status to a code value.
HRESULT | UserStatusToText ([in] TUserStatus Status,[out, retval] BSTR *pVal)
This command converts the user status value to a text string.
HRESULT | TextToUserStatus ([in] BSTR Text,[out, retval] TUserStatus *pVal)
This command converts a string of user status to a code value.
HRESULT | CallFailureReasonToText ([in] TCallFailureReason reason,[out, retval] BSTR *pVal)
This command converts a failure reason to a text string.
HRESULT | AttachmentStatusToText ([in] TAttachmentStatus status,[out, retval] BSTR *pVal)
This command converts an attachment status code to a text string.
HRESULT | ChatLeaveReasonToText ([in] TChatLeaveReason reason,[out, retval] BSTR *pVal)
This command converts a leave reason to a text string.
HRESULT | ChatStatusToText ([in] TChatStatus status,[out, retval] BSTR *pVal)
This command converts a chat status code to a text string.
HRESULT | VoicemailTypeToText ([in] TVoicemailType type,[out, retval] BSTR *pVal)
This command converts a voicemail type to a text string.
HRESULT | VoicemailStatusToText ([in] TVoicemailStatus status,[out, retval] BSTR *pVal)
This command converts a voicemail status to a text string.
HRESULT | TextToVoicemailStatus ([in] BSTR Text,[out, retval] TVoicemailStatus *pVal)
This command converts a voicemail status text string to code.
HRESULT | VoicemailFailureReasonToText ([in] TVoicemailFailureReason code,[out, retval] BSTR *pVal)
This command converts a voicemail failure reason to a text string.
HRESULT | ChatMessageStatusToText ([in] TChatMessageStatus Status,[out, retval] BSTR *pVal)
Thic command converts message status code to text.
HRESULT | TextToChatMessageStatus ([in] BSTR Text,[out, retval] TChatMessageStatus *pVal)
This command converts a message status from text to code.
HRESULT | ChatMessageTypeToText ([in] TChatMessageType Type,[out, retval] BSTR *pVal)
This command converts the message type code to text.
HRESULT | TextToChatMessageType ([in] BSTR Text,[out, retval] TChatMessageType *pVal)
This command converts a message type from text string to code.
HRESULT | TextToAttachmentStatus ([in] BSTR Text,[out, retval] TAttachmentStatus *pVal)
This command converts an attachment status text string to code.
HRESULT | GroupTypeToText ([in] TGroupType Type,[out, retval] BSTR *pVal)
This command converts a group type to a text string.
HRESULT | TextToGroupType ([in] BSTR Text,[out, retval] TGroupType *pVal)
This command converts a text group type to a code value.
HRESULT | CallVideoStatusToText ([in] TCallVideoStatus Status,[out, retval] BSTR *pVal)
This command converts call video status to a text string.
HRESULT | CallVideoSendStatusToText ([in] TCallVideoSendStatus Status,[out, retval] BSTR *pVal)
This command converts call video send status to a text string.
HRESULT | SmsMessageStatusToText ([in] TSmsMessageStatus status,[out, retval] BSTR *pVal)
This command converts SMS message status to a text string.
HRESULT | SmsMessageTypeToText ([in] TSmsMessageType type,[out, retval] BSTR *pVal)
This command converts SMS message type to a text string.
HRESULT | SmsTargetStatusToText ([in] TSmsTargetStatus status,[out, retval] BSTR *pVal)
This command converts SMS target status to a text string.

Properties

BSTR | Language [get, set]
This command queries/sets the language to use for a text conversion.

Detailed Description

Conversion class default interface.

This interface converts Skype4COM constant values to text and converts text back to constant values.

See also:
Refer to the Skype4COM Dev Notes for more information about conversion.

Member Function Documentation

HRESULT AttachmentStatusToText | ( | [in] TAttachmentStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts an attachment status code to a text string.

Parameters:
[in] | status | contains the attachment status code.
[out] | pVal | receives the converted attachment status as a text string.
HRESULT BuddyStatusToText | ( | [in] TBuddyStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts contact status to text.

Parameters:
[in] | status | is the contact status value.
[out] | pVal | receives the contact status value as a text string.
HRESULT CallFailureReasonToText | ( | [in] TCallFailureReason | reason,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a failure reason to a text string.

Parameters:
[in] | reason | contains a failure reason code.
[out] | pVal | receives the failure reason as a text string.
HRESULT CallStatusToText | ( | [in] TCallStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts call status to text.

Parameters:
[in] | status | contains the call status value.
[out] | pVal | receives the call status as a text string.
HRESULT CallTypeToText | ( | [in] TCallType | CallType,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts the call type to text.

Parameters:
[in] | CallType | contains the call type value.
[out] | pVal | receives the call type value as a text string .
HRESULT CallVideoSendStatusToText | ( | [in] TCallVideoSendStatus | Status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts call video send status to a text string.

Parameters:
[in] | Status | contains the video send status code.
[out] | pVal | receives the video send status as a text string.
HRESULT CallVideoStatusToText | ( | [in] TCallVideoStatus | Status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts call video status to a text string.

Parameters:
[in] | Status | contains the video status code.
[out] | pVal | receives the converted code as a text string.
HRESULT ChatLeaveReasonToText | ( | [in] TChatLeaveReason | reason,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a leave reason to a text string.

Parameters:
[in] | reason | contains a leave reason code.
[out] | pVal | receives a leave reason as a text string.
HRESULT ChatMessageStatusToText | ( | [in] TChatMessageStatus | Status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

Thic command converts message status code to text.

Parameters:
[in] | Status | contains the message status value.
[out] | pVal | receives the message status as a text string.
HRESULT ChatMessageTypeToText | ( | [in] TChatMessageType | Type,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts the message type code to text.

Parameters:
[in] | Type | contains the message type code.
[out] | pVal | receives the message type as a text string.
HRESULT ChatStatusToText | ( | [in] TChatStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a chat status code to a text string.

Parameters:
[in] | status | contains the chat status code.
[out] | pVal | receives the converted chat status as a text string.
HRESULT ConnectionStatusToText | ( | [in] TConnectionStatus | Status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts the connection status to a text string.

Parameters:
[in] | Status | contains the connection status value.
[out] | pVal | receives the connection status value as a text string.
HRESULT GroupTypeToText | ( | [in] TGroupType | Type,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a group type to a text string.

Parameters:
[in] | Type | contains the group type code.
[out] | pVal | receives the group type as a text string.
HRESULT OnlineStatusToText | ( | [in] TOnlineStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a user's online status from status code to text.

Parameters:
[in] | status | is the online status value.
[out] | pVal | receives a text string of the current online status.
HRESULT SmsMessageStatusToText | ( | [in] TSmsMessageStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts SMS message status to a text string.

Parameters:
[in] | status | contains SMS message status.
[out] | pVal | receives the status as text string.
HRESULT SmsMessageTypeToText | ( | [in] TSmsMessageType | type,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts SMS message type to a text string.

Parameters:
[in] | type | contains SMS message type.
[out] | pVal | receives the type as text string.
HRESULT SmsTargetStatusToText | ( | [in] TSmsTargetStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts SMS target status to a text string.

Parameters:
[in] | status | contains SMS target status.
[out] | pVal | receives the status as text string.
HRESULT TextToAttachmentStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TAttachmentStatus * | pVal
 | ) |  |

This command converts an attachment status text string to code.

Parameters:
[in] | Text | contains a text string ("UNKNOWN","SUCCESS","PENDING","REFUSED","NOTAVAILABLE","AVAILABLE").
[out] | pVal | receives the converted text attachment status as as status code.
HRESULT TextToBuddyStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TBuddyStatus * | pVal
 | ) |  |

This command converts contact status text to contact status code.

Parameters:
[in] | Text | contains a text string of the contact status.
[out] | pVal | receives the contact status code.
HRESULT TextToCallStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TCallStatus * | pVal
 | ) |  |

This command converts call status text to call status code.

Parameters:
[in] | Text | contains a string ("UNPLACED", "ROUTING", "EARLYMEDIA", "FAILED", "RINGING", "INPROGRESS", "ONHOLD", "FINISHED", "MISSED", "REFUSED", "BUSY", "LOCALHOLD", "REMOTEHOLD").
[out] | pVal | receives the call status text as a call status code.
HRESULT TextToCallType | ( | [in] BSTR | Text,
 |  | [out, retval] TCallType * | pVal
 | ) |  |

This command converts call type text to call type code.

Parameters:
[in] | Text | contains a text string ("INCOMING_PSTN", "OUTGOING_PSTN", "INCOMING_P2P", "OUTGOING_P2P").
[out] | pVal | receives the call type as call type code.
HRESULT TextToChatMessageStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TChatMessageStatus * | pVal
 | ) |  |

This command converts a message status from text to code.

Parameters:
[in] | Text | contains a text string of the message status.
[out] | pVal | receives the text string as message status code.
HRESULT TextToChatMessageType | ( | [in] BSTR | Text,
 |  | [out, retval] TChatMessageType * | pVal
 | ) |  |

This command converts a message type from text string to code.

Parameters:
[in] | Text | contains a text string for the message type.
[out] | pVal | receives the message type in code.
HRESULT TextToConnectionStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TConnectionStatus * | pVal
 | ) |  |

This command converts a text string of connection status to a code value.

Parameters:
[in] | Text | contains a text string ("OFFLINE", "CONNECTING", "PAUSING", "ONLINE", "LOGGEDOUT").
[out] | pVal | receives the converted text string as connection status code.
HRESULT TextToGroupType | ( | [in] BSTR | Text,
 |  | [out, retval] TGroupType * | pVal
 | ) |  |

This command converts a text group type to a code value.

Parameters:
[in] | Text | contains a text string ("CUSTOM_GROUP", "ALL_USERS", "ALL_FRIENDS", "SKYPE_FRIENDS", "SKYPEOUT_FRIENDS", "ONLINE_FRIENDS", "UNKNOWN_OR_PENDINGAUTH_FRIENDS", "RECENTLY_CONTACTED_USERS", "USERS_WAITING_MY_AUTHORIZATION", "USERS_AUTHORIZED_BY_ME", "USERS_BLOCKED_BY_ME", "UNGROUPED_FRIENDS", "SHARED_GROUP", "PROPOSED_SHARED_GROUP")
[out] | pVal | receives the converted text group type as code.
HRESULT TextToOnlineStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TOnlineStatus * | pVal
 | ) |  |

This command converts text to online status code.

Parameters:
[in] | Text | contains a text string ("OFFLINE", "ONLINE", "AWAY", "NA", "DND", "SKYPEME", "SKYPEOUT").
[out] | pVal | receives the online status code.
HRESULT TextToUserSex | ( | [in] BSTR | Text,
 |  | [out, retval] TUserSex * | pVal
 | ) |  |

This command converts the user sex text string to code.

Parameters:
[in] | Text | contains a text string ("UNKNOWN", "MALE", "FEMALE").
[out] | pVal | receives the converted text string as user sex code.
HRESULT TextToUserStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TUserStatus * | pVal
 | ) |  |

This command converts a string of user status to a code value.

Parameters:
[in] | Text | contains a text string ("OFFLINE", "ONLINE", "AWAY", "NA", "DND", "INVISIBLE", "LOGGEDOUT", "SKYPEME").
[out] | pVal | receives the converted text string as a user status code.
HRESULT TextToVoicemailStatus | ( | [in] BSTR | Text,
 |  | [out, retval] TVoicemailStatus * | pVal
 | ) |  |

This command converts a voicemail status text string to code.

Parameters:
[in] | Text | contains a text string ("NOTDOWNLOADED", "DOWNLOADING", "UNPLAYED", "BUFFERING", "PLAYING", "PLAYED", "BLANK", "RECORDING", "RECORDED", "UPLOADING", "UPLOADED", "DELETING", "FAILED", "UNKNOWN").
[out] | pVal | receives the converted voicemail status text as code.
HRESULT UserSexToText | ( | [in] TUserSex | Sex,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts user sex value to text.

Parameters:
[in] | Sex | contains the user sex value.
[out] | pVal | receives the user sex value as a text string.
HRESULT UserStatusToText | ( | [in] TUserStatus | Status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts the user status value to a text string.

Parameters:
[in] | Status | contains the user status value.
[out] | pVal | receives the user status value as a text string.
HRESULT VoicemailFailureReasonToText | ( | [in] TVoicemailFailureReason | code,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a voicemail failure reason to a text string.

Parameters:
[in] | code | contains the voicemail failure reason code.
[out] | pVal | receives the converted voicemail failure reason as a text string.
HRESULT VoicemailStatusToText | ( | [in] TVoicemailStatus | status,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a voicemail status to a text string.

Parameters:
[in] | status | contains the voicemail status code.
[out] | pVal | receives the converted voicemail status as a text string.
HRESULT VoicemailTypeToText | ( | [in] TVoicemailType | type,
 |  | [out, retval] BSTR * | pVal
 | ) |  |

This command converts a voicemail type to a text string.

Parameters:
[in] | type | contains the voicemail type code.
[out] | pVal | receives the converted voicemail type as a text string.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IConversion Member List

This is the complete list of members for IConversion, including all inherited members.
AttachmentStatusToText([in] TAttachmentStatus status,[out, retval] BSTR *pVal) | IConversion
BuddyStatusToText([in] TBuddyStatus status,[out, retval] BSTR *pVal) | IConversion
CallFailureReasonToText([in] TCallFailureReason reason,[out, retval] BSTR *pVal) | IConversion
CallStatusToText([in] TCallStatus Status,[out, retval] BSTR *pVal) | IConversion
CallTypeToText([in] TCallType CallType,[out, retval] BSTR *pVal) | IConversion
CallVideoSendStatusToText([in] TCallVideoSendStatus Status,[out, retval] BSTR *pVal) | IConversion
CallVideoStatusToText([in] TCallVideoStatus Status,[out, retval] BSTR *pVal) | IConversion
ChatLeaveReasonToText([in] TChatLeaveReason reason,[out, retval] BSTR *pVal) | IConversion
ChatMessageStatusToText([in] TChatMessageStatus Status,[out, retval] BSTR *pVal) | IConversion
ChatMessageTypeToText([in] TChatMessageType Type,[out, retval] BSTR *pVal) | IConversion
ChatStatusToText([in] TChatStatus status,[out, retval] BSTR *pVal) | IConversion
ConnectionStatusToText([in] TConnectionStatus Status,[out, retval] BSTR *pVal) | IConversion
GroupTypeToText([in] TGroupType Type,[out, retval] BSTR *pVal) | IConversion
Language | IConversion
OnlineStatusToText([in] TOnlineStatus status,[out, retval] BSTR *pVal) | IConversion
SmsMessageStatusToText([in] TSmsMessageStatus status,[out, retval] BSTR *pVal) | IConversion
SmsMessageTypeToText([in] TSmsMessageType type,[out, retval] BSTR *pVal) | IConversion
SmsTargetStatusToText([in] TSmsTargetStatus status,[out, retval] BSTR *pVal) | IConversion
TextToAttachmentStatus([in] BSTR Text,[out, retval] TAttachmentStatus *pVal) | IConversion
TextToBuddyStatus([in] BSTR Text,[out, retval] TBuddyStatus *pVal) | IConversion
TextToCallStatus([in] BSTR Text,[out, retval] TCallStatus *pVal) | IConversion
TextToCallType([in] BSTR Text,[out, retval] TCallType *pVal) | IConversion
TextToChatMessageStatus([in] BSTR Text,[out, retval] TChatMessageStatus *pVal) | IConversion
TextToChatMessageType([in] BSTR Text,[out, retval] TChatMessageType *pVal) | IConversion
TextToConnectionStatus([in] BSTR Text,[out, retval] TConnectionStatus *pVal) | IConversion
TextToGroupType([in] BSTR Text,[out, retval] TGroupType *pVal) | IConversion
TextToOnlineStatus([in] BSTR Text,[out, retval] TOnlineStatus *pVal) | IConversion
TextToUserSex([in] BSTR Text,[out, retval] TUserSex *pVal) | IConversion
TextToUserStatus([in] BSTR Text,[out, retval] TUserStatus *pVal) | IConversion
TextToVoicemailStatus([in] BSTR Text,[out, retval] TVoicemailStatus *pVal) | IConversion
UserSexToText([in] TUserSex Sex,[out, retval] BSTR *pVal) | IConversion
UserStatusToText([in] TUserStatus Status,[out, retval] BSTR *pVal) | IConversion
VoicemailFailureReasonToText([in] TVoicemailFailureReason code,[out, retval] BSTR *pVal) | IConversion
VoicemailStatusToText([in] TVoicemailStatus status,[out, retval] BSTR *pVal) | IConversion
VoicemailTypeToText([in] TVoicemailType type,[out, retval] BSTR *pVal) | IConversion


Skype4COM: IFileTransfer Interface Reference

Properties

IFileTransfer Interface Reference

File transfer object default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

BSTR | Id [get]
This property returns the file transfer unique identifier.
TFileTransferType | Type [get]
This property returns the file transfer type.
TFileTransferStatus | Status [get]
This property returns the file transfer status.
TFileTransferFailureReason | FailureReason [get]
This property returns the file transfer failure reason code.
BSTR | PartnerHandle [get]
This property returns the file transfer partner skypename.
BSTR | PartnerDisplayName [get]
This property returns the file transfer partner display name.
DATE | StartTime [get]
This property returns the file transfer start timestamp.
DATE | FinishTime [get]
This property returns the file transfer end timestamp.
BSTR | FilePath [get]
This property returns the full path of the file beeing transferred.
BSTR | FileName [get]
This property returns the file name of transferred file.
BSTR | BytesPerSecond [get]
This property returns the transfer speed in bytes per second.
BSTR | BytesTransferred [get]
This property returns the number of bytes transferred.

Detailed Description

File transfer object default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IFileTransfer Member List

This is the complete list of members for IFileTransfer, including all inherited members.
BytesPerSecond | IFileTransfer
BytesTransferred | IFileTransfer
FailureReason | IFileTransfer
FileName | IFileTransfer
FilePath | IFileTransfer
FinishTime | IFileTransfer
Id | IFileTransfer
PartnerDisplayName | IFileTransfer
PartnerHandle | IFileTransfer
StartTime | IFileTransfer
Status | IFileTransfer
Type | IFileTransfer


Skype4COM: IFileTransferCollection Interface Reference

Public Member Functions | Properties

IFileTransferCollection Interface Reference

File transfer collection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IFileTransfer *pItem)
Adds a new item to a collection.
HRESULT | Remove ([in] long Index)
This command removes an item from a collection.
HRESULT | RemoveAll (void)
This command removes all items from a collection.

Properties

LONG | Count [get]
Returns number of items in a collection.
IFileTransfer | Item ([in] LONG Index) [get]
This command queries an item in a collection with a specified index.
IUnknown | _NewEnum [get]
This command queries an enumerator object for a collection.

Detailed Description

File transfer collection class default interface.

Member Function Documentation

HRESULT Add ( [in] IFileTransfer * pItem )

Adds a new item to a collection.

Parameters:
[in] pItem contains the interface pointer for the File Transfer object.
HRESULT Remove ( [in] long Index )

This command removes an item from a collection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries an item in a collection with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IFileTransferCollection Member List

This is the complete list of members for IFileTransferCollection, including all inherited members.
_NewEnum | IFileTransferCollection
Add([in] IFileTransfer *pItem) | IFileTransferCollection
Count | IFileTransferCollection
Item | IFileTransferCollection
Remove([in] long Index) | IFileTransferCollection
RemoveAll(void) | IFileTransferCollection


Skype4COM: IGroup Interface Reference

Public Member Functions | Properties

IGroup Interface Reference

Group class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | AddUser ([in] BSTR Username)
This command adds a user to a group.
HRESULT | RemoveUser ([in] BSTR Username)
This command removes a user from a group.
HRESULT | Share ([in, defaultvalue("")] BSTR MessageText)
This command shares a contact group.
HRESULT | Accept ()
This command accepts an invitation to join a shared contact group.
HRESULT | Decline ()
This command declines an invitation to join a shared contact group.

Properties

LONG | Id [get]
This command queries the group ID.
TGroupType | Type [get]
This command queries a group type.
BSTR | CustomGroupId [get]
This command queries a group persistent ID.
BSTR | DisplayName [get, set]
This command queries/sets the display name of a group.
IUserCollection | Users [get]
This command queries the users in a group.
IUserCollection | OnlineUsers [get]
This command queries the online users in a group.
VARIANT_BOOL | IsVisible [get]
This command queries the visibility status of a group.
VARIANT_BOOL | IsExpanded [get]
This command queries the expanded status of a group.

Detailed Description

Group class default interface.

Member Function Documentation

HRESULT AddUser ( [in] BSTR Username )

This command adds a user to a group.

Parameters:
[in] Username contains the Skypename of the contact to add.
HRESULT RemoveUser ( [in] BSTR Username )

This command removes a user from a group.

Parameters:
[in] Username contains the Skypename of the contact to remove.
HRESULT Share ( [in, defaultvalue("")] BSTR MessageText )

This command shares a contact group.

Parameters:
[in] MessageText contains the message text for group members.

Property Documentation

HRESULT CustomGroupId [get]

This command queries a group persistent ID.

The custom group ID is a persistent value that does not change.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IGroup Member List

This is the complete list of members for IGroup, including all inherited members.
Accept() IGroup
AddUser([in] BSTR Username) | IGroup
CustomGroupId IGroup
Decline() IGroup
DisplayName IGroup
Id IGroup
IsExpanded IGroup
IsVisible IGroup
OnlineUsers IGroup
RemoveUser([in] BSTR Username) | IGroup
Share([in, defaultvalue("")] BSTR MessageText) | IGroup


Skype4COM: IGroupCollection Interface Reference

Public Member Functions | Properties

IGroupCollection Interface Reference

GroupCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IGroup *pGroup)
This command adds a new item to a GroupCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a GroupCollection.
HRESULT | RemoveAll (void)
This command removes all items from a GroupCollection.

Properties

LONG | Count [get]
This command queries the number of groups in a GroupCollection.
IGroup | Item ([in] LONG Index) [get]
This command queries a GroupCollection item with a specified index.
IUnknown | _NewEnum [get]
This command queries a GroupCollection enumerator object.

Detailed Description

GroupCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] IGroup * pGroup )

This command adds a new item to a GroupCollection.

Parameters:
[in] pGroup contains the interface pointer for the Group object.
HRESULT Remove ( [in] long Index )

This command removes an item from a GroupCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries a GroupCollection item with a specified index.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IGroupCollection Member List

This is the complete list of members for IGroupCollection, including all inherited members.
_NewEnum | IGroupCollection
Add([in] IGroup *pGroup) | IGroupCollection
Count | IGroupCollection
Item | IGroupCollection
Remove([in] long Index) | IGroupCollection
RemoveAll(void) | IGroupCollection


Skype4COM: IParticipant Interface Reference

Properties

IParticipant Interface Reference

Participant class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

BSTR | Handle [get]
This command queries the Skypename of a participant in a conference call.
BSTR | DisplayName [get]
This command queries the display name of a participant in a conference call.
TCallType | CallType [get]
This command queries a call type in a conference call.
TCallStatus | CallStatus [get]
This command queries the call status of a participant in a conference call.

Detailed Description

Participant class default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IParticipant Member List

This is the complete list of members for IParticipant, including all inherited members.
CallStatus | IParticipant
CallType | IParticipant
DisplayName | IParticipant
Handle | IParticipant


Skype4COM: IParticipantCollection Interface Reference

Public Member Functions | Properties

IParticipantCollection Interface Reference

ParticipantCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IParticipant *pParticipant)
This command adds a new participant to a ParticipantCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a ParticipantCollection.
HRESULT | RemoveAll (void)
This command removes all items from a ParticipantCollection.

Properties

LONG | Count [get]
This command queries the number of participants in a ParticipantCollection.
IParticipant | Item ([in] LONG Index) [get]
This command queries an item with a specified index in a ParticipantCollection.
IUnknown | _NewEnum [get]
This commmand queries the enumerator object of a ParticipantCollection.

Detailed Description

ParticipantCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] IParticipant * pParticipant )

This command adds a new participant to a ParticipantCollection.

Parameters:
[in] pParticipant contains the interface pointer for the Participant object.
HRESULT Remove ( [in] long Index )

This command removes an item from a ParticipantCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries an item with a specified index in a ParticipantCollection.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IParticipantCollection Member List

This is the complete list of members for IParticipantCollection, including all inherited members.
_NewEnum | IParticipantCollection
Add([in] IParticipant *pParticipant) | IParticipantCollection
Count | IParticipantCollection
Item | IParticipantCollection
Remove([in] long Index) | IParticipantCollection
RemoveAll(void) | IParticipantCollection


Skype4COM: IPluginEvent Interface Reference

Public Member Functions | Properties

IPluginEvent Interface Reference

This is the default interface for the PluginEvent class. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Delete (void)
This command deletes a plug-in event from the events pane in the Skype client.

Properties

BSTR | Id [get]
This property is a unique identifier for a plug-in event.

Detailed Description

This is the default interface for the PluginEvent class.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IPluginEvent Member List

This is the complete list of members for IPluginEvent, including all inherited members.
Delete(void) IPluginEvent


Skype4COM: IPluginMenuItem Interface Reference

Public Member Functions | Properties

IPluginMenuItem Interface Reference

Class PluginMenuItem default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Delete (void)
This command removes a menu item from "Do More" menus.

Properties

BSTR | Id [get]
This property is a unique identifier for a plug-in menu item.
BSTR | Caption [set]
This property contains the name of a plug-in menu item and must be a maximum of 32 characters.
BSTR | Hint [set]
This property contains a second line of text for a plug-in menu item if required and must be a maximum of 32 characters.
VARIANT_BOOL | Enabled [set]
This property is a Boolean indicator that defines whether a menu item is enabled when a user launches the application. If no value is defined, the menu item will be enabled.

Detailed Description

Class PluginMenuItem default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IPluginMenuItem Member List

This is the complete list of members for IPluginMenuItem, including all inherited members.
Caption IPluginMenuItem
Delete(void) IPluginMenuItem


Skype4COM: IProfile Interface Reference

Properties

IProfile Interface Reference

Profile class default interface. More...

import "Skype4COM.idl";

List of all members.

Properties

BSTR | FullName [get, set]
This command queries/sets the full name in the current user profile.
BSTR | Birthday [get, set]
This command queries/sets the birthday in the current user profile.
TUserSex | Sex [get, set]
This command queries/sets the sex in the current user profile.
BSTR | Languages [get, set]
This command queries/sets the language code in the current user profile.
BSTR | Country [get, set]
This command queries/sets the ISO country code in the current user profile.
BSTR | Province [get, set]
This command queries/sets the province in the current user profile.
BSTR | City [get, set]
This command queries/sets the city in the current user profile.
BSTR | PhoneHome [get, set]
This command queries/sets the home phone number in the current user profile.
BSTR | PhoneOffice [get, set]
This command queries/sets the business phone number in the current user profile.
BSTR | PhoneMobile [get, set]
This command queries/sets the mobile phone number in the current user profile.
BSTR | Homepage [get, set]
This command queries/sets the homepage url in the current user profile.
BSTR | About [get, set]
This command queries/sets the "About" text in the current user profile.
BSTR | MoodText [get, set]
This command queries/sets the mood text in the current user profile.
LONG | Timezone [get, set]
This command queries/sets the timezone in the current user profile.
short | CallNoAnswerTimeout [get, set]
This command queries/sets the "call no answer timeout" in the current user profile.
VARIANT_BOOL | CallApplyCF [get, set]
This command queries/sets if call forwarding is set in the current user profile.
VARIANT_BOOL | CallSendToVM [get, set]
This command queries/sets whether calls will be sent to voicemail in the current user profile.
BSTR | CallForwardRules [get, set]
This command queries/sets the call forwarding rules in the current user profile.
LONG | Balance [get]
This command queries the balance in currency cents in the current user profile.
BSTR | BalanceCurrency [get]
This command queries the currency code in the current user profile.
BSTR | BalanceToText [get]
This command queries the balance amount with currency symbol in the current user profile.
BSTR | IPCountry [get]
This command queries the ISO country code by IP address.
BSTR | ValidatedSmsNumbers [get]
This command requests a list of validated SMS numbers.
BSTR | RichMoodText [get, set]
This property returns/sets rich mood text in logged in user profile.

Detailed Description

Profile class default interface.

Property Documentation

HRESULT CallNoAnswerTimeout [get, set]

This command queries/sets the "call no answer timeout" in the current user profile.

The call no answer timeout is the period of time a call will ring without being answered before it stops ringing.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IProfile Member List

This is the complete list of members for IProfile, including all inherited members.
About | IProfile
Balance | IProfile
BalanceCurrency | IProfile
BalanceToText | IProfile
Birthday | IProfile
CallApplyCF | IProfile
CallForwardRules | IProfile
CallNoAnswerTimeout | IProfile
CallSendToVM | IProfile
City | IProfile
Country | IProfile
FullName | IProfile
Homepage | IProfile
IPCountry | IProfile
Languages | IProfile
MoodText | IProfile
PhoneHome | IProfile
PhoneMobile | IProfile
PhoneOffice | IProfile
Province | IProfile
RichMoodText | IProfile
Sex | IProfile
Timezone | IProfile
ValidatedSmsNumbers | IProfile


Skype4COM: ISettings Interface Reference

Public Member Functions | Properties

ISettings Interface Reference

Settings class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | SaveAvatarToFile ([in] BSTR Filename,[in, defaultvalue("1")] BSTR AvatarId)
Saves current user avatar to file.
HRESULT | LoadAvatarFromFile ([in] BSTR Filename,[in, defaultvalue("1")] BSTR AvatarId)
Replaces user current avatar with new avatar from file.
HRESULT | ResetIdleTimer (void)
Reset Skype idle timer.

Properties

BSTR | AudioIn [get, set]
This command queries/sets the name of an audio input device.
BSTR | AudioOut [get, set]
This command queries/sets the name of an audio output device.
VARIANT_BOOL | AutoAway [get, set]
This command queries/sets the "Auto away" status.
BSTR | Ringer [get, set]
This command queries/sets the name of a ringer device.
BSTR | Avatar ([in, defaultvalue("1")] BSTR Id) [set]
This command sets the avatar picture in a user profile.
VARIANT_BOOL | RingToneStatus ([in, defaultvalue("1")] BSTR Id) [get, set]
This command queries or sets the ringtone status.
BSTR | RingTone ([in, defaultvalue("1")] BSTR Id) [set]
This command sets a new ringtone.
BSTR | VideoIn [get, set]
This command queries/sets the name of a video input device.
VARIANT_BOOL | PCSpeaker [get, set]
This command queries/sets the PC speaker status.
VARIANT_BOOL | AGC [get, set]
This command queries/sets the status of automatic gain control.
VARIANT_BOOL | AEC [get, set]
This command queries/sets the status of automatic echo cancellation.
BSTR | Language [get, set]
This command queries/sets the language of the Skype client.

Detailed Description

Settings class default interface.

Member Function Documentation

HRESULT LoadAvatarFromFile | ( | [in] BSTR | Filename,
 |  | [in, defaultvalue("1")] BSTR | AvatarId
 | ) |  |

Replaces user current avatar with new avatar from file.

Parameters:
[in] | Filename | contains file name.
[in] | AvatarId | avatar id.
Example:
 Set oSkype = CreateObject("Skype4COM.Skype")
 oSkype.Settings.LoadAvatarFromFile("c:\temp\new_avatar.jpg")

HRESULT SaveAvatarToFile | ( | [in] BSTR | Filename,
 |  | [in, defaultvalue("1")] BSTR | AvatarId
 | ) |  |

Saves current user avatar to file.

Parameters:
[in] | Filename | contains file name.
[in] | AvatarId | avatar id.
Example:
 Set oSkype = CreateObject("Skype4COM.Skype")
 oSkype.Settings.SaveAvatarToFile("c:\temp\old_avatar.jpg")

Property Documentation

HRESULT Avatar [set]

This command sets the avatar picture in a user profile.

Parameters:
[in] | Id | is an optional avatar ID.
[in] | newVal | contains the new file name.
Deprecated:
Use the ISettings::LoadAvatarFromFile instead.
HRESULT RingTone [set]

This command sets a new ringtone.

Parameters:
[in] Id contains the ringtone ID.
HRESULT RingToneStatus [get, set]

This command queries or sets the ringtone status.

Parameters:
[in] Id contains the ringtone ID.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISettings Member List

This is the complete list of members for ISettings, including all inherited members.
AEC ISettings
AGC ISettings
AudioIn ISettings
AudioOut ISettings
AutoAway ISettings
Avatar ISettings
Language ISettings
LoadAvatarFromFile([in] BSTR Filename,[in, defaultvalue("1")] BSTR AvatarId) | ISettings
PCSpeaker ISettings
ResetIdleTimer(void) | ISettings
Ringer ISettings
RingTone ISettings
RingToneStatus ISettings
SaveAvatarToFile([in] BSTR Filename,[in, defaultvalue("1")] BSTR AvatarId) | ISettings


Skype4COM: ISkype Interface Reference

Public Member Functions | Properties

ISkype Interface Reference

Skype is the default interface for the class. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | SearchForUsers ([in] BSTR Target,[out, retval] IUserCollection **pVal)
This command searches for users.
HRESULT | Attach ([in, defaultvalue(5)] LONG Protocol,[in, defaultvalue(-1)] VARIANT_BOOL Wait)
This command establishes a connection to Skype.
HRESULT | PlaceCall ([in] BSTR Target,[in, defaultvalue("")] BSTR Target2,[in, defaultvalue("")] BSTR Target3,[in, defaultvalue("")] BSTR Target4,[out, retval] ICall **pCall)
This command places a call to a single user or creates a conference call.
HRESULT | SendMessage ([in] BSTR Username,[in] BSTR Text,[out, retval] IChatMessage **pMessage)
This command sends a chat message.
HRESULT | SendCommand ([in] ICommand *pCommand)
This command sends an API command.
HRESULT | ChangeUserStatus ([in] TUserStatus newVal)
This command changes the online status for the current user.
HRESULT | CreateChatWith ([in] BSTR Username,[out, retval] IChat **pVal)
This command creates a chat with a single user.
HRESULT | CreateChatMultiple ([in] IUserCollection *pMembers,[out, retval] IChat **pChat)
This command creates a chat with multiple users.
HRESULT | SendVoicemail ([in] BSTR Username,[out, retval] IVoicemail **pVoicemail)
This command sends a voicemail to a specified user.
HRESULT | ClearChatHistory ()
This command clears chat history.
HRESULT | ClearVoicemailHistory ()
This command clears voicemail history.
HRESULT | ClearCallHistory ([in, defaultvalue("ALL")] BSTR Username,[in, defaultvalue(chsAllCalls)] TCallHistory type)
This command clears call history.
HRESULT | ResetCache ()
This command deletes all cache entries.
HRESULT | CreateGroup ([in] BSTR GroupName,[out, retval] IGroup **pGroup)
This command creates a contact group.
HRESULT | DeleteGroup ([in] LONG GroupId)
This command deletes a contact group. Users in the contact group are moved to the All Contacts hardwired contact group.
HRESULT | EnableApiSecurityContext ([in] TApiSecurityContext Context)
This command enables an API security context for Internet Explorer scripts.
HRESULT | CreateSms ([in] TSmsMessageType MessageType,[in] BSTR TargetNumbers,[out, retval] ISmsMessage **pMessage)
This command creates an SmsMessage.
HRESULT | SendSms ([in] BSTR TargetNumbers,[in] BSTR MessageText,[in, defaultvalue("")] BSTR ReplyToNumber,[out, retval] ISmsMessage **pMessage)
This command sends an SMS message.
HRESULT | AsyncSearchUsers ([in] BSTR Target,[out, retval] LONG *pCookie)
This command can be used to search for Skype users.
HRESULT | FindChatUsingBlob ([in] BSTR Blob,[out, retval] IChat **pChat)
Returns existing chat using given blob.
HRESULT | CreateChatUsingBlob ([in] BSTR Blob,[out, retval] IChat **pChat)
Returns existing or joins a new chat using given blob.

Properties

LONG | Timeout [get, set]
This command queries/sets the wait timeout value in milliseconds.
BSTR | Property ([in] BSTR ObjectType,[in] BSTR ObjectId,[in] BSTR PropName) [get, set]
This command queries/sets the properties of an object.
BSTR | Variable ([in] BSTR Name) [get, set]
This command queries/sets Skype general parameters.
BSTR | CurrentUserHandle [get]
This command queries the Skype name of the current user.
TUserStatus | CurrentUserStatus [get, set]
This command queries/sets the online status of the current user.
TConnectionStatus | ConnectionStatus [get]
This command queries the connection status of the Skype client.
VARIANT_BOOL | Mute [get, set]
This command queries/sets the mute status of the Skype client.
BSTR | Version [get]
This command queries the application version of the Skype client.
VARIANT_BOOL | Privilege ([in] BSTR Name) [get]
This command queries the Skype services (privileges) enabled for the Skype client.
IUser | CurrentUser [get]
This command queries the current user object.
IConversion | Convert [get]
This command queries the conversion object.
IUserCollection | Friends [get]
This command queries the users in a contact list.
ICallCollection | Calls ([in, defaultvalue("")] BSTR Target) [get]
This command queries calls in call history.
ICallCollection | ActiveCalls [get]
This command queries a list of active calls.
ICallCollection | MissedCalls [get]
This command queries a list of missed calls.
IChatMessageCollection | Messages ([in, defaultvalue("")] BSTR Target) [get]
This command queries chat messages which were sent/received by the user.
IChatMessageCollection | MissedMessages [get]
This command queries a list of missed chat messages.
TAttachmentStatus | AttachmentStatus [get]
This command queries the attachment status of the Skype client.
LONG | Protocol [get, set]
This command queries/sets the protocol version used by the Skype client.
IUser | User ([in, defaultvalue("")] BSTR Username) [get]
This command queries a user object.
IChatMessage | Message ([in, defaultvalue(0)] LONG Id) [get]
This command queries a chat message object.
ICall | Call ([in, defaultvalue(0)] LONG Id) [get]
This command queries a call object.
IChatCollection | Chats [get]
This command queries a list of chats.
IChat | Chat ([in, defaultvalue("")] BSTR Name) [get]
This command queries a chat object.
IConference | Conference ([in, defaultvalue(0)] LONG Id) [get]
This command queries a call conference object.
IConferenceCollection | Conferences [get]
This command queries a list of call conferences.
BSTR | Profile ([in] BSTR Property) [get, set]
This command queries/sets user profile properties.
IChatCollection | ActiveChats [get]
This command queries a list of active chats.
IChatCollection | MissedChats [get]
This command queries a list of missed chats.
IChatCollection | RecentChats [get]
This command queries a list of recent chats.
IChatCollection | BookmarkedChats [get]
This command queries a list of bookmarked chats.
IVoicemailCollection | Voicemails [get]
This command queries a list of voicemails.
IUserCollection | UsersWaitingAuthorization [get]
This command queries the list of users waiting for authorization.
VARIANT_BOOL | CommandId [get, set]
This command queries/sets the status of automatic command identifiers.
IApplication | Application ([in] BSTR Name) [get]
This command queries an application object.
IVoicemail | Greeting ([in, defaultvalue("")] BSTR Username) [get]
This command queries the greeting used as voicemail.
VARIANT_BOOL | Cache [get, set]
This command queries/sets the status of internal cache.
IProfile | CurrentUserProfile [get]
This command queries the user profile object.
IGroupCollection | Groups [get]
This command queries the list of all contact groups.
IGroupCollection | CustomGroups [get]
This command queries the list of custom contact groups.
IGroupCollection | HardwiredGroups [get]
This command queries the list of hardwired contact groups.
ISettings | Settings [get]
This command queries the settings for Skype general parameters.
IClient | Client [get]
This command queries the user interface control object.
BSTR | FriendlyName [set]
This command sets a "friendly" name for an application.
ICommand | Command ([in] LONG Id,[in] BSTR Command,[in, defaultvalue("")] BSTR Reply,[in, defaultvalue(0)] VARIANT_BOOL Block,[in, defaultvalue(30000)] LONG Timeout) [get]
This command sets the properties of a command object.
IVoicemail | Voicemail ([in] LONG Id) [get]
This command queries the voicemail object.
IVoicemailCollection | MissedVoicemails [get]
This command requests a list of missed voicemails.
VARIANT_BOOL | ApiSecurityContextEnabled ([in] TApiSecurityContext Context) [get]
This command queries if an API security context for Internet Explorer is enabled.
ISmsMessageCollection | Smss [get]
This command requests a list of all SMS messages.
ISmsMessageCollection | MissedSmss [get]
This command requests a list of all missed SMS messages.
BSTR | ApiWrapperVersion [get]
This command returns API wrapper DLL version.
VARIANT_BOOL | SilentMode [get, set]
This command returns/sets Skype silent mode status.
IFileTransferCollection | FileTransfers [get]
Returns all file transfers.
IFileTransferCollection | ActiveFileTransfers [get]
Returns currently active file transfers.
IUserCollection | FocusedContacts [get]
Returns collection of selected contacts.
BSTR | PredictiveDialerCountry [get]
Returns predictive dialer coutry code.

Detailed Description

Skype is the default interface for the class.

Member Function Documentation

HRESULT AsyncSearchUsers | ( | [in] BSTR | Target,
 |  | [out,retval] LONG * | pCookie
 | ) |  |

This command can be used to search for Skype users.

Parameters:
[in] | Target | contains the person name or email address to be found.
[out] | pCookie | receives search identifier.
See also:
_ISkypeEvents::AsyncSearchUsersFinished
HRESULT Attach | ( | [in, defaultvalue(5)] LONG | Protocol,
 |  | [in, defaultvalue(-1)] VARIANT_BOOL | Wait
 | ) |  |

This command establishes a connection to Skype.

Parameters:
[in] | Protocol | is an optional field where you can enter the Skype protocol version, with a default value of 5.
[in] | Wait | is an optional Boolean value which indicates whether or not to wait for a response before establishing a connection.
HRESULT ChangeUserStatus ( [in] TUserStatus newVal )

This command changes the online status for the current user.

Parameters:
[in] newVal contains the new online status for the user.
Note:
This function waits until the online status changes. Alternatively, use the ISkype::CurrentUserStatus property to perform an immediate change of status.
HRESULT ClearCallHistory | ( | [in, defaultvalue("ALL")] BSTR | Username,
 |  | [in, defaultvalue(chsAllCalls)] TCallHistory | type
 | ) |  |

This command clears call history.

Parameters:
[in] | Username | is the Skypename of the user.
[in] | type | call type.
HRESULT CreateChatMultiple | ( | [in] IUserCollection * | pMembers,
 |  | [out, retval] IChat ** | pVal
 | ) |  |

This command creates a chat with multiple users.

Parameters:
[in] | pMembers | contains an interface pointer to the UserCollection object.
[out] | pVal | receives the interface pointer for the Chat object.
See also:
ISkype::CreateChatWith, IChat::AddMembers
HRESULT CreateChatUsingBlob | ( | [in] BSTR | Blob,
 |  | [out,retval] IChat ** | pChat
 | ) |  |

Returns existing or joins a new chat using given blob.

Parameters:
[in] | Blob | contains unique string indentifying the chat.
[out] | pChat | receives the interface pointer for the Chat object.
HRESULT CreateChatWith | ( | [in] BSTR | Username,
 |  | [out, retval] IChat ** | pVal
 | ) |  |

This command creates a chat with a single user.

Parameters:
[in] | Username | contains the Skypename of the user.
[out] | pVal | receives the interface pointer for the Chat object.
See also:
ISkype::CreateChatMultiple, IChat::AddMembers
HRESULT CreateGroup | ( | [in] BSTR | GroupName,
 |  | [out, retval] IGroup ** | pGroup
 | ) |  |

This command creates a contact group.

Parameters:
[in] | GroupName | group name.
[out] | pGroup | contains the interface pointer for the Group object.
HRESULT CreateSms | ( | [in] TSmsMessageType | MessageType,
 |  | [in] BSTR | TargetNumbers,
 |  | [out, retval] ISmsMessage ** | pMessage
 | ) |  |

This command creates an SmsMessage.

Parameters:
[in] | MessageType | contains the message type.
[in] | TargetNumbers | contains a comma-separated list of target SMS numbers.
[out] | pMessage | receives the interface pointer for the SmsMessage object.
HRESULT DeleteGroup ( [in] LONG GroupId )

This command deletes a contact group. Users in the contact group are moved to the All Contacts hardwired contact group.

Parameters:
[in] GroupId group identifier.
HRESULT EnableApiSecurityContext ( [in] TApiSecurityContext Context )

This command enables an API security context for Internet Explorer scripts.

Parameters:
[in] Context combination of API security context values.
HRESULT FindChatUsingBlob | ( | [in] BSTR | Blob,
 |  | [out,retval] IChat ** | pChat
 | ) |  |

Returns existing chat using given blob.

Parameters:
[in] | Blob | contains unique string indentifying the chat.
[out] | pChat | receives the interface pointer for the Chat object.
HRESULT PlaceCall | ( | [in] BSTR | Target,
 |  | [in, defaultvalue("")] BSTR | Target2,
 |  | [in, defaultvalue("")] BSTR | Target3,
 |  | [in, defaultvalue("")] BSTR | Target4,
 |  | [out, retval] ICall ** | pCall
 | ) |  |

This command places a call to a single user or creates a conference call.

Parameters:
[in] | Target | call target to place a single user call.
[in] | Target2 | is an optional field which can contain an additional participant for a conference call.
[in] | Target3 | is an optional field which can contain an additional participant for a conference call.
[in] | Target4 | is an optional field which can contain an additional participant for a conference call.
[out] | pCall | receives the interface pointer for the Call object.
Note:
If multiple targets are specified, a conference call is created. The call target can be username, phone number, or speed dial code.
HRESULT ResetCache ( )

This command deletes all cache entries.

See also:
Refer to the Skype4COM Dev Notes for information about the API cache.
HRESULT SearchForUsers | ( | [in] BSTR | Target,
 |  | [out, retval] IUserCollection ** | pVal
 | ) |  |

This command searches for users.

Parameters:
[in] | Target | search target.
[out] | pVal | receives the interface pointer for the UserCollection object.
HRESULT SendCommand ( [in] ICommand * pCommand )

This command sends an API command.

Parameters:
[in] pCommand contains the interface pointer for the Command object.
HRESULT SendMessage | ( | [in] BSTR | Username,
 |  | [in] BSTR | Text,
 |  | [out, retval] IChatMessage ** | pMessage
 | ) |  |

This command sends a chat message.

Parameters:
[in] | Username | user handle is the Skypename of the user.
[in] | Text | message text.
[out] | pMessage | receives the interface pointer for the ChatMessage object.
HRESULT SendSms | ( | [in] BSTR | TargetNumbers,
 |  | [in] BSTR | MessageText,
 |  | [in, defaultvalue("")] BSTR | ReplyToNumber,
 |  | [out, retval] ISmsMessage ** | pMessage
 | ) |  |

This command sends an SMS message.

Parameters:
[out] | TargetNumbers | contains a comma-separated list of target numbers.
[out] | MessageText | contains text of the message to send.
[out] | ReplyToNumber | contains the reply-to number.
[out] | pMessage | receives the interface pointer for the SmsMessage object.
HRESULT SendVoicemail | ( | [in] BSTR | Username,
 |  | [out, retval] IVoicemail ** | pVoicemail
 | ) |  |

This command sends a voicemail to a specified user.

Parameters:
[in] | Username | contains the Skypename of the user
[out] | pVoicemail | receives the interface pointer for the Voicemail object.

Property Documentation

HRESULT ApiSecurityContextEnabled [get]

This command queries if an API security context for Internet Explorer is enabled.

Parameters:
[in] Context is the TApiSecurityContext value.
HRESULT Application [get]

This command queries an application object.

Parameters:
[in] Name is the application name.
HRESULT Cache [get, set]

This command queries/sets the status of internal cache.

The internal API cache is used to cache Skype object properties and global parameters.

HRESULT Call [get]

This command queries a call object.

Parameters:
[in] Id is an optional field for the call ID.
HRESULT Calls [get]

This command queries calls in call history.

Parameters:
[in] Target optional call target.
HRESULT Chat [get]

This command queries a chat object.

Parameters:
[in] Name is an optional field for the chat name.
HRESULT Command [get]

This command sets the properties of a command object.

Parameters:
[in] | Id | is the command ID.
[in] | Command | is the command string.
[in] | Reply | is the expected reply string.
[in] | Block | is a blocking indicator. If set to True, ISkype::SendCommand method waits for a response from Skype API.
[in] | Timeout | is the blocking timeout in milliseconds.
See also:
ISkype::SendCommand
HRESULT Conference [get]

This command queries a call conference object.

Parameters:
[in] Id is an optional field for the conference ID.
HRESULT CustomGroups [get]

This command queries the list of custom contact groups.

Custom groups are contact groups defined by the user.

HRESULT Greeting [get]

This command queries the greeting used as voicemail.

Parameters:
[in] Username is an optional field containing the Skypename of the user.
HRESULT HardwiredGroups [get]

This command queries the list of hardwired contact groups.

Hardwired groups are "smart" contact groups, defined by Skype, that cannot be removed.

HRESULT Message [get]

This command queries a chat message object.

Parameters:
[in] Id is an optional field for the message ID.
HRESULT Messages [get]

This command queries chat messages which were sent/received by the user.

Parameters:
[in] Target message sender.
HRESULT Mute [get, set]

This command queries/sets the mute status of the Skype client.

Note:
This value can be set only when there is an active call.
HRESULT PredictiveDialerCountry [get]

Returns predictive dialer coutry code.

Parameters:
[out] pVal receives the country code.
HRESULT Privilege [get]

This command queries the Skype services (privileges) enabled for the Skype client.

Parameters:
[in] Name privilege name ("SKYPEOUT","SKYPEIN","VOICEMAIL").
HRESULT Profile [get, set]

This command queries/sets user profile properties.

Parameters:
[in] Property property name (for example "PSTN_BALANCE", "PSTN_BALANCE_CURRENCY", "FULLNAME", "BIRTHDAY", "SEX", "LANGUAGES", "COUNTRY", "PROVINCE", "CITY", "PHONE_HOME", "PHONE_OFFICE", "PHONE_MOBILE", "HOMEPAGE", "ABOUT")
HRESULT Property [get, set]

This command queries/sets the properties of an object.

Parameters:
[in] | ObjectType | object type ("USER","CALL","CHAT","CHATMESSAGE","VOICEMAIL").
[in] | ObjectId | object id.
[in] | PropName | property name.
Example:
  Set oSkype = CreateObject("Skype4COM.Skype")
  oSkype.Attach
  WScript.Echo oSkype.Property("USER","echo123","FULLNAME")
HRESULT Timeout [get, set]

This command queries/sets the wait timeout value in milliseconds.

This timeout value applies to every command sent to the Skype API. If a response is not received during the timeout period, an error is returned.

HRESULT User [get]

This command queries a user object.

Parameters:
[in] Username is an optional field for the Skypename of the user.
HRESULT Variable [get, set]

This command queries/sets Skype general parameters.

Parameters:
[in] Name variable name.
Example:
  Set oSkype = CreateObject("Skype4COM.Skype")
  oSkype.Attach
  WScript.Echo oSkype.Variable("MUTE")
HRESULT Voicemail [get]

This command queries the voicemail object.

Parameters:
[in] Id id the voicemail id.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISkype Member List

This is the complete list of members for ISkype, including all inherited members.
ActiveCalls | ISkype
ActiveChats | ISkype
ActiveFileTransfers | ISkype
ApiSecurityContextEnabled | ISkype
ApiWrapperVersion | ISkype
Application | ISkype
AsyncSearchUsers([in] BSTR Target,[out, retval] LONG *pCookie) | ISkype
Attach([in, defaultvalue(5)] LONG Protocol,[in, defaultvalue(-1)] VARIANT_BOOL Wait) | ISkype
AttachmentStatus | ISkype
BookmarkedChats | ISkype
Cache | ISkype
Call | ISkype
Calls | ISkype
ChangeUserStatus([in] TUserStatus newVal) | ISkype
Chat | ISkype
Chats | ISkype
ClearCallHistory([in, defaultvalue("ALL")] BSTR Username,[in, defaultvalue(chsAllCalls)] TCallHistory type) | ISkype
ClearChatHistory() | ISkype
ClearVoicemailHistory() | ISkype
Client | ISkype
Command | ISkype
CommandId | ISkype
Conference | ISkype
Conferences | ISkype
ConnectionStatus | ISkype
Convert | ISkype
CreateChatMultiple([in] IUserCollection *pMembers,[out, retval] IChat **pChat) | ISkype
CreateChatUsingBlob([in] BSTR Blob,[out, retval] IChat **pChat) | ISkype
CreateChatWith([in] BSTR Username,[out, retval] IChat **pVal) | ISkype
CreateGroup([in] BSTR GroupName,[out, retval] IGroup **pGroup) | ISkype
CreateSms([in] TSmsMessageType MessageType,[in] BSTR TargetNumbers,[out, retval] ISmsMessage **pMessage) | ISkype
CurrentUser | ISkype
CurrentUserHandle | ISkype
CurrentUserProfile | ISkype
CurrentUserStatus | ISkype
CustomGroups | ISkype
DeleteGroup([in] LONG GroupId) | ISkype
EnableApiSecurityContext([in] TApiSecurityContext Context) | ISkype
FileTransfers | ISkype
FindChatUsingBlob([in] BSTR Blob,[out, retval] IChat **pChat) | ISkype
FocusedContacts | ISkype
FriendlyName | ISkype
Friends | ISkype
Greeting | ISkype
Groups | ISkype
HardwiredGroups | ISkype
Message | ISkype
Messages | ISkype
MissedCalls | ISkype
MissedChats | ISkype
MissedMessages | ISkype
MissedSmss | ISkype
MissedVoicemails | ISkype
Mute | ISkype
PlaceCall([in] BSTR Target,[in, defaultvalue("")] BSTR Target2,[in, defaultvalue("")] BSTR Target3,[in, defaultvalue("")] BSTR Target4,[out, retval] ICall **pCall) | ISkype
PredictiveDialerCountry | ISkype
Privilege | ISkype
Profile | ISkype
Property | ISkype
Protocol | ISkype
RecentChats | ISkype
ResetCache() | ISkype
SearchForUsers([in] BSTR Target,[out, retval] IUserCollection **pVal) | ISkype
SendCommand([in] ICommand *pCommand) | ISkype
SendMessage([in] BSTR Username,[in] BSTR Text,[out, retval] IChatMessage **pMessage) | ISkype
SendSms([in] BSTR TargetNumbers,[in] BSTR MessageText,[in, defaultvalue("")] BSTR ReplyToNumber,[out, retval] ISmsMessage **pMessage) | ISkype
SendVoicemail([in] BSTR Username,[out, retval] IVoicemail **pVoicemail) | ISkype
Settings | ISkype
SilentMode | ISkype
Smss | ISkype
Timeout | ISkype
User | ISkype
UsersWaitingAuthorization | ISkype
Variable | ISkype
Version | ISkype
Voicemail | ISkype
Voicemails | ISkype


Skype4COM: ISmsChunk Interface Reference

Properties

ISmsChunk Interface Reference

SmsChunk is the default interface forthis class. More...

import "Skype4COM.idl";

List of all members.

Properties

LONG | Id [get]
This command requests the ID of an SMS message chunk.
LONG | CharactersLeft [get]
This command requests the number of characters left in an SMS message chunk.
BSTR | Text [get]
This command queries the text in an SMS message chunk.
ISmsMessage | Message [get]
This command queries the SmsMessage associated with a chunk.

Detailed Description

SmsChunk is the default interface forthis class.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISmsChunk Member List

This is the complete list of members for ISmsChunk, including all inherited members.
CharactersLeft | ISmsChunk
Id | ISmsChunk
Message | ISmsChunk
Text | ISmsChunk


Skype4COM: ISmsChunkCollection Interface Reference

Public Member Functions | Properties

ISmsChunkCollection Interface Reference

SmsChunkCollection is the default interface for this class. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] ISmsChunk *pItem)
This command adds a chunk to an SmsChunkCollection.
HRESULT | Remove ([in] long Index)
This command removes a chunk from an SmsChunkCollection.
HRESULT | RemoveAll (void)
This command removes all chunks from an SmsChunkCollection.

Properties

LONG | Count [get]
This command queries the number of chunks in a SmsChunkCollection.
ISmsChunk | Item ([in] LONG Index) [get]
This command requests a chunk with a specified index in an SmsChunkCollection.
IUnknown | _NewEnum [get]
This command requests the enumerator object of an SmsChunkCollection.

Detailed Description

SmsChunkCollection is the default interface for this class.

Member Function Documentation

HRESULT Add ( [in] ISmsChunk * pItem )

This command adds a chunk to an SmsChunkCollection.

Parameters:
[in] pItem contains the interface pointer to the SmsChunk object.
HRESULT Remove ( [in] long Index )

This command removes a chunk from an SmsChunkCollection.

Parameters:
[in] Index contains the index of the chunk to be remove from the SMS chunk collection.

Property Documentation

HRESULT Item [get]

This command requests a chunk with a specified index in an SmsChunkCollection.

Parameters:
[in] Index contains the index of the chunk to return.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISmsChunkCollection Member List

This is the complete list of members for ISmsChunkCollection, including all inherited members.
_NewEnum | ISmsChunkCollection
Add([in] ISmsChunk *pItem) | ISmsChunkCollection
Count | ISmsChunkCollection
Item | ISmsChunkCollection
Remove([in] long Index) | ISmsChunkCollection
RemoveAll(void) | ISmsChunkCollection


Skype4COM: ISmsMessage Interface Reference

Public Member Functions | Properties

ISmsMessage Interface Reference

SmsMessage is the default interface for this class. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Send ()
This command sends an SMS message.
HRESULT | Delete ()
This command deletes an SMS message.

Properties

LONG | Id [get]
This command requests an SMS message ID.
TSmsMessageType | Type [get]
This command queries an SMS message type.
TSmsMessageStatus | Status [get]
This command queries the status of an SMS message.
TSmsFailureReason | FailureReason [get]
This command queries the reason an SMS message failed.
VARIANT_BOOL | IsFailedUnseen [get]
This command queries if a failed SMS message was unseen.
VARIANT_BOOL | Seen [set]
This command sets an SMS message status read.
LONG | Price [get]
This command queries the price of an SMS message.
LONG | PricePrecision [get]
This command queries the price precision associated with an SMS message.
BSTR | PriceCurrency [get]
This command queries price currency code for an SMS message.
BSTR | ReplyToNumber [get, set]
This command queries/sets the reply-to number for an SMS message.
ISmsTargetCollection | Targets [get]
This command queries the targets of an SMS message.
BSTR | Body [get, set]
This command queries/sets the text of an SMS message.
ISmsChunkCollection | Chunks [get]
This command queries the chunks in an SMS message.
DATE | Timestamp [get]
This command queries the timestamp of an SMS message.
BSTR | TargetNumbers [get, set]
This command queries/sets the targets numbers of an SMS message.

Detailed Description

SmsMessage is the default interface for this class.

Property Documentation

HRESULT Price [get]

This command queries the price of an SMS message.

See also:
ISmsMessage::PricePrecision, ISmsMessage::PriceCurrency
HRESULT PriceCurrency [get]

This command queries price currency code for an SMS message.

See also:
ISmsMessage::Price, ISmsMessage::PricePrecision
HRESULT PricePrecision [get]

This command queries the price precision associated with an SMS message.

See also:
ISmsMessage::Price, ISmsMessage::PriceCurrency
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISmsMessage Member List

This is the complete list of members for ISmsMessage, including all inherited members.
Body | ISmsMessage
Chunks | ISmsMessage
Delete() | ISmsMessage
FailureReason | ISmsMessage
Id | ISmsMessage
IsFailedUnseen | ISmsMessage
Price | ISmsMessage
PriceCurrency | ISmsMessage
PricePrecision | ISmsMessage
ReplyToNumber | ISmsMessage
Seen | ISmsMessage
Send() | ISmsMessage
Status | ISmsMessage
TargetNumbers | ISmsMessage
Targets | ISmsMessage
Timestamp | ISmsMessage
Type | ISmsMessage


Skype4COM: ISmsMessageCollection Interface Reference

Public Member Functions | Properties

ISmsMessageCollection Interface Reference

SmsMessageCollection is the default interface for this class. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] ISmsMessage *pItem)
This command adds a new messsage to an SmsMessageCollection.
HRESULT | Remove ([in] long Index)
This command removes a message from an SmsMessageCollection.
HRESULT | RemoveAll (void)
This command removes all messages from an SmsMessageCollection.

Properties

LONG | Count [get]
This command queries the number of messages in an SmsMessageCollection.
ISmsMessage | Item ([in] LONG Index) [get]
This command requests a message with a specified index in an SmsMessageCollection.
IUnknown | _NewEnum [get]
This command requsts the enumerator object of an SmsMessageCollection.

Detailed Description

SmsMessageCollection is the default interface for this class.

See also:
ISkype::Smss, ISkype::MissedSmss

Member Function Documentation

HRESULT Add ( [in] ISmsMessage * pItem )

This command adds a new messsage to an SmsMessageCollection.

Parameters:
[in] pItem contains the interface pointer to an SmsMessage object.
HRESULT Remove ( [in] long Index )

This command removes a message from an SmsMessageCollection.

Parameters:
[in] Index contains the index of the SMS message to be removed.

Property Documentation

HRESULT Item [get]

This command requests a message with a specified index in an SmsMessageCollection.

Parameters:
[in] Index contains the index of the message to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISmsMessageCollection Member List

This is the complete list of members for ISmsMessageCollection, including all inherited members.
_NewEnum | ISmsMessageCollection
Add([in] ISmsMessage *pItem) | ISmsMessageCollection
Count | ISmsMessageCollection
Item | ISmsMessageCollection
Remove([in] long Index) | ISmsMessageCollection
RemoveAll(void) | ISmsMessageCollection


Skype4COM: ISmsTarget Interface Reference

Properties

ISmsTarget Interface Reference

SmsTarget is the default interface for this class. More...

import "Skype4COM.idl";

List of all members.

Properties

TSmsTargetStatus | Status [get]
This command queries the status of an SMS message target.
BSTR | Number [get]
This command queries the target number of an SMS message.
ISmsMessage | Message [get]
This command queries the SmsMessage related to the target.

Detailed Description

SmsTarget is the default interface for this class.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISmsTarget Member List

This is the complete list of members for ISmsTarget, including all inherited members.
Message | ISmsTarget
Number | ISmsTarget
Status | ISmsTarget


Skype4COM: ISmsTargetCollection Interface Reference

Public Member Functions | Properties

ISmsTargetCollection Interface Reference

SmsTargetCollection is the default interface for this class. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] ISmsTarget *pItem)
This command adds a target to an SmsTargetCollection.
HRESULT | Remove ([in] long Index)
This command removes a target from an SmsTargetCollection.
HRESULT | RemoveAll (void)
This command removes all targets from an SmsTargetCollection.

Properties

LONG | Count [get]
This command queries the number of targets in an SmsTargetCollection.
ISmsTarget | Item ([in] LONG Index) [get]
This command queries a target with a specified index in an SmsTargetCollection.
IUnknown | _NewEnum [get]
This command queries the enumerator object of an SmsTargetCollection.

Detailed Description

SmsTargetCollection is the default interface for this class.

Member Function Documentation

HRESULT Add ( [in] ISmsTarget * pItem )

This command adds a target to an SmsTargetCollection.

Parameters:
[in] pItem contains the interface pointer to the new SmsTarget object.
HRESULT Remove ( [in] long Index )

This command removes a target from an SmsTargetCollection.

Parameters:
[in] Index contains the index of the target to remove.

Property Documentation

HRESULT Item [get]

This command queries a target with a specified index in an SmsTargetCollection.

Parameters:
[in] Index contains the index of the target to return.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

ISmsTargetCollection Member List

This is the complete list of members for ISmsTargetCollection, including all inherited members.
_NewEnum | ISmsTargetCollection
Add([in] ISmsTarget *pItem) | ISmsTargetCollection
Count | ISmsTargetCollection
Item | ISmsTargetCollection
Remove([in] long Index) | ISmsTargetCollection
RemoveAll(void) | ISmsTargetCollection


Skype4COM: IUser Interface Reference

Properties

IUser Interface Reference

User class default interface. This interface enables you to read user properties. More...

import "Skype4COM.idl";

List of all members.

Properties

BSTR | Handle [get, set]
This command queries/sets the Skypename of the user.
BSTR | FullName [get]
This command queries the full name of the user.
DATE | Birthday [get]
This command queries the birthday of the user.
TUserSex | Sex [get]
This command queries the sex of the user.
BSTR | Country [get]
This command queries the country of the user.
BSTR | Province [get]
This command queries the province of the user.
BSTR | City [get]
This command queries the city of the user.
BSTR | PhoneHome [get]
This command queries the home telephone number of the user.
BSTR | PhoneOffice [get]
This command queries the office telephone number of the user.
BSTR | PhoneMobile [get]
This command queries the mobile phone number of the user.
BSTR | Homepage [get]
This command queries the homepage url of the user.
BSTR | About [get]
This command queries the about text for the user.
VARIANT_BOOL | HasCallEquipment [get]
This command queries if a user has call equipment. In the current implementation, this command always returns a value of true.
TBuddyStatus | BuddyStatus [get, set]
This command queries/sets user buddy status.
VARIANT_BOOL | IsAuthorized [get, set]
This command queries/sets user authorization status.
VARIANT_BOOL | IsBlocked [get, set]
This command queries/sets whether a user is blocked or not.
BSTR | DisplayName [get, set]
This command queries/sets the display name for a user.
TOnlineStatus | OnlineStatus [get]
This command queries the online status of a user.
DATE | LastOnline [get]
This command queries the time when a user was last online.
BSTR | CountryCode [get]
This command queries the ISO country code of a user.
BSTR | ReceivedAuthRequest [get]
This command queries the authorization request text of a user.
BSTR | SpeedDial [get, set]
This command queries/sets the speed dial code of a user.
VARIANT_BOOL | CanLeaveVoicemail [get]
This command queries if it is possible to send voicemail to a user.
BSTR | MoodText [get]
This command queries the mood text of a user.
BSTR | Aliases [get]
This command queries the alias text of a user.
LONG | Timezone [get]
This command queries the timezone of a user.
VARIANT_BOOL | IsCallForwardActive [get]
This command queries the call forwarding status of a user.
BSTR | Language [get]
This command queries the language of the user.
BSTR | LanguageCode [get]
This command queries the ISO language code of a user.
VARIANT_BOOL | IsVideoCapable [get]
This command queries if a user has video capability.
VARIANT_BOOL | IsSkypeOutContact [get]
This command queries whether a user is a SkypeOut contact.
LONG | NumberOfAuthBuddies [get]
This command queries the number of authenticated buddies of the contact.
BSTR | RichMoodText [get]
This property returns user rich mood text.
VARIANT_BOOL | IsVoicemailCapable [get]
This property returns user voicemail capability status.

Detailed Description

User class default interface. This interface enables you to read user properties.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IUser Member List

This is the complete list of members for IUser, including all inherited members.
About | IUser
Aliases | IUser
Birthday | IUser
BuddyStatus | IUser
CanLeaveVoicemail | IUser
City | IUser
Country | IUser
CountryCode | IUser
DisplayName | IUser
FullName | IUser
Handle | IUser
HasCallEquipment | IUser
Homepage | IUser
IsAuthorized | IUser
IsBlocked | IUser
IsCallForwardActive | IUser
IsSkypeOutContact | IUser
IsVideoCapable | IUser
IsVoicemailCapable | IUser
Language | IUser
LanguageCode | IUser
LastOnline | IUser
MoodText | IUser
NumberOfAuthBuddies | IUser
OnlineStatus | IUser
PhoneHome | IUser
PhoneMobile | IUser
PhoneOffice | IUser
Province | IUser
ReceivedAuthRequest | IUser
RichMoodText | IUser
Sex | IUser
SpeedDial | IUser
Timezone | IUser


Skype4COM: IUserCollection Interface Reference

Public Member Functions | Properties

IUserCollection Interface Reference

UserCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IUser *pUser)
This command adds a new item to a UserCollection.
HRESULT | Remove ([in] long Index)
This command removes an item from a UserCollection.
HRESULT | RemoveAll (void)
This command removes all items from a UserCollection.

Properties

LONG | Count [get]
This command queries the number of users in a UserCollection.
IUser | Item ([in] LONG Index) [get]
This command queries an item in a UserCollection with a specified index value.
IUnknown | _NewEnum [get]
This command queries the enumerator object for a UserCollection.

Detailed Description

UserCollection class default interface.

Member Function Documentation

HRESULT Add ( [in] IUser * pUser )

This command adds a new item to a UserCollection.

Parameters:
[in] pUser receives the interface pointer for the User object.
HRESULT Remove ( [in] long Index )

This command removes an item from a UserCollection.

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries an item in a UserCollection with a specified index value.

Parameters:
[in] Index contains the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IUserCollection Member List

This is the complete list of members for IUserCollection, including all inherited members.
_NewEnum | IUserCollection
Add([in] IUser *pUser) | IUserCollection
Count | IUserCollection
Item | IUserCollection
Remove([in] long Index) | IUserCollection
RemoveAll(void) | IUserCollection


Skype4COM: IVoicemail Interface Reference

Public Member Functions | Properties

IVoicemail Interface Reference

Voicemail class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Open ()
This command opens and plays voicemail.
HRESULT | StartPlayback ()
This command starts playing downloaded voicemail.
HRESULT | StopPlayback ()
This command stops playing downloaded voicemail.
HRESULT | Upload ()
This command uploads recorded voicemail from a local computer to the voicemail server.
HRESULT | Download ()
This command downloads a voicemail object from the voicemail server to a local computer.
HRESULT | StartRecording ()
This command stops playing a voicemail greeting and starts recording a voicemail message.
HRESULT | StopRecording ()
This command ends the recording of a voicemail message.
HRESULT | Delete ()
This command deletes a voicemail object.
HRESULT | StartPlaybackInCall ()
This command starts playing downloaded voicemail during a call.
HRESULT | SetUnplayed ()
This command changes the status of a voicemail from played to unplayed.

Properties

TVoicemailType | Type [get]
This command queries the voicemail type.
BSTR | PartnerHandle [get]
This command queries the Skypename of the user receiving a voicemail.
BSTR | PartnerDisplayName [get]
This command queries the display name of the user receiving the voicemail.
TVoicemailStatus | Status [get]
This command queries the voicemail status.
TVoicemailFailureReason | FailureReason [get]
This command queries the reason a voicemail failed.
DATE | Timestamp [get]
This command queries the timestamp of a voicemail.
LONG | Duration [get]
This command queries the duration of a voicemail.
LONG | AllowedDuration [get]
This command queries the permitted duration of a voicemail.
LONG | Id [get]
This command queries a voicemail ID.

Detailed Description

Voicemail class default interface.

The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IVoicemail Member List

This is the complete list of members for IVoicemail, including all inherited members.
AllowedDuration | IVoicemail
Delete() | IVoicemail
Download() | IVoicemail
Duration | IVoicemail
FailureReason | IVoicemail
Id | IVoicemail
Open() | IVoicemail
PartnerDisplayName | IVoicemail
PartnerHandle | IVoicemail
SetUnplayed() | IVoicemail
StartPlayback() | IVoicemail
StartPlaybackInCall() | IVoicemail
StartRecording() | IVoicemail
Status | IVoicemail
StopPlayback() | IVoicemail
StopRecording() | IVoicemail
Timestamp | IVoicemail
Type | IVoicemail
Upload() | IVoicemail


Skype4COM: IVoicemailCollection Interface Reference

Public Member Functions | Properties

IVoicemailCollection Interface Reference

VoicemailCollection class default interface. More...

import "Skype4COM.idl";

List of all members.

Public Member Functions

HRESULT | Add ([in] IVoicemail *pItem)
This command adds a new item to a VoicemailCollection .
HRESULT | Remove ([in] long Index)
This command removes an item from a VoicemailCollection .
HRESULT | RemoveAll (void)
This command removes all items from a VoicemailCollection .

Properties

LONG | Count [get]
This command returns the number of voicemails in a VoicemailCollection .
IVoicemail | Item ([in] LONG Index) [get]
This command queries an item in a VoicemailCollection with a specified index.
IUnknown | _NewEnum [get]
This command queries a VoicemailCollection enumerator object.

Detailed Description

VoicemailCollection class default interface.

Use the VoicemailCollection to manage Voicemail objects.

Member Function Documentation

HRESULT Add ( [in] IVoicemail * pItem )

This command adds a new item to a VoicemailCollection .

Parameters:
[in] pItem receives the interface pointer for the Voicemail object.
HRESULT Remove ( [in] long Index )

This command removes an item from a VoicemailCollection .

Parameters:
[in] Index contains the item to be removed.

Property Documentation

HRESULT Item [get]

This command queries an item in a VoicemailCollection with a specified index.

Parameters:
[in] Index contains the index of the item to be returned.
The documentation for this interface was generated from the following file:
  • Skype4COM.idl


Skype4COM: Member List

IVoicemailCollection Member List

This is the complete list of members for IVoicemailCollection, including all inherited members.
_NewEnum | IVoicemailCollection
Add([in] IVoicemail *pItem) | IVoicemailCollection
Count | IVoicemailCollection
Item | IVoicemailCollection
Remove([in] long Index) | IVoicemailCollection
RemoveAll(void) | IVoicemailCollection


Skype4COM: Participant Class Reference

  • SKYPE4COMLib
  • Participant

Participant Class Reference

This class manages participants in a conference call. More...

import "Skype4COM.idl";

Detailed Description

This class manages participants in a conference call.

See also:
IParticipant, IParticipantCollection, ICall::Participants
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: ParticipantCollection Class Reference

  • SKYPE4COMLib
  • ParticipantCollection

ParticipantCollection Class Reference

This class manages collections of participants in a conference call. More...

import "Skype4COM.idl";

Detailed Description

This class manages collections of participants in a conference call.

Use the ParticipantCollection class to manage collections of participants in conference calls. To query a collection class use For Each .. Next statements.

See also:
IParticipant, IParticipantCollection, ICall::Participants
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: PluginEvent Class Reference

  • SKYPE4COMLib
  • PluginEvent

PluginEvent Class Reference

This class manages plug-in event. More...

import "Skype4COM.idl";

Detailed Description

This class manages plug-in event.

See also:
IPluginEvent, _ISkypeEvents::PluginEventClicked, IPluginMenuItem
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: PluginMenuItem Class Reference

  • SKYPE4COMLib
  • PluginMenuItem

PluginMenuItem Class Reference

Plugin menu item. More...

import "Skype4COM.idl";

Detailed Description

Plugin menu item.

See also:
IPluginMenuItem, _ISkypeEvents::PluginMenuItemClicked, IPluginEvent
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Profile Class Reference

  • SKYPE4COMLib
  • Profile

Profile Class Reference

This class manages the user profile. More...

import "Skype4COM.idl";

Detailed Description

This class manages the user profile.

See also:
IProfile
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Settings Class Reference

  • SKYPE4COMLib
  • Settings

Settings Class Reference

This class manages the Skype API general parameters. More...

import "Skype4COM.idl";

Detailed Description

This class manages the Skype API general parameters.

See also:
ISettings
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Skype Class Reference

  • SKYPE4COMLib
  • Skype

Skype Class Reference

Skype API COM wrapper. More...

import "Skype4COM.idl";

Detailed Description

Skype API COM wrapper.

See also:
ISkype, _ISkypeEvents
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: SmsChunk Class Reference

  • SKYPE4COMLib
  • SmsChunk

SmsChunk Class Reference

SMS message chunk. More...

import "Skype4COM.idl";

Detailed Description

SMS message chunk.

See also:
ISmsMessage, ISmsChunk, ISmsChunkCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: SmsChunkCollection Class Reference

  • SKYPE4COMLib
  • SmsChunkCollection

SmsChunkCollection Class Reference

Collection class for SmsChunk objects. More...

import "Skype4COM.idl";

Detailed Description

Collection class for SmsChunk objects.

See also:
ISmsMessage, ISmsChunk, ISmsChunkCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: SmsMessage Class Reference

  • SKYPE4COMLib
  • SmsMessage

SmsMessage Class Reference

SMS message. More...

import "Skype4COM.idl";

Detailed Description

SMS message.

See also:
ISmsMessage, ISmsMessageCollection, ISmsTarget, ISmsChunk
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: SmsMessageCollection Class Reference

  • SKYPE4COMLib
  • SmsMessageCollection

SmsMessageCollection Class Reference

Collection class for SMS messages. More...

import "Skype4COM.idl";

Detailed Description

Collection class for SMS messages.

See also:
ISmsMessage, ISmsMessageCollection, ISmsTarget, ISmsChunk
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: SmsTarget Class Reference

  • SKYPE4COMLib
  • SmsTarget

SmsTarget Class Reference

SMS message target. More...

import "Skype4COM.idl";

Detailed Description

SMS message target.

See also:
ISmsMessage, ISmsTarget, ISmsTargetCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: SmsTargetCollection Class Reference

  • SKYPE4COMLib
  • SmsTargetCollection

SmsTargetCollection Class Reference

Collection class for SMS targets. More...

import "Skype4COM.idl";

Detailed Description

Collection class for SMS targets.

See also:
ISmsMessage, ISmsTarget, ISmsTargetCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: User Class Reference

  • SKYPE4COMLib
  • User

User Class Reference

This class manages user properties. More...

import "Skype4COM.idl";

Detailed Description

This class manages user properties.

The User class provides access to user properties.

Example:
  '// Get current user object
  oUser = oSkype.CurrentUser

  '// Get full name
  oHandle = oUser.Fullname

  '// Get about text
  oAbout = oUser.About
See also:
IUser, IUserCollection, ISkype::Friends, ISkype::SearchForUsers, IChat::ActiveMembers, IChat::Adder, IChat::Members, IChat::Posters
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: UserCollection Class Reference

  • SKYPE4COMLib
  • UserCollection

UserCollection Class Reference

User collection. More...

import "Skype4COM.idl";

Detailed Description

User collection.

The UserCollection class returns User objects. To query items in a collection, use For Each .. Next statements.

Example:
  '// To query contacts:
  For Each oUser In oSkype.Friends
  Next

  '// To search for users:
  For Each oUser In oSkype.Users("peeter")
  Next
See also:
IUser, IUserCollection, ISkype::Friends, ISkype::SearchForUsers, IChat::ActiveMembers, IChat::Adder, IChat::Members, IChat::Posters
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Voicemail Class Reference

  • SKYPE4COMLib
  • Voicemail

Voicemail Class Reference

This class manages Skype voicemail. More...

import "Skype4COM.idl";

Detailed Description

This class manages Skype voicemail.

See also:
IVoicemail, IVoicemailCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: VoicemailCollection Class Reference

  • SKYPE4COMLib
  • VoicemailCollection

VoicemailCollection Class Reference

Voicemail collection. More...

import "Skype4COM.idl";

Detailed Description

Voicemail collection.

Use this class to return collections of Voicemail objects. To access items in a VoicemailCollection, use For Each .. Next statements.

See also:
IVoicemail, IVoicemailCollection
The documentation for this class was generated from the following file:
  • Skype4COM.idl


Skype4COM: Class Index

Class Index

A | C | G | I | P | S | U | V | _
A
Conference (SKYPE4COMLib) IChatMember ISettings
S
Application (SKYPE4COMLib) | ConferenceCollection (SKYPE4COMLib) | IChatMemberCollection | ISkype | Settings (SKYPE4COMLib)
ApplicationStream (SKYPE4COMLib) | Conversion (SKYPE4COMLib) | IChatMessage | ISmsChunk | Skype (SKYPE4COMLib)
ApplicationStreamCollection (SKYPE4COMLib)
G
IChatMessageCollection ISmsChunkCollection SmsChunk (SKYPE4COMLib)
C
Group (SKYPE4COMLib) IClient ISmsMessage SmsChunkCollection (SKYPE4COMLib)
Call (SKYPE4COMLib) | GroupCollection (SKYPE4COMLib) | ICommand | ISmsMessageCollection | SmsMessage (SKYPE4COMLib)
CallChannel (SKYPE4COMLib)
I
IConference ISmsTarget SmsMessageCollection (SKYPE4COMLib)
CallChannelCollection (SKYPE4COMLib) | IApplication | IConferenceCollection | ISmsTargetCollection | SmsTarget (SKYPE4COMLib)
CallChannelManager (SKYPE4COMLib) | IApplicationStream | IConversion | IUser | SmsTargetCollection (SKYPE4COMLib)
CallChannelMessage (SKYPE4COMLib) IApplicationStreamCollection IFileTransfer IUserCollection
U
CallCollection (SKYPE4COMLib) | ICall | IFileTransferCollection | IVoicemail | User (SKYPE4COMLib)
Chat (SKYPE4COMLib) | ICallChannel | IGroup | IVoicemailCollection | UserCollection (SKYPE4COMLib)
ChatCollection (SKYPE4COMLib) ICallChannelCollection IGroupCollection
P
V
ChatMember (SKYPE4COMLib) | ICallChannelManager | IParticipant | Participant (SKYPE4COMLib) | Voicemail (SKYPE4COMLib)
ChatMemberCollection (SKYPE4COMLib) | ICallChannelMessage | IParticipantCollection | ParticipantCollection (SKYPE4COMLib) | VoicemailCollection (SKYPE4COMLib)
ChatMessage (SKYPE4COMLib) ICallCollection IPluginEvent PluginEvent (SKYPE4COMLib)
_
ChatMessageCollection (SKYPE4COMLib) | IChat | IPluginMenuItem | PluginMenuItem (SKYPE4COMLib) | _ICallChannelManagerEvents
Client (SKYPE4COMLib) | IChatCollection | IProfile | Profile (SKYPE4COMLib) | _ISkypeEvents
Command (SKYPE4COMLib)


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • _NewEnum : IUserCollection , ICallChannelCollection , IFileTransferCollection , ISmsMessageCollection , ISmsTargetCollection , ISmsChunkCollection , IGroupCollection , IApplicationStreamCollection , IVoicemailCollection , IConferenceCollection , IChatCollection , IChatMemberCollection , IChatMessageCollection , ICallCollection , IParticipantCollection


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • Join() : ICall , IChat


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • Kick() : IChat
  • KickBan() : IChat


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Language : IUser , IConversion , ISettings
  • LanguageCode : IUser
  • Languages : IProfile
  • LastOnline : IUser
  • Leave() : IChat
  • LeaveReason : IChatMessage
  • LoadAvatarFromFile() : ISettings


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • Manager : ICallChannel
  • MemberObjects : IChat
  • Members : IChat
  • Message : ISmsChunk , ISmsTarget , ISkype , _ICallChannelManagerEvents
  • MessageHistory() : _ISkypeEvents
  • Messages : IChat , ISkype
  • MessageStatus() : _ISkypeEvents
  • Minimize() : IClient
  • MissedCalls : ISkype
  • MissedChats : ISkype
  • MissedMessages : ISkype
  • MissedSmss : ISkype
  • MissedVoicemails : ISkype
  • MoodText : IUser , IProfile
  • Mute() : _ISkypeEvents , ISkype
  • MyRole : IChat
  • MyStatus : IChat


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name : IChat , IApplication , ICallChannelManager
  • Number : ISmsTarget
  • NumberOfAuthBuddies : IUser


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OnlineStatus : IUser , _ISkypeEvents
  • OnlineStatusToText() : IConversion
  • OnlineUsers : IGroup
  • Open() : IVoicemail
  • OpenAddContactDialog() : IClient
  • OpenAuthorizationDialog() : IClient
  • OpenBlockedUsersDialog() : IClient
  • OpenCallHistoryTab() : IClient
  • OpenConferenceDialog() : IClient
  • OpenContactsTab() : IClient
  • OpenDialog() : IClient
  • OpenDialpadTab() : IClient
  • OpenFileTransferDialog() : IClient
  • OpenGettingStartedWizard() : IClient
  • OpenImportContactsWizard() : IClient
  • OpenLiveTab() : IClient
  • OpenMessageDialog() : IClient
  • OpenOptionsDialog() : IClient
  • OpenProfileDialog() : IClient
  • OpenSearchDialog() : IClient
  • OpenSendContactsDialog() : IClient
  • OpenSmsDialog() : IClient
  • OpenUserInfoDialog() : IClient
  • OpenVideoTestDialog() : IClient
  • OpenWindow() : IChat
  • Options : IChatMessage , IChat
  • OutputDevice : ICall


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • About : IUser , IProfile
  • Accept() : IGroup
  • AcceptAdd() : IChat
  • ActiveCalls : IConference , ISkype
  • ActiveChats : ISkype
  • ActiveFileTransfers : ISkype
  • ActiveMembers : IChat
  • ActivityTimestamp : IChat
  • Add() : IConferenceCollection , IVoicemailCollection , IApplicationStreamCollection , IGroupCollection , ISmsChunkCollection , ISmsTargetCollection , IUserCollection , ISmsMessageCollection , IFileTransferCollection , IParticipantCollection , ICallChannelCollection , ICallCollection , IChatMessageCollection , IChatCollection
  • Adder : IChat
  • AddMembers() : IChat
  • AddUser() : IGroup
  • AEC : ISettings
  • AGC : ISettings
  • AlertString : IChat
  • Aliases : IUser
  • AllowedDuration : IVoicemail
  • Answer() : ICall
  • ApiSecurityContextEnabled : ISkype
  • ApiWrapperVersion : ISkype
  • Applicants : IChat
  • Application : ISkype
  • ApplicationConnecting() : _ISkypeEvents
  • ApplicationDatagram() : _ISkypeEvents
  • ApplicationName : IApplicationStream
  • ApplicationReceiving() : _ISkypeEvents
  • ApplicationSending() : _ISkypeEvents
  • ApplicationStreams() : _ISkypeEvents
  • AsyncSearchUsers() : ISkype
  • AsyncSearchUsersFinished() : _ISkypeEvents
  • Attach() : ISkype
  • AttachmentStatus : ISkype , _ISkypeEvents
  • AttachmentStatusToText() : IConversion
  • AudioIn : ISettings
  • AudioOut : ISettings
  • AutoAway : ISettings , _ISkypeEvents
  • Avatar : ISettings


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • Balance : IProfile
  • BalanceCurrency : IProfile
  • BalanceToText : IProfile
  • Birthday : IUser , IProfile
  • Blob : IChat
  • Blocking : ICommand
  • Body : IChatMessage , ISmsMessage
  • Bookmark() : IChat
  • Bookmarked : IChat
  • BookmarkedChats : ISkype
  • BuddyStatus : IUser
  • BuddyStatusToText() : IConversion
  • ButtonPressed() : IClient
  • ButtonReleased() : IClient
  • BytesPerSecond : IFileTransfer
  • BytesTransferred : IFileTransfer


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • Cache : ISkype
  • Call : ISkype , ICallChannel
  • CallApplyCF : IProfile
  • CallDtmfReceived() : _ISkypeEvents
  • CallFailureReasonToText() : IConversion
  • CallForwardRules : IProfile
  • CallHistory() : _ISkypeEvents
  • CallInputStatusChanged() : _ISkypeEvents
  • CallNoAnswerTimeout : IProfile
  • Calls : IConference , ISkype
  • CallSeenStatusChanged() : _ISkypeEvents
  • CallSendToVM : IProfile
  • CallStatus() : _ISkypeEvents , IParticipant
  • CallStatusToText() : IConversion
  • CallTransferStatusChanged() : _ISkypeEvents
  • CallType : IParticipant
  • CallTypeToText() : IConversion
  • CallVideoReceiveStatusChanged() : _ISkypeEvents
  • CallVideoSendStatusChanged() : _ISkypeEvents
  • CallVideoSendStatusToText() : IConversion
  • CallVideoStatusChanged() : _ISkypeEvents
  • CallVideoStatusToText() : IConversion
  • CanLeaveVoicemail : IUser
  • CanSetRoleTo : IChatMember
  • CanTransfer : ICall
  • Caption : IPluginMenuItem
  • CaptureMicDevice : ICall
  • ChangeUserStatus() : ISkype
  • Channels : ICallChannelManager , _ICallChannelManagerEvents
  • ChannelType : ICallChannelManager
  • CharactersLeft : ISmsChunk
  • Chat : IChatMessage , IChatMember , ISkype
  • ChatLeaveReasonToText() : IConversion
  • ChatMemberRoleChanged() : _ISkypeEvents
  • ChatMembersChanged() : _ISkypeEvents
  • ChatMessageStatusToText() : IConversion
  • ChatMessageTypeToText() : IConversion
  • ChatName : IChatMessage
  • Chats : ISkype
  • ChatStatusToText() : IConversion
  • Chunks : ISmsMessage
  • City : IUser , IProfile
  • ClearCallHistory() : ISkype
  • ClearChatHistory() : ISkype
  • ClearRecentMessages() : IChat
  • ClearVoicemailHistory() : ISkype
  • Client : ISkype
  • Command : ICommand , ISkype , _ISkypeEvents
  • CommandId : ISkype
  • Conference : ISkype
  • ConferenceId : ICall
  • Conferences : ISkype
  • Connect() : ICallChannelManager , IApplication
  • ConnectableUsers : IApplication
  • ConnectingUsers : IApplication
  • ConnectionStatus : ISkype , _ISkypeEvents
  • ConnectionStatusToText() : IConversion
  • ContactsFocused() : _ISkypeEvents
  • Convert : ISkype
  • Count : IChatMessageCollection , IChatCollection , IFileTransferCollection , ICallCollection , IParticipantCollection , IUserCollection , ICallChannelCollection , IGroupCollection , ISmsTargetCollection , IChatMemberCollection , IVoicemailCollection , IApplicationStreamCollection , ISmsChunkCollection , ISmsMessageCollection , IConferenceCollection
  • Country : IUser , IProfile
  • CountryCode : IUser
  • Create() : IApplication
  • CreateApplication() : ICallChannelManager
  • CreateChatMultiple() : ISkype
  • CreateChatUsingBlob() : ISkype
  • CreateChatWith() : ISkype
  • Created : ICallChannelManager , _ICallChannelManagerEvents
  • CreateEvent() : IClient
  • CreateGroup() : ISkype
  • CreateMenuItem() : IClient
  • CreateSms() : ISkype
  • CurrentUser : ISkype
  • CurrentUserHandle : ISkype
  • CurrentUserProfile : ISkype
  • CurrentUserStatus : ISkype
  • CustomGroupId : IGroup
  • CustomGroups : ISkype


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DataLength : IApplicationStream
  • Decline() : IGroup
  • Delete() : IApplication , ISmsMessage , IVoicemail , IPluginMenuItem , IPluginEvent
  • DeleteGroup() : ISkype
  • Description : IChat
  • DialogPartner : IChat
  • Disband() : IChat
  • Disconnect() : IApplicationStream , ICallChannelManager
  • DisplayName : IGroup , IParticipant , IUser
  • Download() : IVoicemail
  • DTMF : ICall
  • Duration : ICall , IVoicemail


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EditedBy : IChatMessage
  • EditedTimestamp : IChatMessage
  • EnableApiSecurityContext() : ISkype
  • Enabled : IPluginMenuItem
  • EnterPassword() : IChat
  • Error() : _ISkypeEvents
  • Expected : ICommand


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FailureReason : ICall , IVoicemail , IFileTransfer , ISmsMessage
  • FileName : IFileTransfer
  • FilePath : IFileTransfer
  • FileTransfers : ISkype
  • FileTransferStatusChanged() : _ISkypeEvents
  • FindChatUsingBlob() : ISkype
  • Finish() : ICall , IConference
  • FinishTime : IFileTransfer
  • Focus() : IClient
  • FocusedContacts : ISkype
  • Forward() : ICall
  • ForwardedBy : ICall
  • FriendlyName : ISkype , IChat
  • Friends : ISkype
  • FromDisplayName : IChatMessage
  • FromHandle : IChatMessage
  • FullName : IProfile , IUser


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • Greeting : ISkype
  • GroupDeleted() : _ISkypeEvents
  • GroupExpanded() : _ISkypeEvents
  • Groups : ISkype
  • GroupTypeToText() : IConversion
  • GroupUsers() : _ISkypeEvents
  • GroupVisible() : _ISkypeEvents
  • Guid : IChatMessage
  • GuideLines : IChat


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • Handle : IUser , IParticipant , IApplicationStream , IChatMember
  • HardwiredGroups : ISkype
  • HasCallEquipment : IUser
  • Hint : IPluginMenuItem
  • Hold() : ICall , IConference
  • Homepage : IProfile , IUser


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Id : ICommand , ICall , IChatMember , ISmsChunk , ISmsMessage , IConference , IPluginMenuItem , IPluginEvent , IChatMessage , IVoicemail , IFileTransfer , IGroup
  • InputDevice : ICall
  • InputStatus : ICall
  • IPCountry : IProfile
  • IsActive : IChatMember
  • IsAuthorized : IUser
  • IsBlocked : IUser
  • IsCallForwardActive : IUser
  • IsEditable : IChatMessage
  • IsExpanded : IGroup
  • IsFailedUnseen : ISmsMessage
  • IsRunning : IClient
  • IsSkypeOutContact : IUser
  • IsVideoCapable : IUser
  • IsVisible : IGroup
  • IsVoicemailCapable : IUser
  • Item : ICallChannelCollection , IChatMessageCollection , IChatCollection , ISmsTargetCollection , IParticipantCollection , IVoicemailCollection , IChatMemberCollection , IConferenceCollection , IApplicationStreamCollection , ICallCollection , IUserCollection , ISmsChunkCollection , IGroupCollection , IFileTransferCollection , ISmsMessageCollection


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Participants : ICall
  • PartnerDisplayName : ICall , IFileTransfer , IVoicemail
  • PartnerHandle : IFileTransfer , ICall , IVoicemail , IApplicationStream
  • PasswordHint : IChat
  • PCSpeaker : ISettings
  • PhoneHome : IUser , IProfile
  • PhoneMobile : IUser , IProfile
  • PhoneOffice : IProfile , IUser
  • PlaceCall() : ISkype
  • PluginEventClicked() : _ISkypeEvents
  • PluginMenuItemClicked() : _ISkypeEvents
  • Posters : IChat
  • PredictiveDialerCountry : ISkype
  • Price : ISmsMessage
  • PriceCurrency : ISmsMessage
  • PricePrecision : ISmsMessage
  • Privilege : ISkype
  • Profile : ISkype
  • Property : ISkype
  • Protocol : ISkype
  • Province : IUser , IProfile
  • PstnNumber : ICall
  • PstnStatus : ICall


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • Rate : ICall
  • RateCurrency : ICall
  • RatePrecision : ICall
  • Read() : IApplicationStream
  • ReceivedAuthRequest : IUser
  • ReceivedStreams : IApplication
  • RecentChats : ISkype
  • RecentMessages : IChat
  • RedirectToVoicemail() : ICall
  • Remove() : IVoicemailCollection , IApplicationStreamCollection , IGroupCollection , ISmsChunkCollection , IUserCollection , ISmsTargetCollection , ISmsMessageCollection , IParticipantCollection , IFileTransferCollection , ICallChannelCollection , ICallCollection , IChatMessageCollection , IChatCollection , IConferenceCollection
  • RemoveAll() : ISmsMessageCollection , IGroupCollection , ISmsChunkCollection , IChatMessageCollection , ISmsTargetCollection , IFileTransferCollection , ICallChannelCollection , IApplicationStreamCollection , IUserCollection , IParticipantCollection , ICallCollection , IChatCollection , IConferenceCollection , IVoicemailCollection
  • RemoveUser() : IGroup
  • Reply() : _ISkypeEvents , ICommand
  • ReplyToNumber : ISmsMessage
  • ResetCache() : ISkype
  • ResetIdleTimer() : ISettings
  • Resume() : IConference , ICall
  • RichMoodText : IUser , IProfile
  • Ringer : ISettings
  • RingTone : ISettings
  • RingToneStatus : ISettings
  • Role : IChatMessage , IChatMember


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SaveAvatarToFile() : ISettings
  • SearchForUsers() : ISkype
  • Seen : IChatMessage , ISmsMessage , ICall
  • Send() : ISmsMessage
  • SendCommand() : ISkype
  • SendDatagram() : IApplicationStream , IApplication
  • Sender : IChatMessage
  • SendingStreams : IApplication
  • SendMessage() : IChat , ISkype
  • SendSms() : ISkype
  • SendTextMessage() : ICallChannel
  • SendVoicemail() : ISkype
  • SetPassword() : IChat
  • Settings : ISkype
  • SetUnplayed() : IVoicemail
  • Sex : IUser , IProfile
  • Share() : IGroup
  • Shutdown() : IClient
  • SilentMode : ISkype
  • SilentModeStatusChanged() : _ISkypeEvents
  • SmsMessageStatusChanged() : _ISkypeEvents
  • SmsMessageStatusToText() : IConversion
  • SmsMessageTypeToText() : IConversion
  • Smss : ISkype
  • SmsTargetStatusChanged() : _ISkypeEvents
  • SmsTargetStatusToText() : IConversion
  • SpeedDial : IUser
  • Start() : IClient
  • StartPlayback() : IVoicemail
  • StartPlaybackInCall() : IVoicemail
  • StartRecording() : IVoicemail
  • StartTime : IFileTransfer
  • StartVideoReceive() : ICall
  • StartVideoSend() : ICall
  • Status : IFileTransfer , ISmsMessage , ICall , ISmsTarget , IVoicemail , IChatMessage , IChat
  • StopPlayback() : IVoicemail
  • StopRecording() : IVoicemail
  • StopVideoReceive() : ICall
  • StopVideoSend() : ICall
  • Stream : ICallChannel
  • Streams : IApplication
  • Subject : ICall


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TargetIdentity : ICall
  • TargetNumbers : ISmsMessage
  • Targets : ISmsMessage
  • Text : ISmsChunk , ICallChannelMessage
  • TextToAttachmentStatus() : IConversion
  • TextToBuddyStatus() : IConversion
  • TextToCallStatus() : IConversion
  • TextToCallType() : IConversion
  • TextToChatMessageStatus() : IConversion
  • TextToChatMessageType() : IConversion
  • TextToConnectionStatus() : IConversion
  • TextToGroupType() : IConversion
  • TextToOnlineStatus() : IConversion
  • TextToUserSex() : IConversion
  • TextToUserStatus() : IConversion
  • TextToVoicemailStatus() : IConversion
  • Timeout : ICommand , ISkype
  • Timestamp : IVoicemail , ICall , IChatMessage , IChat , ISmsMessage
  • Timezone : IUser , IProfile
  • Topic : IChat
  • TopicXML : IChat
  • Transfer() : ICall
  • TransferActive : ICall
  • TransferredBy : ICall
  • TransferredTo : ICall
  • TransferStatus : ICall
  • Type : IVoicemail , ISmsMessage , IChatMessage , IChat , ICall , ICallChannel , IGroup , IFileTransfer


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UILanguageChanged() : _ISkypeEvents
  • Unbookmark() : IChat
  • Upload() : IVoicemail
  • User : ISkype
  • UserAuthorizationRequestReceived() : _ISkypeEvents
  • UserMood() : _ISkypeEvents
  • Users : IGroup , IChatMessage
  • UserSexToText() : IConversion
  • UserStatus() : _ISkypeEvents
  • UserStatusToText() : IConversion
  • UsersWaitingAuthorization : ISkype


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidatedSmsNumbers : IProfile
  • Variable : ISkype
  • Version : ISkype
  • VideoIn : ISettings
  • VideoReceiveStatus : ICall
  • VideoSendStatus : ICall
  • VideoStatus : ICall
  • VmAllowedDuration : ICall
  • VmDuration : ICall
  • Voicemail : ISkype
  • VoicemailFailureReasonToText() : IConversion
  • Voicemails : ISkype
  • VoicemailStatus() : _ISkypeEvents
  • VoicemailStatusToText() : IConversion
  • VoicemailTypeToText() : IConversion


Skype4COM: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Wallpaper : IClient
  • WallpaperChanged() : _ISkypeEvents
  • Write() : IApplicationStream


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • Accept() : IGroup
  • AcceptAdd() : IChat
  • Add() : IParticipantCollection , IConferenceCollection , ICallChannelCollection , IVoicemailCollection , ICallCollection , IApplicationStreamCollection , IGroupCollection , IUserCollection , IChatMessageCollection , ISmsChunkCollection , ISmsTargetCollection , IChatCollection , ISmsMessageCollection , IFileTransferCollection
  • AddMembers() : IChat
  • AddUser() : IGroup
  • Answer() : ICall
  • ApplicationConnecting() : _ISkypeEvents
  • ApplicationDatagram() : _ISkypeEvents
  • ApplicationReceiving() : _ISkypeEvents
  • ApplicationSending() : _ISkypeEvents
  • ApplicationStreams() : _ISkypeEvents
  • AsyncSearchUsers() : ISkype
  • AsyncSearchUsersFinished() : _ISkypeEvents
  • Attach() : ISkype
  • AttachmentStatus() : _ISkypeEvents
  • AttachmentStatusToText() : IConversion
  • AutoAway() : _ISkypeEvents


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- j -

  • Join() : ICall , IChat


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • Kick() : IChat
  • KickBan() : IChat


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • Leave() : IChat
  • LoadAvatarFromFile() : ISettings


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • Message() : _ICallChannelManagerEvents
  • MessageHistory() : _ISkypeEvents
  • MessageStatus() : _ISkypeEvents
  • Minimize() : IClient
  • Mute() : _ISkypeEvents


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • OnlineStatus() : _ISkypeEvents
  • OnlineStatusToText() : IConversion
  • Open() : IVoicemail
  • OpenAddContactDialog() : IClient
  • OpenAuthorizationDialog() : IClient
  • OpenBlockedUsersDialog() : IClient
  • OpenCallHistoryTab() : IClient
  • OpenConferenceDialog() : IClient
  • OpenContactsTab() : IClient
  • OpenDialog() : IClient
  • OpenDialpadTab() : IClient
  • OpenFileTransferDialog() : IClient
  • OpenGettingStartedWizard() : IClient
  • OpenImportContactsWizard() : IClient
  • OpenLiveTab() : IClient
  • OpenMessageDialog() : IClient
  • OpenOptionsDialog() : IClient
  • OpenProfileDialog() : IClient
  • OpenSearchDialog() : IClient
  • OpenSendContactsDialog() : IClient
  • OpenSmsDialog() : IClient
  • OpenUserInfoDialog() : IClient
  • OpenVideoTestDialog() : IClient
  • OpenWindow() : IChat


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • Bookmark() : IChat
  • BuddyStatusToText() : IConversion
  • ButtonPressed() : IClient
  • ButtonReleased() : IClient


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CallDtmfReceived() : _ISkypeEvents
  • CallFailureReasonToText() : IConversion
  • CallHistory() : _ISkypeEvents
  • CallInputStatusChanged() : _ISkypeEvents
  • CallSeenStatusChanged() : _ISkypeEvents
  • CallStatus() : _ISkypeEvents
  • CallStatusToText() : IConversion
  • CallTransferStatusChanged() : _ISkypeEvents
  • CallTypeToText() : IConversion
  • CallVideoReceiveStatusChanged() : _ISkypeEvents
  • CallVideoSendStatusChanged() : _ISkypeEvents
  • CallVideoSendStatusToText() : IConversion
  • CallVideoStatusChanged() : _ISkypeEvents
  • CallVideoStatusToText() : IConversion
  • ChangeUserStatus() : ISkype
  • Channels() : _ICallChannelManagerEvents
  • ChatLeaveReasonToText() : IConversion
  • ChatMemberRoleChanged() : _ISkypeEvents
  • ChatMembersChanged() : _ISkypeEvents
  • ChatMessageStatusToText() : IConversion
  • ChatMessageTypeToText() : IConversion
  • ChatStatusToText() : IConversion
  • ClearCallHistory() : ISkype
  • ClearChatHistory() : ISkype
  • ClearRecentMessages() : IChat
  • ClearVoicemailHistory() : ISkype
  • Command() : _ISkypeEvents
  • Connect() : IApplication , ICallChannelManager
  • ConnectionStatus() : _ISkypeEvents
  • ConnectionStatusToText() : IConversion
  • ContactsFocused() : _ISkypeEvents
  • Create() : IApplication
  • CreateApplication() : ICallChannelManager
  • CreateChatMultiple() : ISkype
  • CreateChatUsingBlob() : ISkype
  • CreateChatWith() : ISkype
  • Created() : _ICallChannelManagerEvents
  • CreateEvent() : IClient
  • CreateGroup() : ISkype
  • CreateMenuItem() : IClient
  • CreateSms() : ISkype


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • Decline() : IGroup
  • Delete() : IVoicemail , ISmsMessage , IPluginMenuItem , IApplication , IPluginEvent
  • DeleteGroup() : ISkype
  • Disband() : IChat
  • Disconnect() : IApplicationStream , ICallChannelManager
  • Download() : IVoicemail


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • EnableApiSecurityContext() : ISkype
  • EnterPassword() : IChat
  • Error() : _ISkypeEvents


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FileTransferStatusChanged() : _ISkypeEvents
  • FindChatUsingBlob() : ISkype
  • Finish() : IConference , ICall
  • Focus() : IClient
  • Forward() : ICall


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GroupDeleted() : _ISkypeEvents
  • GroupExpanded() : _ISkypeEvents
  • GroupTypeToText() : IConversion
  • GroupUsers() : _ISkypeEvents
  • GroupVisible() : _ISkypeEvents


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • Hold() : ICall , IConference


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PlaceCall() : ISkype
  • PluginEventClicked() : _ISkypeEvents
  • PluginMenuItemClicked() : _ISkypeEvents


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • Read() : IApplicationStream
  • RedirectToVoicemail() : ICall
  • Remove() : IParticipantCollection , IConferenceCollection , ICallChannelCollection , IVoicemailCollection , ICallCollection , IApplicationStreamCollection , IGroupCollection , IUserCollection , IChatMessageCollection , ISmsChunkCollection , ISmsTargetCollection , IChatCollection , ISmsMessageCollection , IFileTransferCollection
  • RemoveAll() : IChatCollection , IFileTransferCollection , IUserCollection , IParticipantCollection , ICallCollection , ICallChannelCollection , IApplicationStreamCollection , IGroupCollection , ISmsTargetCollection , IChatMessageCollection , IConferenceCollection , ISmsChunkCollection , ISmsMessageCollection , IVoicemailCollection
  • RemoveUser() : IGroup
  • Reply() : _ISkypeEvents
  • ResetCache() : ISkype
  • ResetIdleTimer() : ISettings
  • Resume() : ICall , IConference


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • SaveAvatarToFile() : ISettings
  • SearchForUsers() : ISkype
  • Send() : ISmsMessage
  • SendCommand() : ISkype
  • SendDatagram() : IApplicationStream , IApplication
  • SendMessage() : ISkype , IChat
  • SendSms() : ISkype
  • SendTextMessage() : ICallChannel
  • SendVoicemail() : ISkype
  • SetPassword() : IChat
  • SetUnplayed() : IVoicemail
  • Share() : IGroup
  • Shutdown() : IClient
  • SilentModeStatusChanged() : _ISkypeEvents
  • SmsMessageStatusChanged() : _ISkypeEvents
  • SmsMessageStatusToText() : IConversion
  • SmsMessageTypeToText() : IConversion
  • SmsTargetStatusChanged() : _ISkypeEvents
  • SmsTargetStatusToText() : IConversion
  • Start() : IClient
  • StartPlayback() : IVoicemail
  • StartPlaybackInCall() : IVoicemail
  • StartRecording() : IVoicemail
  • StartVideoReceive() : ICall
  • StartVideoSend() : ICall
  • StopPlayback() : IVoicemail
  • StopRecording() : IVoicemail
  • StopVideoReceive() : ICall
  • StopVideoSend() : ICall


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TextToAttachmentStatus() : IConversion
  • TextToBuddyStatus() : IConversion
  • TextToCallStatus() : IConversion
  • TextToCallType() : IConversion
  • TextToChatMessageStatus() : IConversion
  • TextToChatMessageType() : IConversion
  • TextToConnectionStatus() : IConversion
  • TextToGroupType() : IConversion
  • TextToOnlineStatus() : IConversion
  • TextToUserSex() : IConversion
  • TextToUserStatus() : IConversion
  • TextToVoicemailStatus() : IConversion
  • Transfer() : ICall


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UILanguageChanged() : _ISkypeEvents
  • Unbookmark() : IChat
  • Upload() : IVoicemail
  • UserAuthorizationRequestReceived() : _ISkypeEvents
  • UserMood() : _ISkypeEvents
  • UserSexToText() : IConversion
  • UserStatus() : _ISkypeEvents
  • UserStatusToText() : IConversion


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • VoicemailFailureReasonToText() : IConversion
  • VoicemailStatus() : _ISkypeEvents
  • VoicemailStatusToText() : IConversion
  • VoicemailTypeToText() : IConversion


Skype4COM: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • j
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • WallpaperChanged() : _ISkypeEvents
  • Write() : IApplicationStream


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- _ -

  • _NewEnum : IUserCollection , ICallChannelCollection , IFileTransferCollection , ISmsMessageCollection , ISmsTargetCollection , ISmsChunkCollection , IGroupCollection , IApplicationStreamCollection , IVoicemailCollection , IConferenceCollection , IChatCollection , IChatMemberCollection , IChatMessageCollection , ICallCollection , IParticipantCollection


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • Language : IUser , IConversion , ISettings
  • LanguageCode : IUser
  • Languages : IProfile
  • LastOnline : IUser
  • LeaveReason : IChatMessage


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • Manager : ICallChannel
  • MemberObjects : IChat
  • Members : IChat
  • Message : ISmsChunk , ISmsTarget , ISkype
  • Messages : ISkype , IChat
  • MissedCalls : ISkype
  • MissedChats : ISkype
  • MissedMessages : ISkype
  • MissedSmss : ISkype
  • MissedVoicemails : ISkype
  • MoodText : IProfile , IUser
  • Mute : ISkype
  • MyRole : IChat
  • MyStatus : IChat


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • Name : IChat , IApplication , ICallChannelManager
  • Number : ISmsTarget
  • NumberOfAuthBuddies : IUser


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • OnlineStatus : IUser
  • OnlineUsers : IGroup
  • Options : IChat , IChatMessage
  • OutputDevice : ICall


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • About : IUser , IProfile
  • ActiveCalls : ISkype , IConference
  • ActiveChats : ISkype
  • ActiveFileTransfers : ISkype
  • ActiveMembers : IChat
  • ActivityTimestamp : IChat
  • Adder : IChat
  • AEC : ISettings
  • AGC : ISettings
  • AlertString : IChat
  • Aliases : IUser
  • AllowedDuration : IVoicemail
  • ApiSecurityContextEnabled : ISkype
  • ApiWrapperVersion : ISkype
  • Applicants : IChat
  • Application : ISkype
  • ApplicationName : IApplicationStream
  • AttachmentStatus : ISkype
  • AudioIn : ISettings
  • AudioOut : ISettings
  • AutoAway : ISettings
  • Avatar : ISettings


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • Balance : IProfile
  • BalanceCurrency : IProfile
  • BalanceToText : IProfile
  • Birthday : IUser , IProfile
  • Blob : IChat
  • Blocking : ICommand
  • Body : IChatMessage , ISmsMessage
  • Bookmarked : IChat
  • BookmarkedChats : ISkype
  • BuddyStatus : IUser
  • BytesPerSecond : IFileTransfer
  • BytesTransferred : IFileTransfer


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • Cache : ISkype
  • Call : ISkype , ICallChannel
  • CallApplyCF : IProfile
  • CallForwardRules : IProfile
  • CallNoAnswerTimeout : IProfile
  • Calls : ISkype , IConference
  • CallSendToVM : IProfile
  • CallStatus : IParticipant
  • CallType : IParticipant
  • CanLeaveVoicemail : IUser
  • CanSetRoleTo : IChatMember
  • CanTransfer : ICall
  • Caption : IPluginMenuItem
  • CaptureMicDevice : ICall
  • Channels : ICallChannelManager
  • ChannelType : ICallChannelManager
  • CharactersLeft : ISmsChunk
  • Chat : IChatMessage , IChatMember , ISkype
  • ChatName : IChatMessage
  • Chats : ISkype
  • Chunks : ISmsMessage
  • City : IUser , IProfile
  • Client : ISkype
  • Command : ICommand , ISkype
  • CommandId : ISkype
  • Conference : ISkype
  • ConferenceId : ICall
  • Conferences : ISkype
  • ConnectableUsers : IApplication
  • ConnectingUsers : IApplication
  • ConnectionStatus : ISkype
  • Convert : ISkype
  • Count : ICallCollection , ICallChannelCollection , IApplicationStreamCollection , IConferenceCollection , IChatMemberCollection , IVoicemailCollection , IParticipantCollection , IChatMessageCollection , IChatCollection , IUserCollection , ISmsTargetCollection , IGroupCollection , ISmsMessageCollection , IFileTransferCollection , ISmsChunkCollection
  • Country : IUser , IProfile
  • CountryCode : IUser
  • Created : ICallChannelManager
  • CurrentUser : ISkype
  • CurrentUserHandle : ISkype
  • CurrentUserProfile : ISkype
  • CurrentUserStatus : ISkype
  • CustomGroupId : IGroup
  • CustomGroups : ISkype


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • DataLength : IApplicationStream
  • Description : IChat
  • DialogPartner : IChat
  • DisplayName : IUser , IParticipant , IGroup
  • DTMF : ICall
  • Duration : ICall , IVoicemail


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • EditedBy : IChatMessage
  • EditedTimestamp : IChatMessage
  • Enabled : IPluginMenuItem
  • Expected : ICommand


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FailureReason : ICall , IVoicemail , IFileTransfer , ISmsMessage
  • FileName : IFileTransfer
  • FilePath : IFileTransfer
  • FileTransfers : ISkype
  • FinishTime : IFileTransfer
  • FocusedContacts : ISkype
  • ForwardedBy : ICall
  • FriendlyName : IChat , ISkype
  • Friends : ISkype
  • FromDisplayName : IChatMessage
  • FromHandle : IChatMessage
  • FullName : IProfile , IUser


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • Greeting : ISkype
  • Groups : ISkype
  • Guid : IChatMessage
  • GuideLines : IChat


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • Handle : IUser , IParticipant , IApplicationStream , IChatMember
  • HardwiredGroups : ISkype
  • HasCallEquipment : IUser
  • Hint : IPluginMenuItem
  • Homepage : IUser , IProfile


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • Id : ICommand , ICall , IChatMember , ISmsChunk , ISmsMessage , IConference , IPluginMenuItem , IPluginEvent , IChatMessage , IVoicemail , IFileTransfer , IGroup
  • InputDevice : ICall
  • InputStatus : ICall
  • IPCountry : IProfile
  • IsActive : IChatMember
  • IsAuthorized : IUser
  • IsBlocked : IUser
  • IsCallForwardActive : IUser
  • IsEditable : IChatMessage
  • IsExpanded : IGroup
  • IsFailedUnseen : ISmsMessage
  • IsRunning : IClient
  • IsSkypeOutContact : IUser
  • IsVideoCapable : IUser
  • IsVisible : IGroup
  • IsVoicemailCapable : IUser
  • Item : ICallChannelCollection , IChatMessageCollection , IChatCollection , ISmsTargetCollection , IParticipantCollection , IVoicemailCollection , IChatMemberCollection , IConferenceCollection , IApplicationStreamCollection , ICallCollection , IUserCollection , ISmsChunkCollection , IGroupCollection , IFileTransferCollection , ISmsMessageCollection


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • Participants : ICall
  • PartnerDisplayName : ICall , IFileTransfer , IVoicemail
  • PartnerHandle : IFileTransfer , ICall , IVoicemail , IApplicationStream
  • PasswordHint : IChat
  • PCSpeaker : ISettings
  • PhoneHome : IUser , IProfile
  • PhoneMobile : IUser , IProfile
  • PhoneOffice : IProfile , IUser
  • Posters : IChat
  • PredictiveDialerCountry : ISkype
  • Price : ISmsMessage
  • PriceCurrency : ISmsMessage
  • PricePrecision : ISmsMessage
  • Privilege : ISkype
  • Profile : ISkype
  • Property : ISkype
  • Protocol : ISkype
  • Province : IProfile , IUser
  • PstnNumber : ICall
  • PstnStatus : ICall


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • Rate : ICall
  • RateCurrency : ICall
  • RatePrecision : ICall
  • ReceivedAuthRequest : IUser
  • ReceivedStreams : IApplication
  • RecentChats : ISkype
  • RecentMessages : IChat
  • Reply : ICommand
  • ReplyToNumber : ISmsMessage
  • RichMoodText : IUser , IProfile
  • Ringer : ISettings
  • RingTone : ISettings
  • RingToneStatus : ISettings
  • Role : IChatMessage , IChatMember


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • Seen : ICall , IChatMessage , ISmsMessage
  • Sender : IChatMessage
  • SendingStreams : IApplication
  • Settings : ISkype
  • Sex : IProfile , IUser
  • SilentMode : ISkype
  • Smss : ISkype
  • SpeedDial : IUser
  • StartTime : IFileTransfer
  • Status : IChat , ISmsTarget , IVoicemail , IFileTransfer , ISmsMessage , IChatMessage , ICall
  • Stream : ICallChannel
  • Streams : IApplication
  • Subject : ICall


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TargetIdentity : ICall
  • TargetNumbers : ISmsMessage
  • Targets : ISmsMessage
  • Text : ISmsChunk , ICallChannelMessage
  • Timeout : ICommand , ISkype
  • Timestamp : ICall , IChatMessage , IChat , IVoicemail , ISmsMessage
  • Timezone : IUser , IProfile
  • Topic : IChat
  • TopicXML : IChat
  • TransferActive : ICall
  • TransferredBy : ICall
  • TransferredTo : ICall
  • TransferStatus : ICall
  • Type : IVoicemail , IChat , ICallChannel , IGroup , ICall , IFileTransfer , IChatMessage , ISmsMessage


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • User : ISkype
  • Users : IChatMessage , IGroup
  • UsersWaitingAuthorization : ISkype


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • ValidatedSmsNumbers : IProfile
  • Variable : ISkype
  • Version : ISkype
  • VideoIn : ISettings
  • VideoReceiveStatus : ICall
  • VideoSendStatus : ICall
  • VideoStatus : ICall
  • VmAllowedDuration : ICall
  • VmDuration : ICall
  • Voicemail : ISkype
  • Voicemails : ISkype


Skype4COM: Class Members - Properties

  • All
  • Functions
  • Properties
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • Wallpaper : IClient


Skype4COM: File List

  • File List

File List

Here is a list of all documented files with brief descriptions:
Skype4COM.idl [code]


Skype4COM: Examples

Examples

Here is a list of all examples:
  • Answer.vbs
  • Attach.vbs
  • Buttons.vbs
  • Call.php
  • Call.vbs
  • Chats.vbs
  • Chats2.vbs
  • Client.vbs
  • Command.vbs
  • Conference.vbs
  • Conferences.vbs
  • FileTransfers.vbs
  • Groupchat.vbs
  • Groups.vbs
  • Join.vbs
  • MessageStatus.js
  • MessageStatus.vbs
  • MissedMessages.js
  • MissedMessages.vbs
  • Plugins.vbs
  • Profile.vbs
  • Response.vbs
  • Search.vbs
  • Settings.vbs
  • Sms.vbs
  • Smss.vbs
  • VoicemailServer.cs
  • VoicemailServer.vbs


Skype4COM: Answer.vbs

Answer.vbs

This script sets up automatic answering of incoming calls.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Connect to the Skype API:
oSkype.Attach

'// Run an infinite loop to ensure the connection remains active:
Do While True
  WScript.Sleep(60000)
Loop

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub

'// The CallStatus event handler monitors call status and if the status is "ringing" and it is an incoming call, it attempts to answer the call:
Public Sub Skype_CallStatus(ByRef aCall, ByVal aStatus)
  WScript.Echo  ">Call " & aCall.Id & " status " & aStatus & " " & oSkype.Convert.CallStatusToText(aStatus)
  If oSkype.Convert.TextToCallStatus("RINGING") = aStatus And _
    (oSkype.Convert.TextToCallType("INCOMING_P2P") = aCall.Type Or _
     oSkype.Convert.TextToCallType("INCOMING_PSTN") = aCall.Type) Then
     WScript.Echo "Answering call from " & aCall.PartnerHandle
     If aCall.TargetIdentity <> "" Then
       WScript.Echo "Call target identity: " & aCall.TargetIdentity
     End If
     aCall.Answer()
  End If
End Sub


Skype4COM: Attach.vbs

Attach.vbs

This script listens for connections on the Skype API, connects when available, and holds the skypename of the user when a connection is successful.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Connect to the Skype API with protocol version 5 (the default version):
oSkype.Attach 5

'// When attached to the API, send repeated commands to the API to test if they succeed:
Do While True
  WScript.Sleep(1000)
  If oSkype.AttachmentStatus = oSkype.Convert.TextToAttachmentStatus("SUCCESS") Then
    WScript.StdOut.Write "PING.."
    oSkype.SendCommand(oSkype.Command(0, "PING","PONG",TRUE))
   'oSkype.SendCommand(oSkype.Command(0, "PING"))
    WScript.StdOut.Write "ok"
    WScript.Echo ""
  End If
Loop

'// The AttachmentStatus event handler monitors attachment status and returns the Skypename of the user when the status is "success":
Public Sub Skype_AttachmentStatus(ByVal aStatus)
 WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
 If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
 If aStatus = oSkype.Convert.TextToAttachmentStatus("SUCCESS") Then WScript.Echo "Current user is " & oSkype.CurrentUserHandle End If
End Sub


Skype4COM: Buttons.vbs

Buttons.vbs

This script sends key press events to the Skype client.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Connect to the Skype API:
oSkype.Attach

'// Bring the Skype client into focus and open the Contacts tab:
oSkype.Client.Focus
oSkype.Client.OpenContactsTab()

'// Emulate typing "ECHO123" into the address bar of the Skype client (appears in the address bar or the Skype client):
oSkype.Client.ButtonPressed "E"
oSkype.Client.ButtonReleased "E"
WScript.Sleep(1000)
oSkype.Client.ButtonPressed "C"
oSkype.Client.ButtonReleased "C"
WScript.Sleep(1000)
oSkype.Client.ButtonPressed "H"
oSkype.Client.ButtonReleased "H"
WScript.Sleep(1000)
oSkype.Client.ButtonPressed "O"
oSkype.Client.ButtonReleased "O"
WScript.Sleep(1000)
oSkype.Client.ButtonPressed "1"
oSkype.Client.ButtonReleased "1"
WScript.Sleep(1000)
oSkype.Client.ButtonPressed "2"
oSkype.Client.ButtonReleased "2"
WScript.Sleep(1000)
oSkype.Client.ButtonPressed "3"
oSkype.Client.ButtonReleased "3"
WScript.Sleep(1000)

'// Emulate pressing the Green (YES) button and the client starts a call:
oSkype.Client.ButtonPressed "YES"
oSkype.Client.ButtonReleased "YES"
WScript.Sleep(10000)

'// Emulate pressing the Red (NO) button and the client ends the call:
oSkype.Client.ButtonPressed "NO"
oSkype.Client.ButtonReleased "NO"

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Call.php

Call.php

This PHP script places a call through the Skype API, and monitors status while the call is in progress.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

<?php

// Event sink:
class _ISkypeEvents {

  function AttachmentStatus($status) {
   echo ">Attachment status $status\n";
  }
  function CallStatus($call, $status) {
   echo ">Call $call->id status $status\n";
  }
}

// Create a Skype4COM object:
$skype = new COM("Skype4COM.Skype");

// Create a sink object:
$sink =& new _ISkypeEvents ();
$sink->convert = $skype->convert();

// Connect to the sink:
com_event_sink($skype, $sink, "_ISkypeEvents");

// Create a conversion object:
$convert = $skype->convert;
$convert->language = "en";

// Start the Skype client, minimized and with no splash screen:
if (!$skype->client()->isRunning()) {
  $skype->client()->start(true, true);
}

// If the user status is not "online", change user status to "online":
if ($skype->currentUserStatus() == $convert->textToUserStatus("OFFLINE")) {
  $skype->changeUserStatus($convert->textToUserStatus("ONLINE"));
}

// Create a user object
$user = $skype->user("echo123");
echo "User " . $user->handle . " online status is " . $convert->onlineStatusToText($user->onlineStatus) . "\n";

// Place a call
$call = $skype->PlaceCall($user->handle);

// Wait for the call to be "in progress" and report an error if:
while ($call->status <> $convert->textToCallStatus("INPROGRESS")) {
  if ($call->status == $convert->textToCallStatus("FAILED") ||
    $call->status == $convert->textToCallStatus("REFUSED") ||
    $call->status == $convert->textToCallStatus("CANCELLED") ||
    $call->status == $convert->textToCallStatus("FINISHED") ||
    $call->status == $convert->textToCallStatus("BUSY"))
    die ("Call status " . $convert->callStatusToText($call->status));
  else
    com_message_pump (500);
}

// Send dtmf tones:
com_message_pump (10000);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "0";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "1";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "2";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "3";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "4";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "5";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "6";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "7";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "8";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "9";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "#";
com_message_pump (500);
if ($call->status == $convert->textToCallStatus("INPROGRESS")) $call->dtmf = "*";

// Finish the call:
if ($call->status <> $convert->textToCallStatus("FINISHED")) $call->finish();

//Sleep:
com_message_pump (1000);

?>


Skype4COM: Call.vbs

Call.vbs

This script places a call through the Skype API, and monitors status while the call is in progress.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Declare the following Skype constants:
cUserStatus_Offline = oSkype.Convert.TextToUserStatus("OFFLINE")
cUserStatus_Online = oSkype.Convert.TextToUserStatus("ONLINE")
cCallStatus_Ringing = oSkype.Convert.TextToCallStatus("RINGING")
cCallStatus_Inprogress = oSkype.Convert.TextToCallStatus("INPROGRESS")
cCallStatus_Failed = oSkype.Convert.TextToCallStatus("FAILED")
cCallStatus_Refused = oSkype.Convert.TextToCallStatus("REFUSED")
cCallStatus_Cancelled = oSkype.Convert.TextToCallStatus("CANCELLED")
cCallStatus_Finished = oSkype.Convert.TextToCallStatus("FINISHED")
cCallStatus_Busy = oSkype.Convert.TextToCallStatus("BUSY")
cAttachmentStatus_Available = oSkype.Convert.TextToAttachmentStatus("AVAILABLE")

'// The PlaceCall command will fail if the user is offline. To avoid failure, check user status and change to online if necessary:
If cUserStatus_Offline = oSkype.CurrentUserStatus Then oSkype.ChangeUserStatus(cUserStatus_Online) End If

'// Create a user object:
Set oUser = oSkype.User("echo123")
WScript.Echo "User " & oUser.Handle & " online status is " & oSkype.Convert.OnlineStatusToText(oUser.OnlineStatus)

'// Place a call:
Set oCall = oSkype.PlaceCall(oUser.Handle)

'// Wait until the call is in progress and return the relevant error if any other status occurs:
Do While oCall.Status <> cCallStatus_Inprogress
  If oCall.Status = cCallStatus_Failed Or _
    oCall.Status = cCallStatus_Refused Or _
    oCall.Status = cCallStatus_Cancelled Or _
    oCall.Status = cCallStatus_Finished Or _
    oCall.Status = cCallStatus_Busy Then
    Err.Raise vbObjectError + 1, "", "Call status: " & oSkype.Convert.CallStatusToText(oCall.Status)
  End If
  WScript.Sleep(500)
Loop

'// Check sending DTMF tones for use with interactive voice response (IVR) applications:
WScript.Sleep(10000)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "0" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "1" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "2" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "3" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "4" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "5" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "6" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "7" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "8" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "9" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "#" End If
WScript.Sleep(500)
If cCallStatus_InProgress = oCall.Status Then oCall.DTMF = "*" End If
WScript.Sleep(500)

'// Finish the call:
If oCall.Status <> cCallStatus_Finished Then oCall.Finish() End If

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo  ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = cAttachmentStatus_Available Then oSkype.Attach() End If
End Sub

'// If the call status is "failed", the CallStatus event handler returns the relevant failure reason as text:
Public Sub Skype_CallStatus(ByRef aCall, ByVal aStatus)
  WScript.Echo  ">Call " & aCall.Id & " status " & aStatus & " " & oSkype.Convert.CallStatusToText(aStatus)
  If cCallStatus_Failed = aStatus Then
    WScript.Echo ">Failure reason:" & oSkype.Convert.CallFailureReasonToText(aCall.FailureReason)
  End If
End Sub


Skype4COM: Chats.vbs

Chats.vbs

This script queries chats in chat history.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Query the total number of messages in history:
WScript.Echo "Total message count: " & oSkype.Messages.Count

'// Query the timestamp, name, and display name of all chats in history:
WScript.Echo  "All chats:"
For Each oChat In oSkype.Chats
  WScript.Echo  oChat.Timestamp & " " & oChat.Name & " " & oChat.FriendlyName
Next

'// Query the timestamp, name, and display name of all active chats:
WScript.Echo  "Active chats:"
For Each oChat In oSkype.ActiveChats
  WScript.Echo oChat.Timestamp & " " & oChat.Name & " " & oChat.FriendlyName
Next

'// Query the timestamp, name, and display name of all missed chats:
WScript.Echo  "Missed chats:"
For Each oChat In oSkype.MissedChats
  WScript.Echo  oChat.Timestamp & " " & oChat.Name & " " & oChat.FriendlyName
Next

'// Query the timestamp, name, and display name of all recent chats:
WScript.Echo  "Recent chats:"
For Each oChat In oSkype.RecentChats
  WScript.Echo oChat.Timestamp & " " & oChat.Name & " " & oChat.FriendlyName
Next

'// Query the timestamp, name, and display name of all bookmarked chats:
WScript.Echo "Bookmarked chats:"
For Each oChat In oSkype.BookmarkedChats
  WScript.Echo oChat.Timestamp & " " & oChat.Name & " " & oChat.FriendlyName
Next

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Chats2.vbs

Chats2.vbs

An improved chats example to illustrate new chat properties.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create Skype object
Set oSkype = CreateObject("Skype4COM.Skype")

'// Query properties of all recent chats:
WScript.Echo  "Recent chats:"
For Each oChat In oSkype.RecentChats
  displayChatProperties(oChat)
Next

'// Query properties of all bookmarked chats:
WScript.Echo "Bookmarked chats:"
For Each oChat In oSkype.BookmarkedChats
  displayChatProperties(oChat)
Next

'// Displays chat properties
Function displayChatProperties(aChat)
  WScript.Echo vbCrLf & "Label: " & aChat.FriendlyName
  WScript.Echo "Created at: " & aChat.Timestamp
  WScript.Echo "Last activity at: " & aChat.ActivityTimestamp
  WScript.Echo "Id: " & aChat.Name
  WScript.Echo "Blob: " & aChat.Blob
  WScript.Echo "Description: " & aChat.Description
  WScript.Echo "Guidelines: " & aChat.Guidelines
  WScript.Echo "My role: " & chatMemberRoleToText(aChat.MyRole)
  WScript.Echo "My status: " & chatStatusToText(aChat.MyStatus)
  WScript.Echo "Type: " & chatTypeToText(aChat.Type)
  If aChat.Type = chatTypeDialog Or aChat.Type = chatTypeLegacyDialog Then
    WScript.Echo "Dialog partner: " & aChat.DialogPartner
  End If
  If aChat.Members.Count > 0 Then
    WScript.StdOut.Write "Members:"
    For Each oMember In aChat.Members
      WScript.StdOut.Write " " & oMember.Handle
    Next
    WScript.Echo ""
  End If
  If aChat.Applicants.Count > 0 Then
    WScript.StdOut.Write "Applicants:"
    For Each oApplicant In aChat.Applicants
      WScript.StdOut.Write " " & oApplicant.Handle
    Next
    WScript.Echo ""
  End If
End Function

'// Converts chat types to plaintext
Function chatTypeToText(aType)
  Const chatTypeUnknown = -1
  Const chatTypeDialog = 0
  Const chatTypeLegacyDialog = 1
  Const chatTypeLegacyUnsubscribed = 2
  Const chatTypeMultiChat = 3
  Const chatTypeSharedGroup = 4
  Select Case aType
    Case chatTypeUnknown
      chatTypeToText = "Unknown"
    Case chatTypeDialog
      chatTypeToText = "Dialog"
    Case chatTypeLegacyDialog
      chatTypeToText = "Legacy Dialog"
    Case chatTypeLegacyUnsubscribed
      chatTypeToText = "Unsubscribed Legacy Dialog"
    Case chatTypeMultiChat
      chatTypeToText = "Multichat"
    Case chatTypeSharedGroup
      chatTypeToText = "Shared Group"
  End Select
End Function

'// Converts chat roles to plaintext
Function chatMemberRoleToText(aRole)
  Const chatMemberRoleUnknown = -1
  Const chatMemberRoleCreator = 0
  Const chatMemberRoleMaster = 1
  Const chatMemberRoleHelper = 2
  Const chatMemberRoleUser = 3
  Const chatMemberRoleListener = 4
  Const chatMemberRoleApplicant = 5
  Select Case aRole
    Case chatMemberRoleUnknown
      chatMemberRoleToText = "Unknown"
    Case chatMemberRoleCreator
      chatMemberRoleToText = "Creator"
    Case chatMemberRoleMaster
      chatMemberRoleToText = "Master"
    Case chatMemberRoleHelper
      chatMemberRoleToText = "Helper"
    Case chatMemberRoleUser
      chatMemberRoleToText = "User"
    Case chatMemberRoleListener
      chatMemberRoleToText = "Listener"
    Case chatMemberRoleApplicant
      chatMemberRoleToText = "Applicant"
  End Select
End Function

'// Converts chat status to plaintext
Function chatStatusToText(aStatus)
  Const chatStatusUnknown = -1
  Const chatStatusConnecting = 0
  Const chatStatusWaitingRemoteAccept = 1
  Const chatStatusAcceptRequired = 2
  Const chatStatusPasswordRequired = 3
  Const chatStatusSubscribed = 4
  Const chatStatusUnsubscribed = 5
  Const chatStatusDisbanded = 6
  Const chatStatusQueuedBecauseChatIsFull = 7
  Const chatStatusApplicationDenied = 8
  Const chatStatusKicked = 9
  Const chatStatusBanned = 10
  Const chatStatusRetryConnecting = 11
  Select Case aStatus
    Case chatStatusUnknown
      chatStatusToText = "Unknown"
    Case chatStatusConnecting
      chatStatusToText = "Connecting"
    Case chatStatusWaitingRemoteAccept
      chatStatusToText = "Waiting for Remote Accept"
    Case chatStatusAcceptRequired
      chatStatusToText = "Accept Required"
    Case chatStatusPasswordRequired
      chatStatusToText = "Password Required"
    Case chatStatusSubscribed
      chatStatusToText = "Subscribed"
    Case chatStatusUnsubscribed
      chatStatusToText = "Unsubscribed"
    Case chatStatusDisbanded
      chatStatusToText = "Disbanded"
    Case chatStatusQueuedBecauseChatIsFull
      chatStatusToText = "Queued"
    Case chatStatusApplicationDenied
      chatStatusToText = "Application Denied"
    Case chatStatusKicked
      chatStatusToText = "Kicked"
    Case chatStatusBanned
      chatStatusToText = "Banned"
    Case chatStatusRetryConnecting
      chatStatusToText = "Reconnecting"
  End Select
End Function


Skype4COM: Client.vbs

Client.vbs

This script opens different windows in the Skype client.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Bring the client into focus:
oSkype.Client.Focus
WScript.Sleep(1000)

'// Minimize the client to the system tooltray:
oSkype.Client.Minimize
WScript.Sleep(1000)

'// Open the Add Contacts window and enter "echo123" in the contact field:
oSkype.Client.OpenAddContactDialog "echo123"
WScript.Sleep(1000)

'// Open a Chat window with "echo123" and type "Hi" in the message pane:
oSkype.Client.OpenMessageDialog "echo123", "Hi"
WScript.Sleep(1000)

'// Transfer a file to "echo123"
'oSkype.Client.OpenFileTransferDialog "echo123", "c:\temp"
'WScript.Sleep(1000)

'// Open other windows as required, with the following commands:
oSkype.Client.OpenProfileDialog
WScript.Sleep(1000)
oSkype.Client.OpenUserInfoDialog "echo123"
WScript.Sleep(1000)
oSkype.Client.OpenConferenceDialog
WScript.Sleep(1000)
oSkype.Client.OpenSearchDialog
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("GENERAL")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("PRIVACY")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("NOTIFICATIONS")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("SOUNDALERTS")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("SOUNDDEVICES")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("HOTKEYS")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("CONNECTION")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("VOICEMAIL")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("CALLFORWARD")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("VIDEO")
WScript.Sleep(1000)
oSkype.Client.OpenOptionsDialog("ADVANCED")
WScript.Sleep(1000)
oSkype.Client.OpenCallHistoryTab
WScript.Sleep(1000)
oSkype.Client.OpenContactsTab
WScript.Sleep(1000)
oSkype.Client.OpenDialpadTab
WScript.Sleep(1000)
oSkype.Client.OpenLiveTab
WScript.Sleep(1000)
oSkype.Client.OpenSendContactsDialog "echo123"
WScript.Sleep(1000)
oSkype.Client.OpenBlockedUsersDialog
WScript.Sleep(1000)
oSkype.Client.OpenImportContactsWizard
WScript.Sleep(1000)
oSkype.Client.OpenGettingStartedWizard
WScript.Sleep(1000)
oSkype.Client.OpenAuthorizationDialog "echo123"
WScript.Sleep(1000)
oSkype.Client.OpenVideoTestDialog
WScript.Sleep(1000)

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Command.vbs

Command.vbs

This script sends blocking and non-blocking commands to the Skype API.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Connect to the Skype API:
oSkype.Attach

'// Skype4COM can send two types of command; blocking commands and non-blocking commands. Blocking is defined as a Boolean variant of the command object and the default value is False, non-blocking. A blocking command awaits a reply before continuing. A non-blocking command does not require a reply.

'// Send the following non-blocking commands:
oSkype.SendCommand(oSkype.Command(0, "FOCUS"))
oSkype.SendCommand(oSkype.Command(1, "GET AUDIO_IN", "AUDIO_IN"))
oSkype.SendCommand(oSkype.Command(2, "GET AUDIO_OUT", "AUDIO_OUT"))
WScript.Sleep(1000)

'// Send the following blocking commands (note the True (blocking) variant for each command):
oSkype.SendCommand(oSkype.Command(3, "GET CURRENTUSERHANDLE", "CURRENTUSERHANDLE", True))
oSkype.SendCommand(oSkype.Command(4, "GET USER echo123 FULLNAME", "USER echo123 FULLNAME", True))
oSkype.SendCommand(oSkype.Command(5, "GET USER echo123 DISPLAYNAME", "USER echo123 DISPLAYNAME", True))
oSkype.SendCommand(oSkype.Command(6, "GET USER echo123 COUNTRY", "USER echo123 COUNTRY", True))
WScript.Sleep(1000)

'//As with command objects, search commands can be defined as blocking or non-blocking, and the default value is False, non-blocking. A blocking search requires a response before activities continue. Following is a blocking search (note the True (blocking) variant:
Set oBlockingSearch = oSkype.Command(8888, "SEARCH USERS echo123", "USERS ", True)
oSkype.SendCommand(oBlockingSearch)
WScript.Echo "Search Result:" & oBlockingSearch.Reply

'//A non-blocking search does not require a response:
Set oSearchCommand = oSkype.Command(9999, "SEARCH USERS john doe", "USERS ")
oSkype.SendCommand(oSearchCommand)

WScript.Echo "Sleeping ..."
WScript.Sleep(30000)

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub

'// The reply event handler monitors the non-blocking search results:
Public Sub Skype_Reply(ByRef aCmd)
  If IsObject(oSearchCommand) Then
    If oSearchCommand.Id = aCmd.Id Then WScript.Echo "Search Finished!" End If
  End If
End Sub


Skype4COM: Conference.vbs

Conference.vbs

This script creates a conference call.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// The PlaceCall command will fail if the user is offline. To avoid failure, check user status and change to online if necessary:
If oSkype.Convert.TextToUserStatus("OFFLINE") = oSkype.CurrentUserStatus Then
  oSkype.ChangeUserStatus(oSkype.Convert.TextToUserStatus("ONLINE"))
End If

'// To create a conference call, use the PlaceCall command and add multiple users to the list of targets (to the maximum number of conference users supported by the OS environment):
Set oFirstCall = oSkype.PlaceCall("skypeuser1", "skypeuser2")
WScript.Sleep(30000)

'// The AttachmentStatus monitors and returns call status:
Public Sub Skype_CallStatus(ByRef aCall, ByVal aStatus)
  WScript.Echo ">Call " & aCall.Id & " status " & aStatus & " " & oSkype.Convert.CallStatusToText(aStatus)
End Sub

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Conferences.vbs

Conferences.vbs

This script lists conference calls hosted by a user, and lists participants in conference calls not hosted by a user.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Count conference calls hosted by the current user. A conference call hosted by the current user is represented by multiple call objects which have a common conference ID (conf_id). For each conference object,  return the conf_id, the number of calls, and the number of active calls:
WScript.Echo "There are " & oSkype.Conferences.Count & " conference calls hosted by " & oSkype.CurrentUser.Handle
For Each oConf In oSkype.Conferences
  WScript.Echo "Conference " & oConf.Id & " includes " & oConf.Calls.Count & " calls from which " & oConf.ActiveCalls.Count & " are active."
Next

'//  To list conference calls in which the current user is active but not the host, begin by listing active calls for a user:
WScript.Echo "There are total " & oSkype.ActiveCalls.Count & " active calls."

'//Conference calls not hosted by the current user are all calls which have one or more participants (participants do not include the current user or the conference host). For each active call, return the Skypename and display name of each participant:
For Each oCall In oSkype.ActiveCalls

  If oCall.Participants.Count > 0 Then
    WScript.Echo "Conference call " & oCall.Id & " with " & oCall.PartnerHandle & " has " & oCall.Participants.Count & " participants."

    For Each oParticipant In oCall.Participants
      WScript.Echo "Participant " & oParticipant.Handle & " display name is " & oParticipant.DisplayName
    Next
  Else
    WScript.Echo "Active call " & oCall.Id & " with " & oCall.PartnerHandle & " is not a conference call."
  End If
Next

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: FileTransfers.vbs

FileTransfers.vbs

This script lists file transfers.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

For Each oTransfer In oSkype.FileTransfers
  FTDetails(oTransfer)
Next

For Each oTransfer In oSkype.ActiveFileTransfers
  FTDetails(oTransfer)
Next

WScript.Sleep(30000)

Public Sub Skype_FileTransferStatusChanged(ByRef aTransfer, ByVal aStatus)
  WScript.Echo  ">File Transfer " & aTransfer.Id & " status " & FTStatusToText(aStatus)
End Sub

Sub FTDetails(aTransfer)
  WScript.Echo "Id:" & aTransfer.Id & " start:" & aTransfer.StartTime & " end:" & aTransfer.FinishTime
  WScript.Echo " Type:" & FTTypeToText(aTransfer.Type)
  WScript.Echo " Status:" & FTStatusToText(aTransfer.Status)
  WScript.Echo " Partner:" & aTransfer.PartnerHandle & "(" & aTransfer.PartnerDisplayName & ")"
  WScript.Echo " File:" & aTransfer.FilePath
  WScript.Echo " Bytes Transferred:" & aTransfer.BytesTransferred & " bytes"
  WScript.Echo " Transfer Speed:" & aTransfer.BytesPerSecond & " bytes/sec"
  WScript.Echo " Failure Reason:" & FTFailureReasonToText(aTransfer.FailureReason)
End Sub

Function FTTypeToText(aType)

  Const fileTransferTypeIncoming=0
  Const fileTransferTypeOutgoing=1

  Select Case aType
    Case fileTransferTypeIncoming
      FTTypeToText = "Incoming"
    Case fileTransferTypeOutgoing
      FTTypeToText = "Outgoing"
  End Select

End Function

Function FTStatusToText(aStatus)

  Const fileTransferStatusNew = 0
  Const fileTransferStatusConnecting = 1
  Const fileTransferStatusWaitingForAccept = 2
  Const fileTransferStatusTransferring = 3
  Const fileTransferStatusTransferringOverRelay = 4
  Const fileTransferStatusPaused = 5
  Const fileTransferStatusRemotelyPaused = 6
  Const fileTransferStatusCancelled = 7
  Const fileTransferStatusCompleted = 8
  Const fileTransferStatusFailed = 9

  Select Case aStatus
    Case fileTransferStatusNew
      FTStatusToText = "New"
    Case fileTransferStatusConnecting
      FTStatusToText = "Connecting"
    Case fileTransferStatusWaitingForAccept
      FTStatusToText = "Waiting for Accept"
    Case fileTransferStatusTransferring
      FTStatusToText = "Transferring"
    Case fileTransferStatusTransferringOverRelay
      FTStatusToText = "Transferring over Relay"
    Case fileTransferStatusPaused
      FTStatusToText = "Paused"
    Case fileTransferStatusRemotelyPaused
      FTStatusToText = "Remotely Paused"
    Case fileTransferStatusCancelled
      FTStatusToText = "Cancelled"
    Case fileTransferStatusCompleted
      FTStatusToText = "Completed"
    Case fileTransferStatusFailed
      FTStatusToText = "Failed"
  End Select

End Function

Function FTFailureReasonToText(aReason)

  Const fileTransferFailureReasonSenderNotAuthorized= 1
  Const fileTransferFailureReasonRemotelyCancelled= 2
  Const fileTransferFailureReasonFailedRead = 3
  Const fileTransferFailureReasonFailedRemoteRead = 4
  Const fileTransferFailureReasonFailedWrite = 5
  Const fileTransferFailureReasonFailedRemoteWrite = 6
  Const fileTransferFailureReasonRemoteDoesNotSupportFT = 7
  Const fileTransferFailureReasonRemoteOfflineTooLong = 8

  Select Case aReason
    Case fileTransferFailureReasonSenderNotAuthorized
      FTFailureReasonToText = "Sender Not Authorized"
    Case fileTransferFailureReasonRemotelyCancelled
      FTFailureReasonToText = "Remotely Cancelled"
    Case fileTransferFailureReasonFailedRead
      FTFailureReasonToText = "Failed Read"
    Case fileTransferFailureReasonFailedRemoteRead
      FTFailureReasonToText = "Remote Read"
    Case fileTransferFailureReasonFailedWrite
      FTFailureReasonToText = "Write"
    Case fileTransferFailureReasonFailedRemoteWrite
      FTFailureReasonToText = "Remote Write"
    Case fileTransferFailureReasonRemoteDoesNotSupportFT
      FTFailureReasonToText = "Remote Does Not Support FT"
    Case fileTransferFailureReasonRemoteOfflineTooLong
      FTFailureReasonToText = "Remote Offline Too Long"

  End Select

End Function


Skype4COM: Groupchat.vbs

Groupchat.vbs

This script creates a group chat.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Create a UserCollection object and add the multichat users to this collection:
Set oMembers = CreateObject("Skype4COM.UserCollection")
oMembers.Add(oSkype.User("skypeuser2"))
oMembers.Add(oSkype.User("skypeuser3"))

'// Create a multichat:
Set oChat = oSkype.CreateChatMultiple(oMembers)

'// Open a chat window:
oChat.OpenWindow

'// Set a chat topic:
oChat.Topic = "Skype is cool"

'// Send a chat message:
Set oMsg = oChat.SendMessage("Greetings!")

'// Leave a chat:
oChat.Leave

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Groups.vbs

Groups.vbs

This script manages various aspects of contact groups.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Create a custom group:
Set oMyGroup = oSkype.CreateGroup("MyGroup")

'// Add user "echo123" to the group:
oMyGroup.AddUser "echo123"

'// List the users in MyGroup and return the Skypename of each user:
WScript.Echo "Group ("& oMyGroup.Id &") labelled ["& oMyGroup.DisplayName &"] has " & oMyGroup.Users.Count & " users."
For Each oUser In oMyGroup.Users
  WScript.Echo oUser.Handle & " ("& oUser.FullName &")"
Next

'// Remove a user from a group:
oMyGroup.RemoveUser "echo123"

'// Delete a custom group:
oSkype.DeleteGroup oMyGroup.Id

'// List all groups:
WScript.Echo "There are total " & oSkype.Groups.Count & " groups (" &_
oSkype.CustomGroups.Count & " custom and " & oSkype.HardwiredGroups.Count & " hardwired)" & vbCrLf

'// List all custom groups:
WScript.Echo "Custom groups are:"& vbCrLf
For Each oGroup In oSkype.CustomGroups
  WScript.Echo "Group ("& oGroup.Id &") labelled ["& oGroup.DisplayName &"] has " & oGroup.Users.Count & " users."
  For Each oUser In oGroup.Users
    WScript.Echo oUser.Handle & " ("& oUser.FullName &")"
  Next
  WScript.Echo ""
Next

'// List all hardwired groups and return the Skypename and full name of each member of each group:
WScript.Echo "Hardwired groups are:"& vbCrLf
For Each oGroup In oSkype.HardwiredGroups
  WScript.Echo "Group ("& oGroup.Id &") type of ["& oSkype.Convert.GroupTypeToText(oGroup.Type) &"] has " & oGroup.Users.Count & " users."
  For Each oUser In oGroup.Users
    WScript.Echo oUser.Handle & " ("& oUser.FullName &")"
  Next
  WScript.Echo ""
Next

'// Keep the script running for 60 seconds:
WScript.Sleep(60000)

'// The GroupVisible event handler returns information about whether a group is visible or hidden:
Public Sub Skype_GroupVisible(ByRef aGroup, ByVal aVisible)
  WScript.StdOut.Write "Group ("& aGroup.Id &") type of ["& oSkype.Convert.GroupTypeToText(aGroup.Type) &"] labelled ["& aGroup.DisplayName &"]"
  If aVisible Then
    WScript.Echo " is visible."
  Else
    WScript.Echo " is hidden."
  End If
End Sub

'// The GroupExpanded event handler returns information about whether a group is expanded or collapsed:
Public Sub Skype_GroupExpanded(ByRef aGroup, ByVal aExpanded)
  WScript.StdOut.Write "Group ("& aGroup.Id &") type of ["& oSkype.Convert.GroupTypeToText(aGroup.Type) &"] labelled ["& aGroup.DisplayName &"]"
  If aExpanded Then
    WScript.Echo " is expanded."
  Else
    WScript.Echo " is collapsed."
  End If
End Sub

'// The GroupUsers event handler gets the Skypenames of members of a group:
Public Sub Skype_GroupUsers(ByRef aGroup, ByRef aUsers)
  WScript.StdOut.Write "Group ("& aGroup.Id &") type of ["& oSkype.Convert.GroupTypeToText(aGroup.Type) &"] labelled ["& aGroup.DisplayName &"] users"
  Dim oUser
  For Each oUser In aUsers
    WScript.Stdout.Write " " & oUser.Handle
  Next
  WScript.Echo ""
End Sub

'// Delete a group:
Public Sub Skype_GroupDeleted(ByRef aGroupId)
  WScript.Echo "Group " & aGroupId & " deleted."
End Sub

'// Bring a contact into focus:
Public Sub Skype_ContactsFocused(ByVal aHandle)
  If Len(aHandle) Then
    WScript.Echo "Contact " & aHandle & " focused."
  Else
    WScript.Echo "No contact focused."
  End If
End Sub

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Join.vbs

Join.vbs

This script joins callers to form a conference call.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Declare the following Skype constants:
cUserStatus_Offline = oSkype.Convert.TextToUserStatus("OFFLINE")
cUserStatus_Online = oSkype.Convert.TextToUserStatus("ONLINE")
cCallStatus_Ringing = oSkype.Convert.TextToCallStatus("RINGING")
cCallStatus_Inprogress = oSkype.Convert.TextToCallStatus("INPROGRESS")
cCallStatus_Failed = oSkype.Convert.TextToCallStatus("FAILED")
cCallStatus_Refused = oSkype.Convert.TextToCallStatus("REFUSED")
cCallStatus_Cancelled = oSkype.Convert.TextToCallStatus("CANCELLED")
cCallStatus_Finished = oSkype.Convert.TextToCallStatus("FINISHED")
cCallStatus_Busy = oSkype.Convert.TextToCallStatus("BUSY")
cCallStatus_LocalHold = oSkype.Convert.TextToCallStatus("LOCALHOLD")

'// The PlaceCall command will fail if the user is offline. To avoid failure, check user status and change to online if necessary:
If cUserStatus_Offline = oSkype.CurrentUserStatus Then oSkype.ChangeUserStatus(cUserStatus_Online) End If

'// Place a call (the first of more than one):
Set oCall1 = oSkype.PlaceCall("skypeuser1")
WaitForCallStatus oCall1, cCallStatus_Inprogress

'// Put the first call on hold:
oCall1.Hold
WaitForCallStatus oCall1, cCallStatus_LocalHold

'// Place the second call:
Set oCall2 = oSkype.PlaceCall("skypeuser2")
WaitForCallStatus oCall2, cCallStatus_Inprogress

'// Join these two calls to a conference:
WScript.Echo "Join call " & oCall2.Id & " to call " & oCall1.Id
oCall2.Join oCall1.Id

WScript.Sleep(60000)

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub

'// The CallStatus event handler monitors call status and returns status changes as text:
Public Sub Skype_CallStatus(ByRef oCall, ByVal Status)
  WScript.Echo ">Call " & oCall.Id & " status " & Status & " " & oSkype.Convert.CallStatusToText(Status)
End Sub

'// Waits for call status to change:
Public Sub WaitForCallStatus(ByRef aCall, ByVal aStatus)
  Do While aCall.Status <> aStatus
    If aCall.Status = cCallStatus_Failed Or _
      aCall.Status = cCallStatus_Refused Or _
      aCall.Status = cCallStatus_Cancelled Or _
      aCall.Status = cCallStatus_Finished Or _
      aCall.Status = cCallStatus_Busy Then
      Err.Raise vbObjectError + 1, "", "Call " & _
        aCall.Id & " " & oSkype.Convert.CallStatusToText(aCall.Status)
    End If
    WScript.Sleep(500)
  Loop
End Sub


Skype4COM: MessageStatus.js

MessageStatus.js

This script logs chat text messages.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

// Create a Skype4COM object:
var oSkype = new ActiveXObject("Skype4COM.Skype");

// Connect events:
WScript.ConnectObject(oSkype, "Skype_");

// Connect to Skype API:
oSkype.Attach();

// Loop and sleep:
while (true) {
  WScript.Sleep(1000);
}

// Chat message status events:
function Skype_MessageStatus(aMsg, aStatus)
{
  if ((aStatus == oSkype.Convert.TextToChatMessageStatus("RECEIVED") ||
       aStatus == oSkype.Convert.TextToChatMessageStatus("SENT")) &&
       aMsg.Type == oSkype.Convert.TextToChatMessageType("SAID")) {

    WScript.Echo(">Message " + aMsg.Id + " " + aMsg.FromHandle + " said " + aMsg.Body);
  }
}


Skype4COM: MessageStatus.vbs

MessageStatus.vbs

This script logs chat text messages.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = CreateObject("Skype4COM.Skype")

'// Connect events:
WScript.ConnectObject oSkype, "Skype_"

'// Connect to Skype API:
oSkype.Attach

'// Loop and sleep:
Do While True
  WScript.Sleep(60000)
Loop

'// Chat message status events:
Public Sub Skype_MessageStatus(ByRef aMsg, ByVal aStatus)

  If (aStatus = oSkype.Convert.TextToChatMessageStatus("RECEIVED") Or _
      aStatus = oSkype.Convert.TextToChatMessageStatus("SENT")) And _
      aMsg.Type = oSkype.Convert.TextToChatMessageType("SAID") Then

      WScript.Echo ">Message " & aMsg.Id & " " & aMsg.FromHandle & " said " & aMsg.Body
  End If

End Sub


Skype4COM: MissedMessages.js

MissedMessages.js

This script list all missed messages and changes message status to "Read".

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

// Create a Skype4COM object:
var oSkype = new ActiveXObject("Skype4COM.Skype");

// Query the total number of missed messages:
WScript.Echo("Total missed message count: " + oSkype.MissedMessages.Count);

// Query the id, timestamp, and sender Skypename of the message:
for (var i=0; i < oSkype.MissedMessages.Count; i++)
{
  var oMsg = oSkype.MissedMessages.Item(i+1);
  WScript.Echo("Msg id: " + oMsg.Id + " at " + oMsg.Timestamp + " from " + oMsg.FromHandle);
}
// Mark the missed message as "Read"
for (var i=0; i < oSkype.MissedMessages.Count; i++)
{
  var oMsg = oSkype.MissedMessages.Item(i+1);
  oMsg.Seen = true;
}


Skype4COM: MissedMessages.vbs

MissedMessages.vbs

This script list all missed messages and changes message status to "Read".

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Query the total number of missed messages:
WScript.Echo "Total missed message count: " & oSkype.MissedMessages.Count

'// Query the id, timestamp, and sender Skypename of the message:
For Each oMsg In oSkype.MissedMessages
  WScript.Echo "Msg id: " & oMsg.Id & " at " & oMsg.Timestamp & " from " & oMsg.FromHandle
Next

'// Mark the missed message as "Read"
For Each oMsg In oSkype.MissedMessages
  oMsg.Seen = True
Next


Skype4COM: Plugins.vbs

Plugins.vbs

This script demos how to create plugin menu items and events.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

const pluginContextChat = 0
const pluginContextCall = 1
const pluginContextContact = 2
const pluginContextMyself = 3
const pluginContextTools = 4

const pluginContactTypeUndefined = -1
const pluginContactTypeAll = 0
const pluginContactTypeSkype = 1
const pluginContactTypeSkypeOut= 2

const pluginIconPath = "c:\temp\icon.png"

Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

Set oMenu1 = oSkype.Client.CreateMenuItem("menu1", pluginContextContact, ""&_
  "Single Contact of Any Type", "Plugin that does cool stuff for single contact of any type", pluginIconPath, True, pluginContactTypeAll)

Set oMenu2 = oSkype.Client.CreateMenuItem("menu2", pluginContextContact, ""&_
  "Single Skype Contact", "Plugin that does cool stuff for single Skype contact", pluginIconPath, True, pluginContactTypeSkype, False)

Set oMenu3 = oSkype.Client.CreateMenuItem("menu3", pluginContextContact, ""&_
  "Multiple Skype Contacts", "Plugin that does cool stuff for multple contacts", pluginIconPath, True, pluginContactTypeSkype, True)

Set oMenu4 = oSkype.Client.CreateMenuItem("menu4", pluginContextContact, ""&_
  "Single SkypeOut Contact", "Plugin that does cool stuff for a single SkypeOut contact", pluginIconPath, True, pluginContactTypeSkypeOut, False)

Set oMenu5 = oSkype.Client.CreateMenuItem("menu5", pluginContextContact, ""&_
  "Multiple SkypeOut Contacts", "Plugin that does cool stuff for a one or more SkypeOut contacts", pluginIconPath, True, pluginContactTypeSkypeOut, True)

Set oMenu6 = oSkype.Client.CreateMenuItem("menu6", pluginContextCall, ""&_
  "Single Participant Call", "Plugin that does cool stuff in a call", pluginIconPath, True, pluginContactTypeUndefined, False)

Set oMenu7 = oSkype.Client.CreateMenuItem("menu7", pluginContextCall, ""&_
  "Multiple Participants Call", "Plugin that does cool stuff in a conference call", pluginIconPath, True, pluginContactTypeUndefined, True)

Set oMenu8 = oSkype.Client.CreateMenuItem("menu8", pluginContextChat, ""&_
  "Single Chat Member", "Plugin that does cool stuff for one-to-one chat", pluginIconPath, True, pluginContactTypeUndefined, False)

Set oMenu9 = oSkype.Client.CreateMenuItem("menu9", pluginContextChat, ""&_
  "Multiple Chat Members", "Plugin that does cool stuff in group chat", pluginIconPath, True, pluginContactTypeUndefined, True)

Set oMenu10 = oSkype.Client.CreateMenuItem("menu10", pluginContextTools, ""&_
  "Tools plugin", "Plugin that does cool stuff in tools menu", pluginIconPath, True, pluginContactTypeUndefined, False)

Set oEvent = oSkype.Client.CreateEvent("event1","Plugin example is running","Click here to stop the example")
Do While Not bEventClicked
  WScript.Sleep(1000)
Loop
oEvent.Delete
oMenu1.Delete
oMenu2.Delete
oMenu3.Delete
oMenu4.Delete
oMenu5.Delete
oMenu6.Delete
oMenu7.Delete
oMenu8.Delete
oMenu9.Delete
oMenu10.Delete

Public Sub Skype_PluginEventClicked(ByVal aEvent)
  WScript.Echo ">Event "& aEvent.Id &" clicked."
  bEventClicked = True
End Sub

Public Sub Skype_PluginMenuItemClicked(ByRef aMenuItem, ByRef aUsers, ByVal aPluginContext, ByVal aContextId)
  WScript.Echo ">Menu item ["& aMenuItem.Id &"] context [" & pluginContextToText(aPluginContext) & "] id ["& aContextId &"] clicked."
  For Each oUser In aUsers
    WScript.Echo " User: "& oUser.FullName &" (" & oUser.Handle &")"
  Next
End Sub

Function pluginContextToText (context)
   Select Case context
   Case pluginContextChat
      pluginContextToText = "Chat"
   Case pluginContextCall
      pluginContextToText = "Call"
   Case pluginContextContact
      pluginContextToText = "Contact"
   Case pluginContextMyself
      pluginContextToText = "Myself"
   Case pluginContextTools
      pluginContextToText = "Tools"
   End Select
End Function


Skype4COM: Profile.vbs

Profile.vbs

This script lists the profile properties for the current user.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// List the profile properties for the user:
WScript.Echo "Full name: " & oSkype.CurrentUserProfile.FullName
WScript.Echo "Birthday: " & oSkype.CurrentUserProfile.Birthday
WScript.Echo "Sex: " & oSkype.CurrentUserProfile.Sex
WScript.Echo "Languages: " & oSkype.CurrentUserProfile.Languages
WScript.Echo "Country: " & oSkype.CurrentUserProfile.Country
WScript.Echo "IP Country: " & oSkype.CurrentUserProfile.IPCountry
WScript.Echo "Province: " & oSkype.CurrentUserProfile.Province
WScript.Echo "City: " & oSkype.CurrentUserProfile.City
WScript.Echo "Phone home: " & oSkype.CurrentUserProfile.PhoneHome
WScript.Echo "Phone office: " & oSkype.CurrentUserProfile.PhoneOffice
WScript.Echo "Phone mobile: " & oSkype.CurrentUserProfile.PhoneMobile
WScript.Echo "Homepage: " & oSkype.CurrentUserProfile.Homepage
WScript.Echo "About: " & oSkype.CurrentUserProfile.About
WScript.Echo "Mood: " & oSkype.CurrentUserProfile.MoodText
WScript.Echo "Timezone: " & oSkype.CurrentUserProfile.Timezone
WScript.Echo "Noanswer timeout: " & oSkype.CurrentUserProfile.CallNoAnswerTimeout
WScript.Echo "Forward rules: " & oSkype.CurrentUserProfile.CallForwardRules
WScript.Echo "Call apply forward: " & oSkype.CurrentUserProfile.CallApplyCF
WScript.Echo "Call send to voicemail: " & oSkype.CurrentUserProfile.CallSendToVM
WScript.Echo "Balance: " & oSkype.CurrentUserProfile.Balance / 100 &" "& oSkype.CurrentUserProfile.BalanceCurrency
WScript.Echo "Balance Text: " & oSkype.CurrentUserProfile.BalanceToText
WScript.Echo "Validated SMS numbers: " & oSkype.CurrentUserProfile.ValidatedSmsNumbers

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Response.vbs

Response.vbs

This script provides a response to a message received in a chat.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Declare the following Skype constants:
cAttachmentStatus_Available = oSkype.Convert.TextToAttachmentStatus("AVAILABLE")
cMessageStatus_Sending = oSkype.Convert.TextToChatMessageStatus("SENDING")
cMessageStatus_Received = oSkype.Convert.TextToChatMessageStatus("RECEIVED")
cMessageType_Said = oSkype.Convert.TextToChatMessageType("SAID")
cMessageType_Left = oSkype.Convert.TextToChatMessageType("LEFT")

'// The SendMessage command will fail if the user is offline. To avoid failure, check user status and change to online if necessary:
If cUserStatus_Offline = oSkype.CurrentUserStatus Then oSkype.ChangeUserStatus(cUserStatus_Online) End If

'// Sleep
Do While True
  WScript.Sleep(60000)
Loop

'// The AttachmentStatus event handler monitors attachment status and attempts to connect to the Skype API:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo  ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = cAttachmentStatus_Available Then oSkype.Attach() End If
End Sub

'// The MessageStatus event handler monitors message status, decodes received messages and, for those of type "Said", sends an autoresponse quoting the original message:
Public Sub Skype_MessageStatus(ByRef aMsg, ByVal aStatus)
  WScript.Echo ">Message " & aMsg.Id & " status " & oSkype.Convert.ChatMessageStatusToText(aStatus)
  If aStatus = cMessageStatus_Received Then
    DecodeMsg aMsg
    If aMsg.Type = cMessageType_Said Then
     'oSkype.SendMessage aMsg.FromHandle, "This is autoresponse."
      aMsg.Chat.SendMessage "You said [" & aMsg.Body & "]"
    End If
  End If
End Sub

'// The DecodeMsg event handler decodes messages in a chat and converts leave reasons to text for messages of type "Left":
Public Sub DecodeMsg(ByRef oMsg)
  sText = oMsg.FromHandle & " " & oSkype.Convert.ChatMessageTypeToText(oMsg.Type) & ":"
  If len(oMsg.Body) Then
    sText = sText & " " & oMsg.Body
  End If
  Dim oUser
  For Each oUser In oMsg.Users
    sText = sText & " " & oUser.Handle
  Next
  If oMsg.Type = cMessageType_Left Then
    sText = sText & " " & oSkype.Convert.ChatLeaveReasonToText(oMsg.LeaveReason)
  End If
  WScript.Echo ">" & sText
End Sub


Skype4COM: Search.vbs

Search.vbs

This script performs a simple search for a user.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Search for users John Doe and return the Skypname, full name and country of each matching user:
Set oUsers = oSkype.SearchForUsers("john doe")
For Each oUser In oUsers
  WScript.Echo oUser.Handle &" "& oUser.Fullname &" "& oUser.Country
Next

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Settings.vbs

Settings.vbs

This script queries the Skype general parameters.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype","Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Query Skype general parameters:
WScript.Echo "Audio in:" & oSkype.Settings.AudioIn
WScript.Echo "Audio out:" & oSkype.Settings.AudioOut
WScript.Echo "Auto away:" & oSkype.Settings.AutoAway
WScript.Echo "Ringer:" & oSkype.Settings.Ringer
'oSkype.Settings.Avatar = "c:\temp\test.jpg"
WScript.Echo "Ringtone status:" & oSkype.Settings.RingToneStatus
'oSkype.Settings.RingTone = "c:\temp\test.mp3"
WScript.Echo "Video in:" & oSkype.Settings.VideoIn
WScript.Echo "PC speaker:" & oSkype.Settings.PCSpeaker
WScript.Echo "AGC:" & oSkype.Settings.AGC
WScript.Echo "AEC:" & oSkype.Settings.AEC
'oSkype.Settings.Language = "en"
WScript.Echo "Language:" & oSkype.Settings.Language

'// The language change event
Public Sub Skype_UILanguageChanged(ByVal aCode)
  WScript.Echo ">Language changed to " & aCode
End Sub

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = oSkype.Convert.TextToAttachmentStatus("AVAILABLE") Then oSkype.Attach() End If
End Sub


Skype4COM: Sms.vbs

Sms.vbs

This script sends a SMS message.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// Send SMS:
Set oSMS = oSkype.SendSms("+1234567890", "Hello!")

WScript.Sleep(60000)

'// Message event handler:
Public Sub Skype_SmsMessageStatusChanged(ByRef aSms, ByVal aStatus)
  WScript.Echo  ">Sms " & aSms.Id & " status " & aStatus & " " & oSkype.Convert.SmsMessageStatusToText(aStatus)
End Sub

'// Target event handler:
Public Sub Skype_SmsTargetStatusChanged(ByRef aTarget, ByVal aStatus)
  WScript.Echo  ">Sms " & aTarget.Message.Id & " target " & aTarget.Number & " status " & aStatus & " " & oSkype.Convert.SmsTargetStatusToText(aStatus)
End Sub


Skype4COM: Smss.vbs

Smss.vbs

This script lists all SMS messages.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create a Skype4COM object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Start the Skype client:
If Not oSkype.Client.IsRunning Then oSkype.Client.Start() End If

'// List Smss
For Each oSms In oSkype.Smss
  WScript.Echo "Sms Id: " & oSms.Id & " time " & oSms.Timestamp
  WScript.Echo "  type: " & oSms.Type & " " & oSkype.Convert.SmsMessageTypeToText(oSms.Type)
  WScript.Echo "  status: " & oSms.Status & " " & oSkype.Convert.SmsMessageStatusToText(oSms.Status)
  WScript.Echo "  failure reason: " & oSms.FailureReason
  WScript.Echo "  failed unseen: " & oSms.IsFailedUnseen
  WScript.Echo "  price: " & oSms.Price
  WScript.Echo "  price precision: " & oSms.PricePrecision
  WScript.Echo "  price currency: " & oSms.PriceCurrency
  WScript.Echo "  reply to number: " & oSms.ReplyToNumber
  For Each oTarget In oSms.Targets
    WScript.Echo "  target: " & oTarget.Number & " status: " & oSkype.Convert.SmsTargetStatusToText(oTarget.Status)
  Next
  WScript.Echo "  body: [" & oSms.Body & "]"
  For Each oChunk In oSms.Chunks
    WScript.Echo "  chunk: " & oChunk.Id & " [" & oChunk.Text & "]"
  Next
Next


Skype4COM: VoicemailServer.cs

VoicemailServer.cs

This script listens for new voicemails, sends SMS message and answers incoming calls.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

using System;
using System.Collections.Generic;
using System.Text;
using SKYPE4COMLib;

namespace ConsoleApplication1
{
    class VoicemailServer
    {
        [MTAThread]
        static void Main(string[] args)
        {
            oSkype.CallStatus += Skype_CallStatus;
            oSkype.VoicemailStatus += Skype_VoicemailStatus;
            oSkype.Attach(5, true);
            while (true){
                System.Threading.Thread.Sleep(1000);
            }
        }
        static void Skype_CallStatus(Call call, TCallStatus status)
        {
            Console.WriteLine(">Call " + call.Id + " status: " + oConvert.CallStatusToText(status));
            if (status == TCallStatus.clsRinging && (call.Type == TCallType.cltIncomingP2P || call.Type == TCallType.cltIncomingPSTN)) {
                if (call.PartnerHandle == sMyMobileNumber) {
                    call.Answer();
                    foreach (Voicemail oVoicemail in oSkype.Voicemails) {
                        if (oVoicemail.Status == TVoicemailStatus.vmsUnplayed) {
                            oVoicemail.StartPlaybackInCall();
                            while (oVoicemail.Status != TVoicemailStatus.vmsPlayed) {
                                System.Threading.Thread.Sleep(1000);
                            }
                            oVoicemail.SetUnplayed();
                        }
                    }
                }
                if (call.Status == TCallStatus.clsInProgress) {
                    call.Finish();
                }
            }
        }
        static void Skype_VoicemailStatus(Voicemail voicemail, TVoicemailStatus status)
        {
            Console.WriteLine(">Voicemail status: " + oConvert.VoicemailStatusToText(status));
            if (status == TVoicemailStatus.vmsDownloading) {
                Console.WriteLine("Sending SMS to " + sMyMobileNumber);
                SmsMessage oMessage = oSkype.SendSms(sMyMobileNumber, "You have new voicemail from " + voicemail.PartnerDisplayName, "");
            }
        }
        static Skype oSkype = new Skype();
        static Conversion oConvert = new Conversion();
        static String sMyMobileNumber = "+1234567890";
    }
}


Skype4COM: VoicemailServer.vbs

VoicemailServer.vbs

This script listens for new voicemails, sends SMS message and answers incoming calls.

Copyright © 2004-2006 Skype Limited. Licensed under BSD license.

'// Create Skype object:
Set oSkype = WScript.CreateObject("Skype4COM.Skype", "Skype_")

'// Connect to Skype API:
oSkype.Attach

'// The mobile number used in this example
Const cMyMobileNumber = "+1234567890"

'// Skype constants
cCallStatusRinging = oSkype.Convert.TextToCallStatus("RINGING")
cCallStatusInprogress = oSkype.Convert.TextToCallStatus("INPROGRESS")
cCallTypeIncomingP2P = oSkype.Convert.TextToCallType("INCOMING_P2P")
cCallTypeIncomingPSTN = oSkype.Convert.TextToCallType("INCOMING_PSTN")
cVoicemailStatusUnplayed = oSkype.Convert.TextToVoicemailStatus("UNPLAYED")
cVoicemailStatusPlayed = oSkype.Convert.TextToVoicemailStatus("PLAYED")
cAttachmentStatus_Available = oSkype.Convert.TextToAttachmentStatus("AVAILABLE")

'// This script runs forever
Do While True
  WScript.Sleep(30000)
Loop

'// The CallStatus event handler monitors call status and if the status is "ringing" and it is an incoming call, answers the call:
Public Sub Skype_CallStatus(ByRef aCall, ByVal aStatus)
  WScript.Echo  ">Call " & aCall.Id & " status " & aStatus & " " & oSkype.Convert.CallStatusToText(aStatus)
  If cCallStatusRinging = aStatus And _
    (cCallTypeIncomingP2P = aCall.Type Or cCallTypeIncomingPSTN = aCall.Type) Then

     '// Accept incoming call only from predefined phone number or Skypename:
     If aCall.PartnerHandle = cMyMobileNumber Then
       aCall.Answer()
       For Each oVoicemail In oSkype.Voicemails
         If oVoicemail.Status = cVoicemailStatusUnplayed Then
           oVoicemail.StartPlaybackInCall
           Do While oVoicemail.Status <> cVoicemailStatusPlayed
             WScript.Sleep(1000)
           Loop
           '// Change the voicemail status back to "unplayed"
           oVoicemail.SetUnplayed
         End If
       Next
       If cCallStatusInprogress = aCall.Status Then aCall.Finish() End If
     End If
  End If
End Sub

'// The VoicemailStatus event handler monitors voicemail status changes:
Public Sub Skype_VoicemailStatus(aVoicemail, aStatus)
  WScript.Echo ">Voicemail " & aVoicemail.Id & " status " & oSkype.Convert.VoicemailStatusToText(aStatus)
  If cVoicemailStatusDownloading = aStatus Then
    WScript.Echo "Sending SMS to " & cMyMobileNumber
    Set oSms = oSkype.SendSms(cMyMobileNumber, "You have new voicemail from " & aVoicemail.PartnerDisplayName)
  End If
End Sub

'// The AttachmentStatus event handler monitors attachment status and automatically attempts to reattach to the API following loss of connection:
Public Sub Skype_AttachmentStatus(ByVal aStatus)
  WScript.Echo ">Attachment status " & oSkype.Convert.AttachmentStatusToText(aStatus)
  If aStatus = cAttachmentStatus_Available Then oSkype.Attach() End If
End Sub


Skype4COM: Skype4COM.idl Source File

  • File List

Skype4COM.idl

00001 // Skype4COM.idl : IDL source for Skype4COM.dll
00002 //
00003
00004 import "oaidl.idl";
00005 import "ocidl.idl";
00006
00007 #include "HelpString.h"
00008 #include "olectl.h"
00009
00014    [
00015       uuid(74A50AB8-1E6F-4246-8933-08E4FBBCF4E5),
00016       helpstring(hsAttachStatus), helpcontext(17)
00017    ]
00018    typedef enum TAttachmentStatus
00019    {
00020       [helpcontext(17),helpstring(hsAttachStatus_Unknown)] apiAttachUnknown = -1,
00021       [helpcontext(17),helpstring(hsAttachStatus_Success)] apiAttachSuccess = 0,
00022       [helpcontext(17),helpstring(hsAttachStatus_Pending)] apiAttachPendingAuthorization = 1,
00023       [helpcontext(17),helpstring(hsAttachStatus_Refused)] apiAttachRefused = 2,
00024       [helpcontext(17),helpstring(hsAttachStatus_NotAvail)] apiAttachNotAvailable = 3,
00025       [helpcontext(17),helpstring(hsAttachStatus_Available)] apiAttachAvailable = 4
00026    } TAttachmentStatus;
00027
00028    [
00029       uuid(69658FFD-F587-4946-A4EC-7C0709EA9F44),
00030       helpstring(hsConnStatus), helpcontext(17)
00031    ]
00032    typedef enum TConnectionStatus
00033    {
00034       [helpcontext(17),helpstring(hsConnStatus_Unknown)] conUnknown = -1,
00035       [helpcontext(17),helpstring(hsConnStatus_Offline)] conOffline = 0,
00036       [helpcontext(17),helpstring(hsConnStatus_Connecting)] conConnecting = 1,
00037       [helpcontext(17),helpstring(hsConnStatus_Pausing)] conPausing = 2,
00038       [helpcontext(17),helpstring(hsConnStatus_Online)] conOnline = 3
00039    } TConnectionStatus;
00040
00041    [
00042       uuid(FBAB58DC-9C60-4EE6-9826-26EE2335DD0A),
00043       helpstring(hsUserStatus), helpcontext(17)
00044    ]
00045    typedef enum TUserStatus
00046    {
00047       [helpcontext(17),helpstring(hsUserStatus_Unknown)] cusUnknown = -1,
00048       [helpcontext(17),helpstring(hsUserStatus_Offline)] cusOffline = 0,
00049       [helpcontext(17),helpstring(hsUserStatus_Online)] cusOnline = 1,
00050       [helpcontext(17),helpstring(hsUserStatus_Away)] cusAway = 2,
00051       [helpcontext(17),helpstring(hsUserStatus_NotAvail)] cusNotAvailable = 3,
00052       [helpcontext(17),helpstring(hsUserStatus_DND)] cusDoNotDisturb = 4,
00053       [helpcontext(17),helpstring(hsUserStatus_Invisible)] cusInvisible = 5,
00054       [helpcontext(17),helpstring(hsUserStatus_LoggedOut)] cusLoggedOut = 6,
00055       [helpcontext(17),helpstring(hsUserStatus_SkypeMe)] cusSkypeMe = 7
00056    } TUserStatus;
00057
00058    [
00059       uuid(DCE03024-D231-45D4-AB69-D22C9E2954BA),
00060       helpstring(hsFailureReason), helpcontext(17)
00061    ]
00062    typedef enum TCallFailureReason
00063    {
00064       [helpcontext(17),helpstring(hsFailureReason_Unknown)] cfrUnknown = -1,
00065       [helpcontext(17),helpstring(hsFailureReason_MiscError)] cfrMiscError = 0,
00066       [helpcontext(17),helpstring(hsFailureReason_DoesNotExist)] cfrUserDoesNotExist= 1,
00067       [helpcontext(17),helpstring(hsFailureReason_UserOffline)] cfrUserIsOffline = 2,
00068       [helpcontext(17),helpstring(hsFailureReason_NoProxy)] cfrNoProxyFound = 3,
00069       [helpcontext(17),helpstring(hsFailureReason_Terminated)] cfrSessionTerminated= 4,
00070       [helpcontext(17),helpstring(hsFailureReason_NoCodec)] cfrNoCommonCodec = 5,
00071       [helpcontext(17),helpstring(hsFailureReason_SoundIOError)] cfrSoundIOError = 6,
00072       [helpcontext(17),helpstring(hsFailureReason_RemoteDevice)] cfrRemoteDeviceError = 7,
00073       [helpcontext(17),helpstring(hsFailureReason_Blocked)] cfrBlockedByRecipient = 8,
00074       [helpcontext(17),helpstring(hsFailureReason_NotFriend)] cfrRecipientNotFriend = 9,
00075       [helpcontext(17),helpstring(hsFailureReason_NotAuthorized)] cfrNotAuthorizedByRecipient = 10,
00076       [helpcontext(17),helpstring(hsFailureReason_RecordErr)] cfrSoundRecordingError = 11
00077    } TCallFailureReason;
00078
00079    [
00080       uuid(47E3ACA4-04BD-4A4B-AB17-7EBF9FD7F5DE),
00081       helpstring(hsCallStatus), helpcontext(17)
00082    ]
00083    typedef enum TCallStatus
00084    {
00085       [helpcontext(17),helpstring(hsCallStatus_Unknown)] clsUnknown = -1,
00086       [helpcontext(17),helpstring(hsCallStatus_Unplaced)] clsUnplaced = 0,
00087       [helpcontext(17),helpstring(hsCallStatus_Routing)] clsRouting = 1,
00088       [helpcontext(17),helpstring(hsCallStatus_EarlyMedia)] clsEarlyMedia = 2,
00089       [helpcontext(17),helpstring(hsCallStatus_Failed)] clsFailed = 3,
00090       [helpcontext(17),helpstring(hsCallStatus_Ringing)] clsRinging = 4,
00091       [helpcontext(17),helpstring(hsCallStatus_InProgress)] clsInProgress = 5,
00092       [helpcontext(17),helpstring(hsCallStatus_OnHold)] clsOnHold = 6,
00093       [helpcontext(17),helpstring(hsCallStatus_Finished)] clsFinished = 7,
00094       [helpcontext(17),helpstring(hsCallStatus_Missed)] clsMissed = 8,
00095       [helpcontext(17),helpstring(hsCallStatus_Refused)] clsRefused = 9,
00096       [helpcontext(17),helpstring(hsCallStatus_Busy)] clsBusy = 10,
00097       [helpcontext(17),helpstring(hsCallStatus_Cancelled)] clsCancelled = 11,
00098       [helpcontext(17),helpstring(hsCallStatus_LocalHold)] clsLocalHold = 12,
00099       [helpcontext(17),helpstring(hsCallStatus_RemoteHold)] clsRemoteHold = 13,
00100       [helpcontext(17),helpstring(hsCallStatus_VmBuffGreeting)] clsVoicemailBufferingGreeting = 14,
00101       [helpcontext(17),helpstring(hsCallStatus_VmPlayGreeting)] clsVoicemailPlayingGreeting = 15,
00102       [helpcontext(17),helpstring(hsCallStatus_VmRecording)] clsVoicemailRecording = 16,
00103       [helpcontext(17),helpstring(hsCallStatus_VmUploading)] clsVoicemailUploading = 17,
00104       [helpcontext(17),helpstring(hsCallStatus_VmSent)] clsVoicemailSent = 18,
00105       [helpcontext(17),helpstring(hsCallStatus_VmCancelled)] clsVoicemailCancelled = 19,
00106       [helpcontext(17),helpstring(hsCallStatus_VmFailed)] clsVoicemailFailed = 20,
00107       [helpcontext(17),helpstring(hsCallStatus_Transferring)] clsTransferring= 21,
00108       [helpcontext(17),helpstring(hsCallStatus_Transferred)] clsTransferred= 22
00109    } TCallStatus;
00110
00111    [
00112       uuid(38667A7C-DF57-4C1D-AC65-F7FC87B0E000),
00113       helpstring(hsCallType), helpcontext(17)
00114    ]
00115    typedef enum TCallType
00116    {
00117       [helpcontext(17),helpstring(hsCallType_Unknown)] cltUnknown = -1,
00118       [helpcontext(17),helpstring(hsCallType_IncomingPSTN)] cltIncomingPSTN = 0,
00119       [helpcontext(17),helpstring(hsCallType_OutgoingPSTN)] cltOutgoingPSTN = 1,
00120       [helpcontext(17),helpstring(hsCallType_IncomingP2P)] cltIncomingP2P = 2,
00121       [helpcontext(17),helpstring(hsCallType_OutgoingP2P)] cltOutgoingP2P = 3
00122    } TCallType;
00123
00124    [
00125       uuid(AA127663-5272-473D-B14C-1A8BC3FB66C6),
00126       helpstring(hsCallHistory), helpcontext(17)
00127    ]
00128    typedef enum TCallHistory
00129    {
00130       [helpcontext(17),helpstring(hsCallHistory_All)] chsAllCalls = 0,
00131       [helpcontext(17),helpstring(hsCallHistory_Missed)] chsMissedCalls = 1,
00132       [helpcontext(17),helpstring(hsCallHistory_Incoming)] chsIncomingCalls = 2,
00133       [helpcontext(17),helpstring(hsCallHistory_Outgoing)] chsOutgoingCalls = 3
00134    } TCallHistory;
00135
00136    [
00137       uuid(169E6E65-20F4-47AD-8329-02425CD53769),
00138       helpstring(hsCallVideoStatus), helpcontext(17)
00139    ]
00140    typedef enum TCallVideoStatus
00141    {
00142       [helpcontext(17),helpstring(hsCallVStatus_Unknown)] cvsUnknown = -1,
00143       [helpcontext(17),helpstring(hsCallVStatus_None)] cvsNone = 0,
00144       [helpcontext(17),helpstring(hsCallVStatus_SendEnabled)] cvsSendEnabled = 1,
00145       [helpcontext(17),helpstring(hsCallVStatus_RevcEnabled)] cvsReceiveEnabled = 2,
00146       [helpcontext(17),helpstring(hsCallVStatus_BothEnabled)] cvsBothEnabled = 3
00147    } TCallVideoStatus;
00148
00149    [
00150       uuid(944F55CF-F7AC-4955-8368-B89027EBC75C),
00151       helpstring(hsCallVideoSendStatus), helpcontext(17)
00152    ]
00153    typedef enum TCallVideoSendStatus
00154    {
00155       [helpcontext(17),helpstring(hsCallVSendStatus_Unknown)] vssUnknown = -1,
00156       [helpcontext(17),helpstring(hsCallVSendStatus_NotAvailable)] vssNotAvailable = 0,
00157       [helpcontext(17),helpstring(hsCallVSendStatus_Available)] vssAvailable = 1,
00158       [helpcontext(17),helpstring(hsCallVSendStatus_Starting)] vssStarting = 2,
00159       [helpcontext(17),helpstring(hsCallVSendStatus_Rejected)] vssRejected = 3,
00160       [helpcontext(17),helpstring(hsCallVSendStatus_Running)] vssRunning = 4,
00161       [helpcontext(17),helpstring(hsCallVSendStatus_Stopping)] vssStopping = 5,
00162       [helpcontext(17),helpstring(hsCallVSendStatus_Paused)] vssPaused = 6
00163    } TCallVideoSendStatus;
00164
00165    [
00166       uuid(8b0d63f5-57ec-4305-8f0d-517b6e85bad2),
00167       helpstring(hsCallIoDeviceType), helpcontext(17)
00168    ]
00169    typedef enum TCallIoDeviceType
00170    {
00171       [helpcontext(17),helpstring(hsCallIoDeviceTypeUnknown)] callIoDeviceTypeUnknown = -1,
00172       [helpcontext(17),helpstring(hsCallIoDeviceTypeSoundcard)] callIoDeviceTypeSoundcard= 0,
00173       [helpcontext(17),helpstring(hsCallIoDeviceTypePort)] callIoDeviceTypePort = 1,
00174       [helpcontext(17),helpstring(hsCallIoDeviceTypeFile)] callIoDeviceTypeFile = 2
00175    } TCallIoDeviceType;
00176
00177    [
00178       uuid(28B277BA-2D86-467D-BB47-A805A15585C1),
00179       helpstring(hsChatMessageType), helpcontext(17)
00180    ]
00181    typedef enum TChatMessageType
00182    {
00183       [helpcontext(17),helpstring(hsChatMsgType_Unknown)] cmeUnknown = -1,
00184       [helpcontext(17),helpstring(hsChatMsgType_With)] cmeCreatedChatWith = 0,
00185       [helpcontext(17),helpstring(hsChatMsgType_Saw)] cmeSawMembers= 1,
00186       [helpcontext(17),helpstring(hsChatMsgType_Added)] cmeAddedMembers = 2,
00187       [helpcontext(17),helpstring(hsChatMsgType_Topic)] cmeSetTopic = 3,
00188       [helpcontext(17),helpstring(hsChatMsgType_Said)] cmeSaid = 4,
00189       [helpcontext(17),helpstring(hsChatMsgType_Left)] cmeLeft = 5,
00190       [helpcontext(17),helpstring(hsChatMsgType_Emoted)] cmeEmoted = 6,
00191       [helpcontext(17),helpstring(hsChatMsgType_PostContacts)] cmePostedContacts = 7,
00192       [helpcontext(17),helpstring(hsChatMsgType_GapInChat)] cmeGapInChat = 8,
00193       [helpcontext(17),helpstring(hsChatMsgType_SetRole)] cmeSetRole = 9,
00194       [helpcontext(17),helpstring(hsChatMsgType_Kicked)] cmeKicked = 10,
00195       [helpcontext(17),helpstring(hsChatMsgType_SetOpts)] cmeSetOptions = 11,
00196       [helpcontext(17),helpstring(hsChatMsgType_Kickbanned)] cmeKickBanned = 12,
00197       [helpcontext(17),helpstring(hsChatMsgType_Joined)] cmeJoinedAsApplicant = 13,
00198       [helpcontext(17),helpstring(hsChatMsgType_SetPicture)] cmeSetPicture = 14,
00199       [helpcontext(17),helpstring(hsChatMsgType_SetGuideline)] cmeSetGuidelines = 15,
00200    } TChatMessageType;
00201
00202    [
00203       uuid(6CF9ED72-45D0-479E-936A-EB34B748661E),
00204       helpstring(hsChatMessageStatus), helpcontext(17)
00205    ]
00206    typedef enum TChatMessageStatus
00207    {
00208       [helpcontext(17),helpstring(hsChatMsgStat_Unknown)] cmsUnknown = -1,
00209       [helpcontext(17),helpstring(hsChatMsgStat_Sending)] cmsSending = 0,
00210       [helpcontext(17),helpstring(hsChatMsgStat_Sent)] cmsSent = 1,
00211       [helpcontext(17),helpstring(hsChatMsgStat_Received)] cmsReceived = 2,
00212       [helpcontext(17),helpstring(hsChatMsgStat_Read)] cmsRead = 3,
00213    } TChatMessageStatus;
00214
00215    [
00216       uuid(AE9D03DE-7E88-466A-A3E8-1E840ACD9310),
00217       helpstring(hsChatMemberRole), helpcontext(17)
00218    ]
00219    typedef enum TChatMemberRole
00220    {
00221       [helpcontext(17),helpstring(hsChatMemberRole_Unknown)] chatMemberRoleUnknown = -1,
00222       [helpcontext(17),helpstring(hsChatMemberRole_Creator)] chatMemberRoleCreator = 0,
00223       [helpcontext(17),helpstring(hsChatMemberRole_Master)] chatMemberRoleMaster = 1,
00224       [helpcontext(17),helpstring(hsChatMemberRole_Helper)] chatMemberRoleHelper = 2,
00225       [helpcontext(17),helpstring(hsChatMemberRole_User)] chatMemberRoleUser = 3,
00226       [helpcontext(17),helpstring(hsChatMemberRole_Listener)] chatMemberRoleListener = 4,
00227       [helpcontext(17),helpstring("")] chatMemberRoleApplicant = 5,
00228    } TChatMemberRole;
00229
00230    [
00231       uuid(F2E9781B-286D-42C7-8FA3-7DE5C52F286B),
00232       helpstring(hsUserSex), helpcontext(17)
00233    ]
00234    typedef enum TUserSex
00235    {
00236       [helpcontext(17),helpstring(hsUserSex_Unknown)] usexUnknown = -1,
00237       [helpcontext(17),helpstring(hsUserSex_Male)] usexMale = 0,
00238       [helpcontext(17),helpstring(hsUserSex_Female)] usexFemale = 1
00239    } TUserSex;
00240
00241    [
00242       uuid(5E758C58-F940-476C-B737-8D823737FEBA),
00243       helpstring(hsBuddyStatus), helpcontext(17)
00244    ]
00245    typedef enum TBuddyStatus
00246    {
00247       [helpcontext(17),helpstring(hsBuddyStatus_Unknown)] budUnknown = -1,
00248       [helpcontext(17),helpstring(hsBuddyStatus_Never)] budNeverBeenFriend = 0,
00249       [helpcontext(17),helpstring(hsBuddyStatus_Deleted)] budDeletedFriend = 1,
00250       [helpcontext(17),helpstring(hsBuddyStatus_Pending)] budPendingAuthorization = 2,
00251       [helpcontext(17),helpstring(hsBuddyStatus_Friend)] budFriend = 3
00252    } TBuddyStatus;
00253
00254    [
00255       uuid(93F10C8A-D3E5-4E62-9315-1A5D21C9DBC3),
00256       helpstring(hsOnlineStatus), helpcontext(17)
00257    ]
00258    typedef enum TOnlineStatus
00259    {
00260       [helpcontext(17),helpstring(hsOnlineStatus_Unknown)] olsUnknown = -1,
00261       [helpcontext(17),helpstring(hsOnlineStatus_Offline)] olsOffline = 0,
00262       [helpcontext(17),helpstring(hsOnlineStatus_Online)] olsOnline = 1,
00263       [helpcontext(17),helpstring(hsOnlineStatus_Away)] olsAway = 2,
00264       [helpcontext(17),helpstring(hsOnlineStatus_NotAvail)] olsNotAvailable = 3,
00265       [helpcontext(17),helpstring(hsOnlineStatus_DND)] olsDoNotDisturb = 4,
00266       [helpcontext(17),helpstring(hsOnlineStatus_SkypeOut)] olsSkypeOut = 5,
00267       [helpcontext(17),helpstring(hsOnlineStatus_SkypeMe)] olsSkypeMe = 6
00268    } TOnlineStatus;
00269
00270    [
00271       uuid(FCDEF5B9-BAE9-4213-815F-0F68C7A8F03E),
00272       helpstring(hsLeaveReason), helpcontext(17)
00273    ]
00274    typedef enum TChatLeaveReason
00275    {
00276       [helpcontext(17),helpstring(hsLeaveReason_Unknown)] leaUnknown = -1,
00277       [helpcontext(17),helpstring(hsLeaveReason_NotFound)] leaUserNotFound = 0,
00278       [helpcontext(17),helpstring(hsLeaveReason_Incapable)] leaUserIncapable = 1,
00279       [helpcontext(17),helpstring(hsLeaveReason_NotFriend)] leaAdderNotFriend = 2,
00280       [helpcontext(17),helpstring(hsLeaveReason_NotAuthorized)] leaAddedNotAuthorized = 3,
00281       [helpcontext(17),helpstring(hsLeaveReason_Declined)] leaAddDeclined = 4,
00282       [helpcontext(17),helpstring(hsLeaveReason_Unsubscribe)] leaUnsubscribe = 5
00283    } TChatLeaveReason;
00284
00285    [
00286       uuid(D90B58CC-53AA-4A8C-8774-4B48BF307D9B),
00287       helpstring(hsChatStatus), helpcontext(17)
00288    ]
00289    typedef enum TChatStatus
00290    {
00291       [helpcontext(17),helpstring(hsChatStatus_Unknown)] chsUnknown = -1,
00292       [helpcontext(17),helpstring(hsChatStatus_Legacy)] chsLegacyDialog = 0,
00293       [helpcontext(17),helpstring(hsChatStatus_Dialog)] chsDialog = 1,
00294       [helpcontext(17),helpstring(hsChatStatus_Accept)] chsMultiNeedAccept = 2,
00295       [helpcontext(17),helpstring(hsChatStatus_Subscrib)] chsMultiSubscribed = 3,
00296       [helpcontext(17),helpstring(hsChatStatus_Unsubscr)] chsUnsubscribed= 4
00297    } TChatStatus;
00298
00299    [
00300       uuid(204D84E3-D7D1-450D-A038-6A3A5210E4FB),
00301       helpstring(hsChatType), helpcontext(17)
00302    ]
00303    typedef enum TChatType
00304    {
00305       [helpcontext(17),helpstring(hsChatType_Unknown)] chatTypeUnknown = -1,
00306       [helpcontext(17),helpstring(hsChatType_Dialog)] chatTypeDialog = 0,
00307       [helpcontext(17),helpstring(hsChatType_Legacy)] chatTypeLegacyDialog = 1,
00308       [helpcontext(17),helpstring(hsChatType_LegacyUnsub)] chatTypeLegacyUnsubscribed = 2,
00309       [helpcontext(17),helpstring(hsChatType_Multichat)] chatTypeMultiChat = 3,
00310       [helpcontext(17),helpstring(hsChatType_SharedGrp)] chatTypeSharedGroup = 4,
00311    } TChatType;
00312
00313    [
00314       uuid(1685094C-829A-431B-880C-FE61D82A085E),
00315       helpstring(hsChatMyStatus), helpcontext(17)
00316    ]
00317    typedef enum TChatMyStatus
00318    {
00319       [helpcontext(17),helpstring(hsChatMyStatus_Unknown)] chatStatusUnknown = -1,
00320       [helpcontext(17),helpstring(hsChatMyStatus_Connecting)] chatStatusConnecting = 0,
00321       [helpcontext(17),helpstring(hsChatMyStatus_WaitAccept)] chatStatusWaitingRemoteAccept = 1,
00322       [helpcontext(17),helpstring(hsChatMyStatus_AcceptRequired)] chatStatusAcceptRequired = 2,
00323       [helpcontext(17),helpstring(hsChatMyStatus_PasswdRequired)] chatStatusPasswordRequired = 3,
00324       [helpcontext(17),helpstring(hsChatMyStatus_Subscribed)] chatStatusSubscribed = 4,
00325       [helpcontext(17),helpstring(hsChatMyStatus_Unsubscribed)] chatStatusUnsubscribed = 5,
00326       [helpcontext(17),helpstring(hsChatMyStatus_Disbanded)] chatStatusDisbanded = 6,
00327       [helpcontext(17),helpstring(hsChatMyStatus_Queued)] chatStatusQueuedBecauseChatIsFull = 7,
00328       [helpcontext(17),helpstring(hsChatMyStatus_ApplicationDenied)] chatStatusApplicationDenied = 8,
00329       [helpcontext(17),helpstring(hsChatMyStatus_Kicked)] chatStatusKicked = 9,
00330       [helpcontext(17),helpstring(hsChatMyStatus_Banned)] chatStatusBanned = 10,
00331       [helpcontext(17),helpstring(hsChatMyStatus_Reconnecting)] chatStatusRetryConnecting = 11,
00332    } TChatMyStatus;
00333
00334    [
00335       uuid(371F92C4-78BC-45BB-B0B4-E9924C2B9EF9),
00336       helpstring(""), helpcontext(17)
00337    ]
00338    typedef enum TChatOptions
00339    {
00340       [helpcontext(17),helpstring(hsChatOptions_JoinEnabled)] chatOptionJoiningEnabled = 1,
00341       [helpcontext(17),helpstring(hsChatOptions_JoinerApplicant)] chatOptionJoinersBecomeApplicants = 2,
00342       [helpcontext(17),helpstring(hsChatOptions_JoinerListener)] chatOptionJoinersBecomeListeners = 4,
00343       [helpcontext(17),helpstring(hsChatOptions_HistoryDisclosed)] chatOptionHistoryDisclosed = 8,
00344       [helpcontext(17),helpstring(hsChatOptions_UsersAreListeners)] chatOptionUsersAreListeners = 16,
00345       [helpcontext(17),helpstring(hsChatOptions_TopicLocked)] chatOptionTopicAndPictureLockedForUsers = 32,
00346    } TChatOptions;
00347
00348    [
00349       uuid(7771BE16-D5F0-4368-8A88-643B5B519A43),
00350       helpstring(hsVmType), helpcontext(17)
00351    ]
00352    typedef enum TVoicemailType
00353    {
00354       [helpcontext(17),helpstring(hsVmType_Unknown)] vmtUnknown = -1,
00355       [helpcontext(17),helpstring(hsVmType_Incoming)] vmtIncoming = 0,
00356       [helpcontext(17),helpstring(hsVmType_DefaultGreeting)] vmtDefaultGreeting = 1,
00357       [helpcontext(17),helpstring(hsVmType_CustomGreeting)] vmtCustomGreeting = 2,
00358       [helpcontext(17),helpstring(hsVmType_Outgoing)] vmtOutgoing = 3
00359    } TVoicemailType;
00360
00361    [
00362       uuid(F9810AFA-DBC3-4327-9876-E94A47E7CED5),
00363       helpstring(hsVmStatus), helpcontext(17)
00364    ]
00365    typedef enum TVoicemailStatus
00366    {
00367       [helpcontext(17),helpstring(hsVmStatus_Unknown)] vmsUnknown = -1,
00368       [helpcontext(17),helpstring(hsVmStatus_NotDownloaded)] vmsNotDownloaded = 0,
00369       [helpcontext(17),helpstring(hsVmStatus_Downloading)] vmsDownloading = 1,
00370       [helpcontext(17),helpstring(hsVmStatus_Unplayed)] vmsUnplayed = 2,
00371       [helpcontext(17),helpstring(hsVmStatus_Buffering)] vmsBuffering = 3,
00372       [helpcontext(17),helpstring(hsVmStatus_Playing)] vmsPlaying = 4,
00373       [helpcontext(17),helpstring(hsVmStatus_Played)] vmsPlayed = 5,
00374       [helpcontext(17),helpstring(hsVmStatus_Blank)] vmsBlank = 6,
00375       [helpcontext(17),helpstring(hsVmStatus_Recording)] vmsRecording = 7,
00376       [helpcontext(17),helpstring(hsVmStatus_Recorded)] vmsRecorded = 8,
00377       [helpcontext(17),helpstring(hsVmStatus_Uploading)] vmsUploading = 9,
00378       [helpcontext(17),helpstring(hsVmStatus_Uploaded)] vmsUploaded = 10,
00379       [helpcontext(17),helpstring(hsVmStatus_Deleting)] vmsDeleting = 11,
00380       [helpcontext(17),helpstring(hsVmStatus_Failed)] vmsFailed = 12
00381    } TVoicemailStatus;
00382
00383    [
00384       uuid(977E2F50-2361-4E81-B9F3-2303B8C8BB49),
00385       helpstring(hsVmFailureReason), helpcontext(17)
00386    ]
00387    typedef enum TVoicemailFailureReason
00388    {
00389       [helpcontext(17),helpstring(hsVmFailureReason_Unknown)] vmrUnknown = -1,
00390       [helpcontext(17),helpstring(hsVmFailureReason_NoError)] vmrNoError = 0,
00391       [helpcontext(17),helpstring(hsVmFailureReason_MiscError)] vmrMiscError = 1,
00392       [helpcontext(17),helpstring(hsVmFailureReason_ConnectError)] vmrConnectError = 2,
00393       [helpcontext(17),helpstring(hsVmFailureReason_NoPrivilege)] vmrNoPrivilege = 3,
00394       [helpcontext(17),helpstring(hsVmFailureReason_NoVoicemail)] vmrNoVoicemail = 4,
00395       [helpcontext(17),helpstring(hsVmFailureReason_FileReadError)] vmrFileReadError = 5,
00396       [helpcontext(17),helpstring(hsVmFailureReason_FileWriteError)] vmrFileWriteError = 6,
00397       [helpcontext(17),helpstring(hsVmFailureReason_RecordingError)] vmrRecordingError = 7,
00398       [helpcontext(17),helpstring(hsVmFailureReason_PlaybackError)] vmrPlaybackError = 8
00399    } TVoicemailFailureReason;
00400
00401    [
00402       uuid(4015AAE2-C9AD-40E6-A06C-A1609840CCDD),
00403       helpstring(hsGroupType), helpcontext(17)
00404    ]
00405    typedef enum TGroupType
00406    {
00407       [helpcontext(17),helpstring(hsGroupType_Unknown)] grpUnknown = -1,
00408       [helpcontext(17),helpstring(hsGroupType_Custom)] grpCustomGroup = 0,
00409       [helpcontext(17),helpstring(hsGroupType_AllUsers)] grpAllUsers = 1,
00410       [helpcontext(17),helpstring(hsGroupType_AllFriends)] grpAllFriends = 2,
00411       [helpcontext(17),helpstring(hsGroupType_SkypeFriends)] grpSkypeFriends = 3,
00412       [helpcontext(17),helpstring(hsGroupType_SkypeOutFriends)] grpSkypeOutFriends = 4,
00413       [helpcontext(17),helpstring(hsGroupType_OnlineFriends)] grpOnlineFriends = 5,
00414       [helpcontext(17),helpstring(hsGroupType_PendingAuthFriends)] grpPendingAuthorizationFriends = 6,
00415       [helpcontext(17),helpstring(hsGroupType_RecentContactUsers)] grpRecentlyContactedUsers = 7,
00416       [helpcontext(17),helpstring(hsGroupType_WaitMyAuthorization)] grpUsersWaitingMyAuthorization = 8,
00417       [helpcontext(17),helpstring(hsGroupType_AuthorizedByMe)] grpUsersAuthorizedByMe = 9,
00418       [helpcontext(17),helpstring(hsGroupType_BlockedByMe)] grpUsersBlockedByMe = 10,
00419       [helpcontext(17),helpstring(hsGroupType_UngroupedFriends)] grpUngroupedFriends = 11,
00420       [helpcontext(17),helpstring(hsGroupType_SharedGroup)] grpSharedGroup = 12,
00421       [helpcontext(17),helpstring(hsGroupType_ProposedSharedGroup)] grpProposedSharedGroup = 13
00422    } TGroupType;
00423
00424    [
00425       uuid(46FF6EA6-E4B4-4E0A-B079-2E616F633396),
00426       helpstring(hsCallChannelType), helpcontext(17)
00427    ]
00428    typedef enum TCallChannelType
00429    {
00430       [helpcontext(17),helpstring(hsCallChannelType_Unknown)] cctUnknown= -1,
00431       [helpcontext(17),helpstring(hsCallChannelType_Datagram)] cctDatagram= 0,
00432       [helpcontext(17),helpstring(hsCallChannelType_Reliable)] cctReliable = 1
00433    } TCallChannelType;
00434
00435    [
00436       uuid(775c273f-6b14-4aa5-b33c-83127f41ba2e),
00437       helpstring(hsApiSecurityContext), helpcontext(17), hidden
00438    ]
00439    typedef enum TApiSecurityContext
00440    {
00441       [helpcontext(17),helpstring(hsApiSecurityContext_Unknown)]  apiContextUnknown = 0x0000,
00442       [helpcontext(17),helpstring(hsApiSecurityContext_Voice)] apiContextVoice = 0x0001,
00443       [helpcontext(17),helpstring(hsApiSecurityContext_Messaging)] apiContextMessaging = 0x0002,
00444       [helpcontext(17),helpstring(hsApiSecurityContext_Account)] apiContextAccount = 0x0004,
00445       [helpcontext(17),helpstring(hsApiSecurityContext_Contacts)] apiContextContacts = 0x0008
00446    } TApiSecurityContext;
00447
00448    [
00449       uuid(48a2b076-ba6a-433b-8065-314987c89cc1),
00450       helpstring(hsSmsMessageType), helpcontext(17)
00451    ]
00452    typedef enum TSmsMessageType
00453    {
00454       [helpcontext(17),helpstring(hsSmsMessageType_Unknown)] smsMessageTypeUnknown = -1,
00455       [helpcontext(17),helpstring(hsSmsMessageType_Incoming)] smsMessageTypeIncoming = 0,
00456       [helpcontext(17),helpstring(hsSmsMessageType_Outgoing)] smsMessageTypeOutgoing = 1,
00457       [helpcontext(17),helpstring(hsSmsMessageType_CCRequest)] smsMessageTypeCCRequest = 2,
00458       [helpcontext(17),helpstring(hsSmsMessageType_CCSubmit)] smsMessageTypeCCSubmit = 3
00459    } TSmsMessageType;
00460
00461    [
00462       uuid(531f8be0-6ab6-4521-a998-6c87bb9e5d5c),
00463       helpstring(hsSmsMessageStatus), helpcontext(17)
00464    ]
00465    typedef enum TSmsMessageStatus
00466    {
00467       [helpcontext(17),helpstring(hsSmsMessageStatus_Unknown)] smsMessageStatusUnknown = -1,
00468       [helpcontext(17),helpstring(hsSmsMessageStatus_Received)] smsMessageStatusReceived = 0,
00469       [helpcontext(17),helpstring(hsSmsMessageStatus_Read)] smsMessageStatusRead = 1,
00470       [helpcontext(17),helpstring(hsSmsMessageStatus_Composing)] smsMessageStatusComposing = 2,
00471       [helpcontext(17),helpstring(hsSmsMessageStatus_SendToServ)] smsMessageStatusSendingToServer = 3,
00472       [helpcontext(17),helpstring(hsSmsMessageStatus_SentToServ)] smsMessageStatusSentToServer = 4,
00473       [helpcontext(17),helpstring(hsSmsMessageStatus_Delivered)] smsMessageStatusDelivered = 5,
00474       [helpcontext(17),helpstring(hsSmsMessageStatus_TargetsFailed)] smsMessageStatusSomeTargetsFailed = 6,
00475       [helpcontext(17),helpstring(hsSmsMessageStatus_Failed)] smsMessageStatusFailed = 7
00476    } TSmsMessageStatus;
00477
00478    [
00479       uuid(fe7e480a-5b32-432e-9711-e8e9c10c6bf9),
00480       helpstring(hsSmsFailureReason), helpcontext(17)
00481    ]
00482    typedef enum TSmsFailureReason
00483    {
00484       [helpcontext(17),helpstring(hsSmsFailureReason_Unknown)] smsFailureReasonUnknown = -1,
00485       [helpcontext(17),helpstring(hsSmsFailureReason_MiscErr)] smsFailureReasonMiscError = 0,
00486       [helpcontext(17),helpstring(hsSmsFailureReason_ServConnFailed)] smsFailureReasonServerConnectFailed = 1,
00487       [helpcontext(17),helpstring(hsSmsFailureReason_NoSmsCapability)] smsFailureReasonNoSmsCapability = 2,
00488       [helpcontext(17),helpstring(hsSmsFailureReason_InsufficientFunds)] smsFailureReasonInsufficientFunds = 3,
00489       [helpcontext(17),helpstring(hsSmsFailureReason_InvalidCCode)] smsFailureReasonInvalidConfirmationCode = 4,
00490       [helpcontext(17),helpstring(hsSmsFailureReason_UserBlocked)] smsFailureReasonUserBlocked = 5,
00491       [helpcontext(17),helpstring(hsSmsFailureReason_IPBlocked)] smsFailureReasonIPBlocked = 6,
00492       [helpcontext(17),helpstring(hsSmsFailureReason_NodeBlocked)] smsFailureReasonNodeBlocked = 7
00493    } TSmsFailureReason;
00494
00495    [
00496       uuid(34f2a71c-d453-4199-ab29-5b6e17b3fb5e),
00497       helpstring(hsSmsTargetStatus), helpcontext(17)
00498    ]
00499    typedef enum TSmsTargetStatus
00500    {
00501       [helpcontext(17),helpstring(hsSmsTargetStatus_Unknown)] smsTargetStatusUnknown = -1,
00502       [helpcontext(17),helpstring(hsSmsTargetStatus_Undefined)] smsTargetStatusUndefined = 0,
00503       [helpcontext(17),helpstring(hsSmsTargetStatus_Analyzing)] smsTargetStatusAnalyzing = 1,
00504       [helpcontext(17),helpstring(hsSmsTargetStatus_Acceptable)] smsTargetStatusAcceptable = 2,
00505       [helpcontext(17),helpstring(hsSmsTargetStatus_NotRoutable)] smsTargetStatusNotRoutable = 3,
00506       [helpcontext(17),helpstring(hsSmsTargetStatus_DeliveryPending)] smsTargetStatusDeliveryPending = 4,
00507       [helpcontext(17),helpstring(hsSmsTargetStatus_DeliverySuccess)] smsTargetStatusDeliverySuccessful = 5,
00508       [helpcontext(17),helpstring(hsSmsTargetStatus_DeliveryFailed)] smsTargetStatusDeliveryFailed = 6
00509    } TSmsTargetStatus;
00510
00511    [
00512       uuid(ED06559A-B942-49f5-AE48-DBD6BEF807B9),
00513       helpstring(hsPluginContext), helpcontext(17)
00514    ]
00515    typedef enum TPluginContext
00516    {
00517       [helpcontext(17),helpstring(hsPluginContext_Unknown)] pluginContextUnknown = -1,
00518       [helpcontext(17),helpstring(hsPluginContext_Chat)] pluginContextChat = 0,
00519       [helpcontext(17),helpstring(hsPluginContext_Call)] pluginContextCall = 1,
00520       [helpcontext(17),helpstring(hsPluginContext_Contact)] pluginContextContact = 2,
00521       [helpcontext(17),helpstring(hsPluginContext_MySelf)] pluginContextMyself = 3,
00522       [helpcontext(17),helpstring(hsPluginContext_Tools)] pluginContextTools = 4,
00523    } TPluginContext;
00524
00525    [
00526       uuid(000D0FD6-DC80-4cb1-A5AF-1A748DF8159E),
00527       helpstring(hsPluginContactType), helpcontext(17)
00528    ]
00529    typedef enum TPluginContactType
00530    {
00531       [helpcontext(17),helpstring(hsPluginContactType_Unknown)] pluginContactTypeUnknown = -1,
00532       [helpcontext(17),helpstring(hsPluginContactType_All)] pluginContactTypeAll = 0,
00533       [helpcontext(17),helpstring(hsPluginContactType_Skype)] pluginContactTypeSkype = 1,
00534       [helpcontext(17),helpstring(hsPluginContactType_SkypeOut)] pluginContactTypeSkypeOut= 2,
00535    } TPluginContactType;
00536
00537    [
00538       uuid(BD808125-6CB8-46ad-88E1-13961434781F),
00539       helpstring(hsFileTransferType), helpcontext(17)
00540    ]
00541    typedef enum TFileTransferType
00542    {
00543       [helpcontext(17),helpstring(hsFileTransferType_Incoming)] fileTransferTypeIncoming = 0,
00544       [helpcontext(17),helpstring(hsFileTransferType_Outgoing)] fileTransferTypeOutgoing = 1,
00545    } TFileTransferType;
00546
00547    [
00548       uuid(C4CE4074-11E0-4026-A809-5C6D259F1B7C),
00549       helpstring(hsFileTransferStatus), helpcontext(17)
00550    ]
00551    typedef enum TFileTransferStatus
00552    {
00553       [helpcontext(17),helpstring(hsFileTransferStatus_New)] fileTransferStatusNew = 0,
00554       [helpcontext(17),helpstring(hsFileTransferStatus_Connecting)] fileTransferStatusConnecting = 1,
00555       [helpcontext(17),helpstring(hsFileTransferStatus_WaitingForAccept)] fileTransferStatusWaitingForAccept = 2,
00556       [helpcontext(17),helpstring(hsFileTransferStatus_Transferring)] fileTransferStatusTransferring = 3,
00557       [helpcontext(17),helpstring(hsFileTransferStatus_TransferOverRelay)] fileTransferStatusTransferringOverRelay = 4,
00558       [helpcontext(17),helpstring(hsFileTransferStatus_Paused)] fileTransferStatusPaused = 5,
00559       [helpcontext(17),helpstring(hsFileTransferStatus_RemotelyPaused)] fileTransferStatusRemotelyPaused = 6,
00560       [helpcontext(17),helpstring(hsFileTransferStatus_Cancelled)] fileTransferStatusCancelled = 7,
00561       [helpcontext(17),helpstring(hsFileTransferStatus_Completed)] fileTransferStatusCompleted = 8,
00562       [helpcontext(17),helpstring(hsFileTransferStatus_Failed)] fileTransferStatusFailed = 9,
00563    } TFileTransferStatus;
00564
00565    [
00566       uuid(A59E0AAE-86BA-4d10-959B-4E75C2C8DAD4),
00567       helpstring(hsFTFailureReason), helpcontext(17)
00568    ]
00569    typedef enum TFileTransferFailureReason
00570    {
00571       [helpcontext(17),helpstring(hsFTFailureReason_SenderNotAuthorized)] fileTransferFailureReasonSenderNotAuthorized= 1,
00572       [helpcontext(17),helpstring(hsFTFailureReason_RemotelyCancelled)] fileTransferFailureReasonRemotelyCancelled= 2,
00573       [helpcontext(17),helpstring(hsFTFailureReason_FailedRead)] fileTransferFailureReasonFailedRead = 3,
00574       [helpcontext(17),helpstring(hsFTFailureReason_FailedRemoteRead)] fileTransferFailureReasonFailedRemoteRead = 4,
00575       [helpcontext(17),helpstring(hsFTFailureReason_FailedWrite)] fileTransferFailureReasonFailedWrite = 5,
00576       [helpcontext(17),helpstring(hsFTFailureReason_FailedRemoteWrite)] fileTransferFailureReasonFailedRemoteWrite = 6,
00577       [helpcontext(17),helpstring(hsFTFailureReason_RemoteDoesNotSupportFT)] fileTransferFailureReasonRemoteDoesNotSupportFT = 7,
00578       [helpcontext(17),helpstring(hsFTFailureReason_RemoteOfflineTooLong)] fileTransferFailureReasonRemoteOfflineTooLong = 8,
00579    } TFileTransferFailureReason;
00582    [
00583       object,
00584       uuid(48E046A8-31D7-4E5F-A611-47BF32B86405),
00585       dual,
00586       nonextensible,
00587       pointer_default(unique),
00588       oleautomation,
00589       helpstring(hsICommand),
00590       helpcontext(7)
00591    ]
00592    interface ICommand : IDispatch
00593    {
00594       [propget, id(1), helpstring(hsICommand_Id),helpcontext(7)] HRESULT Id([out, retval] LONG *pVal);
00595       [propput, id(1), helpstring(hsICommand_Id),helpcontext(7)] HRESULT Id([in] LONG newVal);
00596       [propget, id(2), helpstring(hsICommand_Timeout),helpcontext(7)] HRESULT Timeout([out, retval] LONG *pVal);
00597       [propput, id(2), helpstring(hsICommand_Timeout),helpcontext(7)] HRESULT Timeout([in] LONG newVal);
00598       [propget, id(3), helpstring(hsICommand_Block),helpcontext(7)] HRESULT Blocking([out, retval] VARIANT_BOOL *pVal);
00599       [propput, id(3), helpstring(hsICommand_Block),helpcontext(7)] HRESULT Blocking([in] VARIANT_BOOL newVal);
00600       [propget, id(4), helpstring(hsICommand_Command),helpcontext(7)] HRESULT Command([out, retval] BSTR *pVal);
00601       [propput, id(4), helpstring(hsICommand_Command),helpcontext(7)] HRESULT Command([in] BSTR newVal);
00602       [propget, id(5), helpstring(hsICommand_Reply),helpcontext(7)] HRESULT Reply([out, retval] BSTR *pVal);
00603       [propput, id(5), helpstring(hsICommand_Reply),helpcontext(7)] HRESULT Reply([in] BSTR newVal);
00604       [propget, id(6), helpstring(hsICommand_Expect),helpcontext(7)] HRESULT Expected([out, retval] BSTR *pVal);
00605       [propput, id(6), helpstring(hsICommand_Expect),helpcontext(7)] HRESULT Expected([in] BSTR newVal);
00606    };
00607    [
00608       object,
00609       uuid(D0BC5168-A518-4192-9D20-0B907B23C4D1),
00610       dual,
00611       nonextensible,
00612       pointer_default(unique),
00613       oleautomation,
00614       helpstring(hsIUser),
00615       helpcontext(15)
00616    ]
00617    interface IUser : IDispatch
00618    {
00619       [propget, id(1), helpstring(hsIUser_Handle), helpcontext(15)] HRESULT Handle([out, retval] BSTR *pVal);
00620       [propput, id(1), helpstring(hsIUser_Handle), helpcontext(15)] HRESULT Handle([in] BSTR newVal);
00621       [propget, id(2), helpstring(hsIUser_FullName), helpcontext(15)] HRESULT FullName([out, retval] BSTR *pVal);
00622       [propget, id(3), helpstring(hsIUser_Birthday), helpcontext(15)] HRESULT Birthday([out, retval] DATE *pVal);
00623       [propget, id(4), helpstring(hsIUser_Sex), helpcontext(15)] HRESULT Sex([out, retval] TUserSex *pVal);
00624       [propget, id(5), helpstring(hsIUser_Country), helpcontext(15)] HRESULT Country([out, retval] BSTR *pVal);
00625       [propget, id(6), helpstring(hsIUser_Province), helpcontext(15)] HRESULT Province([out, retval] BSTR *pVal);
00626       [propget, id(7), helpstring(hsIUser_City), helpcontext(15)] HRESULT City([out, retval] BSTR *pVal);
00627       [propget, id(8), helpstring(hsIUser_PhoneHome), helpcontext(15)] HRESULT PhoneHome([out, retval] BSTR *pVal);
00628       [propget, id(9), helpstring(hsIUser_PhoneOffice), helpcontext(15)] HRESULT PhoneOffice([out, retval] BSTR *pVal);
00629       [propget, id(10), helpstring(hsIUser_PhoneMobile), helpcontext(15)] HRESULT PhoneMobile([out, retval] BSTR *pVal);
00630       [propget, id(11), helpstring(hsIUser_Homepage), helpcontext(15)] HRESULT Homepage([out, retval] BSTR *pVal);
00631       [propget, id(12), helpstring(hsIUser_About), helpcontext(15)] HRESULT About([out, retval] BSTR *pVal);
00632       [propget, id(13), helpstring(hsIUser_HasCallEquipment), helpcontext(15)] HRESULT HasCallEquipment([out, retval] VARIANT_BOOL *pVal);
00633       [propget, id(14), helpstring(hsIUser_BuddyStatus), helpcontext(15)] HRESULT BuddyStatus([out, retval] TBuddyStatus *pVal);
00634       [propput, id(14), helpstring(hsIUser_BuddyStatus), helpcontext(15)] HRESULT BuddyStatus([in] TBuddyStatus newVal);
00635       [propget, id(15), helpstring(hsIUser_Authorized), helpcontext(15)] HRESULT IsAuthorized([out, retval] VARIANT_BOOL *pVal);
00636       [propput, id(15), helpstring(hsIUser_Authorized), helpcontext(15)] HRESULT IsAuthorized([in] VARIANT_BOOL newVal);
00637       [propget, id(16), helpstring(hsIUser_Blocked), helpcontext(15)] HRESULT IsBlocked([out, retval] VARIANT_BOOL *pVal);
00638       [propput, id(16), helpstring(hsIUser_Blocked), helpcontext(15)] HRESULT IsBlocked([in] VARIANT_BOOL newVal);
00639       [propget, id(17), helpstring(hsIUser_DisplayName), helpcontext(15)] HRESULT DisplayName([out, retval] BSTR *pVal);
00640       [propget, id(18), helpstring(hsIUser_OnlineStatus), helpcontext(15)] HRESULT OnlineStatus([out, retval] TOnlineStatus *pVal);
00641       [propget, id(19), helpstring(hsIUser_LastOnline), helpcontext(15)] HRESULT LastOnline([out, retval] DATE *pVal);
00642       [propget, id(20), helpstring(hsIUser_CountryCode), helpcontext(15)] HRESULT CountryCode([out, retval] BSTR *pVal);
00643       [propget, id(21), helpstring(hsIUser_RecvAuthReq), helpcontext(15)] HRESULT ReceivedAuthRequest([out, retval] BSTR *pVal);
00644       [propget, id(22), helpstring(hsIUser_SpeedDial), helpcontext(15)] HRESULT SpeedDial([out, retval] BSTR *pVal);
00645       [propput, id(22), helpstring(hsIUser_SpeedDial), helpcontext(15)] HRESULT SpeedDial([in] BSTR newVal);
00646       [propget, id(23), helpstring(hsIUser_CanLeaveVm), helpcontext(15)] HRESULT CanLeaveVoicemail([out, retval] VARIANT_BOOL *pVal);
00647       [propget, id(24), helpstring(hsIUser_MoodText), helpcontext(15)] HRESULT MoodText([out, retval] BSTR *pVal);
00648       [propget, id(25), helpstring(hsIUser_Aliases), helpcontext(15)] HRESULT Aliases([out, retval] BSTR *pVal);
00649       [propget, id(26), helpstring(hsIUser_Timezone), helpcontext(15)] HRESULT Timezone([out, retval] LONG *pVal);
00650       [propget, id(27), helpstring(hsIUser_IsCFActive), helpcontext(15)] HRESULT IsCallForwardActive([out, retval] VARIANT_BOOL *pVal);
00651       [propget, id(28), helpstring(hsIUser_Language), helpcontext(15)] HRESULT Language([out, retval] BSTR *pVal);
00652       [propget, id(29), helpstring(hsIUser_LanguageCode), helpcontext(15)] HRESULT LanguageCode([out, retval] BSTR *pVal);
00653       [propget, id(30), helpstring(hsIUser_VideoCapable), helpcontext(15)] HRESULT IsVideoCapable([out, retval] VARIANT_BOOL *pVal);
00654       [propget, id(31), helpstring(hsIUser_SkypeOut), helpcontext(15)] HRESULT IsSkypeOutContact([out, retval] VARIANT_BOOL *pVal);
00655       [propget, id(32), helpstring(hsIUser_NumberOfAuthBuddies), helpcontext(15)] HRESULT NumberOfAuthBuddies([out, retval] LONG* pVal);
00656       [propput, id(17), helpstring(hsIUser_DisplayName), helpcontext(15)] HRESULT DisplayName([in] BSTR newVal);
00657       [propget, id(35), helpstring(hsIUser_RichMoodText), helpcontext(15)] HRESULT RichMoodText([out, retval] BSTR *pVal);
00658       [propget, id(36), helpstring(hsIUser_IsVmCapable), helpcontext(15)] HRESULT IsVoicemailCapable([out, retval] VARIANT_BOOL *pVal);
00659    };
00660    [
00661       object,
00662       uuid(EC163200-44EB-483B-907F-A8C1CF56B8EE),
00663       dual,
00664       nonextensible,
00665       pointer_default(unique),
00666       oleautomation,
00667       helpstring(hsIUserColl),
00668       helpcontext(16)
00669    ]
00670    interface IUserCollection : IDispatch
00671    {
00672       [propget, id(1), helpstring(hsIUserColl_Count), helpcontext(16)] HRESULT Count([out, retval] LONG* pVal);
00673       [id(2), helpstring(hsIUserColl_Add), helpcontext(16)] HRESULT Add([in] IUser* pUser);
00674       [id(3), helpstring(hsIUserColl_Remove), helpcontext(16)] HRESULT Remove([in] long Index);
00675       [id(4), helpstring(hsIUserColl_RemoveAll), helpcontext(16)] HRESULT RemoveAll(void);
00676       [propget, id(DISPID_VALUE), helpstring(hsIUserColl_Item), helpcontext(16)] HRESULT Item([in] LONG Index, [out, retval] IUser ** pVal);
00677       [propget, id(DISPID_NEWENUM), helpstring(hsIUserColl_NewEnum), helpcontext(16)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
00678    };
00679    [
00680       object,
00681       uuid(F1B2AD09-1961-4336-A6BF-93010B73DE72),
00682       dual,
00683       nonextensible,
00684       pointer_default(unique),
00685       oleautomation,
00686       helpstring(hsIParticipant),
00687       helpcontext(37)
00688    ]
00689    interface IParticipant : IDispatch
00690    {
00691       [propget, id(1), helpstring(hsIParticipant_Handle), helpcontext(37)] HRESULT Handle([out, retval] BSTR *pVal);
00692       [propget, id(2), helpstring(hsIParticipant_DispName), helpcontext(37)] HRESULT DisplayName([out, retval] BSTR *pVal);
00693       [propget, id(3), helpstring(hsIParticipant_CallType), helpcontext(37)] HRESULT CallType([out, retval] TCallType *pVal);
00694       [propget, id(4), helpstring(hsIParticipant_CallStat), helpcontext(37)] HRESULT CallStatus([out, retval] TCallStatus *pVal);
00695    };
00696    [
00697       object,
00698       uuid(F825FE12-9826-4BD2-BF7E-1ED95B8480FE),
00699       dual,
00700       nonextensible,
00701       pointer_default(unique),
00702       oleautomation,
00703       helpstring(hsIParticipantColl),
00704       helpcontext(38)
00705    ]
00706    interface IParticipantCollection : IDispatch
00707    {
00708       [propget, id(1), helpstring(hsIParticipantColl_Count), helpcontext(38)] HRESULT Count([out, retval] LONG* pVal);
00709       [id(2), helpstring(hsIParticipantColl_Add), helpcontext(38)] HRESULT Add([in] IParticipant* pParticipant);
00710       [id(3), helpstring(hsIParticipantColl_Remove), helpcontext(38)] HRESULT Remove([in] long Index);
00711       [id(4), helpstring(hsIParticipantColl_RemoveAll), helpcontext(38)] HRESULT RemoveAll(void);
00712       [propget, id(DISPID_VALUE), helpstring(hsIParticipantColl_Item), helpcontext(38)] HRESULT Item([in] LONG Index, [out, retval] IParticipant ** pVal);
00713       [propget, id(DISPID_NEWENUM), helpstring(hsIParticipantColl_NewEnum), helpcontext(38)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
00714    };
00715    [
00716       object,
00717       uuid(76036886-436C-405F-A96E-7835CCFB82F3),
00718       dual,
00719       nonextensible,
00720       pointer_default(unique),
00721       oleautomation,
00722       helpstring(hsICall),
00723       helpcontext(5)
00724    ]
00725    interface ICall : IDispatch
00726    {
00727       [propget, id(1), helpstring(hsICall_Id),helpcontext(5)] HRESULT Id([out, retval] LONG *pVal);
00728       [propget, id(2), helpstring(hsICall_Timestamp),helpcontext(5)] HRESULT Timestamp([out, retval] DATE *pVal);
00729       [propget, id(3), helpstring(hsICall_PartHandle),helpcontext(5)] HRESULT PartnerHandle([out, retval] BSTR *pVal);
00730       [propget, id(4), helpstring(hsICall_PartDispName),helpcontext(5)] HRESULT PartnerDisplayName([out, retval] BSTR *pVal);
00731       [propget, id(5), helpstring(hsICall_ConferenceId),helpcontext(5)] HRESULT ConferenceId([out, retval] LONG *pVal);
00732       [propget, id(6), helpstring(hsICall_Type),helpcontext(5)] HRESULT Type([out, retval] TCallType *pVal);
00733       [propget, id(7), helpstring(hsICall_Status),helpcontext(5)] HRESULT Status([out, retval] TCallStatus *pVal);
00734       [propput, id(7), helpstring(hsICall_Status),helpcontext(5)] HRESULT Status([in] TCallStatus newVal);
00735       [propget, id(8), helpstring(hsICall_FailReason),helpcontext(5)] HRESULT FailureReason([out, retval] TCallFailureReason *pVal);
00736       [propget, id(9), helpstring(hsICall_Subject),helpcontext(5)] HRESULT Subject([out, retval] BSTR *pVal);
00737       [propget, id(10), helpstring(hsICall_PSTN_Number),helpcontext(5)] HRESULT PstnNumber([out, retval] BSTR *pVal);
00738       [propget, id(11), helpstring(hsICall_Duration),helpcontext(5)] HRESULT Duration([out, retval] LONG *pVal);
00739       [propget, id(12), helpstring(hsICall_PSTN_Status),helpcontext(5)] HRESULT PstnStatus([out, retval] BSTR *pVal);
00740       [propput, id(13), helpstring(hsICall_Seen),helpcontext(5)] HRESULT Seen([in] VARIANT_BOOL newVal);
00741       [id(14), helpstring(hsICall_Hold),helpcontext(5)] HRESULT Hold();
00742       [id(15), helpstring(hsICall_Resume),helpcontext(5)] HRESULT Resume();
00743       [id(16), helpstring(hsICall_Finish),helpcontext(5)] HRESULT Finish();
00744       [id(17), helpstring(hsICall_Answer),helpcontext(5)] HRESULT Answer();
00745       [propput, id(18), helpstring(hsICall_DTMF),helpcontext(5)] HRESULT DTMF([in] BSTR newVal);
00746       [propget, id(19), helpstring(hsICall_Participants),helpcontext(5)] HRESULT Participants([out, retval] IParticipantCollection **pVal);
00747       [id(20), helpstring(hsICall_Join),helpcontext(5)] HRESULT Join([in] LONG Id);
00748       [propget, id(21), helpstring(hsICall_VmDuration),helpcontext(5)] HRESULT VmDuration([out, retval] LONG *pVal);
00749       [propget, id(22), helpstring(hsICall_VmAllowDuration),helpcontext(5)] HRESULT VmAllowedDuration([out, retval] LONG *pVal);
00750       [propget, id(23), helpstring(hsICall_VStatus),helpcontext(5)] HRESULT VideoStatus([out, retval] TCallVideoStatus *pVal);
00751       [propget, id(24), helpstring(hsICall_VSendStatus),helpcontext(5)] HRESULT VideoSendStatus([out, retval] TCallVideoSendStatus *pVal);
00752       [propget, id(25), helpstring(hsICall_VRecvStatus),helpcontext(5)] HRESULT VideoReceiveStatus([out, retval] TCallVideoSendStatus *pVal);
00753       [id(26), helpstring(hsICall_StartVSend),helpcontext(5)] HRESULT StartVideoSend();
00754       [id(27), helpstring(hsICall_StopVSend),helpcontext(5)] HRESULT StopVideoSend();
00755       [id(28), helpstring(hsICall_StartVRecv),helpcontext(5)] HRESULT StartVideoReceive();
00756       [id(29), helpstring(hsICall_StopVRecv),helpcontext(5)] HRESULT StopVideoReceive();
00757       [id(30), helpstring(hsICall_Redirect),helpcontext(5)] HRESULT RedirectToVoicemail();
00758       [id(31), helpstring(hsICall_Forward),helpcontext(5)] HRESULT Forward();
00759       [propget, id(32), helpstring(hsICall_Rate),helpcontext(5)] HRESULT Rate([out, retval] LONG *pVal);
00760       [propget, id(33), helpstring(hsICall_RateCurr),helpcontext(5)] HRESULT RateCurrency([out, retval] BSTR *pVal);
00761       [propget, id(34), helpstring(hsICall_RatePrecision),helpcontext(5)] HRESULT RatePrecision([out, retval] LONG *pVal);
00762       [propget, id(35), helpstring(hsICall_InputDevice),helpcontext(5)] HRESULT InputDevice([in] TCallIoDeviceType DeviceType, [out, retval] BSTR* pVal);
00763       [propput, id(35), helpstring(hsICall_InputDevice),helpcontext(5)] HRESULT InputDevice([in] TCallIoDeviceType DeviceType, [in] BSTR newVal);
00764       [propget, id(36), helpstring(hsICall_OutputDevice),helpcontext(5)] HRESULT OutputDevice([in] TCallIoDeviceType DeviceType, [out, retval] BSTR* pVal);
00765       [propput, id(36), helpstring(hsICall_OutputDevice),helpcontext(5)] HRESULT OutputDevice([in] TCallIoDeviceType DeviceType, [in] BSTR newVal);
00766       [propget, id(37), helpstring(hsICall_MicDevice),helpcontext(5)] HRESULT CaptureMicDevice([in] TCallIoDeviceType DeviceType, [out, retval] BSTR* pVal);
00767       [propput, id(37), helpstring(hsICall_MicDevice),helpcontext(5)] HRESULT CaptureMicDevice([in] TCallIoDeviceType DeviceType, [in] BSTR newVal);
00768       [propget, id(38), helpstring(hsICall_InputStatus),helpcontext(5)] HRESULT InputStatus([out, retval] VARIANT_BOOL* pVal);
00769       [propget, id(39), helpstring(hsICall_ForwardedBy),helpcontext(5)] HRESULT ForwardedBy([out, retval] BSTR* pVal);
00770       [propget, id(13), helpstring(hsICall_Seen),helpcontext(5)] HRESULT Seen([out, retval] VARIANT_BOOL *pVal);
00771       [propget, id(40), helpstring(hsICall_CanTransfer),helpcontext(5)] HRESULT CanTransfer([in] BSTR Target, [out, retval] VARIANT_BOOL* pVal);
00772       [propget, id(41), helpstring(hsICall_TransferStatus),helpcontext(5)] HRESULT TransferStatus([out, retval] TCallStatus* pVal);
00773       [propget, id(42), helpstring(hsICall_TransferActive),helpcontext(5)] HRESULT TransferActive([out, retval] VARIANT_BOOL* pVal);
00774       [propget, id(43), helpstring(hsICall_TransferredBy),helpcontext(5)] HRESULT TransferredBy([out, retval] BSTR* pVal);
00775       [propget, id(44), helpstring(hsICall_TransferredTo),helpcontext(5)] HRESULT TransferredTo([out, retval] BSTR* pVal);
00776       [id(45), helpstring(hsICall_Transfer),helpcontext(5)] HRESULT Transfer([in] BSTR Target);
00777       [propget, id(46), helpstring(hsICall_TargetIdentity),helpcontext(5)] HRESULT TargetIdentity([out, retval] BSTR *pVal);
00778    };
00779    [
00780       object,
00781       uuid(72E1EC13-0DF9-48AE-8A31-E2900D85BA55),
00782       dual,
00783       nonextensible,
00784       pointer_default(unique),
00785       oleautomation,
00786       helpstring(hsICallColl),
00787       helpcontext(6)
00788    ]
00789    interface ICallCollection : IDispatch
00790    {
00791       [propget, id(1), helpstring(hsICallColl_Count),helpcontext(6)] HRESULT Count([out, retval] LONG* pVal);
00792       [id(2), helpstring(hsICallColl_Add),helpcontext(6)] HRESULT Add([in] ICall* pCall);
00793       [id(3), helpstring(hsICallColl_Remove),helpcontext(6)] HRESULT Remove([in] long Index);
00794       [id(4), helpstring(hsICallColl_RemoveAll),helpcontext(6)] HRESULT RemoveAll(void);
00795       [propget, id(DISPID_VALUE), helpstring(hsICallColl_Item),helpcontext(6)] HRESULT Item([in] LONG Index, [out, retval] ICall ** pVal);
00796       [propget, id(DISPID_NEWENUM), helpstring(hsICallColl_NewEnum),helpcontext(6)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
00797    };
00798
00799    interface IChat;
00800    [
00801       object,
00802       uuid(4CFF5C70-3C95-4566-824A-FA164586D535),
00803       dual,
00804       nonextensible,
00805       pointer_default(unique),
00806       oleautomation,
00807       helpstring(hsIChatMessage),
00808       helpcontext(11)
00809    ]
00810    interface IChatMessage : IDispatch
00811    {
00812       [propget, id(1), helpstring(hsIChatMsg_Id), helpcontext(11)] HRESULT Id([out, retval] LONG *pVal);
00813       [propget, id(2), helpstring(hsIChatMsg_Timestamp), helpcontext(11)] HRESULT Timestamp([out, retval] DATE *pVal);
00814       [propget, id(3), helpstring(hsIChatMsg_FromHandle), helpcontext(11)] HRESULT FromHandle([out, retval] BSTR *pVal);
00815       [propget, id(4), helpstring(hsIChatMsg_FromDispName), helpcontext(11)] HRESULT FromDisplayName([out, retval] BSTR *pVal);
00816       [propget, id(5), helpstring(hsIChatMsg_Type), helpcontext(11)] HRESULT Type([out, retval] TChatMessageType *pVal);
00817       [propget, id(6), helpstring(hsIChatMsg_Status), helpcontext(11)] HRESULT Status([out, retval] TChatMessageStatus *pVal);
00818       [propget, id(7), helpstring(hsIChatMsg_LeaveReason), helpcontext(11)] HRESULT LeaveReason([out, retval] TChatLeaveReason *pVal);
00819       [propget, id(8), helpstring(hsIChatMsg_Body), helpcontext(11)] HRESULT Body([out, retval] BSTR *pVal);
00820       [propget, id(9), helpstring(hsIChatMsg_ChatName), helpcontext(11)] HRESULT ChatName([out, retval] BSTR *pVal);
00821       [propget, id(10), helpstring(hsIChatMsg_Users), helpcontext(11)] HRESULT Users([out, retval] IUserCollection **pVal);
00822       [propput, id(11), helpstring(hsIChatMsg_Seen), helpcontext(11)] HRESULT Seen([in] VARIANT_BOOL newVal);
00823       [propget, id(12), helpstring(hsIChatMsg_Chat), helpcontext(11)] HRESULT Chat([out, retval] IChat** pVal);
00824       [propget, id(13), helpstring(hsIChatMsg_Sender), helpcontext(11)] HRESULT Sender([out, retval] IUser* *pVal);
00825       [propget, id(14), helpstring(hsIChatMsg_EditedBy), helpcontext(11)] HRESULT EditedBy([out, retval] BSTR* pVal);
00826       [propget, id(15), helpstring(hsIChatMsg_EditTime), helpcontext(11)] HRESULT EditedTimestamp([out, retval] DATE* pVal);
00827       [propput, id(8), helpstring(hsIChatMsg_Body), helpcontext(11)] HRESULT Body([in] BSTR newVal);
00828       [propget, id(16), helpstring(hsIChatMsg_Role), helpcontext(11)] HRESULT Role([out, retval] TChatMemberRole* pVal);
00829       [propget, id(17), helpstring(hsIChatMsg_Options), helpcontext(11)] HRESULT Options([out, retval] LONG* pVal);
00830       [propget, id(18), helpstring(hsIChatMsg_Editable), helpcontext(11)] HRESULT IsEditable([out, retval] VARIANT_BOOL* pVal);
00831       [propget, id(19), helpstring(hsIChatMsg_Guid), helpcontext(11)] HRESULT Guid([out, retval] BSTR* pVal);
00832    };
00833    [
00834       object,
00835       uuid(9511117A-7BCA-4669-BE96-6EA6866975C1),
00836       dual,
00837       nonextensible,
00838       pointer_default(unique),
00839       oleautomation,
00840       helpstring(hsIChatMessageColl),
00841       helpcontext(12)
00842    ]
00843    interface IChatMessageCollection : IDispatch
00844    {
00845       [propget, id(1), helpstring(hsIChatMsgColl_Count),helpcontext(12)] HRESULT Count([out, retval] LONG* pVal);
00846       [id(2), helpstring(hsIChatMsgColl_Add),helpcontext(12)] HRESULT Add([in] IChatMessage* pItem);
00847       [id(3), helpstring(hsIChatMsgColl_Remove),helpcontext(12)] HRESULT Remove([in] long Index);
00848       [id(4), helpstring(hsIChatMsgColl_RemoveAll),helpcontext(12)] HRESULT RemoveAll(void);
00849       [propget, id(DISPID_VALUE), helpstring(hsIChatMsgColl_Item),helpcontext(12)] HRESULT Item([in] LONG Index, [out, retval] IChatMessage ** pVal);
00850       [propget, id(DISPID_NEWENUM), helpstring(hsIChatMsgColl_NewEnum),helpcontext(12)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
00851    };
00852
00853    [
00854       object,
00855       uuid(9E9F0473-94C2-4FDD-85D2-43E3478765F9),
00856       dual,
00857       nonextensible,
00858       pointer_default(unique),
00859       oleautomation,
00860       helpstring(hsIChatMember),
00861       helpcontext(85)
00862    ]
00863    interface IChatMember : IDispatch
00864    {
00865       [propget, id(1), helpstring(hsIChatMember_Id), helpcontext(85)] HRESULT Id([out, retval] BSTR* pVal);
00866       [propget, id(2), helpstring(hsIChatMember_Handle), helpcontext(85)] HRESULT Handle([out, retval] BSTR* pVal);
00867       [propget, id(3), helpstring(hsIChatMember_Role), helpcontext(85)] HRESULT Role([out, retval] TChatMemberRole* pVal);
00868       [propput, id(3), helpstring(hsIChatMember_Role), helpcontext(85)] HRESULT Role([in] TChatMemberRole newVal);
00869       [propget, id(4), helpstring(hsIChatMember_CanSetRole), helpcontext(85)] HRESULT CanSetRoleTo([in] TChatMemberRole Role, [out, retval] VARIANT_BOOL* pVal);
00870       [propget, id(5), helpstring(hsIChatMember_IsActive), helpcontext(85)] HRESULT IsActive([out, retval] VARIANT_BOOL* pVal);
00871       [propget, id(6), helpstring(hsIChatMember_Chat), helpcontext(85)] HRESULT Chat([out, retval] IChat** pVal);
00872    };
00873
00874    [
00875       object,
00876       uuid(8FFC686B-2E5E-4763-8B03-FF4FD3A0C4DA),
00877       dual,
00878       pointer_default(unique),
00879       helpstring(hsIChatMemberCollection),
00880       helpcontext(86)
00881    ]
00882    interface IChatMemberCollection : IDispatch
00883    {
00884       [propget, id(1), helpstring(hsIChatMemberCollection_Count),helpcontext(86)] HRESULT Count([out, retval] LONG* pVal);
00885       [propget, id(DISPID_VALUE), helpstring(hsIChatMemberCollection_Item),helpcontext(86)] HRESULT Item([in] LONG Index, [out, retval] IChatMember ** pVal);
00886       [propget, id(DISPID_NEWENUM), helpstring(hsIChatMemberCollection_NewEnum),helpcontext(86)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
00887    };
00888
00889    [
00890       object,
00891       uuid(8C24106C-3368-4580-93E5-5ED4ACCDE306),
00892       dual,
00893       nonextensible,
00894       pointer_default(unique),
00895       oleautomation,
00896       helpstring(hsIChat),
00897       helpcontext(31)
00898    ]
00899    interface IChat : IDispatch
00900    {
00901       [propget, id(1), helpstring(hsIChat_Name), helpcontext(31)] HRESULT Name([out, retval] BSTR *pVal);
00902       [propget, id(2), helpstring(hsIChat_Messages), helpcontext(31)] HRESULT Messages([out, retval] IChatMessageCollection **pVal);
00903       [propget, id(3), helpstring(hsIChat_Timestamp), helpcontext(31)] HRESULT Timestamp([out, retval] DATE *pVal);
00904       [propget, id(4), helpstring(hsIChat_Adder), helpcontext(31)] HRESULT Adder([out, retval] IUser **pVal);
00905       [propget, id(5), helpstring(hsIChat_Status), helpcontext(31)] HRESULT Status([out, retval] TChatStatus *pVal);
00906       [propget, id(6), helpstring(hsIChat_Posters), helpcontext(31)] HRESULT Posters([out, retval] IUserCollection **pVal);
00907       [propget, id(7), helpstring(hsIChat_Members), helpcontext(31)] HRESULT Members([out, retval] IUserCollection **pVal);
00908       [propget, id(8), helpstring(hsIChat_Topic), helpcontext(31)] HRESULT Topic([out, retval] BSTR *pVal);
00909       [propput, id(8), helpstring(hsIChat_Topic), helpcontext(31)] HRESULT Topic([in] BSTR newVal);
00910       [propget, id(9), helpstring(hsIChat_ActiveMembers), helpcontext(31)] HRESULT ActiveMembers([out, retval] IUserCollection **pVal);
00911       [propget, id(10), helpstring(hsIChat_FriendlyName), helpcontext(31)] HRESULT FriendlyName([out, retval] BSTR *pVal);
00912       [id(11), helpstring(hsIChat_OpenWindow), helpcontext(31)] HRESULT OpenWindow();
00913       [id(12), helpstring(hsIChat_SendMessage), helpcontext(31)] HRESULT SendMessage([in] BSTR MessageText, [out, retval] IChatMessage **pVal);
00914       [id(13), helpstring(hsIChat_Leave), helpcontext(31)] HRESULT Leave();
00915       [id(14), helpstring(hsIChat_AddMembers), helpcontext(31)] HRESULT AddMembers([in] IUserCollection* pMembers);
00916       [propget, id(15), helpstring(hsIChat_RecentMessages), helpcontext(31)] HRESULT RecentMessages([out, retval] IChatMessageCollection **pVal);
00917       [propget, id(16), helpstring(hsIChat_Bookmarked)] HRESULT Bookmarked([out, retval] VARIANT_BOOL *pVal);
00918       [id(17), helpstring(hsIChat_Bookmark)] HRESULT Bookmark();
00919       [id(18), helpstring(hsIChat_Bookmark)] HRESULT Unbookmark();
00920       [propget, id(19), helpstring(hsIChat_TopicXML), helpcontext(31)] HRESULT TopicXML([out, retval] BSTR *pVal);
00921       [propput, id(19), helpstring(hsIChat_TopicXML), helpcontext(31)] HRESULT TopicXML([in] BSTR newVal);
00922       [propget, id(20), helpstring(hsIChat_MemberObjs), helpcontext(31)] HRESULT MemberObjects([out, retval] IChatMemberCollection **pVal);
00923       [propget, id(21), helpstring(hsIChat_Blob), helpcontext(31)] HRESULT Blob([out, retval] BSTR* pVal);
00924       [propget, id(22), helpstring(hsIChat_Options), helpcontext(31)] HRESULT Options([out, retval] LONG* pVal);
00925       [propput, id(22), helpstring(hsIChat_Options), helpcontext(31)] HRESULT Options([in] LONG newVal);
00926       [propget, id(23), helpstring(hsIChat_Passwdhint), helpcontext(31)] HRESULT PasswordHint([out, retval] BSTR* pVal);
00927       [id(24), helpstring(hsIChat_Password), helpcontext(31)] HRESULT SetPassword([in] BSTR Password, [in, defaultvalue("")] BSTR Hint);
00928       [propget, id(25), helpstring(hsIChat_Guidelines), helpcontext(31)] HRESULT GuideLines([out, retval] BSTR* pVal);
00929       [propput, id(25), helpstring(hsIChat_Guidelines), helpcontext(31)] HRESULT GuideLines([in] BSTR newVal);
00930       [propget, id(26), helpstring(hsIChat_Description), helpcontext(31)] HRESULT Description([out, retval] BSTR* pVal);
00931       [propput, id(26), helpstring(hsIChat_Description), helpcontext(31)] HRESULT Description([in] BSTR newVal);
00932       [propget, id(27), helpstring(hsIChat_DialogPartner), helpcontext(31)] HRESULT DialogPartner([out, retval] BSTR* pVal);
00933       [propget, id(28), helpstring(hsIChat_ActiveTime), helpcontext(31)] HRESULT ActivityTimestamp([out, retval] DATE* pVal);
00934       [propget, id(29), helpstring(hsIChat_MyRole), helpcontext(31)] HRESULT MyRole([out, retval] TChatMemberRole* pVal);
00935       [propget, id(30), helpstring(hsIChat_Applicants), helpcontext(31)] HRESULT Applicants([out, retval] IUserCollection** pVal);
00936       [id(31), helpstring(hsIChat_Join), helpcontext(31)] HRESULT Join(void);
00937       [id(32), helpstring(hsIChat_Kick), helpcontext(31)] HRESULT Kick([in] BSTR Handle);
00938       [id(33), helpstring(hsIChat_Kickban), helpcontext(31)] HRESULT KickBan([in] BSTR Handle);
00939       [id(34), helpstring(hsIChat_Disband), helpcontext(31)] HRESULT Disband(void);
00940       [id(35), helpstring(hsIChat_EnterPasswd), helpcontext(31)] HRESULT EnterPassword([in] BSTR Password);
00941       [id(36), helpstring(hsIChat_ClearRecentMsg), helpcontext(31)] HRESULT ClearRecentMessages(void);
00942       [id(37), helpstring(hsIChat_AcceptAdd), helpcontext(31)] HRESULT AcceptAdd(void);
00943       [propput, id(38), helpstring(hsIChat_AlertString), helpcontext(31)] HRESULT AlertString([in] BSTR newVal);
00944       [propget, id(39), helpstring(hsIChat_Type), helpcontext(31)] HRESULT Type([out, retval] TChatType* pVal);
00945       [propget, id(40), helpstring(hsIChat_MyStatus), helpcontext(31)] HRESULT MyStatus([out, retval] TChatMyStatus* pVal);
00946    };
00947    [
00948       object,
00949       uuid(052A4165-010A-457D-A874-E661B6322846),
00950       dual,
00951       nonextensible,
00952       pointer_default(unique),
00953       oleautomation,
00954       helpstring(hsIChatColl),
00955       helpcontext(32)
00956    ]
00957    interface IChatCollection : IDispatch
00958    {
00959       [propget, id(1), helpstring(hsIChatColl_Count),helpcontext(32)] HRESULT Count([out, retval] LONG* pVal);
00960       [id(2), helpstring(hsIChatColl_Add),helpcontext(32)] HRESULT Add([in] IChat* pItem);
00961       [id(3), helpstring(hsIChatColl_Remove),helpcontext(32)] HRESULT Remove([in] long Index);
00962       [id(4), helpstring(hsIChatColl_RemoveAll),helpcontext(32)] HRESULT RemoveAll(void);
00963       [propget, id(DISPID_VALUE), helpstring(hsIChatColl_Item),helpcontext(32)] HRESULT Item([in] LONG Index, [out, retval] IChat ** pVal);
00964       [propget, id(DISPID_NEWENUM), helpstring(hsIChatColl_NewEnum),helpcontext(32)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
00965    };
00966    [
00967       object,
00968       uuid(AEB48497-5090-479C-8BE0-BD51597156A1),
00969       dual,
00970       nonextensible,
00971       pointer_default(unique),
00972       oleautomation,
00973       helpstring(hsIConference),
00974       helpcontext(39)
00975    ]
00976    interface IConference : IDispatch
00977    {
00978       [propget, id(1), helpstring(hsIConference_Id), helpcontext(39)] HRESULT Id([out, retval] LONG *pVal);
00979       [propget, id(2), helpstring(hsIConference_Calls), helpcontext(39)] HRESULT Calls([out, retval] ICallCollection **pVal);
00980       [propget, id(3), helpstring(hsIConference_ActiveCalls), helpcontext(39)] HRESULT ActiveCalls([out, retval] ICallCollection **pVal);
00981       [id(4), helpstring(hsIConference_Hold), helpcontext(39)] HRESULT Hold();
00982       [id(5), helpstring(hsIConference_Resume), helpcontext(39)] HRESULT Resume();
00983       [id(6), helpstring(hsIConference_Finish), helpcontext(39)] HRESULT Finish();
00984    };
00985    [
00986       object,
00987       uuid(F3E0C529-7D4F-4AF5-B501-27D25D4D2825),
00988       dual,
00989       nonextensible,
00990       pointer_default(unique),
00991       oleautomation,
00992       helpstring(hsIConferenceColl),
00993       helpcontext(40)
00994    ]
00995    interface IConferenceCollection : IDispatch
00996    {
00997       [propget, id(1), helpstring(hsIConferenceColl_Count), helpcontext(40)] HRESULT Count([out, retval] LONG* pVal);
00998       [id(2), helpstring(hsIConferenceColl_Add), helpcontext(40)] HRESULT Add([in] IConference* pItem);
00999       [id(3), helpstring(hsIConferenceColl_Remove), helpcontext(40)] HRESULT Remove([in] long Index);
01000       [id(4), helpstring(hsIConferenceColl_RemoveAll), helpcontext(40)] HRESULT RemoveAll(void);
01001       [propget, id(DISPID_VALUE), helpstring(hsIConferenceColl_Item), helpcontext(40)] HRESULT Item([in] LONG Index, [out, retval] IConference ** pVal);
01002       [propget, id(DISPID_NEWENUM), helpstring(hsIConferenceColl_NewEnum), helpcontext(40)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01003    };
01004    [
01005       object,
01006       uuid(8D82F88A-B307-4074-8ED5-11C3BD213452),
01007       dual,
01008       nonextensible,
01009       pointer_default(unique),
01010       oleautomation,
01011       helpstring(hsIConversion),
01012       helpcontext(10)
01013    ]
01014    interface IConversion : IDispatch
01015    {
01016       [id(1), helpstring(hsIConversion_OnlineStatus), helpcontext(10)] HRESULT OnlineStatusToText([in] TOnlineStatus status, [out, retval] BSTR *pVal);
01017       [id(2), helpstring(hsIConversion_TxOnlineStatus), helpcontext(10)] HRESULT TextToOnlineStatus([in] BSTR Text, [out, retval] TOnlineStatus *pVal);
01018       [id(3), helpstring(hsIConversion_BuddyStatus), helpcontext(10)] HRESULT BuddyStatusToText([in] TBuddyStatus status, [out, retval] BSTR *pVal);
01019       [id(4), helpstring(hsIConversion_TxBuddyStatus), helpcontext(10)] HRESULT TextToBuddyStatus([in] BSTR Text, [out, retval] TBuddyStatus *pVal);
01020       [id(5), helpstring(hsIConversion_CallStatus), helpcontext(10)] HRESULT CallStatusToText([in] TCallStatus Status, [out, retval] BSTR *pVal);
01021       [id(6), helpstring(hsIConversion_TxCallStatus), helpcontext(10)] HRESULT TextToCallStatus([in] BSTR Text, [out, retval] TCallStatus *pVal);
01022       [id(7), helpstring(hsIConversion_CallType), helpcontext(10)] HRESULT CallTypeToText([in] TCallType CallType, [out, retval] BSTR *pVal);
01023       [id(8), helpstring(hsIConversion_TxCallType), helpcontext(10)] HRESULT TextToCallType([in] BSTR Text, [out, retval] TCallType *pVal);
01024       [id(9), helpstring(hsIConversion_UserSex), helpcontext(10)] HRESULT UserSexToText([in] TUserSex Sex, [out, retval] BSTR *pVal);
01025       [id(10), helpstring(hsIConversion_TxUserSex), helpcontext(10)] HRESULT TextToUserSex([in] BSTR Text, [out, retval] TUserSex *pVal);
01026       [id(11), helpstring(hsIConversion_ConnStatus), helpcontext(10)] HRESULT ConnectionStatusToText([in] TConnectionStatus Status, [out, retval] BSTR *pVal);
01027       [id(12), helpstring(hsIConversion_TxConnStatus), helpcontext(10)] HRESULT TextToConnectionStatus([in] BSTR Text, [out, retval] TConnectionStatus *pVal);
01028       [id(13), helpstring(hsIConversion_UserStatus), helpcontext(10)] HRESULT UserStatusToText([in] TUserStatus Status, [out, retval] BSTR *pVal);
01029       [id(14), helpstring(hsIConversion_TxUserStatus), helpcontext(10)] HRESULT TextToUserStatus([in] BSTR Text, [out, retval] TUserStatus *pVal);
01030       [id(15), helpstring(hsIConversion_FailReason), helpcontext(10)] HRESULT CallFailureReasonToText([in] TCallFailureReason reason, [out, retval] BSTR *pVal);
01031       [id(16), helpstring(hsIConversion_AttachStatus), helpcontext(10)] HRESULT AttachmentStatusToText([in] TAttachmentStatus status, [out, retval] BSTR *pVal);
01032       [id(17), helpstring(hsIConversion_LeaveReason), helpcontext(10)] HRESULT ChatLeaveReasonToText([in] TChatLeaveReason reason, [out, retval] BSTR *pVal);
01033       [id(18), helpstring(hsIConversion_ChatStatus), helpcontext(10)] HRESULT ChatStatusToText([in] TChatStatus status, [out, retval] BSTR *pVal);
01034       [id(19), helpstring(hsIConversion_VmType), helpcontext(10)] HRESULT VoicemailTypeToText([in] TVoicemailType type, [out, retval] BSTR *pVal);
01035       [id(20), helpstring(hsIConversion_VmStatus), helpcontext(10)] HRESULT VoicemailStatusToText([in] TVoicemailStatus status, [out, retval] BSTR *pVal);
01036       [id(21), helpstring(hsIConversion_TxVmStatus), helpcontext(10)] HRESULT TextToVoicemailStatus([in] BSTR Text, [out, retval] TVoicemailStatus* pVal);
01037       [id(22), helpstring(hsIConversion_VmFailureReason), helpcontext(10)] HRESULT VoicemailFailureReasonToText([in] TVoicemailFailureReason code, [out, retval] BSTR *pVal);
01038       [id(23), helpstring(hsIConversion_MessStatus), helpcontext(10)] HRESULT ChatMessageStatusToText([in] TChatMessageStatus Status, [out, retval] BSTR *pVal);
01039       [id(24), helpstring(hsIConversion_TxMessStatus), helpcontext(10)] HRESULT TextToChatMessageStatus([in] BSTR Text, [out, retval] TChatMessageStatus *pVal);
01040       [id(25), helpstring(hsIConversion_MessType), helpcontext(10)] HRESULT ChatMessageTypeToText([in] TChatMessageType Type, [out, retval] BSTR *pVal);
01041       [id(26), helpstring(hsIConversion_TxMessType), helpcontext(10)] HRESULT TextToChatMessageType([in] BSTR Text, [out, retval] TChatMessageType *pVal);
01042       [id(27), helpstring(hsIConversion_TxAttachStat), helpcontext(10)] HRESULT TextToAttachmentStatus([in] BSTR Text, [out, retval] TAttachmentStatus *pVal);
01043       [id(28), helpstring(hsIConversion_GrpType), helpcontext(10)] HRESULT GroupTypeToText([in] TGroupType Type, [out, retval] BSTR *pVal);
01044       [id(29), helpstring(hsIConversion_TxGrpType), helpcontext(10)] HRESULT TextToGroupType([in] BSTR Text, [out, retval] TGroupType *pVal);
01045       [id(30), helpstring(hsIConversion_VideoStatus), helpcontext(10)] HRESULT CallVideoStatusToText([in] TCallVideoStatus Status, [out, retval] BSTR *pVal);
01046       [id(31), helpstring(hsIConversion_VideoSendStatus), helpcontext(10)] HRESULT CallVideoSendStatusToText([in] TCallVideoSendStatus Status, [out, retval] BSTR *pVal);
01047       [propget, id(32), helpstring(hsIConversion_Language), helpcontext(10)] HRESULT Language([out, retval] BSTR *pVal);
01048       [propput, id(32), helpstring(hsIConversion_Language), helpcontext(10)] HRESULT Language([in] BSTR newVal);
01049       [id(33), helpstring(hsIConversion_SmsStatus), helpcontext(10)] HRESULT SmsMessageStatusToText([in] TSmsMessageStatus status, [out, retval] BSTR *pVal);
01050       [id(34), helpstring(hsIConversion_SmsType), helpcontext(10)] HRESULT SmsMessageTypeToText([in] TSmsMessageType type, [out, retval] BSTR *pVal);
01051       [id(35), helpstring(hsIConversion_SmsTargetStatus), helpcontext(10)] HRESULT SmsTargetStatusToText([in] TSmsTargetStatus status, [out, retval] BSTR *pVal);
01052    };
01053    [
01054       object,
01055       uuid(120B425E-6313-4924-B5A9-3E9F2E444A00),
01056       dual,
01057       nonextensible,
01058       pointer_default(unique),
01059       oleautomation,
01060       helpstring(hsIVoicemail),
01061       helpcontext(51)
01062    ]
01063    interface IVoicemail : IDispatch
01064    {
01065       [propget, id(1), helpstring(hsIVoicemail_Type), helpcontext(51)] HRESULT Type([out, retval] TVoicemailType *pVal);
01066       [propget, id(2), helpstring(hsIVoicemail_PartHandle), helpcontext(51)] HRESULT PartnerHandle([out, retval] BSTR *pVal);
01067       [propget, id(3), helpstring(hsIVoicemail_PartDispName), helpcontext(51)] HRESULT PartnerDisplayName([out, retval] BSTR *pVal);
01068       [propget, id(4), helpstring(hsIVoicemail_Status), helpcontext(51)] HRESULT Status([out, retval] TVoicemailStatus *pVal);
01069       [propget, id(5), helpstring(hsIVoicemail_FailureReason), helpcontext(51)] HRESULT FailureReason([out, retval] TVoicemailFailureReason *pVal);
01070       [propget, id(6), helpstring(hsIVoicemail_Timestamp), helpcontext(51)] HRESULT Timestamp([out, retval] DATE *pVal);
01071       [propget, id(7), helpstring(hsIVoicemail_Duration), helpcontext(51)] HRESULT Duration([out, retval] LONG *pVal);
01072       [propget, id(8), helpstring(hsIVoicemail_AllowedDuration), helpcontext(51)] HRESULT AllowedDuration([out, retval] LONG *pVal);
01073       [propget, id(9), helpstring(hsIVoicemail_Id), helpcontext(51)] HRESULT Id([out, retval] LONG *pVal);
01074       [id(10), helpstring(hsIVoicemail_Open), helpcontext(51)] HRESULT Open();
01075       [id(11), helpstring(hsIVoicemail_StartPlay), helpcontext(51)] HRESULT StartPlayback();
01076       [id(12), helpstring(hsIVoicemail_StopPlay), helpcontext(51)] HRESULT StopPlayback();
01077       [id(13), helpstring(hsIVoicemail_Upload), helpcontext(51)] HRESULT Upload();
01078       [id(14), helpstring(hsIVoicemail_Download), helpcontext(51)] HRESULT Download();
01079       [id(15), helpstring(hsIVoicemail_StartRec), helpcontext(51)] HRESULT StartRecording();
01080       [id(16), helpstring(hsIVoicemail_StopRec), helpcontext(51)] HRESULT StopRecording();
01081       [id(17), helpstring(hsIVoicemail_Delete), helpcontext(51)] HRESULT Delete();
01082       [id(18), helpstring(hsIVoicemail_PlayInCall), helpcontext(51)] HRESULT StartPlaybackInCall();
01083       [id(19), helpstring(hsIVoicemail_Unplayed), helpcontext(51)] HRESULT SetUnplayed();
01084    };
01085    [
01086       object,
01087       uuid(21494848-BBD5-4192-BE32-57D1A19D8E94),
01088       dual,
01089       nonextensible,
01090       pointer_default(unique),
01091       oleautomation,
01092       helpstring(hsIVoicemailColl),
01093       helpcontext(52)
01094
01095    ]
01096    interface IVoicemailCollection : IDispatch
01097    {
01098       [propget, id(1), helpstring(hsIVoicemailColl_Count),helpcontext(52)] HRESULT Count([out, retval] LONG* pVal);
01099       [id(2), helpstring(hsIVoicemailColl_Add),helpcontext(52)] HRESULT Add([in] IVoicemail* pItem);
01100       [id(3), helpstring(hsIVoicemailColl_Remove),helpcontext(52)] HRESULT Remove([in] long Index);
01101       [id(4), helpstring(hsIVoicemailColl_RemoveAll),helpcontext(52)] HRESULT RemoveAll(void);
01102       [propget, id(DISPID_VALUE), helpstring(hsIVoicemailColl_Item),helpcontext(52)] HRESULT Item([in] LONG Index, [out, retval] IVoicemail ** pVal);
01103       [propget, id(DISPID_NEWENUM), helpstring(hsIVoicemailColl_NewEnum),helpcontext(52)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01104    };
01105    [
01106       object,
01107       uuid(E072F615-F833-4BCA-B473-CEE44D302030),
01108       dual,
01109       nonextensible,
01110       pointer_default(unique),
01111       oleautomation,
01112       helpstring(hsIApplicationStream),
01113       helpcontext(56)
01114    ]
01115    interface IApplicationStream : IDispatch
01116    {
01117       [propget, id(1), helpstring(hsIAppStm_AppName), helpcontext(56)] HRESULT ApplicationName([out, retval] BSTR *pVal);
01118       [propget, id(2), helpstring(hsIAppStm_Handle), helpcontext(56)] HRESULT Handle([out, retval] BSTR *pVal);
01119       [id(3), helpstring(hsIAppStm_Read), helpcontext(56)] HRESULT Read([out, retval] BSTR *pText);
01120       [id(4), helpstring(hsIAppStm_Write), helpcontext(56)] HRESULT Write([in] BSTR Text);
01121       [id(5), helpstring(hsIAppStm_SendData), helpcontext(56)] HRESULT SendDatagram([in] BSTR Text);
01122       [propget, id(6), helpstring(hsIAppStm_DataLen), helpcontext(56)] HRESULT DataLength([out, retval] LONG *pVal);
01123       [id(7), helpstring(hsIAppStm_Disconnect), helpcontext(56)] HRESULT Disconnect();
01124       [propget, id(8), helpstring(hsIAppStm_PartnerHandle), helpcontext(56)] HRESULT PartnerHandle([out, retval] BSTR *pVal);
01125    };
01126    [
01127       object,
01128       uuid(D8F1BCC4-2A73-47B9-83B3-D4D299CA5BC6),
01129       dual,
01130       nonextensible,
01131       pointer_default(unique),
01132       oleautomation,
01133       helpstring(hsIApplicationStreamColl),
01134       helpcontext(58)
01135    ]
01136    interface IApplicationStreamCollection : IDispatch
01137    {
01138       [propget, id(1), helpstring(hsIAppStmColl_Count),helpcontext(58)] HRESULT Count([out, retval] LONG* pVal);
01139       [id(2), helpstring(hsIAppStmColl_Add),helpcontext(58)] HRESULT Add([in] IApplicationStream* pItem);
01140       [id(3), helpstring(hsIAppStmColl_Remove),helpcontext(58)] HRESULT Remove([in] long Index);
01141       [id(4), helpstring(hsIAppStmColl_RemoveAll),helpcontext(58)] HRESULT RemoveAll(void);
01142       [propget, id(DISPID_VALUE), helpstring(hsIAppStmColl_Item),helpcontext(58)] HRESULT Item([in] LONG Index, [out, retval] IApplicationStream** pVal);
01143       [propget, id(DISPID_NEWENUM), helpstring(hsIAppStmColl_NewEnum),helpcontext(58)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01144    };
01145    [
01146       object,
01147       uuid(F9ADA565-2FAD-424D-878C-7AD12DF9E617),
01148       dual,
01149       nonextensible,
01150       pointer_default(unique),
01151       oleautomation,
01152       helpstring(hsIApplication),
01153       helpcontext(14)
01154    ]
01155    interface IApplication : IDispatch
01156    {
01157       [propget, id(1), helpstring(hsIApp_Name),helpcontext(14)] HRESULT Name([out, retval] BSTR *pVal);
01158       [id(2), helpstring(hsIApp_Create),helpcontext(14)] HRESULT Create();
01159       [id(3), helpstring(hsIApp_Delete),helpcontext(14)] HRESULT Delete();
01160       [propget, id(4), helpstring(hsIApp_Streams),helpcontext(14)] HRESULT Streams([out, retval] IApplicationStreamCollection **pVal);
01161       [propget, id(5), helpstring(hsIApp_ConnectableUsers),helpcontext(14)] HRESULT ConnectableUsers([out, retval] IUserCollection **pVal);
01162       [propget, id(6), helpstring(hsIApp_ConnectingUsers),helpcontext(14)] HRESULT ConnectingUsers([out, retval] IUserCollection **pVal);
01163       [id(7), helpstring(hsIApp_Connect),helpcontext(14)] HRESULT Connect([in] BSTR Username, [in, defaultvalue(0)] VARIANT_BOOL WaitConnected);
01164       [propget, id(8), helpstring(hsIApp_SendStreams),helpcontext(14)] HRESULT SendingStreams([out, retval] IApplicationStreamCollection **pVal);
01165       [propget, id(9), helpstring(hsIApp_RecvStreams),helpcontext(14)] HRESULT ReceivedStreams([out, retval] IApplicationStreamCollection **pVal);
01166       [id(10), helpstring(hsIApp_SendDatagram),helpcontext(14)] HRESULT SendDatagram([in] BSTR Text, [in, defaultvalue(0)] IApplicationStreamCollection* pStreams);
01167    };
01168    [
01169       object,
01170       uuid(B9A3D72F-04C1-4878-993C-D89F83E20569),
01171       dual,
01172       nonextensible,
01173       pointer_default(unique),
01174       oleautomation,
01175       helpstring(hsIProfile),
01176       helpcontext(60)
01177    ]
01178    interface IProfile : IDispatch
01179    {
01180       [propget, id(1), helpstring(hsIProfile_Fullname), helpcontext(60)] HRESULT FullName([out, retval] BSTR *pVal);
01181       [propput, id(1), helpstring(hsIProfile_Fullname), helpcontext(60)] HRESULT FullName([in] BSTR newVal);
01182       [propget, id(2), helpstring(hsIProfile_Birthday), helpcontext(60)] HRESULT Birthday([out, retval] BSTR *pVal);
01183       [propput, id(2), helpstring(hsIProfile_Birthday), helpcontext(60)] HRESULT Birthday([in] BSTR newVal);
01184       [propget, id(3), helpstring(hsIProfile_Sex), helpcontext(60)] HRESULT Sex([out, retval] TUserSex *pVal);
01185       [propput, id(3), helpstring(hsIProfile_Sex), helpcontext(60)] HRESULT Sex([in] TUserSex newVal);
01186       [propget, id(4), helpstring(hsIProfile_Language), helpcontext(60)] HRESULT Languages([out, retval] BSTR *pVal);
01187       [propput, id(4), helpstring(hsIProfile_Language), helpcontext(60)] HRESULT Languages([in] BSTR newVal);
01188       [propget, id(5), helpstring(hsIProfile_Country), helpcontext(60)] HRESULT Country([out, retval] BSTR *pVal);
01189       [propput, id(5), helpstring(hsIProfile_Country), helpcontext(60)] HRESULT Country([in] BSTR newVal);
01190       [propget, id(6), helpstring(hsIProfile_Province), helpcontext(60)] HRESULT Province([out, retval] BSTR *pVal);
01191       [propput, id(6), helpstring(hsIProfile_Province), helpcontext(60)] HRESULT Province([in] BSTR newVal);
01192       [propget, id(7), helpstring(hsIProfile_City), helpcontext(60)] HRESULT City([out, retval] BSTR *pVal);
01193       [propput, id(7), helpstring(hsIProfile_City), helpcontext(60)] HRESULT City([in] BSTR newVal);
01194       [propget, id(8), helpstring(hsIProfile_PhoneHome), helpcontext(60)] HRESULT PhoneHome([out, retval] BSTR *pVal);
01195       [propput, id(8), helpstring(hsIProfile_PhoneHome), helpcontext(60)] HRESULT PhoneHome([in] BSTR newVal);
01196       [propget, id(9), helpstring(hsIProfile_PhoneOffice), helpcontext(60)] HRESULT PhoneOffice([out, retval] BSTR *pVal);
01197       [propput, id(9), helpstring(hsIProfile_PhoneOffice), helpcontext(60)] HRESULT PhoneOffice([in] BSTR newVal);
01198       [propget, id(10), helpstring(hsIProfile_PhoneMobile), helpcontext(60)] HRESULT PhoneMobile([out, retval] BSTR *pVal);
01199       [propput, id(10), helpstring(hsIProfile_PhoneMobile), helpcontext(60)] HRESULT PhoneMobile([in] BSTR newVal);
01200       [propget, id(11), helpstring(hsIProfile_Homepage), helpcontext(60)] HRESULT Homepage([out, retval] BSTR *pVal);
01201       [propput, id(11), helpstring(hsIProfile_Homepage), helpcontext(60)] HRESULT Homepage([in] BSTR newVal);
01202       [propget, id(12), helpstring(hsIProfile_About), helpcontext(60)] HRESULT About([out, retval] BSTR *pVal);
01203       [propput, id(12), helpstring(hsIProfile_About), helpcontext(60)] HRESULT About([in] BSTR newVal);
01204       [propget, id(13), helpstring(hsIProfile_MoodText), helpcontext(60)] HRESULT MoodText([out, retval] BSTR *pVal);
01205       [propput, id(13), helpstring(hsIProfile_MoodText), helpcontext(60)] HRESULT MoodText([in] BSTR newVal);
01206       [propget, id(14), helpstring(hsIProfile_Timezone), helpcontext(60)] HRESULT Timezone([out, retval] LONG *pVal);
01207       [propput, id(14), helpstring(hsIProfile_Timezone), helpcontext(60)] HRESULT Timezone([in] LONG newVal);
01208       [propget, id(15), helpstring(hsIProfile_NATimeout), helpcontext(60)] HRESULT CallNoAnswerTimeout([out, retval] short *pVal);
01209       [propput, id(15), helpstring(hsIProfile_NATimeout), helpcontext(60)] HRESULT CallNoAnswerTimeout([in] short newVal);
01210       [propget, id(16), helpstring(hsIProfile_ApplyCF), helpcontext(60)] HRESULT CallApplyCF([out, retval] VARIANT_BOOL *pVal);
01211       [propput, id(16), helpstring(hsIProfile_ApplyCF), helpcontext(60)] HRESULT CallApplyCF([in] VARIANT_BOOL newVal);
01212       [propget, id(17), helpstring(hsIProfile_SendToVM), helpcontext(60)] HRESULT CallSendToVM([out, retval] VARIANT_BOOL *pVal);
01213       [propput, id(17), helpstring(hsIProfile_SendToVM), helpcontext(60)] HRESULT CallSendToVM([in] VARIANT_BOOL newVal);
01214       [propget, id(18), helpstring(hsIProfile_CFRules), helpcontext(60)] HRESULT CallForwardRules([out, retval] BSTR *pVal);
01215       [propput, id(18), helpstring(hsIProfile_CFRules), helpcontext(60)] HRESULT CallForwardRules([in] BSTR newVal);
01216       [propget, id(19), helpstring(hsIProfile_Balance), helpcontext(60)] HRESULT Balance([out, retval] LONG *pVal);
01217       [propget, id(20), helpstring(hsIProfile_BalanceCurr), helpcontext(60)] HRESULT BalanceCurrency([out, retval] BSTR *pVal);
01218       [propget, id(21), helpstring(hsIProfile_BalanceText), helpcontext(60)] HRESULT BalanceToText([out, retval] BSTR *pVal);
01219       [propget, id(22), helpstring(hsIProfile_IPCountry), helpcontext(60)] HRESULT IPCountry([out, retval] BSTR *pVal);
01220       [propget, id(23), helpstring(hsIProfile_ValidSmsNums), helpcontext(60)] HRESULT ValidatedSmsNumbers([out, retval] BSTR* pVal);
01221       [propget, id(24), helpstring(hsIProfile_RichMoodText), helpcontext(60)] HRESULT RichMoodText([out, retval] BSTR* pVal);
01222       [propput, id(24), helpstring(hsIProfile_RichMoodText), helpcontext(60)] HRESULT RichMoodText([in] BSTR newVal);
01223    };
01224    [
01225       object,
01226       uuid(84513274-9C49-4AAA-B8FC-316EB32CFE95),
01227       dual,
01228       nonextensible,
01229       pointer_default(unique),
01230       oleautomation,
01231       helpstring(hsIGroup),
01232       helpcontext(9)
01233    ]
01234    interface IGroup : IDispatch
01235    {
01236       [propget, id(1), helpstring(hsIGroup_Id), helpcontext(9)] HRESULT Id([out, retval] LONG *pVal);
01237       [propget, id(2), helpstring(hsIGroup_Type), helpcontext(9)] HRESULT Type([out, retval] TGroupType *pVal);
01238       [propget, id(3), helpstring(hsIGroup_CustomId), helpcontext(9)] HRESULT CustomGroupId([out, retval] BSTR *pVal);
01239       [propget, id(4), helpstring(hsIGroup_DisplayName), helpcontext(9)] HRESULT DisplayName([out, retval] BSTR *pVal);
01240       [propput, id(4), helpstring(hsIGroup_DisplayName), helpcontext(9)] HRESULT DisplayName([in] BSTR newVal);
01241       [propget, id(5), helpstring(hsIGroup_Users), helpcontext(9)] HRESULT Users([out, retval] IUserCollection **pVal);
01242       [propget, id(6), helpstring(hsIGroup_OnlineUsers), helpcontext(9)] HRESULT OnlineUsers([out, retval] IUserCollection **pVal);
01243       [propget, id(7), helpstring(hsIGroup_IsVisible), helpcontext(9)] HRESULT IsVisible([out, retval] VARIANT_BOOL *pVal);
01244       [propget, id(8), helpstring(hsIGroup_IsExpanded), helpcontext(9)] HRESULT IsExpanded([out, retval] VARIANT_BOOL *pVal);
01245       [id(9), helpstring(hsIGroup_AddUser), helpcontext(9)] HRESULT AddUser([in] BSTR Username);
01246       [id(10), helpstring(hsIGroup_RemoveUser), helpcontext(9)] HRESULT RemoveUser([in] BSTR Username);
01247       [id(11), helpstring(hsIGroup_Share), helpcontext(9)] HRESULT Share([in, defaultvalue("")] BSTR MessageText);
01248       [id(12), helpstring(hsIGroup_Accept), helpcontext(9)] HRESULT Accept();
01249       [id(13), helpstring(hsIGroup_Decline)] HRESULT Decline();
01250    };
01251    [
01252       object,
01253       uuid(4C5C99DC-09CF-4A9C-BD94-8D655454A1F4),
01254       dual,
01255       nonextensible,
01256       pointer_default(unique),
01257       oleautomation,
01258       helpstring(hsIGroupCollection),
01259       helpcontext(8)
01260    ]
01261    interface IGroupCollection : IDispatch
01262    {
01263       [propget, id(1), helpstring(hsIGroupColl_Count),helpcontext(8)] HRESULT Count([out, retval] LONG* pVal);
01264       [id(2), helpstring(hsIGroupColl_Add),helpcontext(8)] HRESULT Add([in] IGroup* pGroup);
01265       [id(3), helpstring(hsIGroupColl_Remove),helpcontext(8)] HRESULT Remove([in] long Index);
01266       [id(4), helpstring(hsIGroupColl_RemoveAll),helpcontext(8)] HRESULT RemoveAll(void);
01267       [propget, id(DISPID_VALUE), helpstring(hsIGroupColl_Item),helpcontext(8)] HRESULT Item([in] LONG Index, [out, retval] IGroup ** pVal);
01268       [propget, id(DISPID_NEWENUM), helpstring(hsIGroupColl_NewEnum),helpcontext(8)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01269    };
01270    interface ISmsMessage;
01271    [
01272       object,
01273       uuid(A9062508-C926-4415-ABB7-A5A46DB34456),
01274       dual,
01275       nonextensible,
01276       pointer_default(unique),
01277       oleautomation,
01278       helpstring(hsISmsChunk),
01279       helpcontext(72)
01280    ]
01281    interface ISmsChunk : IDispatch
01282    {
01283       [propget, id(1), helpstring(hsISmsChunk_Id), helpcontext(72)] HRESULT Id([out, retval] LONG  *pVal);
01284       [propget, id(2), helpstring(hsISmsChunk_CharsLeft), helpcontext(72)] HRESULT CharactersLeft([out, retval] LONG *pVal);
01285       [propget, id(3), helpstring(hsISmsChunk_Text), helpcontext(72)] HRESULT Text([out, retval] BSTR *pVal);
01286       [propget, id(4), helpstring(hsISmsChunk_Message), helpcontext(72)] HRESULT Message([out, retval] ISmsMessage** pVal);
01287    };
01288    [
01289       object,
01290       uuid(BBDA7D2D-B1C2-4AF9-AB5B-D762341D8903),
01291       dual,
01292       nonextensible,
01293       pointer_default(unique),
01294       oleautomation,
01295       helpstring(hsISmsChunkCollection),
01296       helpcontext(73)
01297    ]
01298    interface ISmsChunkCollection : IDispatch
01299    {
01300       [propget, id(1), helpstring(hsISmsChunkColl_Count),helpcontext(73)] HRESULT Count([out, retval] LONG* pVal);
01301       [id(2), helpstring(hsISmsChunkColl_Add),helpcontext(73)] HRESULT Add([in] ISmsChunk* pItem);
01302       [id(3), helpstring(hsISmsChunkColl_Remove),helpcontext(73)] HRESULT Remove([in] long Index);
01303       [id(4), helpstring(hsISmsChunkColl_RemoveAll),helpcontext(73)] HRESULT RemoveAll(void);
01304       [propget, id(DISPID_VALUE), helpstring(hsISmsChunkColl_Item),helpcontext(73)] HRESULT Item([in] LONG Index, [out, retval] ISmsChunk ** pVal);
01305       [propget, id(DISPID_NEWENUM), helpstring(hsISmsChunkColl_NewEnum),helpcontext(73)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01306    };
01307    [
01308       object,
01309       uuid(A9B9C33A-49A6-41D5-B13F-2AA4F284F406),
01310       dual,
01311       nonextensible,
01312       pointer_default(unique),
01313       oleautomation,
01314       helpstring(hsISmsTarget),
01315       helpcontext(74)
01316    ]
01317    interface ISmsTarget : IDispatch
01318    {
01319       [propget, id(1), helpstring(hsISmsTarget_Status), helpcontext(74)] HRESULT Status([out, retval] TSmsTargetStatus *pVal);
01320       [propget, id(2), helpstring(hsISmsTarget_Number), helpcontext(74)] HRESULT Number([out, retval] BSTR *pVal);
01321       [propget, id(3), helpstring(hsISmsTarget_Message), helpcontext(74)] HRESULT Message([out, retval] ISmsMessage** pVal);
01322    };
01323    [
01324       object,
01325       uuid(A2365EF3-4805-4DD3-A9D4-1A8AE3E17D84),
01326       dual,
01327       nonextensible,
01328       pointer_default(unique),
01329       oleautomation,
01330       helpstring(hsISmsTargetCollection),
01331       helpcontext(75)
01332    ]
01333    interface ISmsTargetCollection : IDispatch
01334    {
01335       [propget, id(1), helpstring(hsISmsTargetColl_Count),helpcontext(75)] HRESULT Count([out, retval] LONG* pVal);
01336       [id(2), helpstring(hsISmsTargetColl_Add),helpcontext(75)] HRESULT Add([in] ISmsTarget* pItem);
01337       [id(3), helpstring(hsISmsTargetColl_Remove),helpcontext(75)] HRESULT Remove([in] long Index);
01338       [id(4), helpstring(hsISmsTargetColl_RemoveAll),helpcontext(75)] HRESULT RemoveAll(void);
01339       [propget, id(DISPID_VALUE), helpstring(hsISmsTargetColl_Item),helpcontext(75)] HRESULT Item([in] LONG Index, [out, retval] ISmsTarget ** pVal);
01340       [propget, id(DISPID_NEWENUM), helpstring(hsISmsTargetColl_NewEnum),helpcontext(75)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01341    };
01342    [
01343       object,
01344       uuid(82D97F2A-0E17-40F3-8E01-24937F936FF4),
01345       dual,
01346       nonextensible,
01347       pointer_default(unique),
01348       oleautomation,
01349       helpstring(hsISmsMessage),
01350       helpcontext(76)
01351    ]
01352    interface ISmsMessage : IDispatch
01353    {
01354       [propget, id(1), helpstring(hsISmsMessage_Id), helpcontext(76)] HRESULT Id([out, retval] LONG *pVal);
01355       [propget, id(2), helpstring(hsISmsMessage_Type), helpcontext(76)] HRESULT Type([out, retval] TSmsMessageType *pVal);
01356       [propget, id(3), helpstring(hsISmsMessage_Status), helpcontext(76)] HRESULT Status([out, retval] TSmsMessageStatus *pVal);
01357       [propget, id(4), helpstring(hsISmsMessage_FailureReason), helpcontext(76)] HRESULT FailureReason([out, retval] TSmsFailureReason *pVal);
01358       [propget, id(5), helpstring(hsISmsMessage_FailedUnseen), helpcontext(76)] HRESULT IsFailedUnseen([out, retval] VARIANT_BOOL *pVal);
01359       [propput, id(6), helpstring(hsISmsMessage_Seen), helpcontext(76)] HRESULT Seen([in] VARIANT_BOOL newVal);
01360       [propget, id(7), helpstring(hsISmsMessage_Price), helpcontext(76)] HRESULT Price([out, retval] LONG *pVal);
01361       [propget, id(8), helpstring(hsISmsMessage_PricePrec), helpcontext(76)] HRESULT PricePrecision([out, retval] LONG *pVal);
01362       [propget, id(9), helpstring(hsISmsMessage_PriceCurr), helpcontext(76)] HRESULT PriceCurrency([out, retval] BSTR *pVal);
01363       [propget, id(10), helpstring(hsISmsMessage_ReplyTo), helpcontext(76)] HRESULT ReplyToNumber([out, retval] BSTR *pVal);
01364       [propput, id(10), helpstring(hsISmsMessage_ReplyTo), helpcontext(76)] HRESULT ReplyToNumber([in] BSTR newVal);
01365       [propget, id(11), helpstring(hsISmsMessage_Targets), helpcontext(76)] HRESULT Targets([out, retval] ISmsTargetCollection* *pVal);
01366       [propget, id(12), helpstring(hsISmsMessage_Body), helpcontext(76)] HRESULT Body([out, retval] BSTR *pVal);
01367       [propput, id(12), helpstring(hsISmsMessage_Body), helpcontext(76)] HRESULT Body([in] BSTR newVal);
01368       [propget, id(13), helpstring(hsISmsMessage_Chunks), helpcontext(76)] HRESULT Chunks([out, retval] ISmsChunkCollection* *pVal);
01369       [propget, id(14), helpstring(hsISmsMessage_Timestamp), helpcontext(76)] HRESULT Timestamp([out, retval] DATE* pVal);
01370       [id(15), helpstring(hsISmsMessage_Send), helpcontext(76)] HRESULT Send();
01371       [id(16), helpstring(hsISmsMessage_Delete), helpcontext(76)] HRESULT Delete();
01372       [propget, id(17), helpstring(hsISmsMessage_TargetNumbers), helpcontext(76)] HRESULT TargetNumbers([out, retval] BSTR* pVal);
01373       [propput, id(17), helpstring(hsISmsMessage_TargetNumbers), helpcontext(76)] HRESULT TargetNumbers([in] BSTR newVal);
01374    };
01375    [
01376       object,
01377       uuid(1D5BAB2E-69CC-4136-8E02-FC20767DC9E2),
01378       dual,
01379       nonextensible,
01380       pointer_default(unique),
01381       oleautomation,
01382       helpstring(hsISmsMessageCollection),
01383       helpcontext(77)
01384    ]
01385    interface ISmsMessageCollection : IDispatch
01386    {
01387       [propget, id(1), helpstring(hsISmsMessageColl_Count),helpcontext(77)] HRESULT Count([out, retval] LONG* pVal);
01388       [id(2), helpstring(hsISmsMessageColl_Add),helpcontext(77)] HRESULT Add([in] ISmsMessage* pItem);
01389       [id(3), helpstring(hsISmsMessageColl_Remove),helpcontext(77)] HRESULT Remove([in] long Index);
01390       [id(4), helpstring(hsISmsMessageColl_RemoveAll),helpcontext(77)] HRESULT RemoveAll(void);
01391       [propget, id(DISPID_VALUE), helpstring(hsISmsMessageColl_Item),helpcontext(77)] HRESULT Item([in] LONG Index, [out, retval] ISmsMessage ** pVal);
01392       [propget, id(DISPID_NEWENUM), helpstring(hsISmsMessageColl_NewEnum),helpcontext(77)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01393    };
01394
01395    [
01396       object,
01397       uuid(2BC8C53B-3312-4A77-AC87-31DF18A1EC51),
01398       dual,
01399       nonextensible,
01400       pointer_default(unique),
01401       oleautomation,
01402       helpstring(hsISettings),
01403       helpcontext(2)
01404    ]
01405    interface ISettings : IDispatch
01406    {
01407       [propget, id(1), helpstring(hsISettings_AudioIn),helpcontext(2)] HRESULT AudioIn([out, retval] BSTR *pVal);
01408       [propput, id(1), helpstring(hsISettings_AudioIn),helpcontext(2)] HRESULT AudioIn([in] BSTR newVal);
01409       [propget, id(2), helpstring(hsISettings_AudioOut),helpcontext(2)] HRESULT AudioOut([out, retval] BSTR *pVal);
01410       [propput, id(2), helpstring(hsISettings_AudioOut),helpcontext(2)] HRESULT AudioOut([in] BSTR newVal);
01411       [propget, id(3), helpstring(hsISettings_AutoAway),helpcontext(2)] HRESULT AutoAway([out, retval] VARIANT_BOOL *pVal);
01412       [propput, id(3), helpstring(hsISettings_AutoAway),helpcontext(2)] HRESULT AutoAway([in] VARIANT_BOOL newVal);
01413       [propget, id(4), helpstring(hsISettings_Ringer),helpcontext(2)] HRESULT Ringer([out, retval] BSTR *pVal);
01414       [propput, id(4), helpstring(hsISettings_Ringer),helpcontext(2)] HRESULT Ringer([in] BSTR newVal);
01415       [propput, id(5), helpstring(hsISettings_Avatar),helpcontext(2)] HRESULT Avatar([in, defaultvalue("1")] BSTR Id, [in] BSTR newVal);
01416       [propget, id(6), helpstring(hsISettings_RingToneStatus),helpcontext(2)] HRESULT RingToneStatus([in, defaultvalue("1")] BSTR Id,[out, retval] VARIANT_BOOL *pVal);
01417       [propput, id(7), helpstring(hsISettings_RingTone),helpcontext(2)] HRESULT RingTone([in, defaultvalue("1")] BSTR Id, [in] BSTR newVal);
01418       [propget, id(8), helpstring(hsISettings_VideoIn),helpcontext(2)] HRESULT VideoIn([out, retval] BSTR *pVal);
01419       [propput, id(8), helpstring(hsISettings_VideoIn),helpcontext(2)] HRESULT VideoIn([in] BSTR newVal);
01420       [propget, id(9), helpstring(hsISettings_PCSpeaker),helpcontext(2)] HRESULT PCSpeaker([out, retval] VARIANT_BOOL *pVal);
01421       [propput, id(9), helpstring(hsISettings_PCSpeaker),helpcontext(2)] HRESULT PCSpeaker([in] VARIANT_BOOL newVal);
01422       [propget, id(10), helpstring(hsISettings_AGC),helpcontext(2)] HRESULT AGC([out, retval] VARIANT_BOOL *pVal);
01423       [propput, id(10), helpstring(hsISettings_AGC),helpcontext(2)] HRESULT AGC([in] VARIANT_BOOL newVal);
01424       [propget, id(11), helpstring(hsISettings_AEC),helpcontext(2)] HRESULT AEC([out, retval] VARIANT_BOOL *pVal);
01425       [propput, id(11), helpstring(hsISettings_AEC),helpcontext(2)] HRESULT AEC([in] VARIANT_BOOL newVal);
01426       [propget, id(12), helpstring(hsISettings_Language),helpcontext(2)] HRESULT Language([out, retval] BSTR *pVal);
01427       [propput, id(12), helpstring(hsISettings_Language),helpcontext(2)] HRESULT Language([in] BSTR newVal);
01428       [propput, id(6), helpstring(hsISettings_RingToneStatus),helpcontext(2)] HRESULT RingToneStatus([in, defaultvalue("1")] BSTR Id,[in] VARIANT_BOOL newVal);
01429       [id(13), helpstring(hsISettings_SaveAvatar), helpcontext(2)] HRESULT SaveAvatarToFile([in] BSTR Filename, [in, defaultvalue("1")] BSTR AvatarId);
01430       [id(14), helpstring(hsISettings_LoadAvatar), helpcontext(2)] HRESULT LoadAvatarFromFile([in] BSTR Filename, [in, defaultvalue("1")] BSTR AvatarId);
01431       [id(15), helpstring(hsISettings_IdleTimer),helpcontext(2)] HRESULT ResetIdleTimer(void);
01432    };
01433    [
01434       object,
01435       uuid(C4BDF667-3FF7-4B44-A9F4-F3937E3E6D86),
01436       dual,
01437       nonextensible,
01438       pointer_default(unique),
01439       oleautomation,
01440       helpstring(hsIPluginMenuItem),
01441       helpcontext(87)
01442    ]
01443    interface IPluginMenuItem : IDispatch
01444    {
01445       [propget, id(1), helpstring(hsIPluginMenuItem_Id), helpcontext(87)] HRESULT Id([out, retval] BSTR* pVal);
01446       [propput, id(2), helpstring(hsIPluginMenuItem_Caption), helpcontext(87)] HRESULT Caption([in] BSTR newVal);
01447       [propput, id(3), helpstring(hsIPluginMenuItem_Hint), helpcontext(87)] HRESULT Hint([in] BSTR newVal);
01448       [propput, id(4), helpstring(hsIPluginMenuItem_Enabled), helpcontext(87)] HRESULT Enabled([in] VARIANT_BOOL newVal);
01449       [id(5), helpstring(hsIPluginMenuItem_Delete), helpcontext(87)] HRESULT Delete(void);
01450    };
01451    [
01452       object,
01453       uuid(4DF5F83A-0ABA-417D-A6FC-62A68AE06EF7),
01454       dual,
01455       nonextensible,
01456       pointer_default(unique),
01457       oleautomation,
01458       helpstring(hsIPluginEvent),
01459       helpcontext(88)
01460    ]
01461    interface IPluginEvent : IDispatch
01462    {
01463       [propget, id(1), helpstring(hsIPluginEvent_Id),helpcontext(88)] HRESULT Id([out, retval] BSTR* pVal);
01464       [id(2), helpstring(hsIPluginEvent_Delete),helpcontext(88)] HRESULT Delete(void);
01465    };
01466    [
01467       object,
01468       uuid(4D36B368-B88C-45fa-B136-3EF77B2EAD39),
01469       dual,
01470       pointer_default(unique),
01471       helpstring(hsIFileTransfer),
01472       helpcontext(89)
01473    ]
01474    interface IFileTransfer : IDispatch
01475    {
01476       [propget, id(1), helpstring(hsIFileTransfer_Id), helpcontext(89)] HRESULT Id([out, retval] BSTR* pVal);
01477       [propget, id(2), helpstring(hsIFileTransfer_Type), helpcontext(89)] HRESULT Type([out, retval] TFileTransferType* pVal);
01478       [propget, id(3), helpstring(hsIFileTransfer_Status), helpcontext(89)] HRESULT Status([out, retval] TFileTransferStatus* pVal);
01479       [propget, id(4), helpstring(hsIFileTransfer_FailReason), helpcontext(89)] HRESULT FailureReason([out, retval] TFileTransferFailureReason* pVal);
01480       [propget, id(5), helpstring(hsIFileTransfer_PartnerHandle), helpcontext(89)] HRESULT PartnerHandle([out, retval] BSTR* pVal);
01481       [propget, id(6), helpstring(hsIFileTransfer_PartnerDispName), helpcontext(89)] HRESULT PartnerDisplayName([out, retval] BSTR* pVal);
01482       [propget, id(7), helpstring(hsIFileTransfer_StartTime), helpcontext(89)] HRESULT StartTime([out, retval] DATE* pVal);
01483       [propget, id(8), helpstring(hsIFileTransfer_FinishTime), helpcontext(89)] HRESULT FinishTime([out, retval] DATE* pVal);
01484       [propget, id(9), helpstring(hsIFileTransfer_FilePath), helpcontext(89)] HRESULT FilePath([out, retval] BSTR* pVal);
01485       [propget, id(10), helpstring(hsIFileTransfer_FileName), helpcontext(89)] HRESULT FileName([out, retval] BSTR* pVal);
01486       [propget, id(11), helpstring(hsIFileTransfer_ByteSec), helpcontext(89)] HRESULT BytesPerSecond([out, retval] BSTR* pVal);
01487       [propget, id(12), helpstring(hsIFileTransfer_ByteTransferred), helpcontext(89)] HRESULT BytesTransferred([out, retval] BSTR* pVal);
01488    };
01489    [
01490       object,
01491       uuid(70A59A25-E823-4c3f-8F33-775008895EE3),
01492       dual,
01493       pointer_default(unique),
01494       helpstring(hsIFileTransferColl),
01495       helpcontext(90)
01496    ]
01497    interface IFileTransferCollection : IDispatch
01498    {
01499       [propget, id(1), helpstring(hsIFileTransferColl_Count),helpcontext(90)] HRESULT Count([out, retval] LONG* pVal);
01500       [id(2), helpstring(hsIFileTransferColl_Add),helpcontext(90)] HRESULT Add([in] IFileTransfer* pItem);
01501       [id(3), helpstring(hsIFileTransferColl_Remove),helpcontext(90)] HRESULT Remove([in] long Index);
01502       [id(4), helpstring(hsIFileTransferColl_RemoveAll),helpcontext(90)] HRESULT RemoveAll(void);
01503       [propget, id(DISPID_VALUE), helpstring(hsIFileTransferColl_Item),helpcontext(90)] HRESULT Item([in] LONG Index, [out, retval] IFileTransfer ** pVal);
01504       [propget, id(DISPID_NEWENUM), helpstring(hsIFileTransferColl_NewEnum),helpcontext(90)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
01505    };
01506    [
01507       object,
01508       uuid(838731B0-88E7-4BED-81DC-B35CA8433341),
01509       dual,
01510       nonextensible,
01511       pointer_default(unique),
01512       oleautomation,
01513       helpstring(hsIClient),
01514       helpcontext(36)
01515    ]
01516    interface IClient : IDispatch
01517    {
01518       [id(1), helpstring(hsIClient_Start),helpcontext(36)] HRESULT Start([in, defaultvalue(0)] VARIANT_BOOL Minimized, [in, defaultvalue(0)] VARIANT_BOOL Nosplash);
01519       [id(2), helpstring(hsIClient_Minimize),helpcontext(36)] HRESULT Minimize();
01520       [id(3), helpstring(hsIClient_Shutdown),helpcontext(36)] HRESULT Shutdown();
01521       [propget, id(4), helpstring(hsIClient_Running),helpcontext(36)] HRESULT IsRunning([out, retval] VARIANT_BOOL *pVal);
01522       [id(5), helpstring(hsIClient_OpenProfile),helpcontext(36)] HRESULT OpenProfileDialog();
01523       [id(6), helpstring(hsIClient_OpenUserinfo),helpcontext(36)] HRESULT OpenUserInfoDialog([in] BSTR Username);
01524       [id(7), helpstring(hsIClient_OpenConference),helpcontext(36)] HRESULT OpenConferenceDialog();
01525       [id(8), helpstring(hsIClient_OpenSearch),helpcontext(36)] HRESULT OpenSearchDialog();
01526       [id(9), helpstring(hsIClient_OpenOptions),helpcontext(36)] HRESULT OpenOptionsDialog([in] BSTR Page);
01527       [id(10), helpstring(hsIClient_OpenCallHist),helpcontext(36)] HRESULT OpenCallHistoryTab();
01528       [id(11), helpstring(hsIClient_OpenContacts),helpcontext(36)] HRESULT OpenContactsTab();
01529       [id(12), helpstring(hsIClient_OpenDialpad),helpcontext(36)] HRESULT OpenDialpadTab();
01530       [id(13), helpstring(hsIClient_OpenSendCont),helpcontext(36)] HRESULT OpenSendContactsDialog([in, defaultvalue("")] BSTR Username);
01531       [id(14), helpstring(hsIClient_OpenBlockUser),helpcontext(36)] HRESULT OpenBlockedUsersDialog();
01532       [id(15), helpstring(hsIClient_OpenImportContact),helpcontext(36)] HRESULT OpenImportContactsWizard();
01533       [id(16), helpstring(hsIClient_OpenGetStart),helpcontext(36)] HRESULT OpenGettingStartedWizard();
01534       [id(17), helpstring(hsIClient_OpenAuthoriz),helpcontext(36)] HRESULT OpenAuthorizationDialog([in] BSTR Username);
01535       [id(18), helpstring(hsIClient_OpenDialog),helpcontext(36)] HRESULT OpenDialog([in] BSTR Name, [in, defaultvalue("")] BSTR Param1, [in, defaultvalue("")] BSTR Param2);
01536       [id(19), helpstring(hsIClient_OpenVideoTest),helpcontext(36)] HRESULT OpenVideoTestDialog();
01537       [id(20), helpstring(hsIClient_OpenAddContact),helpcontext(36)] HRESULT OpenAddContactDialog([in, defaultvalue("")] BSTR Username);
01538       [id(21), helpstring(hsIClient_OpenMessage),helpcontext(36)] HRESULT OpenMessageDialog([in] BSTR Username, [in, defaultvalue("")] BSTR Text);
01539       [id(22), helpstring(hsIClient_OpenFileTrans),helpcontext(36)] HRESULT OpenFileTransferDialog([in] BSTR User, [in] BSTR Folder);
01540       [id(23), helpstring(hsIClient_Focus),helpcontext(36)] HRESULT Focus();
01541       [id(24), helpstring(hsIClient_BtnPressed),helpcontext(36)] HRESULT ButtonPressed([in] BSTR Key);
01542       [id(25), helpstring(hsIClient_BtnReleased),helpcontext(36)] HRESULT ButtonReleased([in] BSTR Key);
01543       [id(26), helpstring(hsIClient_OpenSms)] HRESULT OpenSmsDialog([in] BSTR SmsId);
01544       [id(27), helpstring(hsIClient_CreateEvent), helpcontext(36)] HRESULT CreateEvent([in] BSTR EventId, [in] BSTR Caption, [in] BSTR Hint, [out,retval] IPluginEvent** pEvent);
01545       [id(28), helpstring(hsIClient_CreateMenuItem), helpcontext(36)] HRESULT CreateMenuItem([in] BSTR MenuItemId, [in] TPluginContext PluginContext, [in] BSTR CaptionText, [in,defaultvalue("")] BSTR HintText, [in, defaultvalue("")] BSTR IconPath, [in, defaultvalue(-1)] VARIANT_BOOL Enabled, [in, defaultvalue(pluginContactTypeAll)] TPluginContactType ContactType, [in, defaultvalue(0)] VARIANT_BOOL MultipleContacts, [out,retval] IPluginMenuItem** pMenuItem);
01546       [propget, id(29), helpstring(hsIClient_Wallpaper), helpcontext(36)] HRESULT Wallpaper([out, retval] BSTR* pVal);
01547       [propput, id(29), helpstring(hsIClient_Wallpaper), helpcontext(36)] HRESULT Wallpaper([in] BSTR newVal);
01548       [id(30), helpstring(hsIClient_OpenLive),helpcontext(36)] HRESULT OpenLiveTab();
01549    };
01550    [
01551       object,
01552       uuid(B1878BFE-53D3-402E-8C86-190B19AF70D5),
01553       dual,
01554       nonextensible,
01555       pointer_default(unique),
01556       oleautomation,
01557       helpstring(hsISkype),
01558       helpcontext(13)
01559    ]
01560    interface ISkype : IDispatch
01561    {
01562       [propget, id(1), helpstring(hsISkype_Timeout), helpcontext(13)] HRESULT Timeout([out, retval] LONG *pVal);
01563       [propput, id(1), helpstring(hsISkype_Timeout), helpcontext(13)] HRESULT Timeout([in] LONG newVal);
01564       [propget, id(2), helpstring(hsISkype_Property), helpcontext(13)] HRESULT Property([in] BSTR ObjectType, [in] BSTR ObjectId, [in] BSTR PropName, [out, retval] BSTR *pVal);
01565       [propput, id(2), helpstring(hsISkype_Property), helpcontext(13)] HRESULT Property([in] BSTR ObjectType, [in] BSTR ObjectId, [in] BSTR PropName, [in] BSTR newVal);
01566       [propget, id(3), helpstring(hsISkype_Variable), helpcontext(13)] HRESULT Variable([in] BSTR Name, [out, retval] BSTR *pVal);
01567       [propput, id(3), helpstring(hsISkype_Variable), helpcontext(13)] HRESULT Variable([in] BSTR Name, [in] BSTR newVal);
01568       [propget, id(4), helpstring(hsISkype_CurrentUserHandle), helpcontext(13)] HRESULT CurrentUserHandle([out, retval] BSTR *pVal);
01569       [propget, id(5), helpstring(hsISkype_CurrentUserStatus), helpcontext(13)] HRESULT CurrentUserStatus([out, retval] TUserStatus *pVal);
01570       [propput, id(5), helpstring(hsISkype_CurrentUserStatus), helpcontext(13)] HRESULT CurrentUserStatus([in] TUserStatus newVal);
01571       [propget, id(6), helpstring(hsISkype_ConnectionStatus), helpcontext(13)] HRESULT ConnectionStatus([out, retval] TConnectionStatus *pVal);
01572       [propget, id(7), helpstring(hsISkype_Mute), helpcontext(13)] HRESULT Mute([out, retval] VARIANT_BOOL *pVal);
01573       [propput, id(7), helpstring(hsISkype_Mute), helpcontext(13)] HRESULT Mute([in] VARIANT_BOOL newVal);
01574       [propget, id(8), helpstring(hsISkype_Version), helpcontext(13)] HRESULT Version([out, retval] BSTR *pVal);
01575       [propget, id(9), helpstring(hsISkype_Privilege), helpcontext(13)] HRESULT Privilege([in] BSTR Name, [out, retval] VARIANT_BOOL *pVal);
01576       [propget, id(10), helpstring(hsISkype_CurrentUser), helpcontext(13)] HRESULT CurrentUser([out, retval] IUser **pVal);
01577       [propget, id(11), helpstring(hsISkype_Convert), helpcontext(13)] HRESULT Convert([out, retval] IConversion **pVal);
01578       [propget, id(12), helpstring(hsISkype_Friends), helpcontext(13)] HRESULT Friends([out, retval] IUserCollection **pVal);
01579       [id(13), helpstring(hsISkype_Users), helpcontext(13)] HRESULT SearchForUsers([in] BSTR Target, [out, retval] IUserCollection **pVal);
01580       [propget, id(14), helpstring(hsISkype_Calls), helpcontext(13)] HRESULT Calls([in, defaultvalue("")] BSTR Target, [out, retval] ICallCollection **pVal);
01581       [propget, id(15), helpstring(hsISkype_ActiveCalls), helpcontext(13)] HRESULT ActiveCalls([out, retval] ICallCollection **pVal);
01582       [propget, id(16), helpstring(hsISkype_MissedCalls), helpcontext(13)] HRESULT MissedCalls([out, retval] ICallCollection **pVal);
01583       [propget, id(17), helpstring(hsISkype_Messages), helpcontext(13)] HRESULT Messages([in, defaultvalue("")] BSTR Target, [out, retval] IChatMessageCollection **pVal);
01584       [propget, id(18), helpstring(hsISkype_MissedMessages), helpcontext(13)] HRESULT MissedMessages([out, retval] IChatMessageCollection **pVal);
01585       [propget, id(19), helpstring(hsISkype_AttachmentStatus), helpcontext(13)] HRESULT AttachmentStatus([out, retval] TAttachmentStatus *pVal);
01586       [propget, id(20), helpstring(hsISkype_Protocol), helpcontext(13)] HRESULT Protocol([out, retval] LONG *pVal);
01587       [propput, id(20), helpstring(hsISkype_Protocol), helpcontext(13)] HRESULT Protocol([in] LONG newVal);
01588       [id(21), helpstring(hsISkype_Attach), helpcontext(13)] HRESULT Attach([in, defaultvalue(5)] LONG Protocol, [in, defaultvalue(-1)] VARIANT_BOOL Wait);
01589       [id(22), helpstring(hsISkype_PlaceCall), helpcontext(13)] HRESULT PlaceCall([in] BSTR Target, [in, defaultvalue("")] BSTR Target2, [in, defaultvalue("")] BSTR Target3, [in, defaultvalue("")] BSTR Target4, [out, retval] ICall **pCall);
01590       [id(23), helpstring(hsISkype_SendMessage), helpcontext(13)] HRESULT SendMessage([in] BSTR Username, [in] BSTR Text, [out, retval] IChatMessage **pMessage);
01591       [propget, id(24), helpstring(hsISkype_User), helpcontext(13)] HRESULT User([in, defaultvalue("")] BSTR Username, [out, retval] IUser **pVal);
01592       [propget, id(25), helpstring(hsISkype_Message), helpcontext(13)] HRESULT Message([in, defaultvalue(0)] LONG Id, [out, retval] IChatMessage **pVal);
01593       [propget, id(26), helpstring(hsISkype_Call), helpcontext(13)] HRESULT Call([in, defaultvalue(0)] LONG Id, [out, retval] ICall **pVal);
01594       [id(27), helpstring(hsISkype_SendCommand), helpcontext(13)] HRESULT SendCommand([in] ICommand* pCommand);
01595       [propget, id(28), helpstring(hsISkype_Chats), helpcontext(13)] HRESULT Chats([out, retval] IChatCollection **pVal);
01596       [propget, id(29), helpstring(hsISkype_Chat), helpcontext(13)] HRESULT Chat([in, defaultvalue("")] BSTR Name, [out, retval] IChat **pVal);
01597       [id(30), helpstring(hsISkype_ChangeUserStatus), helpcontext(13)] HRESULT ChangeUserStatus([in] TUserStatus newVal);
01598       [propget, id(31), helpstring(hsISkype_Conference), helpcontext(13)] HRESULT Conference([in, defaultvalue(0)] LONG Id,[out, retval] IConference **pVal);
01599       [propget, id(32), helpstring(hsISkype_Conferences), helpcontext(13)] HRESULT Conferences([out, retval] IConferenceCollection **pVal);
01600       [propget, id(33), helpstring(hsISkype_Profile), helpcontext(13)] HRESULT Profile([in] BSTR Property, [out, retval] BSTR *pVal);
01601       [propput, id(33), helpstring(hsISkype_Profile), helpcontext(13)] HRESULT Profile([in] BSTR Property, [in] BSTR newVal);
01602       [propget, id(34), helpstring(hsISkype_ActiveChats), helpcontext(13)] HRESULT ActiveChats([out, retval] IChatCollection **pVal);
01603       [propget, id(35), helpstring(hsISkype_MissedChats), helpcontext(13)] HRESULT MissedChats([out, retval] IChatCollection **pVal);
01604       [propget, id(36), helpstring(hsISkype_RecentChats), helpcontext(13)] HRESULT RecentChats([out, retval] IChatCollection **pVal);
01605       [propget, id(37), helpstring(hsISkype_BookedChats), helpcontext(13)] HRESULT BookmarkedChats([out, retval] IChatCollection **pVal);
01606       [id(38), helpstring(hsISkype_CreateChat), helpcontext(13)] HRESULT CreateChatWith([in] BSTR Username, [out, retval] IChat **pVal);
01607       [id(39), helpstring(hsISkype_CreateChatMulti), helpcontext(13)] HRESULT CreateChatMultiple([in] IUserCollection *pMembers, [out, retval] IChat **pChat);
01608       [propget, id(40), helpstring(hsISkype_Voicemails), helpcontext(13)] HRESULT Voicemails([out, retval] IVoicemailCollection **pVal);
01609       [id(41), helpstring(hsISkype_SendVoicemail), helpcontext(13)] HRESULT SendVoicemail([in] BSTR Username, [out, retval] IVoicemail **pVoicemail);
01610       [propget, id(42), helpstring(hsISkype_UsersWaitAuth), helpcontext(13)] HRESULT UsersWaitingAuthorization([out, retval] IUserCollection **pVal);
01611       [id(43), helpstring(hsISkype_ClearChats), helpcontext(13)] HRESULT ClearChatHistory();
01612       [id(44), helpstring(hsISkype_ClearVMails), helpcontext(13)] HRESULT ClearVoicemailHistory();
01613       [id(45), helpstring(hsISkype_ClearCalls), helpcontext(13)] HRESULT ClearCallHistory([in, defaultvalue("ALL")] BSTR Username, [in, defaultvalue(chsAllCalls)] TCallHistory type);
01614       [propget, id(46), helpstring(hsISkype_CommandId), helpcontext(13)] HRESULT CommandId([out, retval] VARIANT_BOOL *pVal);
01615       [propput, id(46), helpstring(hsISkype_CommandId), helpcontext(13)] HRESULT CommandId([in] VARIANT_BOOL newVal);
01616       [propget, id(47), helpstring(hsISkype_Application), helpcontext(13)] HRESULT Application([in] BSTR Name, [out, retval] IApplication **pVal);
01617       [propget, id(48), helpstring(hsISkype_Greeting), helpcontext(13)] HRESULT Greeting([in, defaultvalue("")] BSTR Username, [out, retval] IVoicemail **pVal);
01618       [propget, id(49), helpstring(hsISkype_Cache), helpcontext(13)] HRESULT Cache([out, retval] VARIANT_BOOL *pVal);
01619       [propput, id(49), helpstring(hsISkype_Cache), helpcontext(13)] HRESULT Cache([in] VARIANT_BOOL newVal);
01620       [id(50), helpstring(hsISkype_ResetCache), helpcontext(13)] HRESULT ResetCache();
01621       [propget, id(51), helpstring(hsISkype_CurrUserProf), helpcontext(13)] HRESULT CurrentUserProfile([out, retval] IProfile **pVal);
01622       [propget, id(52), helpstring(hsISkype_Groups), helpcontext(13)] HRESULT Groups([out, retval] IGroupCollection* *pVal);
01623       [propget, id(53), helpstring(hsISkype_CustGroups), helpcontext(13)] HRESULT CustomGroups([out, retval] IGroupCollection* *pVal);
01624       [propget, id(54), helpstring(hsISkype_HardGroups), helpcontext(13)] HRESULT HardwiredGroups([out, retval] IGroupCollection* *pVal);
01625       [id(55), helpstring(hsISkype_CreateGroup), helpcontext(13)] HRESULT CreateGroup([in] BSTR GroupName, [out, retval] IGroup** pGroup);
01626       [id(56), helpstring(hsISkype_DeleteGroup), helpcontext(13)] HRESULT DeleteGroup([in] LONG GroupId);
01627       [propget, id(57), helpstring(hsISkype_Settings), helpcontext(13)] HRESULT Settings([out, retval] ISettings* *pVal);
01628       [propget, id(58), helpstring(hsISkype_Client), helpcontext(13)] HRESULT Client([out, retval] IClient* *pVal);
01629       [propput, id(59), helpstring(hsISkype_FriendlyName),helpcontext(13)] HRESULT FriendlyName([in] BSTR newVal);
01630       [propget, id(60), helpstring(hsISkype_Command), helpcontext(13)] HRESULT Command([in] LONG Id, [in] BSTR Command, [in, defaultvalue("")] BSTR Reply, [in, defaultvalue(0)] VARIANT_BOOL Block, [in, defaultvalue(30000)] LONG Timeout, [out, retval] ICommand **pVal);
01631       [propget, id(61), helpstring(hsISkype_Voicemail), helpcontext(13)] HRESULT Voicemail([in] LONG Id, [out, retval] IVoicemail** pVal);
01632       [propget, id(62), helpstring(hsISkype_MissedVoicemails), helpcontext(13)] HRESULT MissedVoicemails([out, retval] IVoicemailCollection* *pVal);
01633       [id(63), helpstring(hsISkype_EnableApiContext), helpcontext(13), hidden] HRESULT EnableApiSecurityContext([in] TApiSecurityContext Context);
01634       [propget, id(64), helpstring(hsISkype_ApiContextEnabled), helpcontext(13), hidden] HRESULT ApiSecurityContextEnabled([in] TApiSecurityContext Context, [out, retval] VARIANT_BOOL* pVal);
01635       [id(65), helpstring(hsISkype_CreateSms), helpcontext(13)] HRESULT CreateSms([in] TSmsMessageType MessageType, [in] BSTR TargetNumbers, [out, retval] ISmsMessage** pMessage);
01636       [propget, id(66), helpstring(hsISkype_Smss), helpcontext(13)] HRESULT Smss([out, retval] ISmsMessageCollection** pVal);
01637       [propget, id(67), helpstring(hsISkype_MissedSmss), helpcontext(13)] HRESULT MissedSmss([out, retval] ISmsMessageCollection** pVal);
01638       [id(68), helpstring(hsISkype_SendSms), helpcontext(13)] HRESULT SendSms([in] BSTR TargetNumbers, [in] BSTR MessageText, [in, defaultvalue("")] BSTR ReplyToNumber, [out, retval] ISmsMessage** pMessage);
01639       [id(69), helpstring(hsISkype_AsyncSearchUsers), helpcontext(13)] HRESULT AsyncSearchUsers([in] BSTR Target, [out,retval] LONG* pCookie);
01640       [propget, id(70), helpstring(hsISkype_WrapperVersion), helpcontext(13)] HRESULT ApiWrapperVersion([out, retval] BSTR* pVal);
01641       [propget, id(71), helpstring(hsISkype_SilentMode), helpcontext(13)] HRESULT SilentMode([out, retval] VARIANT_BOOL* pVal);
01642       [propput, id(71), helpstring(hsISkype_SilentMode), helpcontext(13)] HRESULT SilentMode([in] VARIANT_BOOL newVal);
01643       [propget, id(72), helpstring(hsISkype_FileTransfers), helpcontext(13)] HRESULT FileTransfers([out, retval] IFileTransferCollection **pVal);
01644       [propget, id(73), helpstring(hsISkype_ActiveFileTransfers), helpcontext(13)] HRESULT ActiveFileTransfers([out, retval] IFileTransferCollection **pVal);
01645       [propget, id(74), helpstring(hsISkype_FocusedContacts), helpcontext(13)] HRESULT FocusedContacts([out, retval] IUserCollection **pVal);
01646       [id(75), helpstring(hsISkype_BlobFind), helpcontext(13)] HRESULT FindChatUsingBlob([in] BSTR Blob, [out,retval] IChat** pChat);
01647       [id(76), helpstring(hsISkype_BlobCreat), helpcontext(13)] HRESULT CreateChatUsingBlob([in] BSTR Blob, [out,retval] IChat** pChat);
01648       [propget, id(77), helpstring(""), helpcontext(13)] HRESULT PredictiveDialerCountry([out, retval] BSTR *pVal);
01649    };
01650 #ifndef DOXYGEN_SHOULD_SKIP_THIS
01651    [
01652       object,
01653       uuid(6D0B4547-771D-4C4F-B3E8-98A33FD24D2B),
01654       dual,
01655       nonextensible,
01656       pointer_default(unique),
01657       oleautomation,
01658       helpstring(hsISkypeSms),
01659       helpcontext(78),
01660       hidden
01661    ]
01662    interface ISkypeSms : IDispatch
01663    {
01664       [propget, id(1), helpstring(hsISmsMessage_Type), helpcontext(78)] HRESULT SmsMessageType([in] BSTR SmsId, [out, retval] TSmsMessageType *pVal);
01665       [propget, id(2), helpstring(hsISmsMessage_Status), helpcontext(78)] HRESULT SmsMessageStatus([in] BSTR SmsId, [out, retval] TSmsMessageStatus *pVal);
01666       [propget, id(3), helpstring(hsISmsMessage_FailureReason), helpcontext(78)] HRESULT SmsFailureReason([in] BSTR SmsId, [out, retval] TSmsFailureReason *pVal);
01667       [propget, id(4), helpstring(hsISmsMessage_FailedUnseen), helpcontext(78)] HRESULT SmsIsFailedUnseen([in] BSTR SmsId, [out, retval] VARIANT_BOOL *pVal);
01668       [propput, id(5), helpstring(hsISmsMessage_Seen), helpcontext(78)] HRESULT SmsSeen([in] BSTR SmsId);
01669       [propget, id(6), helpstring(hsISmsMessage_Price), helpcontext(78)] HRESULT SmsPrice([in] BSTR SmsId, [out, retval] LONG *pVal);
01670       [propget, id(7), helpstring(hsISmsMessage_PriceCurr), helpcontext(78)] HRESULT SmsPriceCurrency([in] BSTR SmsId, [out, retval] BSTR *pVal);
01671       [propget, id(8), helpstring(hsISmsMessage_PricePrec), helpcontext(78)] HRESULT SmsPricePrecision([in] BSTR SmsId, [out, retval] LONG *pVal);
01672       [propget, id(9), helpstring(hsISmsMessage_ReplyTo), helpcontext(78)] HRESULT SmsReplyToNumber([in] BSTR SmsId, [out, retval] BSTR* pVal);
01673       [propput, id(9), helpstring(hsISmsMessage_ReplyTo), helpcontext(78)] HRESULT SmsReplyToNumber([in] BSTR SmsId, [in] BSTR newVal);
01674       [propget, id(10), helpstring(hsISmsMessage_Targets), helpcontext(78)] HRESULT SmsTargets([in] BSTR SmsId, [out, retval] ISmsTargetCollection** pVal);
01675       [propget, id(11), helpstring(hsISmsMessage_Body), helpcontext(78)] HRESULT SmsBody([in] BSTR SmsId, [out, retval] BSTR* pVal);
01676       [propput, id(11), helpstring(hsISmsMessage_Body), helpcontext(78)] HRESULT SmsBody([in] BSTR SmsId, [in] BSTR newVal);
01677       [propget, id(12), helpstring(hsISmsMessage_Chunks), helpcontext(78)] HRESULT SmsChunks([in] BSTR SmsId, [out, retval] ISmsChunkCollection** pVal);
01678       [id(13), helpstring(hsISmsMessage_Send), helpcontext(78)] HRESULT SendSmsMessage([in] BSTR SmsId);
01679       [id(14), helpstring(hsISmsMessage_Delete), helpcontext(78)] HRESULT DeleteSmsMessage([in] BSTR SmsId);
01680       [propget, id(15), helpstring(hsISmsTarget_Status), helpcontext(78)] HRESULT SmsTargetStatus([in] BSTR SmsId, [in] BSTR Number, [out, retval] TSmsTargetStatus* pVal);
01681       [propget, id(16), helpstring(hsISmsChunk_Text), helpcontext(78)] HRESULT SmsChunkText([in] BSTR SmsId, [in] BSTR ChunkId, [out, retval] BSTR* pVal);
01682       [propget, id(17), helpstring(hsISmsChunk_CharsLeft), helpcontext(78)] HRESULT SmsChunkCharactersLeft([in] BSTR SmsId, [in] BSTR ChunkId, [out, retval] LONG* pVal);
01683       [propget, id(18), helpstring(hsISmsMessage_Timestamp), helpcontext(78)] HRESULT SmsTimestamp([in] BSTR SmsId, [out, retval] DATE* pVal);
01684       [propget, id(19), helpstring(hsISmsMessage_TargetNumbers), helpcontext(78)] HRESULT SmsTargetNumbers([in] BSTR SmsId, [out, retval] BSTR* pVal);
01685       [propput, id(19), helpstring(hsISmsMessage_TargetNumbers), helpcontext(78)] HRESULT SmsTargetNumbers([in] BSTR SmsId, [in] BSTR newVal);
01686    };
01687    [
01688       object,
01689       uuid(54590FC3-0405-4A2D-B4A5-BEAC026577F2),
01690       dual,
01691       nonextensible,
01692       pointer_default(unique),
01693       oleautomation,
01694       helpstring(hsISkypeCall),
01695       helpcontext(45),
01696       hidden
01697    ]
01698    interface ISkypeCall : IDispatch
01699    {
01700       [propget, id(1), helpstring(hsICall_Timestamp), helpcontext(45), ] HRESULT CallTimestamp([in] BSTR CallId, [out, retval] DATE *pVal);
01701       [propget, id(2), helpstring(hsICall_PartHandle), helpcontext(45)] HRESULT CallPartnerHandle([in] BSTR CallId, [out, retval] BSTR *pVal);
01702       [propget, id(3), helpstring(hsICall_PartDispName), helpcontext(45)] HRESULT CallPartnerDisplayName([in] BSTR CallId, [out, retval] BSTR *pVal);
01703       [propget, id(4), helpstring(hsICall_ConferenceId), helpcontext(45)] HRESULT CallConferenceId([in] BSTR CallId, [out, retval] BSTR *pVal);
01704       [propget, id(5), helpstring(hsICall_Type), helpcontext(45)] HRESULT CallType([in] BSTR CallId, [out, retval] TCallType *pVal);
01705       [propget, id(6), helpstring(hsICall_Status), helpcontext(45)] HRESULT CallStatus([in] BSTR CallId, [out, retval] TCallStatus *pVal);
01706       [propput, id(6), helpstring(hsICall_Status), helpcontext(45)] HRESULT CallStatus([in] BSTR CallId, [in] TCallStatus newVal);
01707       [propget, id(7), helpstring(hsICall_FailReason), helpcontext(45)] HRESULT CallFailureReason([in] BSTR CallId, [out, retval] TCallFailureReason *pVal);
01708       [propget, id(8), helpstring(hsICall_Subject), helpcontext(45)] HRESULT CallSubject([in] BSTR CallId, [out, retval] BSTR *pVal);
01709       [propget, id(9), helpstring(hsICall_PSTN_Number), helpcontext(45)] HRESULT CallPstnNumber([in] BSTR CallId, [out, retval] BSTR *pVal);
01710       [propget, id(10), helpstring(hsICall_Duration), helpcontext(45)] HRESULT CallDuration([in] BSTR CallId, [out, retval] LONG *pVal);
01711       [propget, id(11), helpstring(hsICall_PSTN_Status), helpcontext(45)] HRESULT CallPstnStatus([in] BSTR CallId, [out, retval] BSTR *pVal);
01712       [propput, id(12), helpstring(hsICall_Seen), helpcontext(45)] HRESULT CallSeenStatus([in] BSTR CallId, [in] VARIANT_BOOL newVal);
01713       [id(13), helpstring(hsICall_Hold), helpcontext(45)] HRESULT CallHold([in] BSTR CallId);
01714       [id(14), helpstring(hsICall_Resume), helpcontext(45)] HRESULT CallResume([in] BSTR CallId);
01715       [id(15), helpstring(hsICall_Finish), helpcontext(45)] HRESULT CallFinish([in] BSTR CallId);
01716       [id(16), helpstring(hsICall_Answer), helpcontext(45)] HRESULT CallAnswer([in]  BSTR CallId);
01717       [propput, id(17), helpstring(hsICall_DTMF), helpcontext(45)] HRESULT CallDTMF([in] BSTR CallId, [in] BSTR newVal);
01718       [propget, id(18), helpstring(hsICall_Participants), helpcontext(45)] HRESULT CallParticipants([in] BSTR CallId, [out, retval] IParticipantCollection **pVal);
01719       [id(19), helpstring(hsICall_Join), helpcontext(45)] HRESULT CallJoin([in] BSTR CallId1, [in] BSTR CallId2);
01720       [propget, id(20), helpstring(hsICall_VmDuration), helpcontext(45)] HRESULT CallVmDuration([in] BSTR CallId, [out, retval] LONG *pVal);
01721       [propget, id(21), helpstring(hsICall_VmAllowDuration), helpcontext(45)] HRESULT CallVmAllowedDuration([in] BSTR CallId, [out, retval] LONG *pVal);
01722       [propget, id(22), helpstring(hsICall_VStatus), helpcontext(45)] HRESULT CallVideoStatus([in] BSTR CallId, [out, retval] TCallVideoStatus *pVal);
01723       [propget, id(23), helpstring(hsICall_VSendStatus), helpcontext(45)] HRESULT CallVideoSendStatus([in] BSTR CallId, [out, retval] TCallVideoSendStatus *pVal);
01724       [propget, id(24), helpstring(hsICall_VRecvStatus), helpcontext(45)] HRESULT CallVideoReceiveStatus([in] BSTR CallId, [out, retval] TCallVideoSendStatus *pVal);
01725       [id(25), helpstring(hsICall_StartVSend), helpcontext(45)] HRESULT StartCallVideoSend([in] BSTR CallId);
01726       [id(26), helpstring(hsICall_StopVSend), helpcontext(45)] HRESULT StopCallVideoSend([in] BSTR CallId);
01727       [id(27), helpstring(hsICall_StartVRecv), helpcontext(45)] HRESULT StartCallVideoReceive([in] BSTR CallId);
01728       [id(28), helpstring(hsICall_StopVRecv), helpcontext(45)] HRESULT StopCallVideoReceive([in] BSTR CallId);
01729       [id(29), helpstring(hsICall_Redirect), helpcontext(45)] HRESULT RedirectCallToVoicemail([in] BSTR CallId);
01730       [id(30), helpstring(hsICall_Forward), helpcontext(45)] HRESULT ForwardCall([in] BSTR CallId);
01731       [propget, id(31), helpstring(hsICall_Rate), helpcontext(45)] HRESULT CallRate([in] BSTR CallId, [out, retval] LONG *pVal);
01732       [propget, id(32), helpstring(hsICall_RateCurr), helpcontext(45)] HRESULT CallRateCurrency([in] BSTR CallId, [out, retval] BSTR *pVal);
01733       [propget, id(33), helpstring(hsICall_RatePrecision), helpcontext(45)] HRESULT CallRatePrecision([in] BSTR CallId, [out, retval] LONG *pVal);
01734       [propget, id(34), helpstring(hsICall_InputDevice), helpcontext(45)] HRESULT CallInputDevice([in] BSTR CallId, [in] TCallIoDeviceType DeviceType, [out, retval] BSTR* pVal);
01735       [propput, id(34), helpstring(hsICall_InputDevice), helpcontext(45)] HRESULT CallInputDevice([in] BSTR CallId, [in] TCallIoDeviceType DeviceType, [in] BSTR newVal);
01736       [propget, id(35), helpstring(hsICall_OutputDevice), helpcontext(45)] HRESULT CallOutputDevice([in] BSTR CallId, [in] TCallIoDeviceType DeviceType, [out, retval] BSTR* pVal);
01737       [propput, id(35), helpstring(hsICall_OutputDevice), helpcontext(45)] HRESULT CallOutputDevice([in] BSTR CallId, [in] TCallIoDeviceType DeviceType, [in] BSTR newVal);
01738       [propget, id(36), helpstring(hsICall_MicDevice), helpcontext(45)] HRESULT CallCaptureMicDevice([in] BSTR CallId, [in] TCallIoDeviceType DeviceType, [out, retval] BSTR* pVal);
01739       [propput, id(36), helpstring(hsICall_MicDevice), helpcontext(45)] HRESULT CallCaptureMicDevice([in] BSTR CallId, [in] TCallIoDeviceType DeviceType, [in] BSTR newVal);
01740       [propget, id(37), helpstring(hsICall_InputStatus), helpcontext(45)] HRESULT CallInputStatus([in] BSTR CallId, [out, retval] VARIANT_BOOL* pVal);
01741       [propget, id(38), helpstring(hsICall_ForwardedBy), helpcontext(45)] HRESULT CallForwardedBy([in] BSTR CallId, [out, retval] BSTR* pVal);
01742       [propget, id(12), helpstring(hsICall_Seen), helpcontext(45)] HRESULT CallSeenStatus([in] BSTR CallId, [out, retval] VARIANT_BOOL *pVal);
01743       [propget, id(39), helpstring(hsICall_CanTransfer), helpcontext(45)] HRESULT CallCanTransfer([in] BSTR CallId, [in] BSTR Target, [out, retval] VARIANT_BOOL *pVal);
01744       [propget, id(40), helpstring(hsICall_TransferStatus), helpcontext(45)] HRESULT CallTransferStatus([in] BSTR CallId, [out, retval] TCallStatus *pVal);
01745       [propget, id(41), helpstring(hsICall_TransferActive), helpcontext(45)] HRESULT CallTransferActive([in] BSTR CallId, [out, retval] VARIANT_BOOL *pVal);
01746       [propget, id(42), helpstring(hsICall_TransferredBy), helpcontext(45)] HRESULT CallTransferredBy([in] BSTR CallId, [out, retval] BSTR *pVal);
01747       [propget, id(43), helpstring(hsICall_TransferredTo), helpcontext(45)] HRESULT CallTransferredTo([in] BSTR CallId, [out, retval] BSTR *pVal);
01748       [id(44), helpstring(hsICall_Transfer), helpcontext(45)] HRESULT TransferCall([in] BSTR CallId, [in] BSTR Target);
01749       [propget, id(46), helpstring(hsICall_TargetIdentity), helpcontext(45)] HRESULT CallTargetIdentity([in] BSTR CallId, [out, retval] BSTR *pVal);
01750    };
01751    [
01752       object,
01753       uuid(C219279C-F557-4BAD-B3BE-750E91CA9944),
01754       dual,
01755       nonextensible,
01756       pointer_default(unique),
01757       oleautomation,
01758       helpstring(hsISkypeUser),
01759       helpcontext(46),
01760       hidden
01761    ]
01762    interface ISkypeUser : IDispatch
01763    {
01764       [propget, id(1), helpstring(hsIUser_FullName), helpcontext(46)] HRESULT UserFullName([in] BSTR Username, [out, retval] BSTR *pVal);
01765       [propget, id(2), helpstring(hsIUser_Birthday), helpcontext(46)] HRESULT UserBirthday([in] BSTR Username, [out, retval] DATE *pVal);
01766       [propget, id(3), helpstring(hsIUser_Sex), helpcontext(46)] HRESULT UserSex([in] BSTR Username, [out, retval] TUserSex *pVal);
01767       [propget, id(4), helpstring(hsIUser_Country), helpcontext(46)] HRESULT UserCountry([in] BSTR Username, [out, retval] BSTR *pVal);
01768       [propget, id(5), helpstring(hsIUser_Province), helpcontext(46)] HRESULT UserProvince([in] BSTR Username, [out, retval] BSTR *pVal);
01769       [propget, id(6), helpstring(hsIUser_City), helpcontext(46)] HRESULT UserCity([in] BSTR Username, [out, retval] BSTR *pVal);
01770       [propget, id(7), helpstring(hsIUser_PhoneHome), helpcontext(46)] HRESULT UserPhoneHome([in] BSTR Username, [out, retval] BSTR *pVal);
01771       [propget, id(8), helpstring(hsIUser_PhoneOffice), helpcontext(46)] HRESULT UserPhoneOffice([in] BSTR Username, [out, retval] BSTR *pVal);
01772       [propget, id(9), helpstring(hsIUser_PhoneMobile), helpcontext(46)] HRESULT UserPhoneMobile([in] BSTR Username, [out, retval] BSTR *pVal);
01773       [propget, id(10), helpstring(hsIUser_Homepage), helpcontext(46)] HRESULT UserHomepage([in] BSTR Username, [out, retval] BSTR *pVal);
01774       [propget, id(11), helpstring(hsIUser_About), helpcontext(46)] HRESULT UserAbout([in] BSTR Username, [out, retval] BSTR *pVal);
01775       [propget, id(12), helpstring(hsIUser_HasCallEquipment), helpcontext(46)] HRESULT UserHasCallEquipment([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01776       [propget, id(13), helpstring(hsIUser_BuddyStatus), helpcontext(46)] HRESULT UserBuddyStatus([in] BSTR Username, [out, retval] TBuddyStatus *pVal);
01777       [propput, id(13), helpstring(hsIUser_BuddyStatus), helpcontext(46)] HRESULT UserBuddyStatus([in] BSTR Username, [in] TBuddyStatus newVal);
01778       [propget, id(14), helpstring(hsIUser_Authorized), helpcontext(46)] HRESULT UserIsAuthorized([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01779       [propput, id(14), helpstring(hsIUser_Authorized), helpcontext(46)] HRESULT UserIsAuthorized([in] BSTR Username, [in] VARIANT_BOOL newVal);
01780       [propget, id(15), helpstring(hsIUser_Blocked), helpcontext(46)] HRESULT UserIsBlocked([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01781       [propput, id(15), helpstring(hsIUser_Blocked), helpcontext(46)] HRESULT UserIsBlocked([in] BSTR Username, [in] VARIANT_BOOL newVal);
01782       [propget, id(16), helpstring(hsIUser_DisplayName), helpcontext(46)] HRESULT UserDisplayName([in] BSTR Username, [out, retval] BSTR *pVal);
01783       [propget, id(17), helpstring(hsIUser_OnlineStatus), helpcontext(46)] HRESULT UserOnlineStatus([in] BSTR Username, [out, retval] TOnlineStatus *pVal);
01784       [propget, id(18), helpstring(hsIUser_LastOnline), helpcontext(46)] HRESULT UserLastOnline([in] BSTR Username, [out, retval] DATE *pVal);
01785       [propget, id(19), helpstring(hsIUser_CountryCode), helpcontext(46)] HRESULT UserCountryCode([in] BSTR Username, [out, retval] BSTR *pVal);
01786       [propget, id(20), helpstring(hsIUser_RecvAuthReq), helpcontext(46)] HRESULT UserReceivedAuthRequest([in] BSTR Username, [out, retval] BSTR *pVal);
01787       [propget, id(21), helpstring(hsIUser_SpeedDial), helpcontext(46)] HRESULT UserSpeedDial([in] BSTR Username, [out, retval] BSTR *pVal);
01788       [propput, id(21), helpstring(hsIUser_SpeedDial), helpcontext(46)] HRESULT UserSpeedDial([in] BSTR Username, [in] BSTR newVal);
01789       [propget, id(22), helpstring(hsIUser_CanLeaveVm), helpcontext(46)] HRESULT UserCanLeaveVoicemail([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01790       [propget, id(23), helpstring(hsIUser_MoodText), helpcontext(46)] HRESULT UserMoodText([in] BSTR Username, [out, retval] BSTR *pVal);
01791       [propget, id(24), helpstring(hsIUser_Aliases), helpcontext(46)] HRESULT UserAliases([in] BSTR Username, [out, retval] BSTR *pVal);
01792       [propget, id(25), helpstring(hsIUser_Timezone), helpcontext(46)] HRESULT UserTimezone([in] BSTR Username, [out, retval] LONG *pVal);
01793       [propget, id(26), helpstring(hsIUser_IsCFActive), helpcontext(46)] HRESULT IsCallForwardActive([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01794       [propget, id(27), helpstring(hsIUser_Language), helpcontext(46)] HRESULT UserLanguage([in] BSTR Username, [out, retval] BSTR *pVal);
01795       [propget, id(28), helpstring(hsIUser_LanguageCode), helpcontext(46)] HRESULT UserLanguageCode([in] BSTR Username, [out, retval] BSTR *pVal);
01796       [propget, id(29), helpstring(hsIUser_VideoCapable), helpcontext(46)] HRESULT UserIsVideoCapable([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01797       [propget, id(30), helpstring(hsIUser_NumberOfAuthBuddies), helpcontext(46)] HRESULT UserNumberOfAuthBuddies([in] BSTR Username, [out, retval] LONG* pVal);
01798       [propput, id(16), helpstring(hsIUser_DisplayName), helpcontext(46)] HRESULT UserDisplayName([in] BSTR Username, [in] BSTR newVal);
01799       [propget, id(31), helpstring(hsIUser_RichMoodText), helpcontext(46)] HRESULT UserRichMoodText([in] BSTR Username, [out, retval] BSTR *pVal);
01800       [propget, id(32), helpstring(hsIUser_IsVmCapable), helpcontext(46)] HRESULT UserIsVoicemailCapable([in] BSTR Username, [out, retval] VARIANT_BOOL *pVal);
01801    };
01802    [
01803       object,
01804       uuid(A569B841-CC8A-4C12-B937-CBC17D9E64F0),
01805       dual,
01806       nonextensible,
01807       pointer_default(unique),
01808       oleautomation,
01809       helpstring(hsISkypeChatMessage),
01810       helpcontext(47),
01811       hidden
01812    ]
01813    interface ISkypeChatMessage : IDispatch
01814    {
01815       [propget, id(1), helpstring(hsIChatMsg_Timestamp),helpcontext(47)] HRESULT ChatMessageTimestamp([in] BSTR MessageId, [out, retval] DATE *pVal);
01816       [propget, id(2), helpstring(hsIChatMsg_FromHandle),helpcontext(47)] HRESULT ChatMessageFromHandle([in] BSTR MessageId, [out, retval] BSTR *pVal);
01817       [propget, id(3), helpstring(hsIChatMsg_FromDispName),helpcontext(47)] HRESULT ChatMessageFromDisplayName([in] BSTR MessageId, [out, retval] BSTR *pVal);
01818       [propget, id(4), helpstring(hsIChatMsg_Type),helpcontext(47)] HRESULT ChatMessageType([in] BSTR MessageId, [out, retval] TChatMessageType *pVal);
01819       [propget, id(5), helpstring(hsIChatMsg_Status),helpcontext(47)] HRESULT ChatMessageStatus([in] BSTR MessageId, [out, retval] TChatMessageStatus *pVal);
01820       [propget, id(6), helpstring(hsIChatMsg_LeaveReason),helpcontext(47)] HRESULT ChatMessageLeaveReason([in] BSTR MessageId, [out, retval] TChatLeaveReason *pVal);
01821       [propget, id(7), helpstring(hsIChatMsg_Body),helpcontext(47)] HRESULT ChatMessageBody([in] BSTR MessageId, [out, retval] BSTR *pVal);
01822       [propget, id(8), helpstring(hsIChatMsg_ChatName),helpcontext(47)] HRESULT ChatMessageChatname([in] BSTR MessageId, [out, retval] BSTR *pVal);
01823       [propget, id(9), helpstring(hsIChatMsg_Users),helpcontext(47)] HRESULT ChatMessageUsers([in] BSTR MessageId, [out, retval] IUserCollection* *pVal);
01824       [propput, id(10), helpstring(hsIChatMsg_Seen),helpcontext(47)] HRESULT ChatMessageSeen([in] BSTR MessageId);
01825       [propget, id(11), helpstring(hsIChatMsg_Sender), helpcontext(47)] HRESULT ChatMessageSender([in] BSTR MessageId, [out, retval] IUser* *pVal);
01826       [propget, id(12), helpstring(hsIChatMsg_Editable), helpcontext(47)] HRESULT ChatMessageIsEditable([in] BSTR MessageId, [out, retval] VARIANT_BOOL* pVal);
01827       [propget, id(13), helpstring(hsIChatMsg_EditedBy), helpcontext(47)] HRESULT ChatMessageEditedBy([in] BSTR MessageId, [out, retval] BSTR* pVal);
01828       [propget, id(14), helpstring(hsIChatMsg_EditTime), helpcontext(47)] HRESULT ChatMessageEditedTimestamp(BSTR MessageId, [out, retval] DATE* pVal);
01829       [propput, id(7), helpstring(hsIChatMsg_Body), helpcontext(47)] HRESULT ChatMessageBody([in] BSTR MessageId, [in] BSTR newVal);
01830       [propget, id(15), helpstring(hsIChatMsg_Role), helpcontext(47)] HRESULT ChatMessageRole([in] BSTR MessageId, [out, retval] TChatMemberRole* pVal);
01831       [propget, id(16), helpstring(hsIChatMsg_Options), helpcontext(47)] HRESULT ChatMessageOptons([in] BSTR MessageId, [out, retval] LONG* pVal);
01832       [propget, id(17), helpstring(hsIChatMsg_Guid), helpcontext(47)] HRESULT ChatMessageGuid([in] BSTR MessageId, [out, retval] BSTR* pVal);
01833    };
01834    [
01835       object,
01836       uuid(6CF6DBDE-AB7C-4635-96ED-2FF525AB4457),
01837       dual,
01838       nonextensible,
01839       pointer_default(unique),
01840       oleautomation,
01841       helpstring(hsIChatMember),
01842       helpcontext(0),
01843       hidden
01844    ]
01845    interface ISkypeChatMember : IDispatch
01846    {
01847       [propget, id(1), helpstring(hsIChatMember_Id)] HRESULT ChatMemberHandle([in] BSTR MemberId, [out, retval] BSTR *pVal);
01848       [propget, id(2), helpstring(hsIChatMember_Role)] HRESULT ChatMemberRole([in] BSTR MemberId, [out, retval] TChatMemberRole* pVal);
01849       [propput, id(2), helpstring(hsIChatMember_Role)] HRESULT ChatMemberRole([in] BSTR MemberId, [in] TChatMemberRole newVal);
01850       [propget, id(3), helpstring(hsIChatMember_CanSetRole)] HRESULT CanSetChatMemberRoleTo([in] BSTR MemberId, [in] TChatMemberRole Role, [out, retval] VARIANT_BOOL* pVal);
01851       [propget, id(4), helpstring(hsIChatMember_IsActive)] HRESULT IsChatMemberActive([in] BSTR MemberId, [out, retval] VARIANT_BOOL* pVal);
01852       [propget, id(5), helpstring(hsIChatMember_Chat)] HRESULT ChatMemberChat([in] BSTR MemberId, [out, retval] IChat** pVal);
01853    };
01854    [
01855       object,
01856       uuid(30678F8A-C104-40C0-A6AE-7C150E83300E),
01857       dual,
01858       nonextensible,
01859       pointer_default(unique),
01860       oleautomation,
01861       helpstring(hsISkypeConference),
01862       helpcontext(49),
01863       hidden
01864    ]
01865    interface ISkypeConference : IDispatch
01866    {
01867       [propget, id(1), helpstring(hsIConference_Calls), helpcontext(49)] HRESULT ConferenceCalls([in] BSTR ConfId, [out, retval] ICallCollection **pVal);
01868       [propget, id(2), helpstring(hsIConference_ActiveCalls), helpcontext(49)] HRESULT ConferenceActiveCalls([in] BSTR ConfId, [out, retval] ICallCollection **pVal);
01869    };
01870    [
01871       object,
01872       uuid(4D33E14E-9921-4860-92F4-5DC1586F403C),
01873       dual,
01874       nonextensible,
01875       pointer_default(unique),
01876       oleautomation,
01877       helpstring(hsISkypeVoicemail),
01878       helpcontext(50),
01879       hidden
01880    ]
01881    interface ISkypeVoicemail : IDispatch
01882    {
01883       [propget, id(1), helpstring(hsIVoicemail_Type), helpcontext(50)] HRESULT VoicemailType([in] BSTR VoicemailId, [out, retval] TVoicemailType *pVal);
01884       [propget, id(2), helpstring(hsIVoicemail_PartHandle), helpcontext(50)] HRESULT VoicemailPartnerHandle([in] BSTR VoicemailId, [out, retval] BSTR *pVal);
01885       [propget, id(3), helpstring(hsIVoicemail_PartDispName), helpcontext(50)] HRESULT VoicemailPartnerDisplayName([in] BSTR VoicemailId, [out, retval] BSTR *pVal);
01886       [propget, id(4), helpstring(hsIVoicemail_Status), helpcontext(50)] HRESULT VoicemailStatus([in] BSTR VoicemailId, [out, retval] TVoicemailStatus *pVal);
01887       [propget, id(5), helpstring(hsIVoicemail_FailureReason), helpcontext(50)] HRESULT VoicemailFailureReason([in] BSTR VoicemailId, [out, retval] TVoicemailFailureReason *pVal);
01888       [propget, id(6), helpstring(hsIVoicemail_Timestamp), helpcontext(50)] HRESULT VoicemailTimestamp([in] BSTR VoicemailId, [out, retval] DATE *pVal);
01889       [propget, id(7), helpstring(hsIVoicemail_Duration), helpcontext(50)] HRESULT VoicemailDuration([in] BSTR VoicemailId, [out, retval] LONG *pVal);
01890       [propget, id(8), helpstring(hsIVoicemail_AllowedDuration), helpcontext(50)] HRESULT VoicemailAllowedDuration([in] BSTR VoicemailId, [out, retval] LONG *pVal);
01891       [id(9), helpstring(hsIVoicemail_Open), helpcontext(50)] HRESULT OpenVoicemail([in] BSTR VoicemailId);
01892       [id(10), helpstring(hsIVoicemail_StartPlay), helpcontext(50)] HRESULT StartVoicemailPlayback([in] BSTR VoicemailId);
01893       [id(11), helpstring(hsIVoicemail_StopPlay), helpcontext(50)] HRESULT StopVoicemailPlayback([in] BSTR VoicemailId);
01894       [id(12), helpstring(hsIVoicemail_Upload), helpcontext(50)] HRESULT UploadVoicemail([in] BSTR VoicemailId);
01895       [id(13), helpstring(hsIVoicemail_Download), helpcontext(50)] HRESULT DownloadVoicemail([in] BSTR VoicemailId);
01896       [id(14), helpstring(hsIVoicemail_StartRec), helpcontext(50)] HRESULT StartVoicemailRecording([in] BSTR VoicemailId);
01897       [id(15), helpstring(hsIVoicemail_StopRec), helpcontext(50)] HRESULT StopVoicemailRecording([in] BSTR VoicemailId);
01898       [id(16), helpstring(hsIVoicemail_Delete), helpcontext(50)] HRESULT DeleteVoicemail([in] BSTR VoicemailId);
01899       [id(17), helpstring(hsIVoicemail_PlayInCall), helpcontext(50)] HRESULT StartVoicemailPlaybackInCall([in] BSTR VoicemailId);
01900       [id(18), helpstring(hsIVoicemail_Unplayed), helpcontext(50)] HRESULT SetVoicemailUnplayed([in] BSTR VoicemailId);
01901    };
01902    [
01903       object,
01904       uuid(55A5200C-B2E8-4795-A6FA-858CA3FE2F26),
01905       dual,
01906       nonextensible,
01907       pointer_default(unique),
01908       oleautomation,
01909       helpstring(hsISkypeApplication),
01910       helpcontext(3),
01911       hidden
01912    ]
01913    interface ISkypeApplication : IDispatch
01914    {
01915       [id(1), helpstring(hsIApp_Create),helpcontext(3)] HRESULT CreateApplication([in] BSTR Name);
01916       [id(2), helpstring(hsIApp_Delete),helpcontext(3)] HRESULT DeleteApplication([in] BSTR Name);
01917       [propget, id(3), helpstring(hsIApp_Streams),helpcontext(3)] HRESULT ApplicationStreams([in] BSTR AppName, [out, retval] IApplicationStreamCollection **pVal);
01918       [id(4), helpstring(hsIApp_Connect),helpcontext(3)] HRESULT ConnectApplicationUser([in] BSTR AppName, [in] BSTR Username, [in, defaultvalue(0)] VARIANT_BOOL WaitConnected);
01919       [id(5), helpstring(hsIAppStm_Read),helpcontext(3)] HRESULT ReadApplicationStream([in] BSTR AppName, [in] BSTR StreamHandle, [out, retval] BSTR* pVal);
01920       [id(6), helpstring(hsIAppStm_Write),helpcontext(3)] HRESULT WriteApplicationStream([in] BSTR AppName, [in] BSTR StreamHandle, [in] BSTR Text);
01921       [propget, id(7), helpstring(hsIApp_ConnectableUsers),helpcontext(3)] HRESULT ApplicationConnectableUsers([in] BSTR AppName, [out, retval] IUserCollection* *pVal);
01922       [propget, id(8), helpstring(hsIApp_ConnectingUsers),helpcontext(3)] HRESULT ApplicationConnectingUsers([in] BSTR AppName, [out, retval] IUserCollection* *pVal);
01923       [id(9), helpstring(hsIApp_Disconnect),helpcontext(3)] HRESULT DisconnectApplicationUser([in] BSTR AppName, [in] BSTR Username);
01924       [id(10), helpstring(hsIAppStm_SendData),helpcontext(3)] HRESULT SendApplicationDatagram([in] BSTR AppName, [in] BSTR StreamHandle, [in] BSTR Text);
01925       [propget, id(11), helpstring(hsIApp_SendStreams),helpcontext(3)] HRESULT ApplicationSendingStreams([in] BSTR AppName, [out, retval] IApplicationStreamCollection **pVal);
01926       [propget, id(12), helpstring(hsIApp_RecvStreams),helpcontext(3)] HRESULT ApplicationReceivedStreams([in] BSTR AppName, [out, retval] IApplicationStreamCollection **pVal);
01927    };
01928    [
01929       object,
01930       uuid(2B929860-6AF4-40DF-9D77-308CA7C23E66),
01931       dual,
01932       pointer_default(unique),
01933       helpstring(""),
01934       helpcontext(0),
01935       hidden
01936    ]
01937    interface ISkypeFileTransfer : IDispatch
01938    {
01939       [propget, id(1), helpstring(hsIFileTransfer_Type), helpcontext(0)] HRESULT FileTransferType([in] BSTR TransferId, [out, retval] TFileTransferType* pVal);
01940       [propget, id(2), helpstring(hsIFileTransfer_Status), helpcontext(0)] HRESULT FileTransferStatus([in] BSTR TransferId, [out, retval] TFileTransferStatus* pVal);
01941       [propget, id(3), helpstring(hsIFileTransfer_FailReason), helpcontext(0)] HRESULT FileTransferFailureReason([in] BSTR TransferId, [out, retval] TFileTransferFailureReason* pVal);
01942       [propget, id(4), helpstring(hsIFileTransfer_PartnerHandle), helpcontext(0)] HRESULT FileTransferPartnerHandle([in] BSTR TransferId, [out, retval] BSTR* pVal);
01943       [propget, id(5), helpstring(hsIFileTransfer_PartnerDispName), helpcontext(0)] HRESULT FileTransferPartnerDisplayName([in] BSTR TransferId, [out, retval] BSTR* pVal);
01944       [propget, id(6), helpstring(hsIFileTransfer_StartTime), helpcontext(0)] HRESULT FileTransferStartTime([in] BSTR TransferId, [out, retval] DATE* pVal);
01945       [propget, id(7), helpstring(hsIFileTransfer_FinishTime), helpcontext(0)] HRESULT FileTransferFinishTime([in] BSTR TransferId, [out, retval] DATE* pVal);
01946       [propget, id(8), helpstring(hsIFileTransfer_FilePath), helpcontext(0)] HRESULT FileTransferFilePath([in] BSTR TransferId, [out, retval] BSTR* pVal);
01947       [propget, id(9), helpstring(hsIFileTransfer_FileName), helpcontext(0)] HRESULT FileTransferFileName([in] BSTR TransferId, [out, retval] BSTR* pVal);
01948       [propget, id(10), helpstring(hsIFileTransfer_ByteSec), helpcontext(0)] HRESULT FileTransferBytesPerSecond([in] BSTR TransferId, [out, retval] BSTR* pVal);
01949       [propget, id(11), helpstring(hsIFileTransfer_ByteTransferred), helpcontext(0)] HRESULT FileTransferBytesTransferred([in] BSTR TransferId, [out, retval] BSTR* pVal);
01950    };
01951 #endif /*DOXYGEN_SHOULD_SKIP_THIS*/
01952    [
01953       uuid(F4F90CDD-C620-4118-945E-CAA1BBEBA435),
01954       helpstring(hsISkypeEvents),
01955       helpcontext(4)
01956    ]
01957    dispinterface _ISkypeEvents
01958    {
01959       properties:
01960       methods:
01961       [id(1), helpstring(hsISkypeEvents_Command),helpcontext(4)] HRESULT Command([in] ICommand* pCommand);
01962       [id(2), helpstring(hsISkypeEvents_Reply),helpcontext(4)] HRESULT Reply([in] ICommand* pCommand);
01963       [id(3), helpstring(hsISkypeEvents_Error),helpcontext(4)] HRESULT Error([in] ICommand* pCommand, [in] LONG Number, [in] BSTR Description);
01964       [id(4), helpstring(hsISkypeEvents_AttachStat),helpcontext(4)] HRESULT AttachmentStatus([in] TAttachmentStatus Status);
01965       [id(5), helpstring(hsISkypeEvents_ConnStat),helpcontext(4)] HRESULT ConnectionStatus([in] TConnectionStatus Status);
01966       [id(6), helpstring(hsISkypeEvents_UserStat),helpcontext(4)] HRESULT UserStatus([in] TUserStatus Status);
01967       [id(7), helpstring(hsISkypeEvents_OnlineStat),helpcontext(4)] HRESULT OnlineStatus([in] IUser* pUser, [in] TOnlineStatus Status);
01968       [id(8), helpstring(hsISkypeEvents_CallStat),helpcontext(4)] HRESULT CallStatus([in] ICall* pCall, [in] TCallStatus Status);
01969       [id(9), helpstring(hsISkypeEvents_CallHist),helpcontext(4)] HRESULT CallHistory();
01970       [id(10), helpstring(hsISkypeEvents_Mute),helpcontext(4)] HRESULT Mute([in] VARIANT_BOOL Mute);
01971       [id(11), helpstring(hsISkypeEvents_MessStat),helpcontext(4)] HRESULT MessageStatus([in] IChatMessage* pMessage, [in] TChatMessageStatus Status);
01972       [id(12), helpstring(hsISkypeEvents_MessHist),helpcontext(4)] HRESULT MessageHistory([in] BSTR Username);
01973       [id(13), helpstring(hsISkypeEvents_AutoAway),helpcontext(4)] HRESULT AutoAway([in] VARIANT_BOOL Automatic);
01974       [id(14), helpstring(hsISkypeEvents_CallDtmf),helpcontext(4)] HRESULT CallDtmfReceived([in] ICall* pCall, [in] BSTR Code);
01975       [id(15), helpstring(hsISkypeEvents_VmailStat),helpcontext(4)] HRESULT VoicemailStatus([in] IVoicemail* pMail, [in] TVoicemailStatus Status);
01976       [id(16), helpstring(hsISkypeEvents_AppConnUsr),helpcontext(4)] HRESULT ApplicationConnecting([in] IApplication* pApp, [in] IUserCollection* pUsers);
01977       [id(17), helpstring(hsISkypeEvents_AppStreams),helpcontext(4)] HRESULT ApplicationStreams([in] IApplication* pApp, [in] IApplicationStreamCollection* pStreams);
01978       [id(18), helpstring(hsISkypeEvents_AppDatagrm),helpcontext(4)] HRESULT ApplicationDatagram([in] IApplication* pApp, [in] IApplicationStream* pStream, [in] BSTR Text);
01979       [id(19), helpstring(hsISkypeEvents_AppSending),helpcontext(4)] HRESULT ApplicationSending([in] IApplication* pApp, [in] IApplicationStreamCollection* pStreams);
01980       [id(20), helpstring(hsISkypeEvents_AppReceiving),helpcontext(4)] HRESULT ApplicationReceiving([in] IApplication* pApp, [in] IApplicationStreamCollection* pStreams);
01981       [id(21), helpstring(hsISkypeEvents_ContactFocus),helpcontext(4)] HRESULT ContactsFocused([in] BSTR Username);
01982       [id(22), helpstring(hsISkypeEvents_GroupVisible),helpcontext(4)] HRESULT GroupVisible([in] IGroup* pGroup, [in] VARIANT_BOOL Visible);
01983       [id(23), helpstring(hsISkypeEvents_GroupExpanded),helpcontext(4)] HRESULT GroupExpanded([in] IGroup* pGroup, [in] VARIANT_BOOL Expanded);
01984       [id(24), helpstring(hsISkypeEvents_GroupUsers),helpcontext(4)] HRESULT GroupUsers([in] IGroup* pGroup, [in] IUserCollection* pUsers);
01985       [id(25), helpstring(hsISkypeEvents_GroupDeleted),helpcontext(4)] HRESULT GroupDeleted([in] LONG GroupId);
01986       [id(26), helpstring(hsISkypeEvents_UserMood),helpcontext(4)] HRESULT UserMood([in] IUser* pUser, [in] BSTR MoodText);
01987       [id(27), helpstring(hsISkypeEvents_SmsMessageStatus),helpcontext(4)] HRESULT SmsMessageStatusChanged([in] ISmsMessage* pMessage, [in] TSmsMessageStatus Status);
01988       [id(28), helpstring(hsISkypeEvents_SmsTargetStatus),helpcontext(4)] HRESULT SmsTargetStatusChanged([in] ISmsTarget* pTarget, [in] TSmsTargetStatus Status);
01989       [id(29), helpstring(hsISkypeEvents_VoiceInputStatusChanged),helpcontext(4)] HRESULT CallInputStatusChanged([in] ICall* pCall, [in] VARIANT_BOOL Status);
01990       [id(30), helpstring(hsISkypeEvents_AsyncSearchFinished),helpcontext(4)] HRESULT AsyncSearchUsersFinished([in] LONG Cookie, [in] IUserCollection* pUsers);
01991       [id(31), helpstring(hsISkypeEvents_CallSeenStatusChanged),helpcontext(4)] HRESULT CallSeenStatusChanged([in] ICall* pCall, VARIANT_BOOL Status);
01992       [id(32), helpstring(hsISkypeEvents_PluginEventClicked),helpcontext(4)] HRESULT PluginEventClicked([in] IPluginEvent* pEvent);
01993       [id(33), helpstring(hsISkypeEvents_PluginMenuItemClicked),helpcontext(4)] HRESULT PluginMenuItemClicked([in] IPluginMenuItem* pMenuItem, [in] IUserCollection* pUsers, [in] TPluginContext PluginContext, [in] BSTR ContextId);
01994       [id(34), helpstring(hsISkypeEvents_WallpaperChanged),helpcontext(4)] HRESULT WallpaperChanged([in] BSTR Path);
01995       [id(35), helpstring(hsISkypeEvents_FileTransferStatusChanged),helpcontext(4)] HRESULT FileTransferStatusChanged([in] IFileTransfer* pTransfer, [in] TFileTransferStatus Status);
01996       [id(36), helpstring(hsISkypeEvents_CallTransferStatusChanged),helpcontext(4)] HRESULT CallTransferStatusChanged([in] ICall* pCall, [in] TCallStatus Status);
01997       [id(37), helpstring(hsISkypeEvents_ChatMembersChanged),helpcontext(4)] HRESULT ChatMembersChanged([in] IChat* pChat, [in] IUserCollection* pMembers);
01998       [id(38), helpstring(hsISkypeEvents_ChatMemberRoleChanged),helpcontext(4)] HRESULT ChatMemberRoleChanged([in] IChatMember* pMember, [in] TChatMemberRole Role);
01999       [id(39), helpstring(""),helpcontext(4)] HRESULT CallVideoStatusChanged([in] ICall* pCall, [in] TCallVideoStatus Status);
02000       [id(40), helpstring(""),helpcontext(4)] HRESULT CallVideoSendStatusChanged([in] ICall* pCall, [in] TCallVideoSendStatus Status);
02001       [id(41), helpstring(""),helpcontext(4)] HRESULT CallVideoReceiveStatusChanged([in] ICall* pCall, [in] TCallVideoSendStatus Status);
02002       [id(42), helpstring(""),helpcontext(4)] HRESULT SilentModeStatusChanged([in] VARIANT_BOOL Silent);
02003       [id(43), helpstring(""),helpcontext(4)] HRESULT UILanguageChanged([in] BSTR Code);
02004       [id(44), helpstring(""),helpcontext(4)] HRESULT UserAuthorizationRequestReceived([in] IUser* pUser);
02005    };
02006 #ifndef DOXYGEN_SHOULD_SKIP_THIS
02007    [
02008       object,
02009       uuid(3F6758D2-1D3C-4A8F-BD99-6FC6B0E2DC8F),
02010       dual,
02011       nonextensible,
02012       pointer_default(unique),
02013       oleautomation,
02014       helpstring(hsISkypeChat),
02015       helpcontext(48),
02016       hidden
02017    ]
02018    interface ISkypeChat : IDispatch
02019    {
02020       [propget, id(1), helpstring(hsIChat_Timestamp), helpcontext(48)] HRESULT ChatTimestamp([in] BSTR ChatName, [out, retval] DATE *pVal);
02021       [propget, id(2), helpstring(hsIChat_Adder), helpcontext(48)] HRESULT ChatAdder([in] BSTR ChatName, [out, retval] IUser **pVal);
02022       [propget, id(3), helpstring(hsIChat_Status), helpcontext(48)] HRESULT ChatStatus([in] BSTR ChatName, [out, retval] TChatStatus *pVal);
02023       [propget, id(4), helpstring(hsIChat_Posters), helpcontext(48)] HRESULT ChatPosters([in] BSTR ChatName, [out, retval] IUserCollection **pVal);
02024       [propget, id(5), helpstring(hsIChat_Members), helpcontext(48)] HRESULT ChatMembers([in] BSTR ChatName, [out, retval] IUserCollection **pVal);
02025       [propget, id(6), helpstring(hsIChat_Topic), helpcontext(48)] HRESULT ChatTopic([in] BSTR ChatName, [out, retval] BSTR *pVal);
02026       [propput, id(6), helpstring(hsIChat_Topic), helpcontext(48)] HRESULT ChatTopic([in] BSTR ChatName, [in] BSTR newVal);
02027       [propget, id(7), helpstring(hsIChat_ActiveMembers), helpcontext(48)] HRESULT ChatActiveMembers([in] BSTR ChatName, [out, retval] IUserCollection **pVal);
02028       [propget, id(8), helpstring(hsIChat_FriendlyName), helpcontext(48)] HRESULT ChatFriendlyName([in] BSTR ChatName, [out, retval] BSTR *pVal);
02029       [propget, id(9), helpstring(hsIChat_Messages), helpcontext(48)] HRESULT ChatMessages([in] BSTR ChatName, [out, retval] IChatMessageCollection **pVal);
02030       [id(10), helpstring(hsIChat_OpenWindow), helpcontext(48)] HRESULT OpenChatWindow([in] BSTR ChatName);
02031       [id(11), helpstring(hsIChat_SendMessage), helpcontext(48)] HRESULT SendChatMessage([in] BSTR ChatName, [in] BSTR MessageText, [out, retval] IChatMessage **pVal);
02032       [id(12), helpstring(hsIChat_Leave), helpcontext(48)] HRESULT LeaveChat([in] BSTR ChatName);
02033       [id(13), helpstring(hsIChat_AddMembers), helpcontext(48)] HRESULT AddChatMembers([in] BSTR ChatName, [in] IUserCollection* pMembers);
02034       [propget, id(14), helpstring(hsIChat_RecentMessages), helpcontext(48)] HRESULT ChatRecentMessages([in] BSTR ChatName, [out, retval] IChatMessageCollection **pVal);
02035       [propget, id(15), helpstring(hsIChat_Bookmarked), helpcontext(48)] HRESULT ChatBookmarked([in] BSTR ChatName, [out, retval] VARIANT_BOOL *pVal);
02036       [id(16), helpstring(hsIChat_Bookmark), helpcontext(48)] HRESULT BookmarkChat([in] BSTR ChatName);
02037       [id(17), helpstring(hsIChat_Unbookmark), helpcontext(48)] HRESULT UnbookmarkChat([in] BSTR ChatName);
02038       [propget, id(18), helpstring(hsIChat_TopicXML), helpcontext(48)] HRESULT ChatTopicXML([in] BSTR ChatName, [out, retval] BSTR *pVal);
02039       [propput, id(18), helpstring(hsIChat_TopicXML), helpcontext(48)] HRESULT ChatTopicXML([in] BSTR ChatName, [in] BSTR newVal);
02040       [propget, id(19), helpstring(hsIChat_MemberObjs), helpcontext(48)] HRESULT ChatMemberObjects([in] BSTR ChatName, [out, retval] IChatMemberCollection **pVal);
02041       [propget, id(20), helpstring(hsIChat_Blob), helpcontext(48)] HRESULT ChatBlob([in] BSTR ChatName, [out, retval] BSTR* pVal);
02042       [propget, id(21), helpstring(hsIChat_Options), helpcontext(48)] HRESULT ChatOptions([in] BSTR ChatName, [out, retval] LONG* pVal);
02043       [propput, id(21), helpstring(hsIChat_Options), helpcontext(48)] HRESULT ChatOptions([in] BSTR ChatName, [in] LONG newVal);
02044       [propget, id(22), helpstring(hsIChat_Passwdhint), helpcontext(48)] HRESULT ChatPasswordHint([in] BSTR ChatName, [out, retval] BSTR* pVal);
02045       [id(23), helpstring(hsIChat_Password), helpcontext(48)] HRESULT SetChatPassword([in] BSTR ChatName, [in] BSTR Password, [in, defaultvalue("")] BSTR Hint);
02046       [propget, id(24), helpstring(hsIChat_Guidelines), helpcontext(48)] HRESULT ChatGuideLines([in] BSTR ChatName, [out, retval] BSTR* pVal);
02047       [propput, id(24), helpstring(hsIChat_Guidelines), helpcontext(48)] HRESULT ChatGuideLines([in] BSTR ChatName, [in] BSTR newVal);
02048       [propget, id(25), helpstring(hsIChat_Description), helpcontext(48)] HRESULT ChatDescription([in] BSTR ChatName, [out, retval] BSTR* pVal);
02049       [propput, id(25), helpstring(hsIChat_Description), helpcontext(48)] HRESULT ChatDescription([in] BSTR ChatName, [in] BSTR newVal);
02050       [propget, id(26), helpstring(hsIChat_DialogPartner), helpcontext(48)] HRESULT ChatDialogPartner([in] BSTR ChatName, [out, retval] BSTR* pVal);
02051       [propget, id(27), helpstring(hsIChat_ActiveTime), helpcontext(48)] HRESULT ChatActivityTimestamp([in] BSTR ChatName, [out, retval] DATE* pVal);
02052       [propget, id(28), helpstring(hsIChat_MyRole), helpcontext(48)] HRESULT ChatMyRole([in] BSTR ChatName, [out, retval] TChatMemberRole* pVal);
02053       [propget, id(29), helpstring(hsIChat_Applicants), helpcontext(48)] HRESULT ChatApplicants([in] BSTR ChatName, [out, retval] IUserCollection** pVal);
02054       [id(30), helpstring(hsIChat_Join), helpcontext(48)] HRESULT JoinChat([in] BSTR ChatName);
02055       [id(31), helpstring(hsIChat_Kick), helpcontext(48)] HRESULT KickChatMember([in] BSTR ChatName, [in] BSTR Handle);
02056       [id(32), helpstring(hsIChat_Kickban), helpcontext(48)] HRESULT KickBanChatMember([in] BSTR ChatName, [in] BSTR Handle);
02057       [id(33), helpstring(hsIChat_Disband), helpcontext(48)] HRESULT DisbandChat([in] BSTR ChatName);
02058       [id(34), helpstring(hsIChat_EnterPasswd), helpcontext(48)] HRESULT EnterChatPassword([in] BSTR ChatName, [in] BSTR Password);
02059       [id(35), helpstring(hsIChat_ClearRecentMsg), helpcontext(48)] HRESULT ClearChatRecentMessages([in] BSTR ChatName);
02060       [id(36), helpstring(hsIChat_AcceptAdd), helpcontext(48)] HRESULT AcceptSharedGroupAdd([in] BSTR ChatName);
02061       [propput, id(37), helpstring(hsIChat_AlertString), helpcontext(48)] HRESULT ChatAlertString([in] BSTR ChatName, [in] BSTR newVal);
02062       [propget, id(38), helpstring(hsIChat_Type), helpcontext(48)] HRESULT ChatType([in] BSTR ChatName, [out, retval] TChatType* pVal);
02063       [propget, id(39), helpstring(hsIChat_MyStatus), helpcontext(48)] HRESULT ChatMyStatus([in] BSTR ChatName, [out, retval] TChatMyStatus* pVal);
02064    };
02065    [
02066       object,
02067       uuid(4541C958-6341-4AC1-A6B0-722C89049928),
02068       dual,
02069       nonextensible,
02070       pointer_default(unique),
02071       oleautomation,
02072       helpstring(hsISkypeGroup),
02073       helpcontext(9),
02074       hidden
02075    ]
02076    interface ISkypeGroup : IDispatch
02077    {
02078       [propget, id(1), helpstring(hsIGroup_Type), helpcontext(9)] HRESULT GroupType([in] BSTR GroupId, [out, retval] TGroupType *pVal);
02079       [propget, id(2), helpstring(hsIGroup_CustomId), helpcontext(9)] HRESULT GroupCustomId([in] BSTR GroupId, [out, retval] BSTR *pVal);
02080       [propget, id(3), helpstring(hsIGroup_DisplayName), helpcontext(9)] HRESULT GroupDisplayName([in] BSTR GroupId, [out, retval] BSTR *pVal);
02081       [propput, id(3), helpstring(hsIGroup_DisplayName), helpcontext(9)] HRESULT GroupDisplayName([in] BSTR GroupId, [in] BSTR newVal);
02082       [propget, id(4), helpstring(hsIGroup_Users), helpcontext(9)] HRESULT GroupUsers([in] BSTR GroupId,[out, retval] IUserCollection* *pVal);
02083       [propget, id(5), helpstring(hsIGroup_IsVisible), helpcontext(9)] HRESULT GroupIsVisible([in] BSTR GroupId, [out, retval] VARIANT_BOOL *pVal);
02084       [propget, id(6), helpstring(hsIGroup_IsExpanded), helpcontext(9)] HRESULT GroupIsExpanded([in] BSTR GroupId, [out, retval] VARIANT_BOOL *pVal);
02085       [id(7), helpstring(hsIGroup_AddUser), helpcontext(9)] HRESULT AddGroupUser([in] BSTR GroupId, [in] BSTR Username);
02086       [id(8), helpstring(hsIGroup_RemoveUser), helpcontext(9)] HRESULT RemoveGroupUser([in] BSTR GroupId, [in] BSTR Username);
02087       [id(9), helpstring(hsIGroup_Share), helpcontext(9)] HRESULT ShareGroup([in] BSTR GroupId, [in] BSTR MessageText);
02088       [id(10), helpstring(hsIGroup_Accept), helpcontext(9)] HRESULT AcceptSharedGroup([in] BSTR GroupId);
02089       [id(11), helpstring(hsIGroup_Decline)] HRESULT DeclineSharedGroup([in] BSTR GroupId);
02090    };
02091    [
02092       object,
02093       uuid(B8731A95-8812-48D7-A1D1-438C108F8C2C),
02094       dual,
02095       nonextensible,
02096       pointer_default(unique),
02097       oleautomation,
02098       helpstring(hsISkypeSettings),
02099       helpcontext(2),
02100       hidden
02101    ]
02102    interface ISkypeSettings : IDispatch
02103    {
02104       [propget, id(1), helpstring(hsISettings_AudioIn),helpcontext(2)] HRESULT AudioIn([out, retval] BSTR *pVal);
02105       [propput, id(1), helpstring(hsISettings_AudioIn),helpcontext(2)] HRESULT AudioIn([in] BSTR newVal);
02106       [propget, id(2), helpstring(hsISettings_AudioOut),helpcontext(2)] HRESULT AudioOut([out, retval] BSTR *pVal);
02107       [propput, id(2), helpstring(hsISettings_AudioOut),helpcontext(2)] HRESULT AudioOut([in] BSTR newVal);
02108       [propget, id(3), helpstring(hsISettings_AutoAway),helpcontext(2)] HRESULT AutoAway([out, retval] VARIANT_BOOL *pVal);
02109       [propput, id(3), helpstring(hsISettings_AutoAway),helpcontext(2)] HRESULT AutoAway([in] VARIANT_BOOL newVal);
02110       [propget, id(4), helpstring(hsISettings_Ringer),helpcontext(2)] HRESULT Ringer([out, retval] BSTR *pVal);
02111       [propput, id(4), helpstring(hsISettings_Ringer),helpcontext(2)] HRESULT Ringer([in] BSTR newVal);
02112       [propput, id(5), helpstring(hsISettings_Avatar),helpcontext(2)] HRESULT Avatar([in, defaultvalue("1")] BSTR Id, [in] BSTR newVal);
02113       [propget, id(6), helpstring(hsISettings_RingToneStatus),helpcontext(2)] HRESULT RingToneStatus([in, defaultvalue("1")] BSTR Id,[out, retval] VARIANT_BOOL *pVal);
02114       [propput, id(7), helpstring(hsISettings_RingTone),helpcontext(2)] HRESULT RingTone([in, defaultvalue("1")] BSTR Id, [in] BSTR newVal);
02115       [propget, id(8), helpstring(hsISettings_VideoIn),helpcontext(2)] HRESULT VideoIn([out, retval] BSTR *pVal);
02116       [propput, id(8), helpstring(hsISettings_VideoIn),helpcontext(2)] HRESULT VideoIn([in] BSTR newVal);
02117       [propget, id(9), helpstring(hsISettings_PCSpeaker),helpcontext(2)] HRESULT PCSpeaker([out, retval] VARIANT_BOOL *pVal);
02118       [propput, id(9), helpstring(hsISettings_PCSpeaker),helpcontext(2)] HRESULT PCSpeaker([in] VARIANT_BOOL newVal);
02119       [propget, id(10), helpstring(hsISettings_AGC),helpcontext(2)] HRESULT AGC([out, retval] VARIANT_BOOL *pVal);
02120       [propput, id(10), helpstring(hsISettings_AGC),helpcontext(2)] HRESULT AGC([in] VARIANT_BOOL newVal);
02121       [propget, id(11), helpstring(hsISettings_AEC),helpcontext(2)] HRESULT AEC([out, retval] VARIANT_BOOL *pVal);
02122       [propput, id(11), helpstring(hsISettings_AEC),helpcontext(2)] HRESULT AEC([in] VARIANT_BOOL newVal);
02123       [propget, id(12), helpstring(hsISettings_Language),helpcontext(2)] HRESULT Language([out, retval] BSTR *pVal);
02124       [propput, id(12), helpstring(hsISettings_Language),helpcontext(2)] HRESULT Language([in] BSTR newVal);
02125       [propput, id(6), helpstring(hsISettings_RingToneStatus),helpcontext(2)] HRESULT RingToneStatus([in, defaultvalue("1")] BSTR Id, [in] VARIANT_BOOL newVal);
02126       [id(13), helpstring(hsISettings_SaveAvatar), helpcontext(2)] HRESULT SaveAvatarToFile([in] BSTR Filename, [in, defaultvalue("1")] BSTR AvatarId);
02127       [id(14), helpstring(hsISettings_LoadAvatar), helpcontext(2)] HRESULT LoadAvatarFromFile([in] BSTR Filename, [in, defaultvalue("1")] BSTR AvatarId);
02128       [id(15), helpstring(hsISettings_IdleTimer),helpcontext(2)] HRESULT ResetIdleTimer(void);
02129    };
02130    [
02131       object,
02132       uuid(B6BED647-709E-4B4B-B1E3-B0105999966F),
02133       dual,
02134       nonextensible,
02135       pointer_default(unique),
02136       oleautomation,
02137       helpstring(hsISkypeClient),
02138       helpcontext(36),
02139       hidden
02140    ]
02141    interface ISkypeClient : IDispatch
02142    {
02143       [id(1), helpstring(hsIClient_Start), helpcontext(36)] HRESULT Start([in, defaultvalue(0)] VARIANT_BOOL Minimized, [in, defaultvalue(0)] VARIANT_BOOL Nosplash);
02144       [id(2), helpstring(hsIClient_Minimize), helpcontext(36)] HRESULT Minimize();
02145       [id(3), helpstring(hsIClient_Shutdown), helpcontext(36)] HRESULT Shutdown();
02146       [propget, id(4), helpstring(hsIClient_Running),helpcontext(36)] HRESULT IsRunning([out, retval] VARIANT_BOOL *pVal);
02147       [id(5), helpstring(hsIClient_OpenProfile),helpcontext(36)] HRESULT OpenProfileDialog();
02148       [id(6), helpstring(hsIClient_OpenUserinfo),helpcontext(36)] HRESULT OpenUserInfoDialog([in] BSTR Username);
02149       [id(7), helpstring(hsIClient_OpenConference),helpcontext(36)] HRESULT OpenConferenceDialog();
02150       [id(8), helpstring(hsIClient_OpenSearch),helpcontext(36)] HRESULT OpenSearchDialog();
02151       [id(9), helpstring(hsIClient_OpenOptions),helpcontext(36)] HRESULT OpenOptionsDialog([in] BSTR Page);
02152       [id(10), helpstring(hsIClient_OpenCallHist),helpcontext(36)] HRESULT OpenCallHistoryTab();
02153       [id(11), helpstring(hsIClient_OpenContacts),helpcontext(36)] HRESULT OpenContactsTab();
02154       [id(12), helpstring(hsIClient_OpenDialpad),helpcontext(36)] HRESULT OpenDialpadTab();
02155       [id(13), helpstring(hsIClient_OpenSendCont),helpcontext(36)] HRESULT OpenSendContactsDialog([in, defaultvalue("")] BSTR Username);
02156       [id(14), helpstring(hsIClient_OpenBlockUser),helpcontext(36)] HRESULT OpenBlockedUsersDialog();
02157       [id(15), helpstring(hsIClient_OpenImportContact),helpcontext(36)] HRESULT OpenImportContactsWizard();
02158       [id(16), helpstring(hsIClient_OpenGetStart),helpcontext(36)] HRESULT OpenGettingStartedWizard();
02159       [id(17), helpstring(hsIClient_OpenAuthoriz),helpcontext(36)] HRESULT OpenAuthorizationDialog([in] BSTR Username);
02160       [id(18), helpstring(hsIClient_OpenDialog),helpcontext(36)] HRESULT OpenDialog([in] BSTR Name, [in, defaultvalue("")] BSTR Param1, [in, defaultvalue("")] BSTR Param2);
02161       [id(19), helpstring(hsIClient_OpenVideoTest),helpcontext(36)] HRESULT OpenVideoTestDialog();
02162       [id(20), helpstring(hsIClient_OpenAddContact),helpcontext(36)] HRESULT OpenAddContactDialog([in, defaultvalue("")] BSTR Username);
02163       [id(21), helpstring(hsIClient_OpenMessage),helpcontext(36)] HRESULT OpenMessageDialog([in] BSTR Username, [in, defaultvalue("")] BSTR Text);
02164       [id(22), helpstring(hsIClient_OpenFileTrans),helpcontext(36)] HRESULT OpenFileTransferDialog([in] BSTR Username, [in] BSTR Folder);
02165       [id(23), helpstring(hsIClient_Focus),helpcontext(36)] HRESULT Focus();
02166       [id(24), helpstring(hsIClient_BtnPressed),helpcontext(36)] HRESULT ButtonPressed([in] BSTR Key);
02167       [id(25), helpstring(hsIClient_BtnReleased),helpcontext(36)] HRESULT ButtonReleased([in] BSTR Key);
02168       [id(26), helpstring(hsIClient_OpenSms), helpcontext(36)] HRESULT OpenSmsDialog([in] BSTR SmsId);
02169       [propget, id(27), helpstring(hsIClient_Wallpaper), helpcontext(36)] HRESULT Wallpaper([out, retval] BSTR* pVal);
02170       [propput, id(27), helpstring(hsIClient_Wallpaper), helpcontext(36)] HRESULT Wallpaper([in] BSTR newVal);
02171       [id(28), helpstring(hsIClient_OpenLive),helpcontext(36)] HRESULT OpenLiveTab();
02172    };
02173    [
02174       object,
02175       uuid(B77A3D1F-6847-402f-BB82-A0564379088E),
02176       dual,
02177       nonextensible,
02178       pointer_default(unique),
02179       oleautomation,
02180       helpstring(""),
02181       helpcontext(0),
02182       hidden
02183    ]
02184    interface ISkypePlugin : IDispatch
02185    {
02186       [id(1), helpstring(""), helpcontext(0)] HRESULT CreatePluginEvent([in] BSTR EventId, [in] BSTR Caption, [in] BSTR Hint, [out,retval] IPluginEvent** pEvent);
02187       [id(2), helpstring(""), helpcontext(0)] HRESULT DeletePluginEvent([in] BSTR EventId);
02188       [id(3), helpstring(""), helpcontext(0)] HRESULT CreatePluginMenuItem([in] BSTR MenuItemId, [in] TPluginContext PluginContext, [in] BSTR CaptionText, [in,defaultvalue("")] BSTR HintText, [in, defaultvalue("")] BSTR IconPath, [in, defaultvalue(-1)] VARIANT_BOOL Enabled, [in, defaultvalue(pluginContactTypeAll)] TPluginContactType ContactType, [in, defaultvalue(0)] VARIANT_BOOL MultipleContacts, [out,retval] IPluginMenuItem** pMenuItem);
02189       [id(4), helpstring(""), helpcontext(0)] HRESULT DeletePluginMenuItem([in] BSTR MenuItemId);
02190       [propput, id(5), helpstring(""), helpcontext(0)] HRESULT PluginMenuItemCaption([in] BSTR MenuItemId, [in] BSTR newVal);
02191       [propput, id(6), helpstring(""), helpcontext(0)] HRESULT PluginMenuItemHint([in] BSTR MenuItemId, [in] BSTR newVal);
02192       [id(7), helpstring(""), helpcontext(0)] HRESULT EnablePluginMenuItem([in] BSTR MenuItemId, [in] VARIANT_BOOL Enabled);
02193    };
02194 #endif /*DOXYGEN_SHOULD_SKIP_THIS*/
02195
02196    interface ICallChannelManager;
02197    [
02198       object,
02199       uuid(B76C04C9-0EB1-4748-B0C0-D01DEB595906),
02200       dual,
02201       nonextensible,
02202       pointer_default(unique),
02203       oleautomation,
02204       helpstring(hsICallChannel),
02205       helpcontext(67)
02206    ]
02207    interface ICallChannel : IDispatch
02208    {
02209       [propget, id(2), helpstring(hsICallChannel_Type), helpcontext(67)] HRESULT Type([out, retval] TCallChannelType *pVal);
02210       [propput, id(2), helpstring("hsICallChannel_Type"), helpcontext(67)] HRESULT Type([in] TCallChannelType newVal);
02211       [id(3), helpstring(hsICallChannel_Send), helpcontext(67)] HRESULT SendTextMessage(BSTR Text);
02212       [propget, id(4), helpstring(hsICallChannel_Stream), helpcontext(67)] HRESULT Stream([out, retval] IApplicationStream* *pVal);
02213       [propget, id(5), helpstring(hsICallChannel_Manager), helpcontext(67)] HRESULT Manager([out, retval] ICallChannelManager* *pVal);
02214       [propget, id(6), helpstring(hsICallChannel_Call), helpcontext(67)] HRESULT Call([out, retval] ICall* *pVal);
02215    };
02216    [
02217       object,
02218       uuid(8CB09087-E389-4C6D-A6A2-7D4BCA8545D9),
02219       dual,
02220       nonextensible,
02221       pointer_default(unique),
02222       oleautomation,
02223       helpstring(hsICallChannelColl),
02224       helpcontext(68)
02225    ]
02226    interface ICallChannelCollection : IDispatch
02227    {
02228       [propget, id(1), helpstring(hsICallChannelColl_Count),helpcontext(68)] HRESULT Count([out, retval] LONG* pVal);
02229       [id(2), helpstring(hsICallChannelColl_Add), helpcontext(68)] HRESULT Add([in] ICallChannel* pChannel);
02230       [id(3), helpstring(hsICallChannelColl_Remove), helpcontext(68)] HRESULT Remove([in] long Index);
02231       [id(4), helpstring(hsICallChannelColl_RemoveAll), helpcontext(68)] HRESULT RemoveAll(void);
02232       [propget, id(DISPID_VALUE), helpstring(hsICallChannelColl_Item), helpcontext(68)] HRESULT Item([in] LONG Index, [out, retval] ICallChannel** pVal);
02233       [propget, id(DISPID_NEWENUM), helpstring(hsICallChannelColl_NewEnum), helpcontext(68)] HRESULT _NewEnum([out, retval] IUnknown** pVal);
02234    };
02235    [
02236       object,
02237       uuid(30C27C77-525F-4A3F-B9DD-C5A77C67250D),
02238       dual,
02239       nonextensible,
02240       pointer_default(unique),
02241       oleautomation,
02242       helpstring(hsICallChannelMgr),
02243       helpcontext(69)
02244    ]
02245    interface ICallChannelManager : IDispatch
02246    {
02247       [id(1), helpstring(hsICallChannelMgr_Connect), helpcontext(69)] HRESULT Connect([in] ISkype* pSkype);
02248       [id(2), helpstring(hsICallChannelMgr_Disconnect), helpcontext(69)] HRESULT Disconnect();
02249       [propget, id(3), helpstring(hsICallChannelMgr_Channels), helpcontext(69)] HRESULT Channels([out, retval] ICallChannelCollection** pVal);
02250       [propget, id(6), helpstring(hsICallChannelMgr_ChannelType), helpcontext(69)] HRESULT ChannelType([out, retval] TCallChannelType *pVal);
02251       [propput, id(6), helpstring(hsICallChannelMgr_ChannelType), helpcontext(69)] HRESULT ChannelType([in] TCallChannelType newVal);
02252       [propget, id(7), helpstring(hsICallChannelMgr_Name), helpcontext(69)] HRESULT Name([out, retval] BSTR *pVal);
02253       [propput, id(7), helpstring(hsICallChannelMgr_Name), helpcontext(69)] HRESULT Name([in] BSTR newVal);
02254       [id(8), helpstring(hsICallChannelMgr_Create), helpcontext(69)] HRESULT CreateApplication([in, defaultvalue("")] BSTR ApplicationName);
02255       [propget, id(9), helpstring(hsICallChannelMgr_Created), helpcontext(69)] HRESULT Created([out, retval] VARIANT_BOOL *pVal);
02256    };
02257    [
02258       object,
02259       uuid(0EF6FD5D-607D-4EA3-9C90-683D73449E9D),
02260       dual,
02261       nonextensible,
02262       pointer_default(unique),
02263       oleautomation,
02264       helpstring(hsICallChannelMsg),
02265       helpcontext(70)
02266    ]
02267    interface ICallChannelMessage : IDispatch
02268    {
02269       [propget, id(1), helpstring(hsICallChannelMsg_Text), helpcontext(70)] HRESULT Text([out, retval] BSTR *pVal);
02270       [propput, id(1), helpstring(hsICallChannelMsg_Text), helpcontext(70)] HRESULT Text([in] BSTR newVal);
02271    };
02272    [
02273       uuid(497ABB45-20AE-49D1-A39D-CBE84A31B20C),
02274       helpstring(ICallChannelManagerEvents), helpcontext(71)
02275    ]
02276    dispinterface _ICallChannelManagerEvents
02277    {
02278       properties:
02279       methods:
02280       [id(1), helpstring(ICallChannelManagerEvents_Channels),helpcontext(71)] HRESULT Channels([in] ICallChannelManager* pManager, [in] ICallChannelCollection* pChannels);
02281       [id(2), helpstring(ICallChannelManagerEvents_Message),helpcontext(71)] HRESULT Message([in] ICallChannelManager* pManager, [in] ICallChannel* pChannel, [in] ICallChannelMessage* pMessage);
02282       [id(3), helpstring(ICallChannelManagerEvents_Created),helpcontext(71)] HRESULT Created();
02283    };
02284 [
02285    uuid(03282B5D-B38F-469D-849A-09B0A7F4881B),
02286    version(1.0),
02287    helpstring(hsSkypeLib_Version), helpcontext(1),
02288    helpfile(hsSkypeLib_HelpFile)
02289 ]
02290 library SKYPE4COMLib
02291 {
02292    importlib("stdole32.tlb");
02293    importlib("stdole2.tlb");
02294    interface IApplication;
02295    interface IApplicationStream;
02296    interface IApplicationStreamCollection;
02297    interface ICall;
02298    interface ICallChannel;
02299    interface ICallChannelManager;
02300    interface ICallChannelMessage;
02301    interface ICallCollection;
02302    interface ICallIoDevice;
02303    interface ICallIoDeviceCollection;
02304    interface IChat;
02305    interface IChatCollection;
02306    interface IChatMessage;
02307    interface IChatMessageCollection;
02308    interface IChatMember;
02309    interface IChatMemberCollection;
02310    interface IClient;
02311    interface ICommand;
02312    interface IConference;
02313    interface IConferenceCollection;
02314    interface IConversion;
02315    interface IFileTransfer;
02316    interface IFileTransferCollection;
02317    interface IParticipant;
02318    interface IParticipantCollection;
02319    interface ISettings;
02320    interface ISkype;
02321    interface ISkypeApplication;
02322    interface ISkypeCall;
02323    interface ISkypeChat;
02324    interface ISkypeChatMessage;
02325    interface ISkypeChatMember;
02326    interface ISkypeConference;
02327    interface ISkypeDevice;
02328    interface ISkypeFileTransfer;
02329    interface ISkypeSms;
02330    interface ISkypeUser;
02331    interface ISkypeVoicemail;
02332    interface IUser;
02333    interface IUserCollection;
02334    interface IVoicemail;
02335    interface IVoicemailCollection;
02336    dispinterface _ISkypeEvents;
02337    dispinterface _ICallChannelManagerEvents;
02338
02339    [
02340       uuid(830690FC-BF2F-47A6-AC2D-330BCB402664),
02341       helpstring(hsSkype), helpcontext(18)
02342    ]
02343    coclass Skype
02344    {
02345       [default] interface ISkype;
02346       [default, source] dispinterface _ISkypeEvents;
02347       interface ISkypeApplication;
02348       interface ISkypeCall;
02349       interface ISkypeChat;
02350       interface ISkypeChatMessage;
02351       interface ISkypeConference;
02352       interface ISkypeFileTransfer;
02353       interface ISkypePlugin;
02354       interface ISkypeSms;
02355       interface ISkypeUser;
02356       interface ISkypeVoicemail;
02357    };
02358    [
02359       uuid(3E01D8E0-A72B-4C9F-99BD-8A6E7B97A48D),
02360       helpstring(hsUser), helpcontext(19)
02361    ]
02362    coclass User
02363    {
02364       [default] interface IUser;
02365    };
02366    [
02367       uuid(7B030003-037D-490D-9169-A4F391B3D831),
02368       helpstring(hsUserCollection), helpcontext(20)
02369    ]
02370    coclass UserCollection
02371    {
02372       [default] interface IUserCollection;
02373    };
02374    [
02375       uuid(2EEAB6D0-491E-4962-BBA1-FF1CCA6D4DD0),
02376       helpstring(hsConversion), helpcontext(21)
02377    ]
02378    coclass Conversion
02379    {
02380       [default] interface IConversion;
02381    };
02382    [
02383       uuid(D26B1D42-9C42-4E7B-BB73-86384C4B4345),
02384       helpstring(hsCall), helpcontext(22)
02385    ]
02386    coclass Call
02387    {
02388       [default] interface ICall;
02389    };
02390    [
02391       uuid(F3188CF3-EF22-4C5B-92CB-605964761C3B),
02392       helpstring(hsCallCollection), helpcontext(23)
02393    ]
02394    coclass CallCollection
02395    {
02396       [default] interface ICallCollection;
02397    };
02398    [
02399       uuid(7ACDC5B4-76A1-4BDF-918D-6962FCABBAD3),
02400       helpstring(hsChat), helpcontext(34)
02401    ]
02402    coclass Chat
02403    {
02404       [default] interface IChat;
02405    };
02406    [
02407       uuid(15B6FEE5-5FB3-4071-AC1F-7AEDC0E2A6BB),
02408       helpstring(hsChatColl), helpcontext(35)
02409    ]
02410    coclass ChatCollection
02411    {
02412       [default] interface IChatCollection;
02413    };
02414    [
02415       uuid(52071016-E648-4D3B-B57E-2B46CC993CE0),
02416       helpstring(hsParticipant), helpcontext(41)
02417    ]
02418    coclass Participant
02419    {
02420       [default] interface IParticipant;
02421    };
02422    [
02423       uuid(E1BC9147-C3E3-4E8A-8304-5E6B5C1C0774),
02424       helpstring(hsParticipantColl), helpcontext(42)
02425    ]
02426    coclass ParticipantCollection
02427    {
02428       [default] interface IParticipantCollection;
02429    };
02430    [
02431       uuid(A983C9EC-D73E-4364-B89B-ACD1E405674F),
02432       helpstring(hsConference), helpcontext(43)
02433    ]
02434    coclass Conference
02435    {
02436       [default] interface IConference;
02437    };
02438    [
02439       uuid(3506CDB7-8BC6-40C0-B108-CEA0B9480130),
02440       helpstring(hsConferenceColl), helpcontext(44)
02441    ]
02442    coclass ConferenceCollection
02443    {
02444       [default] interface IConferenceCollection;
02445    };
02446    [
02447       uuid(DD0E8ED5-1494-4B87-A35C-39F6ED4B1153),
02448       helpstring(hsVoicemail), helpcontext(53)
02449    ]
02450    coclass Voicemail
02451    {
02452       [default] interface IVoicemail;
02453    };
02454    [
02455       uuid(A7DF2611-D752-4C9F-A90A-B56F18485EE9),
02456       helpstring(hsVoicemailColl), helpcontext(54)
02457    ]
02458    coclass VoicemailCollection
02459    {
02460       [default] interface IVoicemailCollection;
02461    };
02462    [
02463       uuid(29DCD339-D184-469B-8BFB-199A2CCF014E),
02464       helpstring(hsApplication), helpcontext(29)
02465    ]
02466    coclass Application
02467    {
02468       [default] interface IApplication;
02469    };
02470    [
02471       uuid(6FA10A39-4760-4C94-A210-2398848618EC),
02472       helpstring(hsApplicationStream), helpcontext(55)
02473    ]
02474    coclass ApplicationStream
02475    {
02476       [default] interface IApplicationStream;
02477    };
02478    [
02479       uuid(4B42750B-57A1-47E7-B340-8EAE0E3126A4),
02480       helpstring(hsApplicationStreamColl), helpcontext(57)
02481    ]
02482    coclass ApplicationStreamCollection
02483    {
02484       [default] interface IApplicationStreamCollection;
02485    };
02486    [
02487       uuid(9017071A-2E34-4C3A-9BBB-688CBB5A9FF2),
02488       helpstring(hsChatMessage), helpcontext(24)
02489    ]
02490    coclass ChatMessage
02491    {
02492       [default] interface IChatMessage;
02493    };
02494    [
02495       uuid(10DD084E-A5AE-456F-A3BE-DA67EBE6B090),
02496       helpstring(hsChatMessageColl), helpcontext(25)
02497    ]
02498    coclass ChatMessageCollection
02499    {
02500       [default] interface IChatMessageCollection;
02501    };
02502    [
02503       uuid(452CCB69-6A95-4370-9E5A-B3EFB06A7651),
02504       helpstring(hsProfile), helpcontext(61)
02505    ]
02506    coclass Profile
02507    {
02508       [default] interface IProfile;
02509    };
02510    [
02511       uuid(222C0F35-3D78-4570-9F6D-BAEE289D0304),
02512       helpstring(hsGroup), helpcontext(27)
02513    ]
02514    coclass Group
02515    {
02516       [default] interface IGroup;
02517    };
02518    [
02519       uuid(A8109DB9-88E0-42FE-98EA-8A12BE5394C6),
02520       helpstring(hsGroupCollection), helpcontext(28)
02521    ]
02522    coclass GroupCollection
02523    {
02524       [default] interface IGroupCollection;
02525    };
02526    [
02527       uuid(B0FE88F0-C92F-46D6-878F-31599BEA944C),
02528       helpstring(hsSettings), helpcontext(59)
02529    ]
02530    coclass Settings
02531    {
02532       [default] interface ISettings;
02533    };
02534    [
02535       uuid(B09AC3FF-0D5D-41C6-A34E-7C3F58A3127C),
02536       helpstring(hsClient), helpcontext(62)
02537    ]
02538    coclass Client
02539    {
02540       [default] interface IClient;
02541    };
02542    [
02543       uuid(2DBCDA9F-1248-400B-A382-A56D71BF7B15),
02544       helpstring(hsCommand), helpcontext(26)
02545    ]
02546    coclass Command
02547    {
02548       [default] interface ICommand;
02549    };
02550    [
02551       uuid(89DD2F9D-C325-48BF-A615-96BD039BBC83),
02552       helpstring(hsCallChannel), helpcontext(63)
02553    ]
02554    coclass CallChannel
02555    {
02556       [default] interface ICallChannel;
02557    };
02558    [
02559       uuid(42FE718B-A148-41D6-885B-01A0AFAE8723),
02560       helpstring(hsCallChannelColl), helpcontext(64)
02561    ]
02562    coclass CallChannelCollection
02563    {
02564       [default] interface ICallChannelCollection;
02565    };
02566    [
02567       uuid(5E541E71-A474-4EAD-8FCB-24D400D023B7),
02568       helpstring(hsCallChannelMgr), helpcontext(63)
02569    ]
02570    coclass CallChannelManager
02571    {
02572       [default] interface ICallChannelManager;
02573       [default, source] dispinterface _ICallChannelManagerEvents;
02574    };
02575    [
02576       uuid(3D3E7C1B-79A7-4CC7-8925-41FA813E9913),
02577       helpstring(hsCallChannelMsg), helpcontext(66)
02578    ]
02579    coclass CallChannelMessage
02580    {
02581       [default] interface ICallChannelMessage;
02582    };
02583 #ifndef DOXYGEN_SHOULD_SKIP_THIS
02584    [
02585       uuid(FFC8B962-9B40-4DFF-9458-1830C7DD7F5D),
02586       helpstring("IEProtocolHandler Class"), hidden
02587    ]
02588    coclass IEProtocolHandler
02589    {
02590       [default] interface IUnknown;
02591    };
02592 #endif /*DOXYGEN_SHOULD_SKIP_THIS*/
02593    [
02594       uuid(F278D870-7AF7-4957-96EE-E6AC72D0B109),
02595       helpstring(hsSmsMessage), helpcontext(79)
02596    ]
02597    coclass SmsMessage
02598    {
02599       [default] interface ISmsMessage;
02600    };
02601    [
02602       uuid(1BCA4635-F1FC-44C8-B829-48229AEB32E3),
02603       helpstring(hsSmsMessageCollection), helpcontext(80)
02604    ]
02605    coclass SmsMessageCollection
02606    {
02607       [default] interface ISmsMessageCollection;
02608    };
02609    [
02610       uuid(5792FC7D-5E1D-4F1A-BD4F-A7A50F92BC6E),
02611       helpstring(hsSmsChunk), helpcontext(83)
02612    ]
02613    coclass SmsChunk
02614    {
02615       [default] interface ISmsChunk;
02616    };
02617    [
02618       uuid(CC461FC3-C9BE-41FB-8E47-E0115CBC01CC),
02619       helpstring(hsSmsChunkCollection), helpcontext(84)
02620    ]
02621    coclass SmsChunkCollection
02622    {
02623       [default] interface ISmsChunkCollection;
02624    };
02625    [
02626       uuid(61F8FAF0-82D0-407C-AE97-31441483AE40),
02627       helpstring(hsSmsTarget), helpcontext(81)
02628    ]
02629    coclass SmsTarget
02630    {
02631       [default] interface ISmsTarget;
02632    };
02633    [
02634       uuid(6AC51E9C-7947-4B46-A978-0AD601C4EFC9),
02635       helpstring(hsSmsTargetCollection), helpcontext(82)
02636    ]
02637    coclass SmsTargetCollection
02638    {
02639       [default] interface ISmsTargetCollection;
02640    };
02641    [
02642       uuid(3F06DCD2-3A04-463D-A08B-1FFED02C4D4C),
02643       helpstring(hsPluginMenuItem), helpcontext(91)
02644    ]
02645    coclass PluginMenuItem
02646    {
02647       [default] interface IPluginMenuItem;
02648    };
02649    [
02650       uuid(9D073235-D787-497D-8D1F-929559F1C621),
02651       helpstring(hsPluginEvent), helpcontext(92)
02652    ]
02653    coclass PluginEvent
02654    {
02655       [default] interface IPluginEvent;
02656    };
02657 };
02658